Samsung MB-MS8GA does not boot

Post Reply
crashoverride
Posts: 4470
Joined: Tue Dec 30, 2014 8:42 pm
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 52 times
Contact:

Samsung MB-MS8GA does not boot

Unread post by crashoverride » Tue Dec 30, 2014 10:31 pm

I tried using two of these SD cards and neither would allow the system to boot even after sitting for 5 minutes.

http://www.samsung.com/us/support/owner ... B-MS8GA/US

User avatar
odroid
Site Admin
Posts: 31363
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 50 times
Been thanked: 184 times
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by odroid » Wed Dec 31, 2014 11:52 am

Can you check your flashing process with this guide?
http://odroid.com/dokuwiki/doku.php?id= ... hing_tools
Also let me know the LED status.

It should boot within 1minute if the flashing was okay.

crashoverride
Posts: 4470
Joined: Tue Dec 30, 2014 8:42 pm
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 52 times
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by crashoverride » Wed Dec 31, 2014 8:29 pm

odroid wrote:Can you check your flashing process with this guide?
http://odroid.com/dokuwiki/doku.php?id= ... hing_tools
Also let me know the LED status.

It should boot within 1minute if the flashing was okay.
I have repeatedly successfully flashed a Toshiba SD card without issue. The red power light illuminates and remains lit.

I did some more research into this issue and discovered the following which I believe to be very important and related to other issues reported such as SD cards taking a long time to boot the system:

*** THE PROBLEM ONLY MANIFESTS IF A SERIAL CONSOLE CABLE IS NOT ATTACHED ***

The issue is 100% reproducible.
1) Flash SD card with ubuntu image.
2) Insert into ODROID-C1 with HDMI attached.
3) Observer failure to boot.
4) Remove power from ODROID-C1
5) Attach serial cable (in my case a Sparkfun FT232R Breakout with only TX, RX, GND wired and set for 3.3v operation). Ensure USB port is CONNECTED to computer.
6) Apply power to ODROID-C1 (tested with 5V2A adapter from HardKernel on USA 120V AC)
7) Observe that board boots.

Sometimes after a failed boot, the SD Card takes a bit of time to recover. I believe this is what people are seeing with other SD cards that take a while to boot initially. The ROM on the board continually resets the interfaces and tries to boot from different source until successful.

In conclusion, I believe this to be a power and/or noise issue with the hardware.

crashoverride
Posts: 4470
Joined: Tue Dec 30, 2014 8:42 pm
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 52 times
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by crashoverride » Thu Jan 01, 2015 8:58 pm

crashoverride wrote:In conclusion, I believe this to be a power and/or noise issue with the hardware.
[Edit: See below]
I confirmed this today. I soldered a 4.7uf polarized capacitor to the serial console port 3V3 and GND lines. The device and SD card function correctly with it in place.

[Edit: Spoke too soon. It only works intermittently.]
Last edited by crashoverride on Thu Jan 01, 2015 9:09 pm, edited 1 time in total.

User avatar
odroid
Site Admin
Posts: 31363
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 50 times
Been thanked: 184 times
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by odroid » Thu Jan 01, 2015 9:09 pm

Can you tell which power supply do you use?
Our PSU?

crashoverride
Posts: 4470
Joined: Tue Dec 30, 2014 8:42 pm
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 52 times
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by crashoverride » Thu Jan 01, 2015 9:10 pm

The power supply is official from HardKernel 5V2A

User avatar
odroid
Site Admin
Posts: 31363
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 50 times
Been thanked: 184 times
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by odroid » Thu Jan 01, 2015 9:15 pm

If you have a micro-USB cable for smartphone, connect it between your PC and C1 to increase the ground signal path.
It will be helpful to find a root cause.

Do you use the Samsung Class6 or Toshiba SD now?
What is class or speed of your Toshiba SD? Is it UHS-1?

crashoverride
Posts: 4470
Joined: Tue Dec 30, 2014 8:42 pm
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 52 times
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by crashoverride » Thu Jan 01, 2015 9:36 pm

I use the device with the Toshiba SD card and it functions correctly all the time. The card is 8GB Class 4 (Toshiba C08G).

I attached a USB cable from the computer to the USB OTG port (testing with capacitor removed); however, it did not boot. Windows did recognize a "M8-CHIP" device.

I am exploring further to make sure the image on the Samsung card is not corrupt. I will post any updates here.

crashoverride
Posts: 4470
Joined: Tue Dec 30, 2014 8:42 pm
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 52 times
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by crashoverride » Thu Jan 01, 2015 9:50 pm

I reflashed the Samsung SD-CARD but it still would not boot with the USB OTG connector. I then tried connecting only the GND line of the console port to the FT232R board. It still would not boot. It appears the only consistently reliable way to boot it with the Samsung card is to connect GND, TX, RX of the console port.

crashoverride
Posts: 4470
Joined: Tue Dec 30, 2014 8:42 pm
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 52 times
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by crashoverride » Thu Jan 01, 2015 11:10 pm

My final post on this: Placing a capacitor on the 5V and GND pins of the expansion connector and removing the HDMI connector increases the likelihood the board will boot. However, it too is inconsistent. I have exhausted options available to assist diagnosing this as I simply do not have the proper tools at hand. Therefore I will leave the rest to the manufacturer.

I will say that other than being finicky with SD Cards, I absolutely love this board. It is a perfect combination of price and performance and I look forward to using it in many projects.

User avatar
odroid
Site Admin
Posts: 31363
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 50 times
Been thanked: 184 times
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by odroid » Fri Jan 02, 2015 11:41 am

Thank you for your effort.

I have one more question.
When the boards didn't boot, what is the blue LED status? Is it solid on? or no light?

crashoverride
Posts: 4470
Joined: Tue Dec 30, 2014 8:42 pm
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 52 times
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by crashoverride » Fri Jan 02, 2015 9:41 pm

When the board fails to boot:

Code: Select all

Red LED = ON;
Blue LED = OFF; (It never illuminates)

User avatar
odroid
Site Admin
Posts: 31363
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 50 times
Been thanked: 184 times
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by odroid » Fri Jan 02, 2015 10:35 pm

I've ordered the Samsung MB-MS8GA 8GB Class card.
We will test it next week when it arrive at our office.

sasa
Posts: 10
Joined: Thu Jan 29, 2015 7:03 am
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by sasa » Fri Feb 13, 2015 6:56 pm

I also have that problem, together with serial adapter helping (http://forum.odroid.com/viewtopic.php?f ... 747#p73632 ), but I'm using ADATA 16GB class 10 sdhc without uhs and with uhs option disabled in boot.ini;

I dont't have board at myself nor will have in about week, could you guys test if the board boots if you put 0.1uF blocking capacitors from rx and gnd, and from tx to gnd lines.

I will investigate things when I come home with an scope, but my hunch is that maybe u-boot blocks because of the serial port activity thats caused by the noise on the pins. If uboot works that way.

jeroen79
Posts: 29
Joined: Fri Jan 23, 2015 3:45 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by jeroen79 » Mon Mar 09, 2015 1:44 am

Hi,

I also have this problem, is there a software solution for this?, or do we have to RMA the boards?

ps: it isn't sd rellated, i have tested it with various sd cards.

Thanks,
Jeroen

User avatar
odroid
Site Admin
Posts: 31363
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 50 times
Been thanked: 184 times
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by odroid » Mon Mar 09, 2015 10:34 am

jeroen79 wrote:Hi,

I also have this problem, is there a software solution for this?, or do we have to RMA the boards?

ps: it isn't sd rellated, i have tested it with various sd cards.

Thanks,
Jeroen
Did you try the Sandisk SD?

jeroen79
Posts: 29
Joined: Fri Jan 23, 2015 3:45 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by jeroen79 » Mon Mar 09, 2015 3:47 pm

No, i do not have a sandisk, but i tried many others, and it should work with all sd cards

User avatar
tobetter
Posts: 3688
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 28 times
Been thanked: 116 times
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by tobetter » Mon Mar 09, 2015 5:12 pm

jeroen79 wrote:No, i do not have a sandisk, but i tried many others, and it should work with all sd cards
Unfortunately, ODROID-C1 have MicroSD compatible issue and not able to support all vendors product yet.
For reference, http://odroid.com/dokuwiki/doku.php?id= ... _selection

jeroen79
Posts: 29
Joined: Fri Jan 23, 2015 3:45 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by jeroen79 » Mon Mar 09, 2015 8:21 pm

But what has SD todo with niet booting without serial
Last edited by jeroen79 on Mon Mar 09, 2015 8:27 pm, edited 1 time in total.

User avatar
tobetter
Posts: 3688
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 28 times
Been thanked: 116 times
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by tobetter » Mon Mar 09, 2015 8:23 pm

jeroen79 wrote:But what had SD todo with niet booting without serial attached
??? :?:

jeroen79
Posts: 29
Joined: Fri Jan 23, 2015 3:45 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by jeroen79 » Tue Mar 10, 2015 2:55 am

tobetter wrote:
jeroen79 wrote:But what has SD todo with niet booting without serial attached
??? :?:
well this thread is about the C1 not booting whitout a serial adapter attached, not about the SD card issues.

afremont
Posts: 128
Joined: Sun Mar 08, 2015 12:58 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by afremont » Wed Mar 11, 2015 7:02 am

Is there any possibility that this is all because the power supply voltage doesn't ramp up fast enough due to power lead inductance, or possibly sags on a surge when the device comes out of reset? There is a reset controller chip, right? Can any of you guys try using a shorter power cable.

This is the same thing I wonder about the RPi. They use charging equipment that was never designed to supply rapidly varying currents to a device. Generally when you plug a phone charger in, all it has to do is come up to voltage and when the phone is happy, it starts charging. Once the thing is ramped up, current doesn't change much and it rarely changes very quickly except when the phone stops or restarts charging, but these are single events that are spread apart by very long intervals of time. Charge controllers likely don't care that much about it.

Microcontrollers coming out of reset don't behave like that at all, they suddenly start drawing current and rapidly fluctuate their current draw, hence onboard caps to help supply the juice when that's going on. Too large of a cap and the voltage ramps up too slow, too little and the input voltage to the chip fluctuates quickly with the instantaneous current requirements. This is all exacerbated by long, thin power leads that have a lot of inductive reactance.

I saw this a lot with PIC chips which use minuscule amounts of power. Circuits that powered up fine on a bench supply suddenly didn't work when long, skinny power leads became part of the equation. Trying shorter, fatter power leads makes a big difference in this behavior. It's something to consider and definitely something to look at with a scope. Just tossing out my 2 cents, not that it's actually worth that much.

DISCLAIMER: I don't have one of these boards yet, but I really want to get one once the kinks get ironed out a bit more. I seriously think that this is the problem with a lot of the so-called "bad PS's" on the RPi.

dronus
Posts: 87
Joined: Fri Jul 25, 2014 7:24 pm
languages_spoken: english
ODROIDs: U3, XU4, C1+
Has thanked: 0
Been thanked: 0
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by dronus » Wed Aug 24, 2016 5:34 am

Is this problem oficially fixed in C1+ ? Because I now have those issues too on C1+: Using a Samsung 32gb card, it boots fast after power on, but crashes on read errors after reboot.
I thought that was fixed on the C1+? Is there any software configuration the fix depends on? Or is it a pure hardware change?

User avatar
odroid
Site Admin
Posts: 31363
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 50 times
Been thanked: 184 times
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by odroid » Wed Aug 24, 2016 11:21 am

We added a circuit on C1+ to make a hard-reset on the SD-card while rebooting process.
And many people reported the issue was fixed.

Can you comment out this line in boot.ini file?

Code: Select all

setenv disableuhs "disableuhs"

dronus
Posts: 87
Joined: Fri Jul 25, 2014 7:24 pm
languages_spoken: english
ODROIDs: U3, XU4, C1+
Has thanked: 0
Been thanked: 0
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by dronus » Fri Aug 26, 2016 8:17 pm

Seems that disableuhs solves the issue for me. I will report again if it works reliable and for more then one machine. So we can consider SD Card on Odroid C1+ as realiable, but only if the uhs option is set manually according to the card model?

User avatar
odroid
Site Admin
Posts: 31363
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 50 times
Been thanked: 184 times
Contact:

Re: Samsung MB-MS8GA does not boot

Unread post by odroid » Sat Aug 27, 2016 10:23 am

No.
Further explanation about the UHS mode.
Card enumeration/initialization mode should be done with 3Volt interface and its interface voltage should be changed to 1.8Volt if the card is UHS fast transfer capable one.
When the system reboots, the interface must be changed to 3Volt mode again for proper initialization.
But.. some UHS cards can't go back to original state(3Volt mode) with soft-reset command.

So "disableuhs" option in boot.ini file forces the normal SD mode even your card is UHS compatible.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 0 guests