HC-4 stopped booting from SD card

Post Reply
Posts: 1
Joined: Tue Jul 26, 2022 9:36 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0

HC-4 stopped booting from SD card

Post by acheron »


Some time ago, I've bought my HC-4, found some old SD card, restored Ubuntu Minimal image from the HardKernel site to it (using `dd`), booted it up and configured everything through `ssh`, everything was fine and smooth, had my home cloud set up.

After about 2-3 weeks, I started to get strange ssh errors when connecting to it. I restarted the machine etc., but nothing worked. I unplugged the SD card and popped it into my laptop to see what's wrong. The SD card behaved like it would just died out (strange read errors etc.). So I bought 2 new SD cards (Goodram microSDHC 16GB Class 10 UHS-I (SDU16GHCUHS1AGRR10)) and tried to `dd` Ubuntu Minimal to them, but they all seem not to work. I connected HDMI screen and USB keyboard and I can see that every time it gets stuck at Petitboot screen, like there was no SD card in the slot.

I've searched the forums and found similar problems, but none of the solutions worked for me. Here's what I've tried so far:
- Booting with case's bottom button pushed in
- 3 different SD cards (1 that broke, 2 Goodrams, 1 SD card from my digital camera)
- Update Petitboot (went smooth and was successful, still nothing)
- I've used various `dd` options and then also Linux Mint's "USB Image Writer", then also Linux Mint's Disks program ("Restore Disk Image..."), all with Ubuntu Minimal from HardKernel's site.
- Messing around with Petitboot boot medium options :)

Could you please help me with narrowing down the problem? Thank you.

Posts: 116
Joined: Thu Feb 11, 2021 11:06 pm
languages_spoken: english
Has thanked: 28 times
Been thanked: 21 times

Re: HC-4 stopped booting from SD card

Post by tomerr »

i would try a more branded name SD card like Sandisk - all the Sandisk SD card types I've used so far with the HC4 worked perfectly for me.
also, you can use netinstall (netboot) from Petitboot to install Ubuntu/Debian - look here https://wiki.odroid.com/odroid-hc4/soft ... ll_omv_nas under "Preparation an OS"

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 0 guests