OGA wont charge

Post Reply
PANiCnz
Posts: 8
Joined: Sun Dec 28, 2014 5:31 am
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

OGA wont charge

Unread post by PANiCnz » Sat Feb 15, 2020 6:05 am

Are there any tips or tricks for getting the OGA to charge?

Mines just gone flat and wont charge from the Hardkernal charger or the USB cable. Its got a constant red charger and power led.

User avatar
rooted
Posts: 7277
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 465 times
Been thanked: 129 times
Contact:

Re: OGA wont charge

Unread post by rooted » Sat Feb 15, 2020 8:54 am

Are you certain you are inserting the charge cable enough, when I first got mine in was having some issues but pushing in the cable all the way solved it.

ReZeR
Posts: 5
Joined: Tue Feb 18, 2020 5:18 pm
languages_spoken: english
ODROIDs: N2, Go-Advance
Has thanked: 0
Been thanked: 0
Contact:

Re: OGA wont charge

Unread post by ReZeR » Tue Feb 18, 2020 5:21 pm

Sadly, I have the same problem. During boot the red LED lights up, then turns off and there is no indication it's charging within the OS (Retro Arena).

The barrel connector makes a satisfying click when pushed in, so I am certain it's all the way in.

joy
Posts: 1089
Joined: Fri Oct 02, 2015 1:44 pm
languages_spoken: english
ODROIDs: ODROID-C1+, XU4, X
Has thanked: 65 times
Been thanked: 122 times
Contact:

Re: OGA wont charge

Unread post by joy » Tue Feb 18, 2020 7:03 pm

Could you check the following items to find a root cause?

1. charge LED faulty
On u-boot stage, charge LED should be on as red color by default.
After power-on, charge LED will be on during a couple of seconds.

2. DC jack issue
To confirm DC jack is connected well, please check charge led is on (or blinks) after booting done.
If the led is off even though you connect DC jack, please insert the charge cable enough. (feel clicking)

3. Battery issue
To check battery problem, please check an indicator bar of right top side on display.
- 3.4V (the lowest value) : Empty
- 4.2V : full charged
When you get all empty bars display, please keep DC jack connected.
In 30 minutes~1hour, it should be updated. (to make sure push buttons to refresh display)

Also during charging, charge led will be blinking periodically untill full charged.

joy
Posts: 1089
Joined: Fri Oct 02, 2015 1:44 pm
languages_spoken: english
ODROIDs: ODROID-C1+, XU4, X
Has thanked: 65 times
Been thanked: 122 times
Contact:

Re: OGA wont charge

Unread post by joy » Tue Feb 18, 2020 7:07 pm

ReZeR wrote:
Tue Feb 18, 2020 5:21 pm
Sadly, I have the same problem. During boot the red LED lights up, then turns off and there is no indication it's charging within the OS (Retro Arena).

The barrel connector makes a satisfying click when pushed in, so I am certain it's all the way in.
Can you check the charge indicator bar of right top side on display?
If it shows all empty, please keep connecting DC jack for one or half hour.
It should be updated on one or half hour if there is no battery hw issue.

Or charge led is off even though dc jack is connected,
could you please remove battery and then try booting only using DC jack?
It's to check if there is any issue on DC jack-related HW.

(update)
Or do you use a USB hub as a dc-jack source?
If so, please change the source?
e.g. a desktop usb port

joy
Posts: 1089
Joined: Fri Oct 02, 2015 1:44 pm
languages_spoken: english
ODROIDs: ODROID-C1+, XU4, X
Has thanked: 65 times
Been thanked: 122 times
Contact:

Re: OGA wont charge

Unread post by joy » Fri Feb 21, 2020 10:09 am

And please refer to check a battery and charge status.
https://wiki.odroid.com/odroid_go_advan ... ery_charge

ReZeR
Posts: 5
Joined: Tue Feb 18, 2020 5:18 pm
languages_spoken: english
ODROIDs: N2, Go-Advance
Has thanked: 0
Been thanked: 0
Contact:

Re: OGA wont charge

Unread post by ReZeR » Fri Feb 21, 2020 7:06 pm

Hey. I followed all the tests, with the final test being to disconnect the battery and run only off the DC jack. Nothing, no power, no LED's

ReZeR
Posts: 5
Joined: Tue Feb 18, 2020 5:18 pm
languages_spoken: english
ODROIDs: N2, Go-Advance
Has thanked: 0
Been thanked: 0
Contact:

Re: OGA wont charge

Unread post by ReZeR » Fri Feb 21, 2020 7:07 pm

Hey. I followed all the tests, with the final test being to disconnect the battery and run only off the DC jack. Nothing, no power, no LED's.

I also tested multiple slow and fast chargers, battery packs and USB hubs. Nothing :(

joy
Posts: 1089
Joined: Fri Oct 02, 2015 1:44 pm
languages_spoken: english
ODROIDs: ODROID-C1+, XU4, X
Has thanked: 65 times
Been thanked: 122 times
Contact:

Re: OGA wont charge

Unread post by joy » Sat Feb 22, 2020 10:17 am

Hi @ReZeR,
:(

You need to push the DC-jack to the wole enough until you feel clicking.
Did you?

And can you remove a SD card, then try boot and check LEDs again?
It should be shown as this wiki page.
https://wiki.odroid.com/odroid_go_advan ... _a_battery
OGA_dcjack_uboot.png
OGA_dcjack_uboot.png (524.68 KiB) Viewed 406 times

ReZeR
Posts: 5
Joined: Tue Feb 18, 2020 5:18 pm
languages_spoken: english
ODROIDs: N2, Go-Advance
Has thanked: 0
Been thanked: 0
Contact:

Re: OGA wont charge

Unread post by ReZeR » Sun Feb 23, 2020 9:32 am

Thanks for responding again :)

Yes, all the way in - audible click and cannot physically push it any further.

No SD-Card, no LED's, no battery. Without the battery I get nothing.

Image

Image

Charger that I am currently using (I have tried many!) is rated at 9v/1.67a and 5v/2.0a

PaulF8080
Posts: 15
Joined: Fri Feb 14, 2020 9:40 am
languages_spoken: english
ODROIDs: go, go advance, xu4
Has thanked: 0
Been thanked: 1 time
Contact:

Re: OGA wont charge

Unread post by PaulF8080 » Sun Feb 23, 2020 2:25 pm

The 9v is a mystery to me. What kind of charger does 9v?

User avatar
mad_ady
Posts: 7381
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 359 times
Been thanked: 258 times
Contact:

Re: OGA wont charge

Unread post by mad_ady » Sun Feb 23, 2020 3:01 pm

A fast charger. It shouldn't be a problem since 9V requires negociation, but to be sure can you try with a PC usb port?

joy
Posts: 1089
Joined: Fri Oct 02, 2015 1:44 pm
languages_spoken: english
ODROIDs: ODROID-C1+, XU4, X
Has thanked: 65 times
Been thanked: 122 times
Contact:

Re: OGA wont charge

Unread post by joy » Mon Feb 24, 2020 10:33 am

Hi @ReZeR,
Thank you for sharing the information.

Could you try a PC usb port directly as @mad_ady mentioned?

If it still doesn't work, I think it's power-related HW faulty.
Please check it and and share the result with us.

joy
Posts: 1089
Joined: Fri Oct 02, 2015 1:44 pm
languages_spoken: english
ODROIDs: ODROID-C1+, XU4, X
Has thanked: 65 times
Been thanked: 122 times
Contact:

Re: OGA wont charge

Unread post by joy » Mon Feb 24, 2020 12:35 pm

As we tested, it doesn't worrk with 9V adapter,
Please use 5V adapter, Not to use 9V.

User avatar
odroid
Site Admin
Posts: 33398
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 409 times
Been thanked: 464 times
Contact:

Re: OGA wont charge

Unread post by odroid » Mon Feb 24, 2020 2:09 pm

We could reproduce the issue with a QuickCharge compatible 9V PSU.
https://wiki.odroid.com/odroid_go_advan ... limitation

ReZeR
Posts: 5
Joined: Tue Feb 18, 2020 5:18 pm
languages_spoken: english
ODROIDs: N2, Go-Advance
Has thanked: 0
Been thanked: 0
Contact:

Re: OGA wont charge

Unread post by ReZeR » Tue Feb 25, 2020 5:15 pm

Thanks for the feedback. I have now tested two different 5V/2.4A charges - sadly, still no charge or power on :(

User avatar
odroid
Site Admin
Posts: 33398
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 409 times
Been thanked: 464 times
Contact:

Re: OGA wont charge

Unread post by odroid » Tue Feb 25, 2020 5:24 pm

Do you have a DMM to narrow down root causes?
viewtopic.php?f=196&t=37943&p=282927#p282920

Post Reply

Return to “General Topics”

Who is online

Users browsing this forum: No registered users and 6 guests