XU4 w. Cloudshell, SSD not recognized

Post Reply
Robs
Posts: 17
Joined: Thu Nov 26, 2015 6:47 am
languages_spoken: english french german spanish
ODROIDs: xu4 with emmc module and cloudshell
Location: France
Has thanked: 0
Been thanked: 0
Contact:

XU4 w. Cloudshell, SSD not recognized

Unread post by Robs » Tue Feb 04, 2020 3:23 am

Hi, I have been struggling following this tutorial:
https://wiki.odroid.com/odroid-xu4/soft ... _webserver
I installed ubuntu-16.04.3-4.14-minimal-odroid-xu4-20171213 on the emmc.

I have an ssd in the cloudshell (Sandisk ultra 2 500Go).
It shows on lsusb:
id: 05e3:0735
but will not create a link to /dev/sdX and does not appear with fdisk -l.
If I unplug the usb3 port from the cloudshell and replug it in, it gets recognized by fdisk, but disappears after reboot. (I want to boot on the SSD so it's problematic).

I read on the forum about UAS issues but it seems not be the case, the driver listed in lsusb is :

Code: Select all

|/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/2p, 5000M
        |__ Port 1: Dev 4, If 0, Class=Mass Storage, Driver=usb-storage, 5000M

Having doubts, I tried nonetheless to append usb-storage.quirks=0x05e3:0x0735:u to the kernel parameters in boot.ini but it had no effects on the issue.
Dmesg reads:

Code: Select all

scsi host0: usb-storage 4-1.1:1.0
[ 7378.564143] scsi 0:0:0:0: Direct-Access     SanDisk  SDSSDHII480G     1003 PQ: 0 ANSI: 6
[ 7378.575001] scsi 0:0:0:0: Attached scsi generic sg0 type 0
[ 7378.577961] sd 0:0:0:0: [sda] 937703072 512-byte logical blocks: (480 GB/447 GiB)
[ 7378.578641] sd 0:0:0:0: [sda] Write Protect is off
[ 7378.578650] sd 0:0:0:0: [sda] Mode Sense: 5f 00 10 08
[ 7378.579384] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, supports DPO and FUA
[ 7378.582151]  sda: sda1 sda2
[ 7378.584240] sd 0:0:0:0: [sda] Attached SCSI disk
but when I reboot, it reads :

Code: Select all

usb 4-1.1: reset SuperSpeed USB device number 3 using xhci-hcd
and the disk disappears in fdisk again.

I tried to change the usb 3 cable in the cloudshell, as well as the usb port, no effects.
I managed to get the ssd disk to be recognized automatically with fdisk when connected to the board through an external housing. The ssd disk was still recognized after reboot that way as well.

I had been experiencing issues with HDD/SSD previously on the past with different OS (OGST, various Ubuntu and Debian flavours...) and I figured it was because of the original 4A PSU. I finally bought the 6A PSU as recommended and it does not work any better so far...
Any ideas?
Thanks in advance

User avatar
odroid
Site Admin
Posts: 33375
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 402 times
Been thanked: 462 times
Contact:

Re: XU4 w. Cloudshell, SSD not recognized

Unread post by odroid » Tue Feb 04, 2020 9:33 am

Clean the USB host ports.
viewtopic.php?f=147&t=30446&p=218401#p218401

BTW, did you try this Ubuntu 18.04.3 image too?
https://wiki.odroid.com/odroid-xu4/os_i ... 10-minimal

Robs
Posts: 17
Joined: Thu Nov 26, 2015 6:47 am
languages_spoken: english french german spanish
ODROIDs: xu4 with emmc module and cloudshell
Location: France
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 w. Cloudshell, SSD not recognized

Unread post by Robs » Wed Feb 05, 2020 3:55 am

Thanks, I had cleaned them a while back, I will try again this weekend, as well as newest Ubuntu image, and let you know of the results.

Robs
Posts: 17
Joined: Thu Nov 26, 2015 6:47 am
languages_spoken: english french german spanish
ODROIDs: xu4 with emmc module and cloudshell
Location: France
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 w. Cloudshell, SSD not recognized

Unread post by Robs » Fri Feb 07, 2020 3:34 pm

Hi,
I tried both recleaning usb 3 ports on the XU4 and Cloudshell boards, no effects.
I tried with the ubuntu 18.04 image as well and it did not work either.
I still have the same replicable issue:
I have to disconnect and connect the usb3 cable while power on in order to let the SSD appear with fdisk.
When I reboot XU4, the SSD via the cloudshell is not recognized anymore.

User avatar
odroid
Site Admin
Posts: 33375
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 402 times
Been thanked: 462 times
Contact:

Re: XU4 w. Cloudshell, SSD not recognized

Unread post by odroid » Mon Feb 10, 2020 11:21 am

Do you still have reset SuperSpeed USB device number 3 using xhci-hcd in the dmesg output after rebooting?

Robs
Posts: 17
Joined: Thu Nov 26, 2015 6:47 am
languages_spoken: english french german spanish
ODROIDs: xu4 with emmc module and cloudshell
Location: France
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 w. Cloudshell, SSD not recognized

Unread post by Robs » Mon Feb 10, 2020 1:25 pm

Hello,
yes, I still have it as the last message in dmesg.
Lsusb still reads the 05e3:0735 controller, but no disks shows in fdisk.

Robs
Posts: 17
Joined: Thu Nov 26, 2015 6:47 am
languages_spoken: english french german spanish
ODROIDs: xu4 with emmc module and cloudshell
Location: France
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 w. Cloudshell, SSD not recognized

Unread post by Robs » Sat Feb 15, 2020 7:01 pm

Could it be a hardware default?

User avatar
odroid
Site Admin
Posts: 33375
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 402 times
Been thanked: 462 times
Contact:

Re: XU4 w. Cloudshell, SSD not recognized

Unread post by odroid » Mon Feb 17, 2020 2:38 pm

Please try other USB cable.

Post Reply

Return to “CloudShell”

Who is online

Users browsing this forum: No registered users and 2 guests