XU4 Won't boot from eMMC

Post Reply
zuluzombie
Posts: 4
Joined: Tue Jan 14, 2020 5:21 am
languages_spoken: english
ODROIDs: 5 XU4's
Has thanked: 0
Been thanked: 0
Contact:

XU4 Won't boot from eMMC

Unread post by zuluzombie » Tue Jan 14, 2020 5:46 am

We have been using an XU4 in production for
about a year.

We recently purchased an additional 4 XU4s.

We cloned the eMMC cards from the working production unit.

Ubuntu 16.04.2 LTS
Linux odroid 4.9.27-35 #1 SMP PREEMPT Tue May 9

Three of the units worked great.

One unit will not boot.

We tested the cloned eMMC on another unit. It works fine.

We put problematic board (with a verified working
eMMC card) into a working
system (power supply, monitor, kbd, mouse, monitor, cables, etc)

It failed.

Yes, the switch is in the proper position.

It appears to get into the boot process .. (tons of messages on the
monitor). No evil error messages. Stops at different places.
Sometimes just after initializing the random number generator,
sometimes hanging on some sort of issue with the USB mouse.
(We tried several mice, but remember it's sitting in a working
set of peripherals .. see above).

Need help.

Tom

joshua.yang
Posts: 342
Joined: Fri Sep 22, 2017 5:54 pm
languages_spoken: Korean, English
ODROIDs: XU4, XU4Q + Cloudshell2, H2, N2
Has thanked: 9 times
Been thanked: 64 times
Contact:

Re: XU4 Won't boot from eMMC

Unread post by joshua.yang » Tue Jan 14, 2020 10:36 am

Hi.

Actually I don't know what could be the root cause for now.
Looks that problematic board may have hardware corrupts. :shock:
But it also looks you use quite an old kernel version for your system. Although that kernel works fine on the other XU4s, could you test with the latest image just for a test?

User avatar
odroid
Site Admin
Posts: 33043
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 296 times
Been thanked: 418 times
Contact:

Re: XU4 Won't boot from eMMC

Unread post by odroid » Tue Jan 14, 2020 11:57 am

Flash the latest Ubuntu 18.04.3 + Kernel 4.14 image to an eMMC module to narrow down root causes.
Note that some new eMMC chipsets from Samsung have a compatibility issue with old kernels.

zuluzombie
Posts: 4
Joined: Tue Jan 14, 2020 5:21 am
languages_spoken: english
ODROIDs: 5 XU4's
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 Won't boot from eMMC

Unread post by zuluzombie » Wed Jan 15, 2020 6:12 am

Flashed ..
ubuntu-18.04.1-4.14-mate-odroid-xu4-20181203.img

Booted up to Login fine.

First time appeared to crash after 15 secs before I could
do the login. Black screen / No Video.

Tried three times after the first fail and everything works
fine.

Not sure if the HW is flaky. I'll keep playing with it.
Now that I can't clone I have to do a bunch of evil installs.
Java, Segger JLink Commander (problematic), etc.
Last time it took 3 days to get it all working.

I ordered two more XU4's. I'm hoping those will work
out of the box. Am I risking that the three working units
will die at the customer site?

Thanks for the help!

If it dies again with 18.04 I'll let you know.

Tom

joshua.yang
Posts: 342
Joined: Fri Sep 22, 2017 5:54 pm
languages_spoken: Korean, English
ODROIDs: XU4, XU4Q + Cloudshell2, H2, N2
Has thanked: 9 times
Been thanked: 64 times
Contact:

Re: XU4 Won't boot from eMMC

Unread post by joshua.yang » Wed Jan 15, 2020 11:43 am

Glad to hear that it solved.

Actually, ubuntu-18.04.3-4.14-mate-odroid-xu4-20190929.img.xz is the latest image we provide. :)
You can find it from here: https://wiki.odroid.com/getting_started ... #downloads

o_lampe
Posts: 47
Joined: Wed Jan 01, 2020 12:35 am
languages_spoken: english german
ODROIDs: MC1 solo
Has thanked: 0
Been thanked: 2 times
Contact:

Re: XU4 Won't boot from eMMC

Unread post by o_lampe » Wed Jan 15, 2020 3:39 pm

Maybe crashing the first three boots was due to thermal issues?
On new boards, I'd consider removing the heatsink and check that the thermal pad is OK or remove it right away and replace it with better stuff.
***try at your own risk***

joshua.yang
Posts: 342
Joined: Fri Sep 22, 2017 5:54 pm
languages_spoken: Korean, English
ODROIDs: XU4, XU4Q + Cloudshell2, H2, N2
Has thanked: 9 times
Been thanked: 64 times
Contact:

Re: XU4 Won't boot from eMMC

Unread post by joshua.yang » Wed Jan 15, 2020 5:45 pm

Not sure but even if it were so, it would boot anyway. Because thermal throttling occurs when a high temperature.
How about check the current running machines' CPU temperature first?

Code: Select all

cat /sys/devices/virtual/thermal/thermal_zone0/temp

zuluzombie
Posts: 4
Joined: Tue Jan 14, 2020 5:21 am
languages_spoken: english
ODROIDs: 5 XU4's
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 Won't boot from eMMC

Unread post by zuluzombie » Thu Jan 16, 2020 5:11 am

Thanks for the suggestions! ..

Running all night (with very little to do) ..

cat /sys/devices/virtual/thermal/thermal_zone0/temp
yields 48000

Which I assume is a little over body temp -> Ok.

Tom

zuluzombie
Posts: 4
Joined: Tue Jan 14, 2020 5:21 am
languages_spoken: english
ODROIDs: 5 XU4's
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 Won't boot from eMMC

Unread post by zuluzombie » Sat Jan 18, 2020 5:36 am

Just received two additional
XU4's both work fine with the
old firmware.

with the previous 4 boards,
hat's 5 out 6 that are good.

This really leads me to believe
that the one fail it's a board hardware problem.

Tom

User avatar
odroid
Site Admin
Posts: 33043
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 296 times
Been thanked: 418 times
Contact:

Re: XU4 Won't boot from eMMC

Unread post by odroid » Mon Jan 20, 2020 10:15 am

It seems to be a eMMC driver timing tolerance.

Do you have a USB-UART console kit to see the boot loader booting process?

Post Reply

Return to “General Topics”

Who is online

Users browsing this forum: No registered users and 0 guests