[SOLVED] Artifacts after booting CoreELec from eMMC

Post Reply
snoopyx
Posts: 11
Joined: Thu Aug 02, 2018 1:26 am
languages_spoken: english
ODROIDs: C2
Has thanked: 2 times
Been thanked: 0
Contact:

[SOLVED] Artifacts after booting CoreELec from eMMC

Post by snoopyx »

Hey guys,
after 3 years of owning a C2 with LibreElec on an black eMMC module I upgraded to a new 4K TV and purchased a N2 with a microSD card with CoreElec. After migrating all the settings and watched list I decided to move the working install to the black C2 eMMC module using installtoemmc. Using the script worked and I could boot from the eMMC but it produces huge artifacts, horizontal stripes, as soon as I go through the menu. As soon as I press any button, left, right, up or down, I have these horizontal lines making it impossible to see anything beneath. I repeated installtoemmc once again but the problem persists. And it only exists when booting from eMMC. Using the factory microSD card it works as a charm. According to this thread, it shouldn't be a compatibility issue between the black eMMC and the N2. Removing the eMMC from the C2 I had to peal off some kind of glue pad from side opposite of the connector. Is it possible that I broke the eMMC doing that? Any other ideas in fixing that issue?

User avatar
odroid
Site Admin
Posts: 36465
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1451 times
Been thanked: 988 times
Contact:

Re: Artifacts after booting CoreELec from eMMC

Post by odroid »

The black eMMC should work with N2.

Try flashing the CoreELEC OS image into the eMMC freshly with Etcher.
Do you have a USB card reader with an eMMC-to-microSD adapter board?
viewtopic.php?f=53&t=2725

BTW, don't remove the plastic double side tape from the eMMC module.
It is a sort of rider.

snoopyx
Posts: 11
Joined: Thu Aug 02, 2018 1:26 am
languages_spoken: english
ODROIDs: C2
Has thanked: 2 times
Been thanked: 0
Contact:

Re: Artifacts after booting CoreELec from eMMC

Post by snoopyx »

Thanks for the info. Sadly I don't have access to a reader. Ordering one would take weeks and cost a lot due to shipping as there is no distributor in Croatia.
I already removed that type of "heatpad thing", as I needed to remove the eMMC from the C2. Can you explain what you mean by rider?

Sent from my Aquaris X Pro using Tapatalk


User avatar
odroid
Site Admin
Posts: 36465
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1451 times
Been thanked: 988 times
Contact:

Re: Artifacts after booting CoreELec from eMMC

Post by odroid »

The plastic tape prevents the eMMC module from tilting and makes a stable mechanical as well as electrical connection.
So we call it a rider.

We will try to make a detail guide for flashing the eMMC module with a micro-USB cable via Petitboot feature in the SPI flash.
Give us a few days.

snoopyx
Posts: 11
Joined: Thu Aug 02, 2018 1:26 am
languages_spoken: english
ODROIDs: C2
Has thanked: 2 times
Been thanked: 0
Contact:

Re: Artifacts after booting CoreELec from eMMC

Post by snoopyx »

Thanks for the info. I'll guess I improvise something with isolation tape.

That would be great and no worries, I ain't in a rush.

User avatar
cdu13a
Posts: 336
Joined: Tue Jan 20, 2015 3:33 pm
languages_spoken: english
ODROIDs: C1, C2, XU4, HC1, N2
Has thanked: 16 times
Been thanked: 105 times
Contact:

Re: Artifacts after booting CoreELec from eMMC

Post by cdu13a »

@snoopyx Can you check what version of CoreELEC is currently installed on the sd card that you are trying to install on the emmc?

snoopyx
Posts: 11
Joined: Thu Aug 02, 2018 1:26 am
languages_spoken: english
ODROIDs: C2
Has thanked: 2 times
Been thanked: 0
Contact:

Re: Artifacts after booting CoreELec from eMMC

Post by snoopyx »

After overtime and finally dinner here the info: CoreElec 9.2.0, Build 18.4

Sent from my Aquaris X Pro using Tapatalk


pherrmann
Posts: 32
Joined: Wed Dec 11, 2019 7:11 pm
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: Artifacts after booting CoreELec from eMMC

Post by pherrmann »

snoopyx wrote:
Wed Jan 15, 2020 4:15 am
After overtime and finally dinner here the info: CoreElec 9.2.0, Build 18.4
CE is now at 9.2.1 stable and there are nightlies with a new kernel and stuff. Maybe try to update.
These users thanked the author pherrmann for the post:
snoopyx (Fri Jan 17, 2020 6:39 am)

snoopyx
Posts: 11
Joined: Thu Aug 02, 2018 1:26 am
languages_spoken: english
ODROIDs: C2
Has thanked: 2 times
Been thanked: 0
Contact:

Re: Artifacts after booting CoreELec from eMMC

Post by snoopyx »

Updated the install on the microSD to 9.2.1. and now I have a new problem: when I set the display Resolution to 4K I only see the top left quarter of the Kodi menu on my TV (Phillips 50PUS7304). Before the update everything worked fine.

Sent from my Aquaris X Pro using Tapatalk


User avatar
rooted
Posts: 8278
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 728 times
Been thanked: 307 times
Contact:

Re: Artifacts after booting CoreELec from eMMC

Post by rooted »

snoopyx wrote:Updated the install on the microSD to 9.2.1. and now I have a new problem: when I set the display Resolution to 4K I only see the top left quarter of the Kodi menu on my TV (Phillips 50PUS7304). Before the update everything worked fine.

Sent from my Aquaris X Pro using Tapatalk
Set the resolution then go to the power menu and restart Kodi, I've been having a strange resolution issue on 9.2.1 on my 4K also and this fixes it. If I reboot I have to set the resolution and restart Kodi again.

snoopyx
Posts: 11
Joined: Thu Aug 02, 2018 1:26 am
languages_spoken: english
ODROIDs: C2
Has thanked: 2 times
Been thanked: 0
Contact:

Re: Artifacts after booting CoreELec from eMMC

Post by snoopyx »

I set the resolution several times, rebooted, changed back and forth, rebooted again, reversed to default, rebooted and so on. No help so far.

Sent from my Aquaris X Pro using Tapatalk


User avatar
cdu13a
Posts: 336
Joined: Tue Jan 20, 2015 3:33 pm
languages_spoken: english
ODROIDs: C1, C2, XU4, HC1, N2
Has thanked: 16 times
Been thanked: 105 times
Contact:

Re: Artifacts after booting CoreELec from eMMC

Post by cdu13a »

snoopyx wrote:
Fri Jan 17, 2020 4:39 am
Updated the install on the microSD to 9.2.1. and now I have a new problem: when I set the display Resolution to 4K I only see the top left quarter of the Kodi menu on my TV (Phillips 50PUS7304). Before the update everything worked fine.

Sent from my Aquaris X Pro using Tapatalk
I assume at some point you used kodi's built in "display calibration" feature to try and adjust overscan instead of adjusting the overscan on the TV. The new version handles the gui a little bit different then it did before(scaled gui at 4k vs non scaled gui at 4k) and kodi is using the settings from when you did the display calibration before without realizing that the values it has in it's saved calibration now mean something different then before.

This can be fixed by editing the /storage/.kodi/userdata/guisettings.xml file. It is important that kodi is not running when you edit this file otherwise kodi will just overwrite any edits you make to it.

So the best way to do so is by using the following commands via ssh. See below for information as to what changes we are making.

Code: Select all

systemctl stop kodi
nano /storage/.kodi/userdata/guisettings.xml
systemctl start kodi
In the guisettings.xml file you will find a <resolutions> tag containing may entries inside it that look like the following. One for each resolution and refresh rate combination that your system supports. This is how kodi saves the display calibration info it saves when you do a display calibration. You can either delete each of these sections or manually correct each one by editing the values in left, top, right, and bottom tags, but it is much easier just to delete them and let kodi sort the situation on when you restart it.

Code: Select all

        <resolution>
            <description>1920x1080 @ 60.00 - Full Screen</description>
            <subtitles>1042</subtitles>
            <pixelratio>1.000000</pixelratio>
            <overscan>
                <left>0</left>
                <top>0</top>
                <right>1920</right>
                <bottom>1080</bottom>
            </overscan>
        </resolution>

snoopyx
Posts: 11
Joined: Thu Aug 02, 2018 1:26 am
languages_spoken: english
ODROIDs: C2
Has thanked: 2 times
Been thanked: 0
Contact:

Re: Artifacts after booting CoreELec from eMMC

Post by snoopyx »

cdu13a, you mean delete everything inside <resolutions>? Just leave the following?
<resolutions>
</resolutions>

User avatar
cdu13a
Posts: 336
Joined: Tue Jan 20, 2015 3:33 pm
languages_spoken: english
ODROIDs: C1, C2, XU4, HC1, N2
Has thanked: 16 times
Been thanked: 105 times
Contact:

Re: Artifacts after booting CoreELec from eMMC

Post by cdu13a »

snoopyx wrote:
Fri Jan 17, 2020 5:38 am
cdu13a, you mean delete everything inside <resolutions>? Just leave the following?
<resolutions>
</resolutions>
yes delete everything between those two and just leave

Code: Select all

<resolutions>
</resolutions>
These users thanked the author cdu13a for the post:
snoopyx (Fri Jan 17, 2020 6:24 am)

snoopyx
Posts: 11
Joined: Thu Aug 02, 2018 1:26 am
languages_spoken: english
ODROIDs: C2
Has thanked: 2 times
Been thanked: 0
Contact:

Re: Artifacts after booting CoreELec from eMMC

Post by snoopyx »

cdu13a you wear exactly right. Thanks for the solving the issue concerning the resolution. Note another try with the eMMC module.

Sent from my Aquaris X Pro using Tapatalk


snoopyx
Posts: 11
Joined: Thu Aug 02, 2018 1:26 am
languages_spoken: english
ODROIDs: C2
Has thanked: 2 times
Been thanked: 0
Contact:

Re: Artifacts after booting CoreELec from eMMC

Post by snoopyx »

pherrman your advice apparently did the trick as well. Thanks to all for their involvement.

pherrmann
Posts: 32
Joined: Wed Dec 11, 2019 7:11 pm
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: Artifacts after booting CoreELec from eMMC

Post by pherrmann »

snoopyx wrote:
Fri Jan 17, 2020 6:40 am
pherrman your advice apparently did the trick as well. Thanks to all for their involvement.
Cool :)

mxxmmxxm
Posts: 2
Joined: Tue Jul 16, 2019 7:04 am
languages_spoken: english
Has thanked: 0
Been thanked: 1 time
Contact:

Re: [SOLVED] Artifacts after booting CoreELec from eMMC

Post by mxxmmxxm »

snoopyx, are you still having the eMMC issue? I'm on the 20200116 Nightly CoreElec and when i have any card in the eMMC slot, i seem to have the same weird video artifacting in CoreElec (even if it's booting & running from microsd)

snoopyx
Posts: 11
Joined: Thu Aug 02, 2018 1:26 am
languages_spoken: english
ODROIDs: C2
Has thanked: 2 times
Been thanked: 0
Contact:

Re: [SOLVED] Artifacts after booting CoreELec from eMMC

Post by snoopyx »

No. After the update of the microSD install to 9.2.1 and transfer to eMMC via 'installtoemmc' everything works fine.

Sent from my Aquaris X Pro using Tapatalk



Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 14 guests