HDMI black screen issue for OS pie_20191213

Post Reply
ponots03
Posts: 21
Joined: Thu Jul 18, 2019 11:26 pm
languages_spoken: english
ODROIDs: odroid-n2
Has thanked: 8 times
Been thanked: 2 times
Contact:

HDMI black screen issue for OS pie_20191213

Unread post by ponots03 » Wed Dec 18, 2019 5:59 am

hi,

We encounter black screen on un-plugging and plugging HDMI for OS version https://wiki.odroid.com/odroid-n2/os_im ... e_20191213. After this happens, we need to reboot unit for the screen to come back.We are able to reproduce this consistently. This wasn't an issue for the 191028 OS version. I haven't tested the 1121 or 1205 version for this issue.

This was an issue both for TV as well as monitor. Same issue also happen when you use an external HDMI switch and toggle between odroid-n2 and some other device.

Please help with this. It looks like something changed from the 1028 version that caused this issue.

thanks!
These users thanked the author ponots03 for the post:
Helios (Fri Dec 20, 2019 9:46 am)

ponots03
Posts: 21
Joined: Thu Jul 18, 2019 11:26 pm
languages_spoken: english
ODROIDs: odroid-n2
Has thanked: 8 times
Been thanked: 2 times
Contact:

Re: HDMI black screen issue for OS pie_20191213

Unread post by ponots03 » Thu Jan 16, 2020 6:20 am

Hello, we see this same issue for the OS that was uploaded on 0110 also https://wiki.odroid.com/odroid-n2/os_im ... e_20200110.
Upon unplugging and plugging the HDMI cable to the odroid unit , we get black screen.
Is anyone of the hardkernel team able to replicate this ? If so, when is a resolution expected ?

the 102819 version of the OS did not have this issue. Subsequent releases have them.

thanks

joy
Posts: 993
Joined: Fri Oct 02, 2015 1:44 pm
languages_spoken: english
ODROIDs: ODROID-C1+, XU4, X
Has thanked: 39 times
Been thanked: 94 times
Contact:

Re: HDMI black screen issue for OS pie_20191213

Unread post by joy » Thu Jan 16, 2020 9:07 am

Hi @ponots03,

Can you share your boot.ini to check which hdmi resolution you're using and to replicate the issue with my environment?

ponots03
Posts: 21
Joined: Thu Jul 18, 2019 11:26 pm
languages_spoken: english
ODROIDs: odroid-n2
Has thanked: 8 times
Been thanked: 2 times
Contact:

Re: HDMI black screen issue for OS pie_20191213

Unread post by ponots03 » Thu Jan 16, 2020 9:46 am

hi joy, we have been using 1080p60Hz.

thanks

User avatar
tobetter
Posts: 4461
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 71 times
Been thanked: 296 times
Contact:

Re: HDMI black screen issue for OS pie_20191213

Unread post by tobetter » Thu Jan 16, 2020 12:31 pm

@ponots03, can you try to set autodetect as false in boot.ini?

ponots03
Posts: 21
Joined: Thu Jul 18, 2019 11:26 pm
languages_spoken: english
ODROIDs: odroid-n2
Has thanked: 8 times
Been thanked: 2 times
Contact:

Re: HDMI black screen issue for OS pie_20191213

Unread post by ponots03 » Thu Jan 16, 2020 2:24 pm

Hi @tobetter we have tried both true and false. Am curious, are you able to replicate the issue? We are able to consistently replicate the issue by simply unplugging and plugging back the HDMI. This is also the case when the odroid is one of the inputs for a HDMI switch.when you switch to another input and then back to odroid we get black screen.

User avatar
tobetter
Posts: 4461
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 71 times
Been thanked: 296 times
Contact:

Re: HDMI black screen issue for OS pie_20191213

Unread post by tobetter » Thu Jan 16, 2020 2:34 pm

ponots03 wrote:
Thu Jan 16, 2020 2:24 pm
Hi @tobetter we have tried both true and false. Am curious, are you able to replicate the issue? We are able to consistently replicate the issue by simply unplugging and plugging back the HDMI. This is also the case when the odroid is one of the inputs for a HDMI switch.when you switch to another input and then back to odroid we get black screen.
Earlier this issue was able to be reproducible easily but after some BSP update plus fixes, this issue is not hard to see. Many user had complaint about the same issue but not reporting now. Seems the issue still happens with a certain display model I have but it works after switching the value of autodetect.
Could you try to change the resolution, like 720p, and see if the issue still persist?
Would you please provide the display model and HDMI-switch what you are using?

ponots03
Posts: 21
Joined: Thu Jul 18, 2019 11:26 pm
languages_spoken: english
ODROIDs: odroid-n2
Has thanked: 8 times
Been thanked: 2 times
Contact:

Re: HDMI black screen issue for OS pie_20191213

Unread post by ponots03 » Fri Jan 17, 2020 6:34 am

Here's the relevant boot.ini setting.
# Display Auto Detection
setenv display_autodetect "false"

btw, note that in some case you have plug/un-plug 4x before getting the black screen issue.

TV/Monitors that we had issue with (basically all that we tried on show this issue)

Monitor(s)
LG 32MA68HY
LG 27MK60TM

TV
Hisense 55H9F

HDMI switch
HDMI Switch 4K HDMI Splitter-Techole


720p60Hz did not help.

ponots03
Posts: 21
Joined: Thu Jul 18, 2019 11:26 pm
languages_spoken: english
ODROIDs: odroid-n2
Has thanked: 8 times
Been thanked: 2 times
Contact:

Re: HDMI black screen issue for OS pie_20191213

Unread post by ponots03 » Thu Jan 23, 2020 12:45 am

hi @tobetter, any feedback on above ? I also wanted to bring up the fact again that 102819 version of the OS did not show this problem. Is that potentially helpful ?

User avatar
tobetter
Posts: 4461
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 71 times
Been thanked: 296 times
Contact:

Re: HDMI black screen issue for OS pie_20191213

Unread post by tobetter » Thu Jan 23, 2020 1:03 am

ponots03 wrote:
Thu Jan 23, 2020 12:45 am
hi @tobetter, any feedback on above ? I also wanted to bring up the fact again that 102819 version of the OS did not show this problem. Is that potentially helpful ?
AFAIK, @joy made a patch for a similar issue and it's not been merged into Android Kernel yet while merged to Linux image. If you have a chance, can you try if Ubuntu also has a similar issue? Let me check if this issue tomorrow in the office.
These users thanked the author tobetter for the post:
ponots03 (Thu Jan 23, 2020 2:39 am)

Post Reply

Return to “Android”

Who is online

Users browsing this forum: No registered users and 1 guest