Micro USB port Odroid N2 not working

Post Reply
hightek
Posts: 2
Joined: Wed Dec 04, 2019 2:01 am
languages_spoken: english, Italian
ODROIDs: ODROID N2, ODROID XU4
Has thanked: 0
Been thanked: 0
Contact:

Micro USB port Odroid N2 not working

Post by hightek »

I took a new ODROID N2 but unfortunately the micro USB port, next to the eMMC switch, is not working. In order to test if it was a problem related to the installed OS versione, I have used the eMMC with another ODROID N2 and the micro USB interface works perfectly. So I am sure this is a hadware problem. What to do in this case?

User avatar
tobetter
Posts: 6649
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 331 times
Been thanked: 927 times
Contact:

Re: Micro USB port Odroid N2 not working

Post by tobetter »

How did you test the USB port?
Is any other host port working?

hightek
Posts: 2
Joined: Wed Dec 04, 2019 2:01 am
languages_spoken: english, Italian
ODROIDs: ODROID N2, ODROID XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: Micro USB port Odroid N2 not working

Post by hightek »

I have tested the interface by attaching a camera and typing the shell command: lsusb.
I have used 2 different ODROID N2 and 2 different eMMC with the OS installed

Using the damaged ODROID
  • I have attached the camera to the ODROID N2 with the first eMMC and I have verified if the camera is detected -> Result: NO DETECTED
  • I have attached the camera to the ODROID N2 with the second eMMC and I have verified if the camera is detected -> Result: NO DETECTED
  • I have, in both cases listed above, attached the camera to a different USB port, and it is perfectly detected
Using the working ODROID
I did the same passages listed above and in every case the camera IS DETECTED.

Since I have used two platforms and two OSs and I have tried all possible combinations obtaining the same result (camera detected on working ODROID and no detected on DAMAGED), I suppose that it is a hardware problem.

I can confirm that the other 4 USB ports work perfectly

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest