XU4 no boot, red led only

Post Reply
jrabe
Posts: 4
Joined: Tue Dec 03, 2019 4:23 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

XU4 no boot, red led only

Unread post by jrabe » Tue Dec 03, 2019 4:52 am

We received our order a month and a half ago. We measured the ODroid and other components to make some hardware to mount it on along with some other components.

Unfortunately one of the XU4's we ordered won’t boot now that we're getting into this project. The red led lights solid but the blue led never lights up. 5v (5.01v measured) and 3.3v (3.31v measured) are both good but there is no 1.8v on the board, its reading 0.003v. Is there a jumper or a setting I might be missing? I tried the power button, holding the power button. No change. I was testing the voltages with a level shifter shield installed on top. If I realized the warranty was only 30 days we would have tested this earlier.

I used Etcher with the ubuntu-18.04.3-4.9-mate-odroid-n2-20190812.img.xz from your site with both a Sandisk 16Gb and Samsung 32Gb UHS-1 micro sd cards. I also tried using 7zip in between the image download and Etcher for both. No change. I verified the sd / emmc switch is on sd.

Am i missing something / a step or is this board bad?

jrabe
Posts: 4
Joined: Tue Dec 03, 2019 4:23 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 no boot, red led only

Unread post by jrabe » Tue Dec 03, 2019 5:29 am

I flashed this image to the micro SD as recommended in another XU4 wont boot post on this forum, https://odroid.in/ubuntu_18.04lts/XU3_X ... 929.img.xz and it booted.

I am struggling with it to output video over hdmi though. Currently connected to a Xenarc 7" touchscreen, https://www.xenarc.com/709CNH-7-inch-IP ... nitor.html I'm going to check some other monitors first. I found the grounded HDMI cable thing too, I'll dig into that.

Is there something wrong with the image, ubuntu-18.04.3-4.9-mate-odroid-n2-20190812.img.xz thats posted on the ODroid wiki? It was this link, http://east.us.odroid.in/ubuntu_18.04lt ... 812.img.xz from the wiki here, https://wiki.odroid.com/getting_started ... tion_guide

jrabe
Posts: 4
Joined: Tue Dec 03, 2019 4:23 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 no boot, red led only

Unread post by jrabe » Tue Dec 03, 2019 6:12 am

Jumping the casing / outer metal housing of the HDMI port with the USB casing makes the HDMI port work and the touchscreen works.

Is everyone just connecting the usb housing with the HDMI housing together permanently? Was there a safer way to enable the HDMI output to work without doing the ground short technique? The HDMI cable is part of this touchscreen.

User avatar
odroid
Site Admin
Posts: 32677
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 209 times
Been thanked: 364 times
Contact:

Re: XU4 no boot, red led only

Unread post by odroid » Tue Dec 03, 2019 10:39 am

Our Vu7/Vu5 series has a common ground path and there was no such issue.
jrabe wrote:
Tue Dec 03, 2019 5:29 am
I found the grounded HDMI cable thing too, I'll dig into that.
Was it working? or not?

jrabe
Posts: 4
Joined: Tue Dec 03, 2019 4:23 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 no boot, red led only

Unread post by jrabe » Tue Dec 03, 2019 11:27 pm

The HDMI out was not working with the touchscreen until I jumped the USB metal outer housing to the HDMI outer housing. It just needs a jump to get the screen started, once its up it doesn't need the ground to be continuously jumped.

The touchscreen I'm using has the HDMI cable built into it. I can't swap out the cable.
What does Vu7/Vu5 mean?
When you say it has a common ground path, the HDMI port is supposed to be tied to ground in newer hardware versions? Is this through a capacitor, resistor, or directly to ground?

Is it possible to feed 5v into the XU4 through the shifter shield for XU4 power?
If its allowed, does it change the way it functions or bypass any safeties?

User avatar
odroid
Site Admin
Posts: 32677
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 209 times
Been thanked: 364 times
Contact:

Re: XU4 no boot, red led only

Unread post by odroid » Wed Dec 04, 2019 11:00 am

Vu7: https://www.hardkernel.com/shop/odroid- ... apability/
Vu5: https://www.hardkernel.com/shop/odroid- ... apability/

Yes, you can feed 5V via Shifter-Shied.
Please carefully look into the schematics.
http://dn.odroid.com/homebackup/XU4_SHI ... REV0.1.pdf

But it will bypass the over-voltage/over-current protection circuits near the XU4 barrel DC jack.
If you 5V source is very stable at 4Amp load, it will not be a problem.
Check the XU4 schematics too.
https://wiki.odroid.com/odroid-xu4/hard ... d_drawings

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 0 guests