buildroot OpenGL flickering on N2

Post Reply
brianli903
Posts: 2
Joined: Wed Nov 27, 2019 8:16 pm
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 0
Contact:

buildroot OpenGL flickering on N2

Unread post by brianli903 » Wed Nov 27, 2019 8:33 pm

I compiled a buildroot image following the instructions below.
https://wiki.odroid.com/odroid-n2/softw ... _buildroot

After booting the box, I run OpenGL sample binaries (e.g. /usr/share/arm/opengles_2.0/cube/cube) .
The animation is flickering. Looks like it's displaying alternative frames only (frame 1->3->5...).

Any potential reason causing this? HDMI resolution output issue or gfx/Mali driver issue?

User avatar
tobetter
Posts: 4263
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 58 times
Been thanked: 234 times
Contact:

Re: buildroot OpenGL flickering on N2

Unread post by tobetter » Thu Nov 28, 2019 1:53 am

Buildroot is not have been tested recently due to very less demand while Linux kernel 4.9.y branch is hugely grown up, but it should work...let me try it out. HDMI resolution is not a matter, but I suspect if a decent Mali driver is being copied.

brianli903
Posts: 2
Joined: Wed Nov 27, 2019 8:16 pm
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 0
Contact:

Re: buildroot OpenGL flickering on N2

Unread post by brianli903 » Mon Dec 02, 2019 4:49 pm

FYI. I am using 4G N2 board.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 0 guests