Very high idle temperatures XU4

Post Reply
mjp2017
Posts: 12
Joined: Fri Feb 10, 2017 3:43 pm
languages_spoken: english
ODROIDs: lots
Has thanked: 0
Been thanked: 1 time
Contact:

Very high idle temperatures XU4

Unread post by mjp2017 » Tue Nov 12, 2019 6:31 pm

Hello,

One of our XU4 fleet odroids ends on to my desk today being labelled as "broken". First I thought that the example unit was killed by failing fan (which is usually the case) of broken XU4s. The fan had died and I also noticed that emmc card was broken/corrupted. I installed a new emmc card and the device came into life again. But now it runs very hot without any load. Temperature seems to be hovering around 80c without any load and metallic parts are too hot touch. I checked a few other odroids from our production fleet and some have also very high idle temperatures compared to others and these units get around 95-97c with a full load while others nearly hit the 80s. I'm wondering if there others who have noticed this kind of behaviour. I'm thinking the fans are failing due to this increased temperature, not by the time they have been in use. If there is any way to detect if some of the internal parts of XU4 is broken down and causing this temperature rise this would be very nice to know to minimize downtime. (At first, I suspect faulty temp sensors, but the unit on my desk is very very hot indeed so I can rule that out on my theory).(board revision is: 0.1 20151201)

Currently, I need to replace around 2-4 units per month due to the failed fan or the temperatures are getting so high that cores can't keep on (I run them already on lower MHz and use industrial power sources).



Br, Mikko

User avatar
odroid
Site Admin
Posts: 32677
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 209 times
Been thanked: 364 times
Contact:

Re: Very high idle temperatures XU4

Unread post by odroid » Tue Nov 12, 2019 6:51 pm

Which OS image and Kernel version do you use?

User avatar
meveric
Posts: 10563
Joined: Mon Feb 25, 2013 2:41 pm
languages_spoken: german, english
ODROIDs: X2, U2, U3, XU-Lite, XU3, XU3-Lite, C1, XU4, C2, C1+, XU4Q, HC1, N1, Go, H2 (N4100), N2, H2 (J4105)
Has thanked: 19 times
Been thanked: 161 times
Contact:

Re: Very high idle temperatures XU4

Unread post by meveric » Tue Nov 12, 2019 10:00 pm

if you have 3 of the A15 cores running at 100% the temperature will nearly always rise to 95 °C.
2 cores at 100% is already over 80 °C. That is "sadly" normal.
Replacing fan can actually help a lot, I had to replace a failing fan on my XU3 as well, which resulted in a 10°C lower idle temperature.
Donate to support my work on the ODROID GameStation Turbo Image for U2/U3 XU3/XU4 X2 X C1 as well as many other releases.
Check out the Games and Emulators section to find some of my work or check the files in my repository to find the software i build for ODROIDs.
If you want to add my repository to your image read my HOWTO integrate my repo into your image.

mjp2017
Posts: 12
Joined: Fri Feb 10, 2017 3:43 pm
languages_spoken: english
ODROIDs: lots
Has thanked: 0
Been thanked: 1 time
Contact:

Re: Very high idle temperatures XU4

Unread post by mjp2017 » Tue Nov 12, 2019 10:39 pm

odroid wrote:
Tue Nov 12, 2019 6:51 pm
Which OS image and Kernel version do you use?
Linux version 3.10.106-151 (root@1604_builder_armhf) (gcc version 4.9.4 (Ubuntu/Linaro 4.9.4-2ubuntu1~16.04) ) #1 SMP PREEMPT Wed Jan 3 02:56:52 UTC 2018

The problem is in the said device that I got very high IDLE temperatures when no cores are actually in use. We use this Linux version on all our Xu4s.

br. Mikko

User avatar
odroid
Site Admin
Posts: 32677
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 209 times
Been thanked: 364 times
Contact:

Re: Very high idle temperatures XU4

Unread post by odroid » Wed Nov 13, 2019 8:45 am

Kernel version looks fine.

Let's try to find clues to narrow down root causes.
1. Check "htop" output to monitor CPU loads and CPU governor.
2. Compare the power consumption with a normal XU4 by a laboratory power supply or our SmartPower2.
3. Check the status of the thermal paste/grease under the cooler.
4. Any possible way to use the XU4Q (a fan-less version of the XU4)

User avatar
mad_ady
Posts: 6858
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 235 times
Been thanked: 177 times
Contact:

Re: Very high idle temperatures XU4

Unread post by mad_ady » Wed Nov 13, 2019 2:56 pm

Also check with top. I found that when a kernel thread is locked at 100% htop doesn't show it by default, while top does.
Also fsck your storage card. Un fscked issues caused high load for me in the past...

mjp2017
Posts: 12
Joined: Fri Feb 10, 2017 3:43 pm
languages_spoken: english
ODROIDs: lots
Has thanked: 0
Been thanked: 1 time
Contact:

Re: Very high idle temperatures XU4

Unread post by mjp2017 » Wed Nov 13, 2019 4:45 pm

odroid wrote:
Wed Nov 13, 2019 8:45 am
Kernel version looks fine.

Let's try to find clues to narrow down root causes.
1. Check "htop" output to monitor CPU loads and CPU governor.
2. Compare the power consumption with a normal XU4 by a laboratory power supply or our SmartPower2.
3. Check the status of the thermal paste/grease under the cooler.
4. Any possible way to use the XU4Q (a fan-less version of the XU4)
I think I found the problem. It was the replacement fan I installed (it was spinning but too slow). I replaced that fan when I checked the thermal paste (which was ok) and now with a new fan, the system temperatures are now in correct levels (51c idle). I did not measure the AMPs (I only have fluke meter here).

So now I'm making a new alert target for our monitoring system to show an alert if there dropped core messages on Syslog and then we replace odroid and service the fan on "broken" device.

Thanks for your help.

Best regards, Mikko
These users thanked the author mjp2017 for the post:
odroid (Wed Nov 13, 2019 4:51 pm)

rs677567
Posts: 7
Joined: Sat Nov 09, 2019 8:15 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Very high idle temperatures XU4

Unread post by rs677567 » Wed Nov 13, 2019 6:11 pm

mjp2017 wrote:
Wed Nov 13, 2019 4:45 pm
I think I found the problem. It was the replacement fan I installed (it was spinning but too slow).
I had a similar issue where the fan didn't spin at all. It was a bit dirty but I didn't remember if it was supposed to spin idle or not, as I didn't use my Odroid for a long time. Cleaning the bits between the fan and its motor with canned air and then spraying it with silicone based lubricant solved the issue for me.

User avatar
rooted
Posts: 6878
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 267 times
Been thanked: 58 times
Contact:

Re: Very high idle temperatures XU4

Unread post by rooted » Thu Nov 14, 2019 1:47 am

The biggest issue with high idle temperatures is having the governor set to performance.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 0 guests