XFCE Terminal, LXTERMINAL and Guake not working

Post Reply
smaTc
Posts: 2
Joined: Tue Oct 01, 2019 8:36 pm
languages_spoken: english
ODROIDs: ODROID-N2
Has thanked: 0
Been thanked: 0
Contact:

XFCE Terminal, LXTERMINAL and Guake not working

Unread post by smaTc » Tue Oct 01, 2019 8:43 pm

XFCE, LXTERMINAL and Guake Terminal is not working anymore after System Update on Arch or Manjaro. I tested both systems and after updating the system with pacman the terminals don't work. The XFCE/LXTERMINAL just closes instantly and Guake just shows and empty Tab when visible. Xterm is working. Desktop is XFCE, but I also testet LXDE with the same problem. Any idea how to solve this?

User avatar
mad_ady
Posts: 6674
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 194 times
Been thanked: 148 times
Contact:

Re: XFCE Terminal, LXTERMINAL and Guake not working

Unread post by mad_ady » Tue Oct 01, 2019 11:55 pm

What's your shell in /etc/passwd?
Do you get any message in xterm if you try to run xfce4-terminal from within xterm?

smaTc
Posts: 2
Joined: Tue Oct 01, 2019 8:36 pm
languages_spoken: english
ODROIDs: ODROID-N2
Has thanked: 0
Been thanked: 0
Contact:

Re: XFCE Terminal, LXTERMINAL and Guake not working

Unread post by smaTc » Wed Oct 02, 2019 8:32 pm

No I also tried so see if there are any error messages if I start the other terminals with xterm. I forgot to mention this.

/etc/passwd output is:

Code: Select all

root:x:0:0::/root:/bin/bash
bin:x:1:1::/:/usr/bin/nologin
daemon:x:2:2::/:/usr/bin/nologin
mail:x:8:12::/var/spool/mail:/usr/bin/nologin
ftp:x:14:11::/srv/ftp:/usr/bin/nologin
http:x:33:33::/srv/http:/usr/bin/nologin
nobody:x:65534:65534:Nobody:/:/usr/bin/nologin
dbus:x:81:81:System Message Bus:/:/usr/bin/nologin
systemd-journal-remote:x:982:982:systemd Journal Remote:/:/usr/bin/nologin
systemd-network:x:981:981:systemd Network Management:/:/usr/bin/nologin
systemd-resolve:x:980:980:systemd Resolver:/:/usr/bin/nologin
systemd-timesync:x:979:979:systemd Time Synchronization:/:/usr/bin/nologin
systemd-coredump:x:978:978:systemd Core Dumper:/:/usr/bin/nologin
uuidd:x:68:68::/:/usr/bin/nologin
avahi:x:977:977:Avahi mDNS/DNS-SD daemon:/:/usr/bin/nologin
colord:x:976:976:Color management daemon:/var/lib/colord:/usr/bin/nologin
git:x:975:975:git daemon user:/:/usr/bin/git-shell
lightdm:x:974:974:Light Display Manager:/var/lib/lightdm:/usr/bin/nologin
polkitd:x:102:102:PolicyKit daemon:/:/usr/bin/nologin
rtkit:x:133:133:RealtimeKit:/proc:/usr/bin/nologin
usbmux:x:140:140:usbmux user:/:/usr/bin/nologin
od-n2:x:1000:1000:N2,,,,:/home/od-n2:/bin/bash

Andrew57
Posts: 3
Joined: Sat Jun 01, 2019 11:27 pm
languages_spoken: english
ODROIDs: Odroid N2 4GB
Has thanked: 0
Been thanked: 0
Contact:

Re: XFCE Terminal, LXTERMINAL and Guake not working

Unread post by Andrew57 » Thu Oct 10, 2019 9:06 pm

I too hit this problem with LXterminal exiting silently when started. lxterminal -v gives the version as 0.3.2 which is a year old, so unlikely to be the problem. However lxterminal is a wrapper around libvte which actually does the grunt work of terminal emulation. I think libvte is also used by the other terminal programs you mention.
libvte belongs to the package vte3 which has been updated recently. The temporary fix for this problem is to downgrade the installed vte3 package to version 56.
pacman -U /var/cache/pacman/pkg/vte3-0.56.3-1-aarch64.pkg.tar.xz
and now lxterminal is working for me again!

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest