Flashing red powed LED

Post Reply
omvistus
Posts: 4
Joined: Sun Jul 17, 2016 8:00 pm
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Flashing red powed LED

Post by omvistus »

I shutdown my XU4 last night and went to power it up this morning and there's nothing but the power LED flashing red. The heat sink fan never spins up, and the board seems unresponsive. Changing SD cards doesn't help, neither does a different power supply. I can't seem to find any info regarding a flashing red LED on the XU4. It's a shame seeing as this board is just under 3 years old. I don't suppose it's salvageable in any way, would it?

mad_ady
Posts: 8315
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 573 times
Been thanked: 434 times
Contact:

Re: Flashing red powed LED

Post by mad_ady »

Check that the boot switch is in the sd position (wiggle it a bit if necessary).
Also try to start it with everything but power disconnected.

User avatar
odroid
Site Admin
Posts: 34849
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 927 times
Been thanked: 758 times
Contact:

Re: Flashing red powed LED

Post by odroid »

If the red LED is not solid on, some portion of the PMIC, DRAM or CPU could be damaged by uncertain electrical shock.
Sorry about that.

omvistus
Posts: 4
Joined: Sun Jul 17, 2016 8:00 pm
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: Flashing red powed LED

Post by omvistus »

Well, I guess I need to buy a replacement then.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest