Two ODROID XU4 dead

Post Reply
famo5
Posts: 5
Joined: Tue Sep 10, 2019 12:53 am
languages_spoken: English
ODROIDs: XU4 and N2
Has thanked: 0
Been thanked: 0
Contact:

Two ODROID XU4 dead

Unread post by famo5 » Tue Sep 10, 2019 9:35 am

Hi,

I bought a couple ODROID XU4 boards from ameriDroid in Jan 2019. One died within a couple months of idling. and ameriDroid said they only have a 30-day warranty. Oh well, bad luck I thought. Perhaps a bad unit.

Now, eight months later, the second XU4 board has died.
- No Red LED when plugged in.
- The power supply is the recommended one (5V, 4A) and is showing 5.2V.
- Between pins 1 and 2 of CON10, I get 0.09V. And similar voltage at various places on the board.

Another interesting thing is that I hear a click-click-click noise when I plug the power in. At about a rate of four per second. It goes off when the power is disconnected. The board also gets warm, though not hot. The click-click-click noise happens only on the board that just died a few days ago, not the one that died early on in Feb.

I read other posts on the forum, and it was suggested I remove the IC TPS259251. Unfortunately, I haven't got a soldering iron or skills to do that.

Any help would be appreciated.
Thanks

User avatar
odroid
Site Admin
Posts: 32104
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 115 times
Been thanked: 287 times
Contact:

Re: Two ODROID XU4 dead

Unread post by odroid » Tue Sep 10, 2019 9:54 am

Which USB devices have you used with the XU4 boards?
Did you connect any peripherals to the 30pin header connector?

famo5
Posts: 5
Joined: Tue Sep 10, 2019 12:53 am
languages_spoken: English
ODROIDs: XU4 and N2
Has thanked: 0
Been thanked: 0
Contact:

Re: Two ODROID XU4 dead

Unread post by famo5 » Tue Sep 10, 2019 10:50 am

The one that died in February had only an Ethernet and a power cable connected.

The one that died a few days ago and is making the clicking noises had an Anker USB-to-Ethernet RTL8153 adapter. I was using it as a router.

Neither boards ever had anything connected to 30pin header or had any other connections.

User avatar
odroid
Site Admin
Posts: 32104
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 115 times
Been thanked: 287 times
Contact:

Re: Two ODROID XU4 dead

Unread post by odroid » Tue Sep 10, 2019 12:28 pm

Thank you for the answers.
But there is no clue how/why your XU4 was dead by uncertain electrical shock.
Sorry about that.

famo5
Posts: 5
Joined: Tue Sep 10, 2019 12:53 am
languages_spoken: English
ODROIDs: XU4 and N2
Has thanked: 0
Been thanked: 0
Contact:

Re: Two ODROID XU4 dead

Unread post by famo5 » Tue Sep 10, 2019 12:36 pm

Is there a reasonably economical way to RMA the two devices?

User avatar
odroid
Site Admin
Posts: 32104
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 115 times
Been thanked: 287 times
Contact:

Re: Two ODROID XU4 dead

Unread post by odroid » Tue Sep 10, 2019 1:16 pm

Two way shipping cost from/to the US to/from Korea is too expensive.
Also consider we can't repair it if CPU or DRAM or PMIC is damaged though.

BTW, did you use the XU4 board with a plastic case or enclosure?

User avatar
mad_ady
Posts: 6519
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 163 times
Been thanked: 125 times
Contact:

Re: Two ODROID XU4 dead

Unread post by mad_ady » Tue Sep 10, 2019 2:16 pm

You may be able to follow this guide if you go to a local phone repair shop. They should have the tools and skills necessary.
https://wiki.odroid.com/odroid-xu4/trou ... _ic_ncp372

famo5
Posts: 5
Joined: Tue Sep 10, 2019 12:53 am
languages_spoken: English
ODROIDs: XU4 and N2
Has thanked: 0
Been thanked: 0
Contact:

Re: Two ODROID XU4 dead

Unread post by famo5 » Tue Sep 10, 2019 9:41 pm

@odroid: The one that died early had a plastic enclosure with the blue heatsink it came with. For the other one, I invested in an a machined aluminium heatsink (https://www.youtube.com/watch?v=GvqoWKBJDsA). htop reported fair temperatures (~ 40C). Also, I don't think it could be due to any uncertain electrical shock: I have multiple devices (Rock64, Odroid N2, and Raspberry Pi) connected to the outlet, which is plugged into a Cyberpower UPS/Surge Protector. None of the other devices have failed.

@mad_ady: Thanks for the link! It looks promising. I'll give it a try.

famo5
Posts: 5
Joined: Tue Sep 10, 2019 12:53 am
languages_spoken: English
ODROIDs: XU4 and N2
Has thanked: 0
Been thanked: 0
Contact:

Re: Two ODROID XU4 dead

Unread post by famo5 » Tue Sep 10, 2019 10:12 pm

Oddly enough, the ODROID XU4 I've got only has one "over voltage protection IC" on board, and two on another.

This is the image:
20190910_090230.jpg
20190910_090230.jpg (545.31 KiB) Viewed 128 times
Last edited by famo5 on Tue Sep 10, 2019 11:52 pm, edited 1 time in total.

User avatar
mad_ady
Posts: 6519
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 163 times
Been thanked: 125 times
Contact:

Re: Two ODROID XU4 dead

Unread post by mad_ady » Tue Sep 10, 2019 10:44 pm

They are different revisions. I think the extra over voltage was added to handle extra load for USB HDDs.

User avatar
odroid
Site Admin
Posts: 32104
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 115 times
Been thanked: 287 times
Contact:

Re: Two ODROID XU4 dead

Unread post by odroid » Wed Sep 11, 2019 8:47 am

Here are PCB revision history and schematics.
https://wiki.odroid.com/odroid-xu4/hard ... on_history

Your second board version is 20170905 while the first one seems to be 20151201.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest