[Resolved] XU4Q has very high CPU usage on khubd

Post Reply
thach
Posts: 5
Joined: Thu Aug 29, 2019 6:50 am
languages_spoken: english
ODROIDs: XU4 XU4Q
Has thanked: 0
Been thanked: 0
Contact:

[Resolved] XU4Q has very high CPU usage on khubd

Unread post by thach » Thu Aug 29, 2019 6:56 am

I have 2 XU4 boards.

1- First board is XU4 with FAN, it worked for 2 years and suddenly dead last week, I will find another thread to check the reason why, no led, only little noise from circuits. :(
This board has 1 USB WIFI, 1 USB 720p camera from Hardkernel

2-The brand new XU4 Q, I just setup the same: 1 usb camera, 1 usb wifi.

The CPU is crazy high:

Code: Select all

Tasks: 137 total,   4 running, 133 sleeping,   0 stopped,   0 zombie
%Cpu(s):  1.2 us, 15.3 sy,  0.0 ni, 83.5 id,  0.0 wa,  0.0 hi,  0.0 si,  0.0 st
KiB Mem :  2038608 total,  1387496 free,   422248 used,   228864 buff/cache
KiB Swap:        0 total,        0 free,        0 used.  1580759 avail Mem

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND
   55 root      20   0       0      0      0 R  58.9  0.0   4:20.92 khubd
 1004 root      20   0       0      0      0 R  14.6  0.0   0:27.55 kworker/5:0
  241 root      20   0       0      0      0 S  13.6  0.0   1:12.40 kworker/6:2
   60 root      20   0       0      0      0 S  13.2  0.0   1:13.01 kworker/7:1
   68 root      20   0       0      0      0 S  13.2  0.0   1:12.82 kworker/4:1
  800 root      20   0  199320  60924  13980 S   9.3  3.0   0:39.97 motion
 1009 root      20   0       0      0      0 R   5.6  0.0   0:01.96 kworker/0:1
 1008 root      20   0       0      0      0 S   5.0  0.0   0:01.38 kworker/2:1
   73 root      20   0       0      0      0 S   4.6  0.0   0:06.39 kworker/1:1
 1012 root      20   0       0      0      0 S   3.0  0.0   0:00.09 kworker/3:0
  945 root      20   0       0      0      0 S   1.7  0.0   0:05.91 kworker/3:2
 1011 root      20   0    6680   1540   1020 R   0.7  0.1   0:00.11 top
  279 root      20   0   12256   2116   1020 S   0.3  0.1   0:03.55 systemd-udevd
  482 root      20   0   55716  14796   4284 S   0.3  0.7   0:02.14 meyectl
  756 root      20   0  414348  40676   4548 S   0.3  2.0   0:09.60 hass
  775 root      20   0    3432   1052    788 S   0.3  0.1   0:00.24 tincd
    1 root      20   0   24112   3264   1856 S   0.0  0.2   0:10.96 systemd
    2 root      20   0       0      0      0 S   0.0  0.0   0:00.01 kthreadd
    3 root      20   0       0      0      0 S   0.0  0.0   0:00.03 ksoftirqd/0
    4 root      20   0       0      0      0 S   0.0  0.0   0:00.00 kworker/0:0
    
Nothing is running, just plugged those USB and it shows like that.

Here is the version:

Code: Select all

Linux odroid 3.10.96-113 #1 SMP PREEMPT Wed Jul 6 22:19:28 UTC 2016 armv7l armv7l armv7l GNU/Linux
root@odroid:~#
Any idea how to fix this, if CPU is at this high, I think the new board will be killed soon by heat.

Thank you!
Last edited by thach on Thu Aug 29, 2019 7:29 am, edited 1 time in total.

thach
Posts: 5
Joined: Thu Aug 29, 2019 6:50 am
languages_spoken: english
ODROIDs: XU4 XU4Q
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4Q has very high CPU usage on khubd

Unread post by thach » Thu Aug 29, 2019 7:05 am

I tried to upgrade:

Code: Select all


oot@odroid:~# sudo apt update && sudo apt upgrade && sudo apt dist-upgrade
Hit:1 http://ppa.launchpad.net/deadsnakes/ppa/ubuntu xenial InRelease
Hit:2 http://deb.odroid.in/5422 xenial InRelease
Hit:3 http://ports.ubuntu.com/ubuntu-ports xenial InRelease
Hit:4 http://ppa.launchpad.net/saiarcot895/myppa/ubuntu xenial InRelease
Hit:5 http://ports.ubuntu.com/ubuntu-ports xenial-updates InRelease
Hit:6 http://ports.ubuntu.com/ubuntu-ports xenial-backports InRelease
Hit:7 http://ports.ubuntu.com/ubuntu-ports xenial-security InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  linux-image-xu3
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  linux-image-xu3
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
root@odroid:~#

And problem is still remaining...

thach
Posts: 5
Joined: Thu Aug 29, 2019 6:50 am
languages_spoken: english
ODROIDs: XU4 XU4Q
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4Q has very high CPU usage on khubd

Unread post by thach » Thu Aug 29, 2019 7:14 am

Just upgraded kernel,
https://odroid.com/dokuwiki/doku.php?id ... e_20161011

sudo apt install linux-image-xu3
sudo reboot

Now it's better, no more khubd and kworker

thach
Posts: 5
Joined: Thu Aug 29, 2019 6:50 am
languages_spoken: english
ODROIDs: XU4 XU4Q
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4Q has very high CPU usage on khubd

Unread post by thach » Thu Aug 29, 2019 7:29 am

Resolved!

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest