Unusable display after install

Post Reply
Ampere
Posts: 4
Joined: Tue Jul 23, 2019 6:20 pm
languages_spoken: english
ODROIDs: odroid c2/odroid n2
Has thanked: 0
Been thanked: 0
Contact:

Unusable display after install

Unread post by Ampere » Sat Aug 10, 2019 7:37 am

Hi all,
Have ubuntu running fine, thought i give android a go.
Did a clean flash with the latest image, installs fine.
When booting up after the android logo my screen gets all distorted, when reaching the desktop i have four desktops but unusable.
I have a freesync monitor, can that be related ?
I have the same with lineageos, coreelec and ubuntu are running fine.
Thank you....

Luke.go
Posts: 327
Joined: Mon May 30, 2016 1:55 pm
languages_spoken: english
Has thanked: 4 times
Been thanked: 6 times
Contact:

Re: Unusable display after install

Unread post by Luke.go » Mon Aug 12, 2019 10:25 am

If you can edit /odm/boot.ini on the android, please try followings.

set hdmi resolution to here.

Code: Select all

setenv hdmimode "[resolution_value at above list]"
and change display_autodetect value to false

Code: Select all

setenv display_autodetect "false"
and reboot the board.

Please let me know result. :)

Ampere
Posts: 4
Joined: Tue Jul 23, 2019 6:20 pm
languages_spoken: english
ODROIDs: odroid c2/odroid n2
Has thanked: 0
Been thanked: 0
Contact:

Re: Unusable display after install

Unread post by Ampere » Thu Aug 15, 2019 11:11 pm

thanks for the suggestion, but unfortunately it stays the same
i used
setenv hdmimode "2560x1440p60hz" my native resolution
setenv display_autodetect "false"
I flashed the latest release, to no avail

milesian
Posts: 9
Joined: Fri Nov 10, 2017 6:52 am
languages_spoken: english
ODROIDs: xu4
Has thanked: 6 times
Been thanked: 1 time
Contact:

Re: Unusable display after install

Unread post by milesian » Fri Aug 16, 2019 12:10 am

I had this exact problem at the exact same resolution. Going down to x1080 solved the issue, but that's a bummer. My monitor is not freesync so that shouldn't be the cause.

OP, is there a 50 Hz at x1440 resolution you can try? I had success with that fixing similar problem on the Lineage OS ROM.



Sent from my ONEPLUS A5000 using Tapatalk


Ampere
Posts: 4
Joined: Tue Jul 23, 2019 6:20 pm
languages_spoken: english
ODROIDs: odroid c2/odroid n2
Has thanked: 0
Been thanked: 0
Contact:

Re: Unusable display after install

Unread post by Ampere » Sat Aug 17, 2019 9:04 pm

thank you, lowering the resolution worked for both android and lineage
they are now both in "1920x1200p60hz".
Its unfortunate my native res does not work, but now i have a usable screen at least.

Post Reply

Return to “Android”

Who is online

Users browsing this forum: Google [Bot], gsgs and 1 guest