XU4 with 2 HD

Post Reply
artonge
Posts: 4
Joined: Sat Dec 08, 2018 12:33 am
languages_spoken: english, french
ODROIDs: XU4, H2
Has thanked: 0
Been thanked: 0
Contact:

XU4 with 2 HD

Unread post by artonge » Thu Jul 11, 2019 10:38 pm

Hi,

I'm trying to build a server with an XU4 and two HD but they are making clicking noises.
I don't have much knowledge on hardware and power supply so I have some trouble investigate what is going wrong, but I suspect a lack of power making them reboot.

Here are some informations about the parts:
- Power supply: 5V 6A (https://www.aliexpress.com/item/3272747 ... 4c4dk1URQQ)
- 2x HD: 1To 2.5" Seagate Barracuda compute marked as consuming +5V 1.0A
- 2x SATA to USB cables (https://www.aliexpress.com/item/3279363 ... 4c4dMfDwk5)

Here some observations:
- It only do clicking noises when both HD are plugged, usually on boot or when I try to mount them both.
- I have the same setup in some remote location and the HD seems to run fine, but I don't now if they click.

Here are some questions:
- Is the XU4 supposed to be able to power two 2.5" HD ?
- If not, can I use some PSU to power the XU4 and the HD ? I couldn't find any with a jack port for the XU4 and two SATA power ports for the drives. And how can I connect the HD to the XU4 ?
- I have read that it can be useful to clean the USB ports, but I was from a 2015 thread and apparently Hardkernel now cleans the ports during manufacturing. Is it still relevant ?
- Do you have any idea how to investigate ? I have an UART kit, but never used it.
- Are the HD drawing to much power ? If so, are there other HD the will draw less ? If so do you have any reference ?

Thanks a lot for your help,

artonge

User avatar
odroid
Site Admin
Posts: 31381
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 54 times
Been thanked: 184 times
Contact:

Re: XU4 with 2 HD

Unread post by odroid » Fri Jul 12, 2019 8:21 am

Each USB 3.0 port supply 900mA on the XU4.
But many external USB 3.0 HDDs peak current(in-rush current) could be up to 1200mA.

If you have a DMM, please measure the voltage between 5V0 and GND on the 30pin header.
https://wiki.odroid.com/odroid-xu4/hard ... _2x15_pins
It must be stable at 4.8volt at least in the starting process after power-on.

artonge
Posts: 4
Joined: Sat Dec 08, 2018 12:33 am
languages_spoken: english, french
ODROIDs: XU4, H2
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 with 2 HD

Unread post by artonge » Fri Jul 12, 2019 5:41 pm

Hi, thanks for you answer.

Here are my measurements:
- During boot 0 HD: can go as low as 4.65
- During boot 1 HD: can go as low as 4.50
- During boot 2 HD: can go as low as 4.45

- After boot 0 HD: Stable at 5.05
- After boot 1 HD (0 mounted): Stable at 4.95
- After boot 2 HD (0 mounted): Stable at 4.83

- After boot 2 HD (1 mounted): 4.75 - 4.85
- After boot 2 HD (2 mounted): 4.70 - 4.80

I wish I could make some cool graphs to better see the evolution.

Do you think a more powerful power supply could make it work ? Like a 5V 8A one ? I have no Idea if the voltage drop can be compensated by adding more Amperes.

phaseshifter
Posts: 3433
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: U-2,U3+,,XU-3,,XU3-LITE,,XU-4
C1+,,C-2,,,
N-1,,N-2,...other odroid acc`s as well
Has thanked: 34 times
Been thanked: 38 times
Contact:

Re: XU4 with 2 HD

Unread post by phaseshifter » Sat Jul 13, 2019 6:04 pm

i think you do require more current not voltage..your very border line with the boot voltages and running voltages are on the borderline too.....prolly caused by your hdds drawing inrush currents..etc.etc

i think if you went to 8 Amp it should be enough..i would query the power supply your using,,,it should do the job ..check maybe re-frlash it. again when you get an new supply,
.make shure you use 15/18 awg gauge wiring for the load this will stop load drop from the supply....

from boot..this is not good...also i would check your media..not kingston pls...

you media may have been corrupted from the voltage drop outs,,
the 8 amp should do the job no trouble there unless it has poor initial out rush/inrush from the load..etc..etc,,,.

when you turn the power supply get an 8-10 inch screwdriver star is best but flat-blade will do..put your ear onto the plastic handle while you put the other end onto the supply case can you hear the ticking...etc,etc,,...
i think that it is faulty..some where in the power supply circuit ..i`m not going into specifics ...of how and why....
Build It And They Will Come...Be Bold And Mighty Forces Will Come To Your Aid..!!!

User avatar
odroid
Site Admin
Posts: 31381
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 54 times
Been thanked: 184 times
Contact:

Re: XU4 with 2 HD

Unread post by odroid » Mon Jul 15, 2019 11:17 am

I think an external powered-hub will be a much more stable solution if you keep using two HDDs.

artonge
Posts: 4
Joined: Sat Dec 08, 2018 12:33 am
languages_spoken: english, french
ODROIDs: XU4, H2
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 with 2 HD

Unread post by artonge » Mon Jul 15, 2019 11:35 pm

Thanks @phaseshifter for you answer. I never saw the advice to use a 8A power supply for the XU4, will it be ok ? wouldn't it risk to damage it ?
@odroid, do you have an opinion about that ?

@odroid, I would really prefer to avoid an external power supply because I don't want to have two power supplies for the setup.

The hard drives that are causing trouble are 7200 rmp and the ones that work are 5400. Maybe if I only use 5400 HD it will be ok as they don't draw as much power. I ordered two to check that.
Last edited by artonge on Thu Jul 18, 2019 1:01 am, edited 1 time in total.

User avatar
odroid
Site Admin
Posts: 31381
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 54 times
Been thanked: 184 times
Contact:

Re: XU4 with 2 HD

Unread post by odroid » Tue Jul 16, 2019 8:41 am

You can use 8A or 100A PSU since XU4 takes what it needs.
But USB power path has a current limiter circuit on the board.

5400rpm HDDs must have lower power consumption.
Once you receive them, please let us know the test result.

phaseshifter
Posts: 3433
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: U-2,U3+,,XU-3,,XU3-LITE,,XU-4
C1+,,C-2,,,
N-1,,N-2,...other odroid acc`s as well
Has thanked: 34 times
Been thanked: 38 times
Contact:

Re: XU4 with 2 HD

Unread post by phaseshifter » Sun Jul 21, 2019 3:14 pm

5400 spinners will draw less current....you might do best to check the data sheets or specs on the hdds...before buying,,
old hdd`s will draw more current due to wear & and newer drives have better technology so may be much more efficient ..
ssd`s if you can use them you should not have a problem...
Build It And They Will Come...Be Bold And Mighty Forces Will Come To Your Aid..!!!

Post Reply

Return to “Hardware and peripherals”

Who is online

Users browsing this forum: No registered users and 1 guest