low perfromance when runing simple fragment shader

Post Reply
barakooda
Posts: 5
Joined: Mon Jul 08, 2019 11:58 pm
languages_spoken: english
ODROIDs: 2x N2
Has thanked: 3 times
Been thanked: 0
Contact:

low perfromance when runing simple fragment shader

Unread post by barakooda » Tue Jul 09, 2019 4:59 pm

I have the feeling it should run way faster.
https://hexler.net/products/kodelife#linux

keep up the great work.

B.
Attachments
Screenshot at 2019-07-09 07-56-36.png
Screenshot at 2019-07-09 07-56-36.png (836.83 KiB) Viewed 372 times
Screenshot at 2019-07-09 07-50-15.png
Screenshot at 2019-07-09 07-50-15.png (896.93 KiB) Viewed 372 times

crashoverride
Posts: 4471
Joined: Tue Dec 30, 2014 8:42 pm
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 52 times
Contact:

Re: low perfromance when runing simple fragment shader

Unread post by crashoverride » Tue Jul 09, 2019 6:07 pm

Since its using CPU software emulation of a GPU, the performance is as expected.
These users thanked the author crashoverride for the post:
barakooda (Wed Jul 10, 2019 4:51 am)

barakooda
Posts: 5
Joined: Mon Jul 08, 2019 11:58 pm
languages_spoken: english
ODROIDs: 2x N2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: low perfromance when runing simple fragment shader

Unread post by barakooda » Wed Jul 10, 2019 4:49 am

thank you very much,
can you please explain how did you notice that ?
8-)

User avatar
meveric
Posts: 10279
Joined: Mon Feb 25, 2013 2:41 pm
languages_spoken: german, english
ODROIDs: X2, U2, U3, XU-Lite, XU3, XU3-Lite, C1, XU4, C2, C1+, XU4Q, HC1, N1, Go, H2 (N4100), N2
Has thanked: 13 times
Been thanked: 103 times
Contact:

Re: low perfromance when runing simple fragment shader

Unread post by meveric » Wed Jul 10, 2019 4:53 am

barakooda wrote:
Wed Jul 10, 2019 4:49 am
thank you very much,
can you please explain how did you notice that ?
8-)
That is very simple:

You run it on the desktop.
Desktop has no GPU acceleration at the moment, ergo you can only run it in software rendering ;)
Donate to support my work on the ODROID GameStation Turbo Image for U2/U3 XU3/XU4 X2 X C1 as well as many other releases.
Check out the Games and Emulators section to find some of my work or check the files in my repository to find the software i build for ODROIDs.
If you want to add my repository to your image read my HOWTO integrate my repo into your image.

barakooda
Posts: 5
Joined: Mon Jul 08, 2019 11:58 pm
languages_spoken: english
ODROIDs: 2x N2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: low perfromance when runing simple fragment shader

Unread post by barakooda » Wed Jul 10, 2019 5:09 am

o, cool - i`m not using linux too often,
I was assume the mali g52 is supported.

when it is planned to be supported with the ubuntu mate ?
any idea ? - it will ever be ?
should i get it myself somehow ?
https://www.cnx-software.com/2019/03/27 ... es2-score/

now i think it explain so many other issues i have.

User avatar
memeka
Posts: 4320
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 1 time
Been thanked: 12 times
Contact:

Re: low perfromance when runing simple fragment shader

Unread post by memeka » Wed Jul 10, 2019 6:58 am

Not on Ubuntu mate, that’s X11. I doubt it will ever work.
But on gnome3 on wayland, yes.
These users thanked the author memeka for the post:
barakooda (Thu Jul 11, 2019 7:31 pm)

barakooda
Posts: 5
Joined: Mon Jul 08, 2019 11:58 pm
languages_spoken: english
ODROIDs: 2x N2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: low perfromance when runing simple fragment shader

Unread post by barakooda » Wed Jul 10, 2019 12:13 pm

Thanks mate,
Why Odroid publish a board with os which not support all of its features ?

User avatar
meveric
Posts: 10279
Joined: Mon Feb 25, 2013 2:41 pm
languages_spoken: german, english
ODROIDs: X2, U2, U3, XU-Lite, XU3, XU3-Lite, C1, XU4, C2, C1+, XU4Q, HC1, N1, Go, H2 (N4100), N2
Has thanked: 13 times
Been thanked: 103 times
Contact:

Re: low perfromance when runing simple fragment shader

Unread post by meveric » Wed Jul 10, 2019 11:18 pm

The GPU drivers come from ARM (or AmLogic as a distributer of the SoC) and ARM decided to no longer support X11.
There are GPU drivers for fbdev where you can use GPU acceleration, but there are no GPU drivers for X11.
So GPU drivers DO exist, just X11 support was dropped by ARM.
These users thanked the author meveric for the post:
barakooda (Thu Jul 11, 2019 7:30 pm)
Donate to support my work on the ODROID GameStation Turbo Image for U2/U3 XU3/XU4 X2 X C1 as well as many other releases.
Check out the Games and Emulators section to find some of my work or check the files in my repository to find the software i build for ODROIDs.
If you want to add my repository to your image read my HOWTO integrate my repo into your image.

barakooda
Posts: 5
Joined: Mon Jul 08, 2019 11:58 pm
languages_spoken: english
ODROIDs: 2x N2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: low perfromance when runing simple fragment shader

Unread post by barakooda » Thu Jul 11, 2019 7:30 pm

Thank you very much for the explanation!

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 0 guests