Issue with USB ports & SD Card slot

Post Reply
User avatar
secuflag
Posts: 116
Joined: Sun Jun 16, 2019 12:12 am
languages_spoken: English, Italian
ODROIDs: N2 - C4
Location: Switzerland
Has thanked: 23 times
Been thanked: 59 times
Contact:

Issue with USB ports & SD Card slot

Post by secuflag » Sat Jun 29, 2019 2:32 am

Bad news here,

I received my N2 less than 7 days ago and today for no reason I realized that all the 4 USB ports and the MicroSD card slot stopped working :(

I tried to install ubuntu-18.04.2-4.9-mate-odroid-n2-20190325 on the eMMC and this is the output of lsusb with attached two WiFi dongle, a
mouse and a keyboard:
root@odroid:~# lsusb
Bus 002 Device 002: ID 05e3:0620 Genesys Logic, Inc.
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
I also tried with different USB keys formatted with FAT32, NTFS, exFAT, nothing, the same with Android booted from the eMMC.

I cannot boot anything from the MicroSD slot, the card seems to be not recognized.

I can boot into SPI mode but the USB keyboard isn't recognized and can't move up and down the menu.

Any help?
If you like my work feel free to contribute to buy me some beers. ;)

User avatar
tobetter
Posts: 5211
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 176 times
Been thanked: 545 times
Contact:

Re: Issue with USB ports & SD Card slot

Post by tobetter » Sat Jun 29, 2019 3:32 am

Do you see the red LED is on?
When you plug in your USB keyboard to the USB host, does the LED on the keyboard are on?

User avatar
secuflag
Posts: 116
Joined: Sun Jun 16, 2019 12:12 am
languages_spoken: English, Italian
ODROIDs: N2 - C4
Location: Switzerland
Has thanked: 23 times
Been thanked: 59 times
Contact:

Re: Issue with USB ports & SD Card slot

Post by secuflag » Sat Jun 29, 2019 7:23 am

tobetter wrote:
Sat Jun 29, 2019 3:32 am
Do you see the red LED is on?
Till now I never seen a red LED switched on on my board.
The only I can see is the blue one blinking when the system starts.
tobetter wrote:
Sat Jun 29, 2019 3:32 am
When you plug in your USB keyboard to the USB host, does the LED on the keyboard are on?
Nothing at all :cry:
If you like my work feel free to contribute to buy me some beers. ;)

User avatar
tobetter
Posts: 5211
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 176 times
Been thanked: 545 times
Contact:

Re: Issue with USB ports & SD Card slot

Post by tobetter » Sat Jun 29, 2019 11:11 am

secuflag wrote:
Sat Jun 29, 2019 7:23 am
tobetter wrote:
Sat Jun 29, 2019 3:32 am
Do you see the red LED is on?
Till now I never seen a red LED switched on on my board.
The only I can see is the blue one blinking when the system starts.
tobetter wrote:
Sat Jun 29, 2019 3:32 am
When you plug in your USB keyboard to the USB host, does the LED on the keyboard are on?
Nothing at all :cry:
By any chance, are you able to measure the voltage at pin #2 and #4 on GPIO pin header?
https://wiki.odroid.com/_detail/odroid- ... connectors

Would you please capture the photo of LED when powered on?

User avatar
secuflag
Posts: 116
Joined: Sun Jun 16, 2019 12:12 am
languages_spoken: English, Italian
ODROIDs: N2 - C4
Location: Switzerland
Has thanked: 23 times
Been thanked: 59 times
Contact:

Re: Issue with USB ports & SD Card slot

Post by secuflag » Sat Jun 29, 2019 11:55 pm

On PIN #2 and #4: 44.5 mV

This is what happens when connect the power source, ubuntu-18.04.2-4.9-mate-odroid-n2-20190325 on the MMC. https://www.dropbox.com/s/nm20fodqfd0c9 ... 190629.mp4

Thanks for your help tobetter!
If you like my work feel free to contribute to buy me some beers. ;)

User avatar
tobetter
Posts: 5211
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 176 times
Been thanked: 545 times
Contact:

Re: Issue with USB ports & SD Card slot

Post by tobetter » Sun Jun 30, 2019 12:08 am

secuflag wrote:
Sat Jun 29, 2019 11:55 pm
On PIN #2 and #4: 44.5 mV

This is what happens when connect the power source, ubuntu-18.04.2-4.9-mate-odroid-n2-20190325 on the MMC. https://www.dropbox.com/s/nm20fodqfd0c9 ... 190629.mp4

Thanks for your help tobetter!
Thanks for the video and check the voltage at the PIN #2 and #4.
Is the adapter from Hardkernel or you purchased one? If it's not Hardkernel one, please let me know a brand and a model.

Since your N2 defects somehow and if you like to have RMA, please send an email to odroid at hardkernel dot com if you have purchased from Hardkernel with the link of this thread or please contact with your local distributor.

Sorry about your N2 has a problem.

User avatar
secuflag
Posts: 116
Joined: Sun Jun 16, 2019 12:12 am
languages_spoken: English, Italian
ODROIDs: N2 - C4
Location: Switzerland
Has thanked: 23 times
Been thanked: 59 times
Contact:

Re: Issue with USB ports & SD Card slot

Post by secuflag » Sun Jun 30, 2019 6:26 am

My adapter: https://ibb.co/m0r2fdm

Yes I bought my N2 from Hardkernel, but before to ask a RMA I will check with another adapter.

Edit: Tested with another adapter, same result :cry:
If you like my work feel free to contribute to buy me some beers. ;)

User avatar
tobetter
Posts: 5211
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 176 times
Been thanked: 545 times
Contact:

Re: Issue with USB ports & SD Card slot

Post by tobetter » Mon Jul 01, 2019 8:34 pm

secuflag wrote:
Sun Jun 30, 2019 6:26 am
My adapter: https://ibb.co/m0r2fdm

Yes I bought my N2 from Hardkernel, but before to ask a RMA I will check with another adapter.

Edit: Tested with another adapter, same result :cry:
Sorry about that, please send an email to odroid at hardkernel dot com with any proof you purchased from Hardkernel and the link of this thread.

User avatar
secuflag
Posts: 116
Joined: Sun Jun 16, 2019 12:12 am
languages_spoken: English, Italian
ODROIDs: N2 - C4
Location: Switzerland
Has thanked: 23 times
Been thanked: 59 times
Contact:

Re: Issue with USB ports & SD Card slot

Post by secuflag » Fri Aug 16, 2019 9:16 pm

I'm here again, two weeks ago I received back my board from the RMA process, now I have, again, exactly the same problem like before.
This morning I powered up the board and surprise; No more red light (only the blue one is blinking), all the 4 USB ports and the MicroSD card slot stopped working.

Output from GPIO PINs:
#1: 3.3V
#2: ~45 mV
#4: ~45 mV

:( :( :(
If you like my work feel free to contribute to buy me some beers. ;)

User avatar
tobetter
Posts: 5211
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 176 times
Been thanked: 545 times
Contact:

Re: Issue with USB ports & SD Card slot

Post by tobetter » Sat Aug 17, 2019 12:12 am

secuflag wrote:
Fri Aug 16, 2019 9:16 pm
I'm here again, two weeks ago I received back my board from the RMA process, now I have, again, exactly the same problem like before.
This morning I powered up the board and surprise; No more red light (only the blue one is blinking), all the 4 USB ports and the MicroSD card slot stopped working.

Output from GPIO PINs:
#1: 3.3V
#2: ~45 mV
#4: ~45 mV

:( :( :(
That's odd. Would you let us know what devices are connected other than your adapter with the new board? Would you mind to share the picture of how the boards are set up as well?

User avatar
secuflag
Posts: 116
Joined: Sun Jun 16, 2019 12:12 am
languages_spoken: English, Italian
ODROIDs: N2 - C4
Location: Switzerland
Has thanked: 23 times
Been thanked: 59 times
Contact:

Re: Issue with USB ports & SD Card slot

Post by secuflag » Sat Aug 17, 2019 1:38 am

Nothing else than the HDMI and a old usb mouse still with cord, that's all.

[click on thumbnail]
Image
If you like my work feel free to contribute to buy me some beers. ;)

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest