Server

mad_ady
Posts: 8167
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 568 times
Been thanked: 408 times
Contact:

Re: Server

Post by mad_ady »

With a usb2 disk you can expect about 10-20MB/s throughput because of the drive.

dabarsa87
Posts: 189
Joined: Tue Feb 23, 2016 5:06 am
languages_spoken: spanish
Has thanked: 0
Been thanked: 1 time
Contact:

Re: Server

Post by dabarsa87 »

Well, I got the speeds it says but I do not understand because in the writing it starts at about 60mb and at the second it goes down to about 4.5mb in download with 110mb and all this from a pendrive 2.0

Enviado desde mi SM-G930F mediante Tapatalk


AreaScout
Posts: 1361
Joined: Sun Jul 07, 2013 3:05 am
languages_spoken: german, english
ODROIDs: X2, U3, XU3, C2, HiFi Shield, XU4, XU4Q,
N1, Go, VU5A, Show2, CloudShell2,
H2, N2, VU7A, VuShell, Go2, C4
Has thanked: 62 times
Been thanked: 195 times
Contact:

Re: Server

Post by AreaScout »

dabarsa87 wrote:
Sun Jun 30, 2019 3:54 am
Well, I got the speeds it says but I do not understand because in the writing it starts at about 60mb and at the second it goes down to about 4.5mb in download with 110mb and all this from a pendrive 2.0

Enviado desde mi SM-G930F mediante Tapatalk
No need to benchmark a pendrive here, they are different in speed, never once are of course faster, with HDD you will get rock solid 100MB/s on gigabit LAN, with a large file, if you upload a lot of small files it will not reach that speed but overall it's a fast NAS, regular available NAS drives mostly do not have such a powerful processor inside ;)

RG

dabarsa87
Posts: 189
Joined: Tue Feb 23, 2016 5:06 am
languages_spoken: spanish
Has thanked: 0
Been thanked: 1 time
Contact:

Re: Server

Post by dabarsa87 »

How do you see what the link I put?
https://obihoernchen.net/1235/odroid-xu ... ediavault/

Enviado desde mi SM-G930F mediante Tapatalk


AreaScout
Posts: 1361
Joined: Sun Jul 07, 2013 3:05 am
languages_spoken: german, english
ODROIDs: X2, U3, XU3, C2, HiFi Shield, XU4, XU4Q,
N1, Go, VU5A, Show2, CloudShell2,
H2, N2, VU7A, VuShell, Go2, C4
Has thanked: 62 times
Been thanked: 195 times
Contact:

Re: Server

Post by AreaScout »

    It looks like it's outdated, it's OMV 2.x and now we use OMV 4.x and 5.x is under it's way

    mad_ady
    Posts: 8167
    Joined: Wed Jul 15, 2015 5:00 pm
    languages_spoken: english
    ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
    Location: Bucharest, Romania
    Has thanked: 568 times
    Been thanked: 408 times
    Contact:

    Re: Server

    Post by mad_ady »

    dabarsa87 wrote:Well, I got the speeds it says but I do not understand because in the writing it starts at about 60mb and at the second it goes down to about 4.5mb in download with 110mb and all this from a pendrive 2.0

    Enviado desde mi SM-G930F mediante Tapatalk
    This is how write caching behaves. When you write files to a disk the cache (ram) is filled first (at top speed) and it gets written to disk (low speed). When the cache is full you notice a decrease in speed, because the system is waiting for the disk.

    dabarsa87
    Posts: 189
    Joined: Tue Feb 23, 2016 5:06 am
    languages_spoken: spanish
    Has thanked: 0
    Been thanked: 1 time
    Contact:

    Re: Server

    Post by dabarsa87 »

    I already configure transmissions to download torrents also in my browser add the extension remote transmission ++ to add the torrents or see the download status. Now I would like to see the images and the movies downloaded on my smart tv lg, if I need to install an app on my tv or it will look like an external hdd. Well for you to know a bit how I have my home network installed I tell you that the router of the company I have unplugged the wifi and I connected my pc, the odroid xu4 and I have a tplink router that is responsible for supplying cable internet to my smart tv in addition to the wifi this router I give signal by the wlan connector. If I need an app which ed and a guide to configure it?

    Enviado desde mi SM-G930F mediante Tapatalk


    mad_ady
    Posts: 8167
    Joined: Wed Jul 15, 2015 5:00 pm
    languages_spoken: english
    ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
    Location: Bucharest, Romania
    Has thanked: 568 times
    Been thanked: 408 times
    Contact:

    Re: Server

    Post by mad_ady »

    See if your TV supports DLNA (or maybe Samba). For DLNA you'll need to install twonky or mediatomb on your xu4 to share your videos with the tv.
    The tv and xu4 need to be in the same layer 2 lan (broadcast domain) for dlna to work (uses multicast for discovery).

    AreaScout
    Posts: 1361
    Joined: Sun Jul 07, 2013 3:05 am
    languages_spoken: german, english
    ODROIDs: X2, U3, XU3, C2, HiFi Shield, XU4, XU4Q,
    N1, Go, VU5A, Show2, CloudShell2,
    H2, N2, VU7A, VuShell, Go2, C4
    Has thanked: 62 times
    Been thanked: 195 times
    Contact:

    Re: Server

    Post by AreaScout »

      Or you follow my tutorial and install Kodi on your XU4 with OMV ;)

      viewtopic.php?f=147&t=33860#p246481

      RG

      dabarsa87
      Posts: 189
      Joined: Tue Feb 23, 2016 5:06 am
      languages_spoken: spanish
      Has thanked: 0
      Been thanked: 1 time
      Contact:

      Re: Server

      Post by dabarsa87 »

      mad_ady wrote:See if your TV supports DLNA (or maybe Samba). For DLNA you'll need to install twonky or mediatomb on your xu4 to share your videos with the tv.
      The tv and xu4 need to be in the same layer 2 lan (broadcast domain) for dlna to work (uses multicast for discovery).
      I do not understand what you mean with layer 2. The company router has the generic ip 192.168.0.1, the other router is connected to this first one with the 192.168.0.1 gateway and the ip of the router is 192.168.1.1, the tv but I remember I think its ip I put it static and it is 192.168.1.100 and it uses the same gateway as the secondary router that is where the cable is connected. Would the network be well installed? Does having to go through another router affect performance? the secondary router is not gigabit the connection

      Enviado desde mi SM-G930F mediante Tapatalk


      dabarsa87
      Posts: 189
      Joined: Tue Feb 23, 2016 5:06 am
      languages_spoken: spanish
      Has thanked: 0
      Been thanked: 1 time
      Contact:

      Re: Server

      Post by dabarsa87 »

      mad_ady wrote:
      Wed Jul 03, 2019 4:31 am
      See if your TV supports DLNA (or maybe Samba). For DLNA you'll need to install twonky or mediatomb on your xu4 to share your videos with the tv.
      The tv and xu4 need to be in the same layer 2 lan (broadcast domain) for dlna to work (uses multicast for discovery).
      Searching by google I already understand what you want to tell me, it has to be the xu4 and the tv connected to the same router.
      My idea was not to connect xu4 to the secondary router which is where the tv is. Could you configure the router so that the 2 routers are as one and so you can connect the xu4 in the main router and the tv in the secondary as I have now?

      mad_ady
      Posts: 8167
      Joined: Wed Jul 15, 2015 5:00 pm
      languages_spoken: english
      ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
      Location: Bucharest, Romania
      Has thanked: 568 times
      Been thanked: 408 times
      Contact:

      Re: Server

      Post by mad_ady »

      Yes, your second router would need to act only as a switch/bridge. You would have the same subnet (192.168.0.0/24) on all devices (including tv). You would need to turn off the dhcp server in your second router, to prevent conflicts. It would work as a wifi access point, maybe it has that option.

      dabarsa87
      Posts: 189
      Joined: Tue Feb 23, 2016 5:06 am
      languages_spoken: spanish
      Has thanked: 0
      Been thanked: 1 time
      Contact:

      Re: Server

      Post by dabarsa87 »

      Good people, I already managed to configure the 2 router and I have managed to see from the smart tv the xu4, when I enter a folder called browse folder and others called video, picture and music.
      Inside the browse folder are the folders that I have created. Can something be done to not have so many folders that do not work?

      mad_ady
      Posts: 8167
      Joined: Wed Jul 15, 2015 5:00 pm
      languages_spoken: english
      ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
      Location: Bucharest, Romania
      Has thanked: 568 times
      Been thanked: 408 times
      Contact:

      Re: Server

      Post by mad_ady »

      If you're using DLNA/Mediatomb you'll need to adjust its default config (can't tell you how - I haven't used it for 4-5 years). But it does like to group your media by type, author, etc.

      dabarsa87
      Posts: 189
      Joined: Tue Feb 23, 2016 5:06 am
      languages_spoken: spanish
      Has thanked: 0
      Been thanked: 1 time
      Contact:

      Re: Server

      Post by dabarsa87 »

      Install a plugin called minidlna with that I can see my content on the smart tv but I do not understand why so many folders come out. I would like to simplify it to just videos, music and photos.

      Enviado desde mi SM-G930F mediante Tapatalk


      dabarsa87
      Posts: 189
      Joined: Tue Feb 23, 2016 5:06 am
      languages_spoken: spanish
      Has thanked: 0
      Been thanked: 1 time
      Contact:

      Re: Server

      Post by dabarsa87 »

      Also try to put a static ip, I give to save and when I get the little yellow sign to apply summarizes that something is not right, it takes a long time to restart and if I get it I get the yellow little sign again. How do I set the static ip? I did it from the network oestaña

      Enviado desde mi SM-G930F mediante Tapatalk


      dabarsa87
      Posts: 189
      Joined: Tue Feb 23, 2016 5:06 am
      languages_spoken: spanish
      Has thanked: 0
      Been thanked: 1 time
      Contact:

      Re: Server

      Post by dabarsa87 »

      I found a video of how to put the static ip, followed his steps and my surprise was that my xu4 is already with static ip, it seems that although I failed to apply the configuration I kept the configuration

      dabarsa87
      Posts: 189
      Joined: Tue Feb 23, 2016 5:06 am
      languages_spoken: spanish
      Has thanked: 0
      Been thanked: 1 time
      Contact:

      Re: Server

      Post by dabarsa87 »

      Now I think that I would only be able to access all the files from any place and from any device that is outside the network where the xu4 is connected, how do I do this?

      mad_ady
      Posts: 8167
      Joined: Wed Jul 15, 2015 5:00 pm
      languages_spoken: english
      ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
      Location: Bucharest, Romania
      Has thanked: 568 times
      Been thanked: 408 times
      Contact:

      Re: Server

      Post by mad_ady »

      You need to set up dynamic dns and port forwarding on your router. There should be a guide on odroid wiki.

      dabarsa87
      Posts: 189
      Joined: Tue Feb 23, 2016 5:06 am
      languages_spoken: spanish
      Has thanked: 0
      Been thanked: 1 time
      Contact:

      Re: Server

      Post by dabarsa87 »

      ok, what you mention to me is to have access to the OMV configuration, maybe you do not explain me well, I was referring to having access to my files as photos and videos from any place without being connected to my network.

      mad_ady
      Posts: 8167
      Joined: Wed Jul 15, 2015 5:00 pm
      languages_spoken: english
      ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
      Location: Bucharest, Romania
      Has thanked: 568 times
      Been thanked: 408 times
      Contact:

      Re: Server

      Post by mad_ady »

      Sorry, I'm not familiar with OMV. You'd need to set up a vpn to access the samba shares directly.

      dabarsa87
      Posts: 189
      Joined: Tue Feb 23, 2016 5:06 am
      languages_spoken: spanish
      Has thanked: 0
      Been thanked: 1 time
      Contact:

      Re: Server

      Post by dabarsa87 »

      ok, if someone knows how to do it

      Enviado desde mi SM-G930F mediante Tapatalk


      AreaScout
      Posts: 1361
      Joined: Sun Jul 07, 2013 3:05 am
      languages_spoken: german, english
      ODROIDs: X2, U3, XU3, C2, HiFi Shield, XU4, XU4Q,
      N1, Go, VU5A, Show2, CloudShell2,
      H2, N2, VU7A, VuShell, Go2, C4
      Has thanked: 62 times
      Been thanked: 195 times
      Contact:

      Re: Server

      Post by AreaScout »

      dabarsa87 wrote:
      Sun Jul 07, 2019 3:52 pm
      ok, if someone knows how to do it

      Enviado desde mi SM-G930F mediante Tapatalk
      You have to enable port forwarding on your router, the idea is to map a service (FTP, NETBIOS/SAMBA, NFS) from your CloudShell2/XU4/OMV internal network to the network IP reachable from the global internet, be sure to secure those services/network-protocols with a password, not only you, but anyone from the global internet can reach it and try to connect/hack your network, as mad_ady pointed out already, another more secure way would be to use a VPN tunnel, please search the internet how to setup it, there is a VPN addon for OMV but I haven't tested it so far.

      RG

      dabarsa87
      Posts: 189
      Joined: Tue Feb 23, 2016 5:06 am
      languages_spoken: spanish
      Has thanked: 0
      Been thanked: 1 time
      Contact:

      Re: Server

      Post by dabarsa87 »

      ok, I'll look to make vpn if it's safer.
      I already bought the couldshell2 but it takes 4 to 7 weeks, as soon as I get it I install it and configure it.
      By the way I saw that there are applications that are in plugins and others that can be installed through docker, if they are the same app as transmisions for example what difference does it have to install in one way or another?

      AreaScout
      Posts: 1361
      Joined: Sun Jul 07, 2013 3:05 am
      languages_spoken: german, english
      ODROIDs: X2, U3, XU3, C2, HiFi Shield, XU4, XU4Q,
      N1, Go, VU5A, Show2, CloudShell2,
      H2, N2, VU7A, VuShell, Go2, C4
      Has thanked: 62 times
      Been thanked: 195 times
      Contact:

      Re: Server

      Post by AreaScout »

        I think not much as of Docker should be a way to ease installation, but I am really no expert in Docker, in fact I haven't used it at all

        Just a video about transmission I found https://www.youtube.com/watch?v=rwovJ9kUSoA

        RG

        dabarsa87
        Posts: 189
        Joined: Tue Feb 23, 2016 5:06 am
        languages_spoken: spanish
        Has thanked: 0
        Been thanked: 1 time
        Contact:

        Re: Server

        Post by dabarsa87 »

        and Plex would be good to do what I want ?? It works well?

        dabarsa87
        Posts: 189
        Joined: Tue Feb 23, 2016 5:06 am
        languages_spoken: spanish
        Has thanked: 0
        Been thanked: 1 time
        Contact:

        Re: Server

        Post by dabarsa87 »

        I got the box coud shell 2, the truth very fast for the estimated time. I have followed the steps of @AreaScout and it is working perfectly, I only need to buy the 2 hdd of 3tb for raid 1.

        Enviado desde mi SM-G930F mediante Tapatalk


        AreaScout
        Posts: 1361
        Joined: Sun Jul 07, 2013 3:05 am
        languages_spoken: german, english
        ODROIDs: X2, U3, XU3, C2, HiFi Shield, XU4, XU4Q,
        N1, Go, VU5A, Show2, CloudShell2,
        H2, N2, VU7A, VuShell, Go2, C4
        Has thanked: 62 times
        Been thanked: 195 times
        Contact:

        Re: Server

        Post by AreaScout »

        dabarsa87 wrote:
        Wed Jul 10, 2019 12:11 am
        and Plex would be good to do what I want ?? It works well?
        I didn't tested Plex, I only use Kodi to watch/stream movies, sorry
        dabarsa87 wrote:
        Sun Jul 14, 2019 12:21 am
        I got the box coud shell 2, the truth very fast for the estimated time. I have followed the steps of @AreaScout and it is working perfectly, I only need to buy the 2 hdd of 3tb for raid 1.

        Enviado desde mi SM-G930F mediante Tapatalk
        Good to hear :) Did you do your test with smaller hard disk drives ?

        dabarsa87
        Posts: 189
        Joined: Tue Feb 23, 2016 5:06 am
        languages_spoken: spanish
        Has thanked: 0
        Been thanked: 1 time
        Contact:

        Re: Server

        Post by dabarsa87 »

        If you test with a pendrive to see its operation and the truth very satisfied, I repressed video stored through samba and minidlna and it worked perfectly without jerks. Kodi guess that you have to connect by hdmi the server to the tv to play the content. I was watching Plex and the truth that seems to be very good, the same software knew that download the covers and metadata of the movies that you downloaded or saved in the nas but I read that it was not very good so I asked if it worked well because they have updated and now it works better.

        Enviado desde mi SM-G930F mediante Tapatalk


        dabarsa87
        Posts: 189
        Joined: Tue Feb 23, 2016 5:06 am
        languages_spoken: spanish
        Has thanked: 0
        Been thanked: 1 time
        Contact:

        Re: Server

        Post by dabarsa87 »

        As I discussed my idea of ​​the nas is similar to yours, my goal in addition to the storage of my videos and homemade photos and documents I wanted to use to download torrents that I want to play on my smart tv, but of course the subject of photos and videos home gustaria accder with mobiles. That's why I had learned in Plex besides that I do not have the possibility to connect by hdmi the nas to the tv

        Enviado desde mi SM-G930F mediante Tapatalk


        dabarsa87
        Posts: 189
        Joined: Tue Feb 23, 2016 5:06 am
        languages_spoken: spanish
        Has thanked: 0
        Been thanked: 1 time
        Contact:

        Re: Server

        Post by dabarsa87 »

        Hello people, I'm still here.
        I already bought the first hdd for the Nas, a WD 3TB, but my doubt is the following, if I connect the first hdd and start saving files when I install the second hdd and have to configure the raid 1 that I want to do, I have to format the 2 hdd to configure it well or can I install an hdd and then later install the second hdd and configure the raid 1 and make a copy of everything that has the hdd 1?

        dabarsa87
        Posts: 189
        Joined: Tue Feb 23, 2016 5:06 am
        languages_spoken: spanish
        Has thanked: 0
        Been thanked: 1 time
        Contact:

        Re: Server

        Post by dabarsa87 »

        Another question I have, because on the coudshell screen it showed me the fixed IP that I configured and now it shows me a different one?
        I still have access to the IP that I configure, I think this happened when I installed Docker and enabled it, but I disabled it and deleted it but it has not shown the IP that I configure again, how can I solve it?

        dabarsa87
        Posts: 189
        Joined: Tue Feb 23, 2016 5:06 am
        languages_spoken: spanish
        Has thanked: 0
        Been thanked: 1 time
        Contact:

        Re: Server

        Post by dabarsa87 »

        Another question I have, because on the coudshell screen it showed me the fixed IP that I configured and now it shows me a different one?
        I still have access to the IP that I configure, I think this happened when I installed Docker and enabled it, but I disabled it and deleted it but it has not shown the IP that I configure again, how can I solve it?
        In addition to this the network icon shows that it does not work and actually if it does, look at the image
        Image

        mad_ady
        Posts: 8167
        Joined: Wed Jul 15, 2015 5:00 pm
        languages_spoken: english
        ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
        Location: Bucharest, Romania
        Has thanked: 568 times
        Been thanked: 408 times
        Contact:

        Re: Server

        Post by mad_ady »

        I think you can configure the raid1 with only one disk and the array will appear as broken until you plug the second disk, but should work/rebuild fine.
        Regarding ghe ip - the package might have been updated and it overwrote its config

        dabarsa87
        Posts: 189
        Joined: Tue Feb 23, 2016 5:06 am
        languages_spoken: spanish
        Has thanked: 0
        Been thanked: 1 time
        Contact:

        Re: Server

        Post by dabarsa87 »

        mad_ady wrote:
        Fri Aug 02, 2019 12:32 am
        I think you can configure the raid1 with only one disk and the array will appear as broken until you plug the second disk, but should work/rebuild fine.
        Regarding ghe ip - the package might have been updated and it overwrote its config
        And how do I only show the IP that I configure?

        AreaScout
        Posts: 1361
        Joined: Sun Jul 07, 2013 3:05 am
        languages_spoken: german, english
        ODROIDs: X2, U3, XU3, C2, HiFi Shield, XU4, XU4Q,
        N1, Go, VU5A, Show2, CloudShell2,
        H2, N2, VU7A, VuShell, Go2, C4
        Has thanked: 62 times
        Been thanked: 195 times
        Contact:

        Re: Server

        Post by AreaScout »

          RAID State: Broken .... congrats :D How did you do that ? You can't configure a RAID1 without losing all your data on disk, so there is only one disk connected now ?

          You have to manually configure your Ethernet node name like /dev/enxBlablabla , my guess is that the start-lcd script has probably problems to obtain the device name of the network card due to Docker

          What is the outcome of this command ls /sys/class/net -I lo | head -1 can you try it please ?

          RG

          mad_ady
          Posts: 8167
          Joined: Wed Jul 15, 2015 5:00 pm
          languages_spoken: english
          ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
          Location: Bucharest, Romania
          Has thanked: 568 times
          Been thanked: 408 times
          Contact:

          Re: Server

          Post by mad_ady »

          @AreaScout: I recommend selecting the default interface based on where the lowest metric default gateway points to. Though it can fool you if using ppp/a vpn on top.

          AreaScout
          Posts: 1361
          Joined: Sun Jul 07, 2013 3:05 am
          languages_spoken: german, english
          ODROIDs: X2, U3, XU3, C2, HiFi Shield, XU4, XU4Q,
          N1, Go, VU5A, Show2, CloudShell2,
          H2, N2, VU7A, VuShell, Go2, C4
          Has thanked: 62 times
          Been thanked: 195 times
          Contact:

          Re: Server

          Post by AreaScout »

            The start-lcd script is collecting this on a standard installation/configuration of a CS2:

            Code: Select all

            root@odroidxu4:~# ls /sys/class/net -I lo | head -1
            enx001e06368a9c
            
            And my config file states this:

            Code: Select all

            # The Network Interface name i.e NETIF=eth0, it is detected automatically by the tool startup script, but here you can overwrite it
            #NETIF=
            
            So it should be clear after some digging around what to do, I hope it works :D @dabarsa87 don't use the full device path, only node name !

            RG

            mad_ady
            Posts: 8167
            Joined: Wed Jul 15, 2015 5:00 pm
            languages_spoken: english
            ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
            Location: Bucharest, Romania
            Has thanked: 568 times
            Been thanked: 408 times
            Contact:

            Re: Server

            Post by mad_ady »

            This is what it outputs on my docker-enabled system (a n1, not xu4):

            Code: Select all

            adrianp@aldebaran64:~$ ls -1p /sys/class/net/         
            docker0
            eth0
            hassio
            lo
            veth48c3d73
            veth9bb76d7
            veth9f94608
            vethdfa6657
            vethea1babf
            vethf90e12a
            vethfbc4882
            adrianp@aldebaran64:~$ ls /sys/class/net -I lo | head -1
            docker0
            adrianp@aldebaran64:~$
            
            Ignoring docker returns eth0, but only because they are sorted:

            Code: Select all

            adrianp@aldebaran64:~$ ls /sys/class/net -I lo | grep -v docker | head -1
            eth0
            
            Maybe there's a reliable way to start from the driver and get its interface name...

            AreaScout
            Posts: 1361
            Joined: Sun Jul 07, 2013 3:05 am
            languages_spoken: german, english
            ODROIDs: X2, U3, XU3, C2, HiFi Shield, XU4, XU4Q,
            N1, Go, VU5A, Show2, CloudShell2,
            H2, N2, VU7A, VuShell, Go2, C4
            Has thanked: 62 times
            Been thanked: 195 times
            Contact:

            Re: Server

            Post by AreaScout »

              No, I don't want to solve this on a driver level, you have a config file to overwrite this value for special configurations, over and out, if the docker0 network device does not have it's corresponding sysfs values for connection speed under /sys/class/net/docker0/speed then it's logical that you do not get the connection speed icons.

              If you want your mysql server to listen on a specific IP address you also have to edit a config file, but thanks for your tip to obtain the device name, I think I will add that too :)

              RG

              dabarsa87
              Posts: 189
              Joined: Tue Feb 23, 2016 5:06 am
              languages_spoken: spanish
              Has thanked: 0
              Been thanked: 1 time
              Contact:

              Re: Server

              Post by dabarsa87 »

              Thanks, as soon as I get back from work I will try it. The broken RAID is because it has no hdd at the moment haha ​​I am waiting for the wl priner hdd to arrive today. Then I can install the first hdd and start entering files and when I have the second hdd install it and have the copy made without losing anything? About the network status and the IP that was modified was when installing docker, because that ip has the docker, I was seeing it

              Enviado desde mi SM-G930F mediante Tapatalk


              dabarsa87
              Posts: 189
              Joined: Tue Feb 23, 2016 5:06 am
              languages_spoken: spanish
              Has thanked: 0
              Been thanked: 1 time
              Contact:

              Re: Server

              Post by dabarsa87 »

              I have tried the command and nothing comes out, I will format again and do a clean installation.
              Regarding RAID 1 if I install an hdd now and I upload it, when I install the second disk do I have to format and mount the 2 at the same time and lose the data?
              I have in couldshell configured for Raid 1, it would only be to install hdds and format and mount but I could only buy one this month so I ask if you can put one now and the other next month without having to lose data

              mad_ady
              Posts: 8167
              Joined: Wed Jul 15, 2015 5:00 pm
              languages_spoken: english
              ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
              Location: Bucharest, Romania
              Has thanked: 568 times
              Been thanked: 408 times
              Contact:

              Re: Server

              Post by mad_ady »

              It should be ok to install the second disk later - in theory, but I've never tried it...

              dabarsa87
              Posts: 189
              Joined: Tue Feb 23, 2016 5:06 am
              languages_spoken: spanish
              Has thanked: 0
              Been thanked: 1 time
              Contact:

              Re: Server

              Post by dabarsa87 »

              I am trying to update the kernel but I don't get what command I should write?
              The version I have is this:
              root @ NAS: ~ # uname -a
              Linux NAS 4.9.103-odroidxu4 # 1 SMP PREEMPT Tue May 29 03:38:14 PDT 2018 armv7l GNU / Linux
              And I wanted to put the 4.14

              AreaScout
              Posts: 1361
              Joined: Sun Jul 07, 2013 3:05 am
              languages_spoken: german, english
              ODROIDs: X2, U3, XU3, C2, HiFi Shield, XU4, XU4Q,
              N1, Go, VU5A, Show2, CloudShell2,
              H2, N2, VU7A, VuShell, Go2, C4
              Has thanked: 62 times
              Been thanked: 195 times
              Contact:

              Re: Server

              Post by AreaScout »

                Ah ok, you are still on 4.9, logon with the admin interface in your browser and look on the left side system -> update management from there you can update your system to 4.14 and all other upgrade packages, it's nearly a must, I don't know if there are any side effects with 4.9 and my tool.

                You have to get used to the admin interface as much as possible, we can't tell you everything, after a while YOU should teach us ;)

                If you setup the RAID1 with the DIP-switch and setup button on the front, all your data will be lost, you don't have to format the second hard disk nor the first for the RAID1 config, after it's done you can format and mount it

                RG

                dabarsa87
                Posts: 189
                Joined: Tue Feb 23, 2016 5:06 am
                languages_spoken: spanish
                Has thanked: 0
                Been thanked: 1 time
                Contact:

                Re: Server

                Post by dabarsa87 »

                I tried what you told me and nothing came out, I was testing commands that I saw on the internet and when I restarted and put the command once and told me that I had the latest kernel version. It will be difficult for me to teach you haha, I am waiting to buy the other hdd and finish the raid.

                Enviado desde mi SM-G930F mediante Tapatalk


                AreaScout
                Posts: 1361
                Joined: Sun Jul 07, 2013 3:05 am
                languages_spoken: german, english
                ODROIDs: X2, U3, XU3, C2, HiFi Shield, XU4, XU4Q,
                N1, Go, VU5A, Show2, CloudShell2,
                H2, N2, VU7A, VuShell, Go2, C4
                Has thanked: 62 times
                Been thanked: 195 times
                Contact:

                Re: Server

                Post by AreaScout »

                  Commands ? No, you have to do that via the web interface I already told you
                  2019-08-04.png
                  2019-08-04.png (159.63 KiB) Viewed 1852 times
                  RG

                  dabarsa87
                  Posts: 189
                  Joined: Tue Feb 23, 2016 5:06 am
                  languages_spoken: spanish
                  Has thanked: 0
                  Been thanked: 1 time
                  Contact:

                  Re: Server

                  Post by dabarsa87 »

                  If I already have it, it seems that when updating everything the new kernel was installed. Thank you

                  Enviado desde mi SM-G930F mediante Tapatalk


                  dabarsa87
                  Posts: 189
                  Joined: Tue Feb 23, 2016 5:06 am
                  languages_spoken: spanish
                  Has thanked: 0
                  Been thanked: 1 time
                  Contact:

                  Re: Server

                  Post by dabarsa87 »

                  I have a problem, when I restart the computer it turns off and when it is booting it does not finish doing it, if it could turn on the couldshell screen but it shows nothing, how can I fix it?

                  AreaScout
                  Posts: 1361
                  Joined: Sun Jul 07, 2013 3:05 am
                  languages_spoken: german, english
                  ODROIDs: X2, U3, XU3, C2, HiFi Shield, XU4, XU4Q,
                  N1, Go, VU5A, Show2, CloudShell2,
                  H2, N2, VU7A, VuShell, Go2, C4
                  Has thanked: 62 times
                  Been thanked: 195 times
                  Contact:

                  Re: Server

                  Post by AreaScout »

                    Wait more the 1.5min, this is the timeout when OMV can't access the hard disk, if it starts after that, you have to troubleshoot why it can't find the hard disk, if you get a logon screen in the small display, logon with a keyboard connected and run fsck /dev/sda

                    RG

                    Post Reply

                    Return to “CloudShell”

                    Who is online

                    Users browsing this forum: No registered users and 0 guests