X11 not working on odroid xu4 ubuntu 18.04 (ROS)

Post Reply
rbrnfh
Posts: 1
Joined: Mon Jun 10, 2019 3:37 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

X11 not working on odroid xu4 ubuntu 18.04 (ROS)

Unread post by rbrnfh » Mon Jun 10, 2019 3:42 am

Hello everyone,

Do you know how to make ROS to work on Odroid XU4 with a Ubuntu 18.04. I've tried unsuccessful to run simple services, but anything that might use EGL gives me errors. From the error described it looks like X11 issue but no idea how to solve it.

Code: Select all

root@odroid:~# rosrun turtlesim turtlesim_node
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
[ INFO] [1560105239.329076964]: Starting turtlesim with node name /turtlesim
[ INFO] [1560105239.340655895]: Spawning turtle [turtle1] at x=[5.544445], y=[5.544445], theta=[0.000000]
Unable to find an X11 visual which matches EGL config 9
Segmentation fault
Any help is appreciated! Thanks!

User avatar
odroid
Site Admin
Posts: 32570
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 190 times
Been thanked: 355 times
Contact:

Re: X11 not working on odroid xu4 ubuntu 18.04 (ROS)

Unread post by odroid » Mon Jun 10, 2019 10:14 am

Try to run "es2gears" or "glmark2-es2" after reinstalling x11 mali GPU driver with sudo apt install --reinstall mali-x11.

User avatar
tony.hong
Posts: 50
Joined: Tue Jun 04, 2019 1:49 pm
languages_spoken: korean
ODROIDs: All
Location: korea
Has thanked: 11 times
Been thanked: 9 times
Contact:

Re: X11 not working on odroid xu4 ubuntu 18.04 (ROS)

Unread post by tony.hong » Wed Jun 12, 2019 4:47 pm

odroid xu4
ubuntu-18.04.1 (20181203)

Code: Select all

odroid@odroid:~$ wget http://deb.odroid.in/5422-s/pool/main/q/qtbase-opensource-src/libqt5gui5_5.9.5%2bdfsg-0ubuntu2_armhf.deb
odroid@odroid:~$ sudo dpkg -i libqt5gui5_5.9.5+dfsg-0ubuntu2_armhf.deb
odroid@odroid:~$ roscore
another terminal

Code: Select all

odroid@odroid:~$ rosrun turtlesim turtlesim_node
Follow the above command. Your problem will be solved.
If you update ubuntu, this problem may occur again until there is the fixed version.
If so, try the above command again.
Or make sure to block the update of 'libqt5gui5' using the below command.

Code: Select all

odroid@odroid:~$ sudo apt-mark hold libqt5gui5

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 6 guests