Not receiving UDP broadcasts

Post Reply
ASword
Posts: 167
Joined: Fri Aug 04, 2017 12:48 pm
languages_spoken: english
ODROIDs: XU4, HC1
Has thanked: 1 time
Been thanked: 1 time
Contact:

Not receiving UDP broadcasts

Unread post by ASword » Sat May 18, 2019 8:06 am

Anyone happen to know why an N2 on Ethernet running Ubuntu 18.04 minimal would not see UDP broadcasts (sent to 192.168.0.255, same subnet as the N2 is on). Another ARM SBC running Ubuntu 16.04 receives them just fine. Exactly the same software running on both trying to receive. My HC-1 running Ubuntu 16.04 also behaves like the N2 (i.e. none received).

User avatar
tobetter
Posts: 3251
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 17 times
Been thanked: 64 times
Contact:

Re: Not receiving UDP broadcasts

Unread post by tobetter » Sat May 18, 2019 10:16 am

ASword wrote:
Sat May 18, 2019 8:06 am
Anyone happen to know why an N2 on Ethernet running Ubuntu 18.04 minimal would not see UDP broadcasts (sent to 192.168.0.255, same subnet as the N2 is on). Another ARM SBC running Ubuntu 16.04 receives them just fine. Exactly the same software running on both trying to receive. My HC-1 running Ubuntu 16.04 also behaves like the N2 (i.e. none received).
Would you please run iperf3 test with an option -u for UDP test? It would be also a good idea if you test with an option -R and without. One thing what I'd suggest if possible, please check the version of U-boot running on ODROID-N2.
Please share the result if you happen to test it.

User avatar
mad_ady
Posts: 5830
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 67 times
Been thanked: 41 times
Contact:

Re: Not receiving UDP broadcasts

Unread post by mad_ady » Sat May 18, 2019 6:52 pm

Also run tcpdump on the n2 to see if the packets arrive but are dropped by firewall/userspace

ASword
Posts: 167
Joined: Fri Aug 04, 2017 12:48 pm
languages_spoken: english
ODROIDs: XU4, HC1
Has thanked: 1 time
Been thanked: 1 time
Contact:

Re: Not receiving UDP broadcasts

Unread post by ASword » Sun May 19, 2019 2:14 am

I ran tcpdump on the N2 and it saw nothing either. I may have gotten the command line arguments wrong though: sudo tcpdump -n "broadcast or multicast"

ASword
Posts: 167
Joined: Fri Aug 04, 2017 12:48 pm
languages_spoken: english
ODROIDs: XU4, HC1
Has thanked: 1 time
Been thanked: 1 time
Contact:

Re: Not receiving UDP broadcasts

Unread post by ASword » Sun May 19, 2019 3:21 am

Ah, looks like this was my mistake -- the sending device isn't actually sending broadcasts, and its UI is misleading about when its configuration changes take effect.

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 0 guests