Wifi disconnecting after 30-60 minutes

Post Reply
iskoko
Posts: 19
Joined: Mon Apr 29, 2019 6:07 pm
languages_spoken: english
Has thanked: 11 times
Been thanked: 0
Contact:

Wifi disconnecting after 30-60 minutes

Unread post by iskoko » Thu May 16, 2019 6:26 pm

Hello everyone,

I am having a continuous issue with Wifi connectivity on N2, it is disconnecting from the Wifi network after 30-60 minutes of working.
N2 and our app are running, there is a connection to Wifi for the first 30-60 minutes, but then it just stops. Not sure if it is related to the fact that there is no interaction with the board, but our app is running. Our app is a .apk installed on the board, that runs continuously in the foreground and needs an internet connection to communicate to the server.
I have Wifi module (5A) and it is connected to the regular USB port. Should it be connected via OTG perhaps?

Did anyone else have this issue?

Thanks!

User avatar
tobetter
Posts: 3277
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 17 times
Been thanked: 69 times
Contact:

Re: Wifi disconnecting after 30-60 minutes

Unread post by tobetter » Thu May 16, 2019 6:43 pm

iskoko wrote:
Thu May 16, 2019 6:26 pm
Hello everyone,

I am having a continuous issue with Wifi connectivity on N2, it is disconnecting from the Wifi network after 30-60 minutes of working.
N2 and our app are running, there is a connection to Wifi for the first 30-60 minutes, but then it just stops. Not sure if it is related to the fact that there is no interaction with the board, but our app is running. Our app is a .apk installed on the board, that runs continuously in the foreground and needs an internet connection to communicate to the server.
I have Wifi module (5A) and it is connected to the regular USB port. Should it be connected via OTG perhaps?

Did anyone else have this issue?

Thanks!
Is the Wifi completely disconnected once it happens?
Do you see any suspicious logs from dmesg or logcat?
Are there any devices attached to USB 3.0 ports?

iskoko
Posts: 19
Joined: Mon Apr 29, 2019 6:07 pm
languages_spoken: english
Has thanked: 11 times
Been thanked: 0
Contact:

Re: Wifi disconnecting after 30-60 minutes

Unread post by iskoko » Thu May 16, 2019 9:24 pm

tobetter wrote:
Thu May 16, 2019 6:43 pm
iskoko wrote:
Thu May 16, 2019 6:26 pm
Hello everyone,

I am having a continuous issue with Wifi connectivity on N2, it is disconnecting from the Wifi network after 30-60 minutes of working.
N2 and our app are running, there is a connection to Wifi for the first 30-60 minutes, but then it just stops. Not sure if it is related to the fact that there is no interaction with the board, but our app is running. Our app is a .apk installed on the board, that runs continuously in the foreground and needs an internet connection to communicate to the server.
I have Wifi module (5A) and it is connected to the regular USB port. Should it be connected via OTG perhaps?

Did anyone else have this issue?

Thanks!
Is the Wifi completely disconnected once it happens?
Do you see any suspicious logs from dmesg or logcat?
Are there any devices attached to USB 3.0 ports?
Wifi is turned on, but it is disconnected from the wifi network. I need to go to settings every time and re-connect it again.
No logs currently.
3 devices are attached to USB 3.0 ports - wifi module, 1 web camera, wireless keyboard. Is that the problem?

skeetre
Posts: 41
Joined: Mon Apr 29, 2019 11:27 am
languages_spoken: english
ODROIDs: Odroid-N2
Location: FL, USA
Has thanked: 10 times
Been thanked: 10 times
Contact:

Re: Wifi disconnecting after 30-60 minutes

Unread post by skeetre » Thu May 16, 2019 9:35 pm

I went to watch youtube tv on my N2 last night and it wasn't connected to wifi either. I tried just clicking the wifi icon to reconnect, but that didn't seem to work. I removed and reinserted the usb wifi module (#4) and then was able to reconnect and watched about an hour or more of tv before going to sleep.

This is on Android with the 9 May image.

I have a wireless keyboard/mouse usb dongle on the otg port and the wifi on a usb3 port. I did have a 2.4ghz wireless gamepad dongle on usb 3 also, but removed it last night to see if that makes a difference.
These users thanked the author skeetre for the post:
iskoko (Thu May 16, 2019 11:15 pm)

User avatar
tobetter
Posts: 3277
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 17 times
Been thanked: 69 times
Contact:

Re: Wifi disconnecting after 30-60 minutes

Unread post by tobetter » Thu May 16, 2019 10:13 pm

iskoko wrote:
Thu May 16, 2019 9:24 pm
tobetter wrote:
Thu May 16, 2019 6:43 pm
iskoko wrote:
Thu May 16, 2019 6:26 pm
Hello everyone,

I am having a continuous issue with Wifi connectivity on N2, it is disconnecting from the Wifi network after 30-60 minutes of working.
N2 and our app are running, there is a connection to Wifi for the first 30-60 minutes, but then it just stops. Not sure if it is related to the fact that there is no interaction with the board, but our app is running. Our app is a .apk installed on the board, that runs continuously in the foreground and needs an internet connection to communicate to the server.
I have Wifi module (5A) and it is connected to the regular USB port. Should it be connected via OTG perhaps?

Did anyone else have this issue?

Thanks!
Is the Wifi completely disconnected once it happens?
Do you see any suspicious logs from dmesg or logcat?
Are there any devices attached to USB 3.0 ports?
Wifi is turned on, but it is disconnected from the wifi network. I need to go to settings every time and re-connect it again.
No logs currently.
3 devices are attached to USB 3.0 ports - wifi module, 1 web camera, wireless keyboard. Is that the problem?
One possibility, I guess, is the interference of USB 3.0 with 2.4GHz devices.
viewtopic.php?f=180&t=34945

Or you could try to run without web camera which would cause heavy traffic on USB bu.
These users thanked the author tobetter for the post:
iskoko (Thu May 16, 2019 11:15 pm)

skeetre
Posts: 41
Joined: Mon Apr 29, 2019 11:27 am
languages_spoken: english
ODROIDs: Odroid-N2
Location: FL, USA
Has thanked: 10 times
Been thanked: 10 times
Contact:

Re: Wifi disconnecting after 30-60 minutes

Unread post by skeetre » Fri May 17, 2019 6:18 am

when I got home today, my youtube tv was still on, so the wifi was too. I left the gamepad dongle removed. Only thing plugged into usb3 is my wifi dongle now.
These users thanked the author skeetre for the post:
iskoko (Fri May 17, 2019 4:51 pm)

iskoko
Posts: 19
Joined: Mon Apr 29, 2019 6:07 pm
languages_spoken: english
Has thanked: 11 times
Been thanked: 0
Contact:

Re: Wifi disconnecting after 30-60 minutes

Unread post by iskoko » Fri May 17, 2019 5:02 pm

I will test now without the camera and usb from the wireless keyboard.
But I also have a GPS module that is connected to USB 3.0, and I cannot remove that because it is required for our app.
Let's see, will report the findings.

iskoko
Posts: 19
Joined: Mon Apr 29, 2019 6:07 pm
languages_spoken: english
Has thanked: 11 times
Been thanked: 0
Contact:

Re: Wifi disconnecting after 30-60 minutes

Unread post by iskoko » Mon May 20, 2019 6:31 pm

Update after 2 (almost 3) days of testing.
I have tested various scenarios with 5A module wifi dongle and in all, it got disconnected after 30-90 mins.
with just Wifi dongle connected to USB 3.0, it disconnected working after 60-90 mins
with just Wifi dongle connected over USB 2.0 OTG, it disconnected working after 30-60 mins
with Wifi and web camera on USB 3.0, it disconnected after 60-90 mins
with Wifi on USB 3.0 and camera via 2.0 OTG, it disconnected after 60-90 mins[/list]
Etc. you get the point.

I also ordered ASUS wifi dongle (https://www.amazon.de/gp/product/B00GCB ... UTF8&psc=1), connected it to Odroid's USB 3.0 (while web camera is via 2.0 OTG) and it is not disconnecting after 36 hours or work. Also, it shows "excellent" connection to my router, while 5A was showing "poor" all the time.

So my guess is that there is an issue with Wifi 5A module I bought with Odroid.

skeetre
Posts: 41
Joined: Mon Apr 29, 2019 11:27 am
languages_spoken: english
ODROIDs: Odroid-N2
Location: FL, USA
Has thanked: 10 times
Been thanked: 10 times
Contact:

Re: Wifi disconnecting after 30-60 minutes

Unread post by skeetre » Mon May 20, 2019 8:02 pm

Thanks for the update. Sorry your 5a from odroid was bad but at least you'd be got a solid connection now.

Post Reply

Return to “Android”

Who is online

Users browsing this forum: phaseshifter and 0 guests