XU4 solid red light

Post Reply
lowlife
Posts: 5
Joined: Fri Dec 15, 2017 5:18 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

XU4 solid red light

Unread post by lowlife » Sun May 12, 2019 1:16 pm

Hi,

My XU4 suddenly died :( - solid red light. I replaced the SD card and power supply (5v 4a), but nothing has changed. When I power it on, the red light turns on instantly and nothing else happens. No flashing, no other LEDs, no fan.

Is there something I can do?

User avatar
odroid
Site Admin
Posts: 30667
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 13 times
Been thanked: 98 times
Contact:

Re: XU4 solid red light

Unread post by odroid » Mon May 13, 2019 11:44 am

Do you have a DMM to measure a voltage on 1.8Volt rail on 30pin header?
https://wiki.odroid.com/odroid-xu4/hard ... connectors
If yes, check the voltage while pressing the power button.

Also flash this OS image (ubuntu-18.04.1-4.14-mate-odroid-xu4-20181203.img.xz) into your SD card with Etcher.
https://wiki.odroid.com/odroid-xu4/os_i ... 4/20181203

lowlife
Posts: 5
Joined: Fri Dec 15, 2017 5:18 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 solid red light

Unread post by lowlife » Tue May 14, 2019 3:23 am

I flashed the image, no change.
The German reseller prompted me to send the XU4 to them, so hopefully they will fix or replace it.

I'm very lucky, this happened almost exactly 2 years after the purchase (the warranty in the EU is 2 years).

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 0 guests