Can't get HC2 to boot up

Post Reply
BillyHalley
Posts: 4
Joined: Sat May 11, 2019 3:25 am
languages_spoken: english
ODROIDs: HC2
Has thanked: 0
Been thanked: 0
Contact:

Can't get HC2 to boot up

Unread post by BillyHalley » Sat May 11, 2019 3:28 am

Hi, I recently bought an ODROID HC2, i tried with several os (archarm, ubuntu from the official wiki, armbian), and several SD cards, but it doesn't manage to boot up.

When I power it, all LEDS turn on, then the blue one turns off and then nothing happens, and it doesn't show in my router settings where i should see it's IP address.

Anyone can help?

BillyHalley
Posts: 4
Joined: Sat May 11, 2019 3:25 am
languages_spoken: english
ODROIDs: HC2
Has thanked: 0
Been thanked: 0
Contact:

Re: Can't get HC2 to boot up

Unread post by BillyHalley » Sat May 11, 2019 9:23 pm

I managed to make the serial connection work, and during boot, i'm installing ArchArm following this https://archlinuxarm.org/platforms/armv ... odroid-hc2.
It's stuck with this output:

Code: Select all

[    2.108323] usbcore: registered new interface driver usb-storage
[    2.114245] usbcore: registered new interface driver ums-cypress
[    2.120880] mousedev: PS/2 mouse device common for all mice
[    2.127050] i2c /dev entries driver
[    2.144603] vdd_ldo9: Bringing 3300000uV into 3000000-3000000uV
[    2.167257] vdd_sd: Bringing 3300000uV into 2800000-2800000uV
[    2.190213] vdd_ldo30: Bringing 1800000uV into 3300000-3300000uV
[    2.222678] vdd_1.8v_ldo: Bringing 1850000uV into 1500000-1500000uV
[    3.269449] s5m-rtc s2mps14-rtc: rtc core: registered s5m-rtc as rtc0
[    3.277332] s5p-jpeg 11f50000.jpeg: Linked as a consumer to 11f10000.sysmmu
[    3.282939] iommu: Adding device 11f50000.jpeg to group 2
[    3.288598] s5p-jpeg 11f50000.jpeg: encoder device registered as /dev/video30
[    3.295501] s5p-jpeg 11f50000.jpeg: decoder device registered as /dev/video31
[    3.302437] s5p-jpeg 11f50000.jpeg: Samsung S5P JPEG codec
[    3.308101] s5p-jpeg 11f60000.jpeg: Linked as a consumer to 11f20000.sysmmu
[    3.314905] iommu: Adding device 11f60000.jpeg to group 3
[    3.320550] s5p-jpeg 11f60000.jpeg: encoder device registered as /dev/video32
[    3.327473] s5p-jpeg 11f60000.jpeg: decoder device registered as /dev/video33
[    3.334411] s5p-jpeg 11f60000.jpeg: Samsung S5P JPEG codec
[    3.340943] s5p-mfc 11000000.codec: Linked as a consumer to 11200000.sysmmu
[    3.346961] s5p-mfc 11000000.codec: Linked as a consumer to 11210000.sysmmu
[    3.353791] iommu: Adding device 11000000.codec to group 4

User avatar
odroid
Site Admin
Posts: 30625
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 13 times
Been thanked: 89 times
Contact:

Re: Can't get HC2 to boot up

Unread post by odroid » Mon May 13, 2019 11:23 am

Can you try flashing our "ubuntu-18.04.1-4.14-minimal-odroid-xu4-20181203.img.xz " with Etcher.
https://wiki.odroid.com/odroid-xu4/os_i ... 03-minimal
https://wiki.odroid.com/troubleshooting ... s#flashing

And please show me the serial console output to find what's wrong.

BillyHalley
Posts: 4
Joined: Sat May 11, 2019 3:25 am
languages_spoken: english
ODROIDs: HC2
Has thanked: 0
Been thanked: 0
Contact:

Re: Can't get HC2 to boot up

Unread post by BillyHalley » Mon May 13, 2019 9:40 pm

I tried with many os, even that, flashed with etcher, it always has the same output, it's a problem during the loading of the kernel, so i guess it's "correct" that it has the same problem with a different os

User avatar
odroid
Site Admin
Posts: 30625
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 13 times
Been thanked: 89 times
Contact:

Re: Can't get HC2 to boot up

Unread post by odroid » Tue May 14, 2019 8:47 am

I see.
I think some portion of the system memory seems to be damaged by uncertain electrical shock.
Contact "odroid at hardkernel dot com" with a link of this post.
They will help your RMA process if you purchased the board from us directly.
Otherwise, contact your local distributor/reseller.

BillyHalley
Posts: 4
Joined: Sat May 11, 2019 3:25 am
languages_spoken: english
ODROIDs: HC2
Has thanked: 0
Been thanked: 0
Contact:

Re: Can't get HC2 to boot up

Unread post by BillyHalley » Tue May 14, 2019 11:35 pm

Thanks, I sent an email

Post Reply

Return to “Hardware and peripherals”

Who is online

Users browsing this forum: No registered users and 2 guests