Android doesn't recognize Ethernet as default (wifi not installed)

Post Reply
5953LC
Posts: 8
Joined: Thu May 09, 2019 3:33 am
languages_spoken: english
ODROIDs: c2 n2
Has thanked: 0
Been thanked: 0
Contact:

Android doesn't recognize Ethernet as default (wifi not installed)

Unread post by 5953LC » Thu May 09, 2019 5:06 am

So the Android OS for N2

doesn't have Ethernet set as default (keeps asking for Wifi enabling to update apps when 1) there is no Wifi installed 2) there is Ethernet (by default, duh - on mobo), and 3) Ethernet is active and working ...

User avatar
tobetter
Posts: 3251
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 17 times
Been thanked: 64 times
Contact:

Re: Android doesn't recognize Ethernet as default (wifi not installed)

Unread post by tobetter » Thu May 09, 2019 9:23 am

5953LC wrote:
Thu May 09, 2019 5:06 am
So the Android OS for N2

doesn't have Ethernet set as default (keeps asking for Wifi enabling to update apps when 1) there is no Wifi installed 2) there is Ethernet (by default, duh - on mobo), and 3) Ethernet is active and working ...
Ethernet is always the default network device when a Wifi is not activated. How do you check if the ethernet is active and working? Do you have pop up message which asks Wifi?

5953LC
Posts: 8
Joined: Thu May 09, 2019 3:33 am
languages_spoken: english
ODROIDs: c2 n2
Has thanked: 0
Been thanked: 0
Contact:

Re: Android doesn't recognize Ethernet as default (wifi not installed)

Unread post by 5953LC » Fri May 10, 2019 3:48 pm

Yes. Ethernet is working. I can browse the web, get files, etc. I can use Odroid Settings -> Update to see and update from old version of Andriod to new version ...

I keep getting a pop up saying wifi needed to get updates, etc.

User avatar
odroid
Site Admin
Posts: 30638
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 13 times
Been thanked: 91 times
Contact:

Re: Android doesn't recognize Ethernet as default (wifi not installed)

Unread post by odroid » Fri May 10, 2019 4:06 pm

Can you capture a screen of the pop up?
If specific apps require the WiFi connection, you might need to install fake-wifi tweaks from the Xposed framework.

5953LC
Posts: 8
Joined: Thu May 09, 2019 3:33 am
languages_spoken: english
ODROIDs: c2 n2
Has thanked: 0
Been thanked: 0
Contact:

Re: Android doesn't recognize Ethernet as default (wifi not installed)

Unread post by 5953LC » Sat May 11, 2019 3:22 pm

odroid wrote:
Fri May 10, 2019 4:06 pm
Can you capture a screen of the pop up?
If specific apps require the WiFi connection, you might need to install fake-wifi tweaks from the Xposed framework.
As I said, I fully reformatted a spare emmc with your latest Android image (thanks again), and since I had a wifi module plugged in that time around, the error message sort of went away.....

If I can I will try to reproduce and attach screen shots....

but I ordered bluetooth and wifi modules through Ameridroid and since I've received them, I've attached those to one of my test N2's ... (it's soooooo distracting....)

PS suggestions

HS400 emmcs would be a great thing for the N2 (and C2's) - I'd pay a premium for them if they were available.

SAMJOSEPH
Posts: 1
Joined: Sat May 11, 2019 7:13 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Android doesn't recognize Ethernet as default (wifi not installed)

Unread post by SAMJOSEPH » Sat May 11, 2019 7:16 pm

hey, i am also looking for the same.. can anyone help??
thanks in advance!!
best regards!

kafan1986
Posts: 59
Joined: Tue Feb 27, 2018 8:05 am
languages_spoken: english
Has thanked: 0
Been thanked: 1 time
Contact:

Re: Android doesn't recognize Ethernet as default (wifi not installed)

Unread post by kafan1986 » Tue May 14, 2019 2:37 pm

5953LC wrote:
Fri May 10, 2019 3:48 pm
Yes. Ethernet is working. I can browse the web, get files, etc. I can use Odroid Settings -> Update to see and update from old version of Andriod to new version ...

I keep getting a pop up saying wifi needed to get updates, etc.
Has this issue been resolved? I only have ethernet available, although I am able to access internet and do everything else. The updater program inside Odroid settings was giving me error message "wifi needed ..." Currently using the 0418 image.

Luke.go
Posts: 313
Joined: Mon May 30, 2016 1:55 pm
languages_spoken: english
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: Android doesn't recognize Ethernet as default (wifi not installed)

Unread post by Luke.go » Tue May 14, 2019 3:01 pm

@kafan1986, when you can see the "wifi needed.." message?
I can't reproduce the message. and I can download the latest package by ethernet and install the package at latest image (0509). :cry:

SAM41
Posts: 12
Joined: Wed Feb 20, 2019 6:48 pm
languages_spoken: german, english
ODROIDs: none yet
Has thanked: 1 time
Been thanked: 5 times
Contact:

Re: Android doesn't recognize Ethernet as default (wifi not installed)

Unread post by SAM41 » Thu May 16, 2019 4:02 am

I've got a similar issue (see attached screenshot).
The notification won't hide.
I am not sure there is anything to update.
Attachments
Screenshot_20190515-205927.png
Screenshot_20190515-205927.png (573.06 KiB) Viewed 146 times

Luke.go
Posts: 313
Joined: Mon May 30, 2016 1:55 pm
languages_spoken: english
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: Android doesn't recognize Ethernet as default (wifi not installed)

Unread post by Luke.go » Thu May 16, 2019 10:51 am

@SAM41, Oh, yours is really related to gapps problem. :)
did you try update the app on the gapps?
And did you install the atv ui or packages? looks good.

SAM41
Posts: 12
Joined: Wed Feb 20, 2019 6:48 pm
languages_spoken: german, english
ODROIDs: none yet
Has thanked: 1 time
Been thanked: 5 times
Contact:

Re: Android doesn't recognize Ethernet as default (wifi not installed)

Unread post by SAM41 » Thu May 16, 2019 9:25 pm

That's just the ATV Launcher from the Playstore.
Will check gapps when I'm back from work.

SAM41
Posts: 12
Joined: Wed Feb 20, 2019 6:48 pm
languages_spoken: german, english
ODROIDs: none yet
Has thanked: 1 time
Been thanked: 5 times
Contact:

Re: Android doesn't recognize Ethernet as default (wifi not installed)

Unread post by SAM41 » Fri May 17, 2019 2:15 am

Luke.go wrote:
Thu May 16, 2019 10:51 am
@SAM41, Oh, yours is really related to gapps problem. :)
did you try update the app on the gapps?
And did you install the atv ui or packages? looks good.
My apps from playstore are up to date.
It looks like the system tries to finish the initial setup.
I'll try an xposed wifi fake module tomorrow.

Post Reply

Return to “Android”

Who is online

Users browsing this forum: No registered users and 2 guests