DOA?

Post Reply
mlfricke52
Posts: 3
Joined: Thu Apr 18, 2019 1:51 am
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 0
Contact:

DOA?

Unread post by mlfricke52 » Thu Apr 18, 2019 2:17 am

Plugged my N2 in for the first time this morning. I first connected all of the other cables, USB, HDMI, Network, then plugged in a 12V supply. I got a wisp of smoke and the LED next to the power connector lit up. Nothing more. I confirmed that I have 12.32V at the N2 power connector and that the polarity is correct. DOA?

phaseshifter
Posts: 3241
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: U-2,U3+,,XU-3,,XU3-LITE,,XU-4
C1+,,C-2,,,
N-1,,N-2 @15 V D.C ,,...other odroid acc`s as well
Has thanked: 10 times
Been thanked: 20 times
Contact:

Re: DOA?

Unread post by phaseshifter » Thu Apr 18, 2019 2:29 am

I got a wisp of smoke
yu got smoke out of the n-2..is that a custom supply your using,,is it home made..??
whch opp sys image did you use.???
Build It And They Will Come...Be Bold And Mighty Forces Will Come To Your Aid..!!!

phaseshifter
Posts: 3241
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: U-2,U3+,,XU-3,,XU3-LITE,,XU-4
C1+,,C-2,,,
N-1,,N-2 @15 V D.C ,,...other odroid acc`s as well
Has thanked: 10 times
Been thanked: 20 times
Contact:

Re: DOA?

Unread post by phaseshifter » Thu Apr 18, 2019 2:51 am

do you use an sd-card or emmc..??
Build It And They Will Come...Be Bold And Mighty Forces Will Come To Your Aid..!!!

mlfricke52
Posts: 3
Joined: Thu Apr 18, 2019 1:51 am
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 0
Contact:

Re: DOA?

Unread post by mlfricke52 » Thu Apr 18, 2019 8:52 am

I used the Linux emmc card purchased from HK.

mlfricke52
Posts: 3
Joined: Thu Apr 18, 2019 1:51 am
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 0
Contact:

Re: DOA?

Unread post by mlfricke52 » Thu Apr 18, 2019 9:08 am

I thought I answered your earlier question on the PS but don't see it here. It is a 2A/12V brick. I confirmed that the polarity is correct (center is positive) and measured the voltage on the board at 12.3V. Thanks

User avatar
odroid
Site Admin
Posts: 30260
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 3 times
Been thanked: 24 times
Contact:

Re: DOA?

Unread post by odroid » Thu Apr 18, 2019 10:21 am

Contact "odroid at hardkernel dot com" with a link of this post.
She will help your RMA process if you purchased the board from us directly.
Otherwise, contact your local distributor/reseller.

BTW, can you give us a link of your PSU description?

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: xabolcs and 0 guests