[SOLVED] Odroid C2 First Boot Failure (Blue LED blinking twice)

Post Reply
scoobydrvr
Posts: 4
Joined: Sun Apr 14, 2019 3:31 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

[SOLVED] Odroid C2 First Boot Failure (Blue LED blinking twice)

Unread post by scoobydrvr » Sun Apr 14, 2019 4:02 am

Hello all, new to Odroid but not the SBC world. I recently purchased a starter kit of sorts to get running with the Odroid C2 consisting of the board, 16Gb eMMC module, eMMC reader, v5 wifi module, and the recommended DC power supply. When I first assembled everything I did not show any output on my monitor. Looking at the status lights I see a solid red (assuming that means power is good) and blue light blinking in a "blink-blink, delay, blink-blink, delay" pattern. From what I can tell in the owners manual this indicates a kernel panic. I assumed something had gone wrong with the image burned to the eMMC module so I downloaded the latest image from the wiki page (v3.0). Burned the image using the reader and Etcher and got the same results.
I have tried this with process with the following images
* ubuntu64-16.04.2lts-mate-odroid-c2-20170301.img
* DietPi_OdroidC2-ARMv8-Stretch
* ubuntu-18.04-3.16-minimal-odroid-c2-20180626.img
* ubuntu64-16.04.3-minimal-odroid-c2-20171005.img
These all exhibit the same behavior described above but, randomly, the blue LED with stop blinking altogether after some time.

Obviously I'm doing something wrong here but I'm not sure what. What other troubleshooting methods can I use?
(Apologies if this is addressed elsewhere in the forum; the search function was not very helpful)

EDIT
I've also tried a Diet Pi image on an SD card to see if the issue is with the eMMC module but the same behavior is exhibited.

User avatar
odroid
Site Admin
Posts: 32146
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 119 times
Been thanked: 297 times
Contact:

Re: Odroid C2 First Boot Failure (Blue LED blinking twice)

Unread post by odroid » Mon Apr 15, 2019 10:29 am

The blue LED seems to be okay.
See this video at around 1min 30sec to check the normal behavior of the blue LED.
https://www.youtube.com/watch?v=fEyeMTS3idU

You don't need to uncompress .xz file if you use Etcher.
https://wiki.odroid.com/troubleshooting ... extracting

BTW, what is the native resolution of your HDMI monitor?

scoobydrvr
Posts: 4
Joined: Sun Apr 14, 2019 3:31 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Odroid C2 First Boot Failure (Blue LED blinking twice)

Unread post by scoobydrvr » Mon Apr 15, 2019 11:22 am

As best as I can understand the resolution of the monitor is 1920 x 1080
https://www.asus.com/us/Commercial-Moni ... fications/

User avatar
odroid
Site Admin
Posts: 32146
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 119 times
Been thanked: 297 times
Contact:

Re: Odroid C2 First Boot Failure (Blue LED blinking twice)

Unread post by odroid » Mon Apr 15, 2019 11:27 am

1920x1080 must work out of the box.
Try other HDMI cable or display just in case.

scoobydrvr
Posts: 4
Joined: Sun Apr 14, 2019 3:31 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Odroid C2 First Boot Failure (Blue LED blinking twice)

Unread post by scoobydrvr » Mon Apr 15, 2019 11:36 am

The HDMI cable was the culprit. This device does not like the Monoprice active HDMI cables. Thank you for the suggestion and support!

Post Reply

Return to “General Topics”

Who is online

Users browsing this forum: No registered users and 0 guests