[SOLVED] Ubuntu 18.04.1-4.14 Won't work With emmc

Locked
o00scorpion00o
Posts: 84
Joined: Mon May 25, 2015 7:31 pm
languages_spoken: english
ODROIDs: Xu3-LITE
Has thanked: 4 times
Been thanked: 0
Contact:

[SOLVED] Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by o00scorpion00o » Thu Apr 11, 2019 1:17 am

Hi all,

I've flashed with Etcher and it boots once and then hangs, reboots and gets stuck in a boot loop. I tried another emmc and the same thing happens. Using Xu3 Lite.

it works over SD no problem.

Any ideas ?

User avatar
tobetter
Posts: 3003
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 8 times
Been thanked: 19 times
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by tobetter » Thu Apr 11, 2019 3:10 am

o00scorpion00o wrote:
Thu Apr 11, 2019 1:17 am
Hi all,

I've flashed with Etcher and it boots once and then hangs, reboots and gets stuck in a boot loop. I tried another emmc and the same thing happens. Using Xu3 Lite.

it works over SD no problem.

Any ideas ?
What's the color of eMMC card? Have it worked with your XU3 earlier?

o00scorpion00o
Posts: 84
Joined: Mon May 25, 2015 7:31 pm
languages_spoken: english
ODROIDs: Xu3-LITE
Has thanked: 4 times
Been thanked: 0
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by o00scorpion00o » Thu Apr 11, 2019 3:47 am

Hmm think one of them is red not sure about the other, first time I had issues with emmc. All worked previously before. I have 2 x Xu3 lites and the same happens with both.

User avatar
tobetter
Posts: 3003
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 8 times
Been thanked: 19 times
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by tobetter » Thu Apr 11, 2019 8:03 am

o00scorpion00o wrote:
Thu Apr 11, 2019 3:47 am
Hmm think one of them is red not sure about the other, first time I had issues with emmc. All worked previously before. I have 2 x Xu3 lites and the same happens with both.
If your boards can boot up flawless with Micro SD, they would not defect I guess.
Only when eMMC cannot boot up, I think it's worth to try to recover bootloader and this is the instruction link.
https://wiki.odroid.com/accessory/emmc/recovery_xu4

If this does not work, please share the boot log from U-boot if possible....boot log gives more hints.
These users thanked the author tobetter for the post:
o00scorpion00o (Thu Apr 11, 2019 5:55 pm)

o00scorpion00o
Posts: 84
Joined: Mon May 25, 2015 7:31 pm
languages_spoken: english
ODROIDs: Xu3-LITE
Has thanked: 4 times
Been thanked: 0
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by o00scorpion00o » Thu Apr 11, 2019 8:40 pm

Thanks , it loads Android from emmc no problem now , I will try the Ubuntu image again later.

o00scorpion00o
Posts: 84
Joined: Mon May 25, 2015 7:31 pm
languages_spoken: english
ODROIDs: Xu3-LITE
Has thanked: 4 times
Been thanked: 0
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by o00scorpion00o » Thu Apr 11, 2019 8:42 pm

Thanks , it loads Android from emmc no problem now , I will try the Ubuntu image again later.

o00scorpion00o
Posts: 84
Joined: Mon May 25, 2015 7:31 pm
languages_spoken: english
ODROIDs: Xu3-LITE
Has thanked: 4 times
Been thanked: 0
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by o00scorpion00o » Thu Apr 11, 2019 11:39 pm

There's no "U-boot" on the emmc .

No logs at all that I can see.

I will try an old image , this one obviously doesn't work. If Android loads then it must be image related.

phaseshifter
Posts: 3241
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: U-2,U3+,,XU-3,,XU3-LITE,,XU-4
C1+,,C-2,,,
N-1,,N-2 @15 V D.C ,,...other odroid acc`s as well
Has thanked: 10 times
Been thanked: 20 times
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by phaseshifter » Fri Apr 12, 2019 12:20 am

?? what power supply r u using..should be 5 volt 4amp`s...
Build It And They Will Come...Be Bold And Mighty Forces Will Come To Your Aid..!!!

o00scorpion00o
Posts: 84
Joined: Mon May 25, 2015 7:31 pm
languages_spoken: english
ODROIDs: Xu3-LITE
Has thanked: 4 times
Been thanked: 0
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by o00scorpion00o » Fri Apr 12, 2019 12:23 am

It's a 2 amp supply, never had issue with it before to be honest. For some reason this is the one I got with it. Unless it's dodgy.

phaseshifter
Posts: 3241
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: U-2,U3+,,XU-3,,XU3-LITE,,XU-4
C1+,,C-2,,,
N-1,,N-2 @15 V D.C ,,...other odroid acc`s as well
Has thanked: 10 times
Been thanked: 20 times
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by phaseshifter » Fri Apr 12, 2019 12:30 am

well your lucky but i think it`s given up the ghost trying to provide more current than what it was designed to do...
Build It And They Will Come...Be Bold And Mighty Forces Will Come To Your Aid..!!!

o00scorpion00o
Posts: 84
Joined: Mon May 25, 2015 7:31 pm
languages_spoken: english
ODROIDs: Xu3-LITE
Has thanked: 4 times
Been thanked: 0
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by o00scorpion00o » Fri Apr 12, 2019 1:08 am

Yes think you're correct and the more I think about it the more I think about it the more I think could have been the PSU of the C2 before I gave it to my Brother who probably has the higher amp supply because I didn't have issues like this before. I must have given it to him by mistake. I haven't used the Xu3's in a long time.

Anyway some details.

Linear supply 5.13 , no load
Switch mode PSU 5.22 no load

Lowest voltage just before power off = 4.75 Linear and 4.5 - 4.6 v smp so that's that.

One solution could be to see if there is a trimmer inside the linear to up the voltage so the drop won't be low enough to kill the Xu3.

What is the max voltage the Xu3 Lite can take ?

User avatar
tobetter
Posts: 3003
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 8 times
Been thanked: 19 times
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by tobetter » Fri Apr 12, 2019 1:22 am

o00scorpion00o wrote:
Fri Apr 12, 2019 1:08 am
Yes think you're correct and the more I think about it the more I think about it the more I think could have been the PSU of the C2 before I gave it to my Brother who probably has the higher amp supply because I didn't have issues like this before. I must have given it to him by mistake. I haven't used the Xu3's in a long time.

Anyway some details.

Linear supply 5.13 , no load
Switch mode PSU 5.22 no load

Lowest voltage just before power off = 4.75 Linear and 4.5 - 4.6 v smp so that's that.

One solution could be to see if there is a trimmer inside the linear to up the voltage so the drop won't be low enough to kill the Xu3.

What is the max voltage the Xu3 Lite can take ?
Max voltage for XU3 and XU4 are 5V and considering voltage drops due to heavy loads, you should supply a bit more. Recommended voltage is 4.8V~5.2V.

phaseshifter
Posts: 3241
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: U-2,U3+,,XU-3,,XU3-LITE,,XU-4
C1+,,C-2,,,
N-1,,N-2 @15 V D.C ,,...other odroid acc`s as well
Has thanked: 10 times
Been thanked: 20 times
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by phaseshifter » Fri Apr 12, 2019 1:28 am

what current output is the linear supply???

5.13 volt may be ok if you could find the trimpot adjust it to 5.3 votls
Build It And They Will Come...Be Bold And Mighty Forces Will Come To Your Aid..!!!

o00scorpion00o
Posts: 84
Joined: Mon May 25, 2015 7:31 pm
languages_spoken: english
ODROIDs: Xu3-LITE
Has thanked: 4 times
Been thanked: 0
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by o00scorpion00o » Fri Apr 12, 2019 1:43 am

phaseshifter wrote:
Fri Apr 12, 2019 1:28 am
what current output is the linear supply???

5.13 volt may be ok if you could find the trimpot adjust it to 5.3 votls
It's supposed to supply 3.5 amps but I think max 4. But obviously not.

I may order a more powerful smp PSU for now and if what I'm doing works I may get a linear, they are expensive from China though but I need a clean supply.

Yes, I just might see if I can get it to 5.3 V first.

phaseshifter
Posts: 3241
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: U-2,U3+,,XU-3,,XU3-LITE,,XU-4
C1+,,C-2,,,
N-1,,N-2 @15 V D.C ,,...other odroid acc`s as well
Has thanked: 10 times
Been thanked: 20 times
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by phaseshifter » Fri Apr 12, 2019 1:47 am

does the linear have a model number on it...???
Build It And They Will Come...Be Bold And Mighty Forces Will Come To Your Aid..!!!

o00scorpion00o
Posts: 84
Joined: Mon May 25, 2015 7:31 pm
languages_spoken: english
ODROIDs: Xu3-LITE
Has thanked: 4 times
Been thanked: 0
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by o00scorpion00o » Fri Apr 12, 2019 2:27 am

No it’s one I got made from China.

It powered the kiwi and beaglebone black with no issues but they are obviously less power hungry.

I also have 2 more I got from the same supplier on eBay and they work fine.

phaseshifter
Posts: 3241
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: U-2,U3+,,XU-3,,XU3-LITE,,XU-4
C1+,,C-2,,,
N-1,,N-2 @15 V D.C ,,...other odroid acc`s as well
Has thanked: 10 times
Been thanked: 20 times
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by phaseshifter » Fri Apr 12, 2019 2:38 am

so you have it working now..??? if so good..enjoy..
Build It And They Will Come...Be Bold And Mighty Forces Will Come To Your Aid..!!!

o00scorpion00o
Posts: 84
Joined: Mon May 25, 2015 7:31 pm
languages_spoken: english
ODROIDs: Xu3-LITE
Has thanked: 4 times
Been thanked: 0
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by o00scorpion00o » Fri Apr 12, 2019 4:16 am

I managed to get the voltage to 5.3 v but it still doesn't work.

What puzzles me more is why it works with Android , and with the 2 amp supply ? now when I say works I mean it loads the image and boots fine, I never messed around with it so it could be unstable.

The transformer in the linear is 25 va so by my maths that should mean 25 divide by 5 = 5 amps ? so something isn't right.

Transformer make and model is BingZi M25-02

According to here gives the specs below. https://p.globalsources.com/IMAGES/PDT/ ... 701994.pdf

Ⅵ Rated Voltage:
1. Primary: 2×110V±10% 50Hz/60Hz
Secondary: 2×6V, 2×7.5V, 2×9V, 2×12V, 2×15V, 2×18V, 2×21V, 2×24V, 2×27V。
2.Non-standard series:It can be customized based on customer's requirements.

phaseshifter
Posts: 3241
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: U-2,U3+,,XU-3,,XU3-LITE,,XU-4
C1+,,C-2,,,
N-1,,N-2 @15 V D.C ,,...other odroid acc`s as well
Has thanked: 10 times
Been thanked: 20 times
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by phaseshifter » Fri Apr 12, 2019 5:13 am

ok it`s dual 9v hard to make a real comment because there rated stat`s differ slightly..
however if you have the 25-02 then it has dual secondary`s both 9v..
but if it is 25 va in parallel would give 9v at approx 2.7amps ..yes that works at 25 va approx ...still not want you want to be putting into an xu3/4 board..you'll fry it..

and this what i have spoken about is the M25-02 25/2 is 12.24 per winding watts so

look bottom line it is inadequate .....

which unit did you get 5,3 volts out of..i`m somewhat confused,,,???
Build It And They Will Come...Be Bold And Mighty Forces Will Come To Your Aid..!!!

o00scorpion00o
Posts: 84
Joined: Mon May 25, 2015 7:31 pm
languages_spoken: english
ODROIDs: Xu3-LITE
Has thanked: 4 times
Been thanked: 0
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by o00scorpion00o » Fri Apr 12, 2019 6:08 am

phaseshifter wrote:
Fri Apr 12, 2019 5:13 am
ok it`s dual 9v hard to make a real comment because there rated stat`s differ slightly..
however if you have the 25-02 then it has dual secondary`s both 9v..
but if it is 25 va in parallel would give 9v at approx 2.7amps ..yes that works at 25 va approx ...still not want you want to be putting into an xu3/4 board..you'll fry it..

and this what i have spoken about is the M25-02 25/2 is 12.24 per winding watts so

look bottom line it is inadequate .....

which unit did you get 5,3 volts out of..i`m somewhat confused,,,???
I'm talking about the linear supply It's stepped down to 5v. The other PSU must have been given to my Brother by mistake when I gave him the C1 I meant to say not C2.

I got the Linear supply from 5.1 to 5.3 volts but it made no difference the voltage drop must have been too much. So going to order a 5v 4 amp .

It's strange because it was powering both Kiwi sdr + beaglebone black + Antenna preamp. Perhaps something went faulty but either way time to call it a day on that PSU shame because it was so damn quiet RF wise compared to those filthy switch mode power supplies.

I got 3 linear supplies from the same supplier in China and both are still working perfectly.

I'll see how all this works with Airspy's "Spyserver" and the Xu3 before I consider another linear supply.

phaseshifter
Posts: 3241
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: U-2,U3+,,XU-3,,XU3-LITE,,XU-4
C1+,,C-2,,,
N-1,,N-2 @15 V D.C ,,...other odroid acc`s as well
Has thanked: 10 times
Been thanked: 20 times
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by phaseshifter » Fri Apr 12, 2019 7:24 am

yes i prefer a nice linear supply too...i know how quiet and the really is no ripple or so little that it dont matter.or just add a cap here and there.
when i see all the rave about s-modes i tend to shudder,the one`s of the internet there really harsh unless you cough up 500 od dollars for a bench-top supply..,but the ones on the net..there flooded with them..are compact and versatile..and can give huge amounts of current easily ...but the ripple some are just to noisy...the c-2`s cpu is rather noisy on it`s own in some cases have been talked about i have 3 c-2`s and i find them to be noisy..but if you hook up a hi-fi sheild to it there pretty good..few cases of noisy ones..but often it`s those cheap usb speakers with poor grounding...

btw..both c-1 and c-2 take the same 2 amp supply it`s the xu3/l/xu4 that take 4 amp...all 5 volt`ers..

btw..order a 6 amp you'll be glad you did,.,,in the long run..
Build It And They Will Come...Be Bold And Mighty Forces Will Come To Your Aid..!!!

o00scorpion00o
Posts: 84
Joined: Mon May 25, 2015 7:31 pm
languages_spoken: english
ODROIDs: Xu3-LITE
Has thanked: 4 times
Been thanked: 0
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by o00scorpion00o » Fri Apr 12, 2019 4:27 pm

phaseshifter wrote:
Fri Apr 12, 2019 7:24 am
yes i prefer a nice linear supply too...i know how quiet and the really is no ripple or so little that it dont matter.or just add a cap here and there.
when i see all the rave about s-modes i tend to shudder,the one`s of the internet there really harsh unless you cough up 500 od dollars for a bench-top supply..,but the ones on the net..there flooded with them..are compact and versatile..and can give huge amounts of current easily ...but the ripple some are just to noisy...the c-2`s cpu is rather noisy on it`s own in some cases have been talked about i have 3 c-2`s and i find them to be noisy..but if you hook up a hi-fi sheild to it there pretty good..few cases of noisy ones..but often it`s those cheap usb speakers with poor grounding...

btw..both c-1 and c-2 take the same 2 amp supply it`s the xu3/l/xu4 that take 4 amp...all 5 volt`ers..

btw..order a 6 amp you'll be glad you did,.,,in the long run..
I ended up ordering a 5 amp after, normal switch mode.

Some are better than others , some important filtering components are left out to save money and sometimes this results in dirty RF being radiated across the house mains wires.

LED lights, phone chargers etc all big offenders and not much is done about it despite most of them being actually non compliant.

Anyway, it should be here by about Wednesday or Thursday next week.

o00scorpion00o
Posts: 84
Joined: Mon May 25, 2015 7:31 pm
languages_spoken: english
ODROIDs: Xu3-LITE
Has thanked: 4 times
Been thanked: 0
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by o00scorpion00o » Fri Apr 19, 2019 5:18 am

Ok after receiving the new PSU today it works perfectly, thanks for all the help everyone.

Got Airspy server and drivers installed and it runs.

How do I get a script to run at startup ?

User avatar
odroid
Site Admin
Posts: 30260
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 3 times
Been thanked: 24 times
Contact:

Re: Ubuntu 18.04.1-4.14 Won't work With emmc

Unread post by odroid » Fri Apr 19, 2019 9:13 am

Please open a new topic.

Locked

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 2 guests