XU4 USB 3.0 not working and no power

Post Reply
Petro
Posts: 2
Joined: Wed Apr 10, 2019 5:34 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

XU4 USB 3.0 not working and no power

Unread post by Petro » Wed Apr 10, 2019 5:47 pm

Hi,

I have ODROID-XU4 with USB 3.0 ports problem. USB 2.0 port works fine, but USB 3.0 does not work at all, even as USB 2.0, as there is no power.

USB 3 root hub does not send enable signal to USB protection circuits. These circuits signal that there is no overcurrent (OVERCURB and OVERCURC are high), but hub keeps PWRENB and PWRENC low. During startup, hub send a few times short high pulses to enable protection circtuits, but they are kept off after that.
My guess is that there is something with USN root hub configuration, which is kept on IS25L Q512B (u11) memory circuit.

Could you please help? There is no open-source documentation on the hub, so I have a dead end.

User avatar
odroid
Site Admin
Posts: 30282
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 3 times
Been thanked: 26 times
Contact:

Re: XU4 USB 3.0 not working and no power

Unread post by odroid » Wed Apr 10, 2019 5:53 pm

Can you show us "lsusb" and "lsusb -t" outputs first?

Petro
Posts: 2
Joined: Wed Apr 10, 2019 5:34 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 USB 3.0 not working and no power

Unread post by Petro » Fri Apr 19, 2019 4:59 pm

Sorry for the delay.

USB 3.0 has no power on connectors and here is the output:

odroid@odroid:~/Desktop$ lsusb
Bus 006 Device 002: ID 0bda:8153 Realtek Semiconductor Corp.
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 2318:2808 Shining Technologies, Inc. [hex]
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

odroid@odroid:~/Desktop$ lsusb -t
/: Bus 06.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
|__ Port 1: Dev 2, If 0, Class=Vendor Specific Class, Driver=r8152, 5000M
/: Bus 05.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 480M
/: Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
/: Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 480M
/: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=exynos-ohci/3p, 12M
|__ Port 1: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 12M
|__ Port 1: Dev 2, If 1, Class=Human Interface Device, Driver=usbhid, 12M
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=s5p-ehci/3p, 480M

User avatar
odroid
Site Admin
Posts: 30282
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 3 times
Been thanked: 26 times
Contact:

Re: XU4 USB 3.0 not working and no power

Unread post by odroid » Fri Apr 19, 2019 5:03 pm

The on-board hub controller GL3521 doesn't exist.
It seems to be damaged by unknown electrical shock probably.

Contact "odroid at hardkernel dot com" with a link of this post.
She will help your RMA process within a couple of working days if you purchased the board from us directly.
Otherwise, contact your local distributor/reseller.

Post Reply

Return to “Hardware and peripherals”

Who is online

Users browsing this forum: No registered users and 0 guests