Wifi Module 0 - Slow throughput when connected to USB 3

Post Reply
mcgillca
Posts: 9
Joined: Fri Nov 10, 2017 3:43 pm
languages_spoken: english
ODROIDs: XU4
Contact:

Wifi Module 0 - Slow throughput when connected to USB 3

Unread post by mcgillca » Sun Dec 30, 2018 3:44 am

Hi - I am connecting to my XU4 through the Wifi Module 0 and controlling it through VNC.

I have found that when I connect the Module to the USB 2 socket, everything works well - I get a data transfer rate (as reported by VNC) of 55mbps.

However, when I connect the module to the USB 3 socket, or to a hub connected to the USB socket, the transfer rate is less than 1 mbps.

I see others in the forum have mentioned post throughputs from their wifi connectors and I wonder if this is the problem for them too?

Any ideas?

I'm using Ubuntu mate 16.04.

Thank you,

Colin

User avatar
mad_ady
Posts: 5387
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Contact:

Re: Wifi Module 0 - Slow throughput when connected to USB 3

Unread post by mad_ady » Sun Dec 30, 2018 8:29 pm

I can't help you with your problem, but wifi0 module is a usb2 device, so there would be no benefit to connect it to usb3.
You should do some speedtests as well (with iperf) in both configurations, to rule out other factors.

User avatar
odroid
Site Admin
Posts: 29994
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: Wifi Module 0 - Slow throughput when connected to USB 3

Unread post by odroid » Mon Dec 31, 2018 10:44 am

Do you have a USB 2.0 extension cable to narrow down root causes?

Post Reply

Return to “Hardware and peripherals”

Who is online

Users browsing this forum: No registered users and 2 guests