emmc dosent work

Post Reply
Titanity
Posts: 5
Joined: Tue Dec 11, 2018 4:28 am
languages_spoken: english
ODROIDs: XU4
Contact:

emmc dosent work

Unread post by Titanity » Wed Dec 12, 2018 11:56 am

Hello guys...

I bought a XU4 and a 16gb emmc with it... Problem is the emmc dosent work at all. When i try flash a OS using etcher then i put the EMMC (on a usb) into the computer and windows10 reconize the module right away but also turns it off again after 5 secs... Both the emmc and the board is brand new...

What can i do?

User avatar
odroid
Site Admin
Posts: 30028
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: emmc dosent work

Unread post by odroid » Wed Dec 12, 2018 12:21 pm

Which eMMC do you have?
https://wiki.odroid.com/accessory/emmc/reference_chart
Let me know the PCB color.

Did you set the slide switch position correctly?

User avatar
mad_ady
Posts: 5427
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Contact:

Re: emmc dosent work

Unread post by mad_ady » Wed Dec 12, 2018 3:10 pm

You should also try a different usb reader in your pc

User avatar
OverSun
Posts: 1432
Joined: Mon Apr 29, 2013 5:12 pm
languages_spoken: english
Contact:

Re: emmc dosent work

Unread post by OverSun » Wed Dec 12, 2018 4:13 pm

I have similar problem with all new orange eMMC and my reader. None of them work properly in it. Old red and blue ones are totally fine. Try to get and test another reader.

Titanity
Posts: 5
Joined: Tue Dec 11, 2018 4:28 am
languages_spoken: english
ODROIDs: XU4
Contact:

Re: emmc dosent work

Unread post by Titanity » Wed Dec 12, 2018 11:47 pm

It´s the orange one i have. And i tryed many different ways to connect it. Also on my girlfriends computer

Titanity
Posts: 5
Joined: Tue Dec 11, 2018 4:28 am
languages_spoken: english
ODROIDs: XU4
Contact:

Re: emmc dosent work

Unread post by Titanity » Wed Dec 12, 2018 11:48 pm

And yes ofcourse i set the side switch correctly

User avatar
mad_ady
Posts: 5427
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Contact:

Re: emmc dosent work

Unread post by mad_ady » Thu Dec 13, 2018 12:32 am

Does the emmc heat up a lot after you connect it to power?One that died on me electrically did that.

Since you have an xu4 you can flash it from the xu4. Boot with it and an sd card attached and with the boot switch in the sd position. You can use dd to write to /dev/mmcblk0.

Titanity
Posts: 5
Joined: Tue Dec 11, 2018 4:28 am
languages_spoken: english
ODROIDs: XU4
Contact:

Re: emmc dosent work

Unread post by Titanity » Thu Dec 13, 2018 5:00 am

No i wouldent say it gets more hot than what normal is... And i would love to do as you wrote with:

Since you have an xu4 you can flash it from the xu4. Boot with it and an sd card attached and with the boot switch in the sd position. You can use dd to write to /dev/mmcblk0.

But im not a experienced user. So if you have a guide my friend... Then i can try

User avatar
odroid
Site Admin
Posts: 30028
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: emmc dosent work

Unread post by odroid » Thu Dec 13, 2018 11:07 am

Try this eMMC recovery process first.
viewtopic.php?f=53&t=6173

Titanity
Posts: 5
Joined: Tue Dec 11, 2018 4:28 am
languages_spoken: english
ODROIDs: XU4
Contact:

Re: emmc dosent work

Unread post by Titanity » Fri Dec 14, 2018 5:18 am

So i finally found a solution and it worked. I made a rescue cd and booted it up. Used a dos partitioner program to work with the emmc card. And its possible to do so because i booted up from the cd. So the card got totally formatted and all partitions were deleted. And then i used your link o droid and the image worked. Further more then i installed Lineage os 15.1 and updated it aswell. But i havent booted any Linux yet and i cant make it work. So only android so far.

What should i do to make a ubuntu mate os on either emmc or micro sd card? Do i have to write the OS like i wrote the android OS from the sd card to emmc?

User avatar
mad_ady
Posts: 5427
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Contact:

Re: emmc dosent work

Unread post by mad_ady » Fri Dec 14, 2018 2:31 pm

You can use etcher on your pc to write an ubuntu image to the sd card. Copy the same image (unpack it from xz) to a usb stick.
Put the boot slider in the sd position, put the sd and emmc inside the xu4 and boot it. After the first boot it will power off. Power it on again and insert the usb.
From the xu4 you can now run something lke:

Code: Select all

dd if=/path/to/usb/ubuntu.img of=/dev/mmcblk0 bs=1M
When it's done, power off, eemove the sd and put the boot slider in the emmc position.

npatch
Posts: 10
Joined: Sat Jan 12, 2019 3:21 am
languages_spoken: english
ODROIDs: XU4
Contact:

Re: emmc dosent work

Unread post by npatch » Mon Jan 14, 2019 2:25 am

I'm having issues with both of my emmc's and perhaps the USB adapter(all recently purchased). Etcher gives me an error(Can't write to this location...maybe the port/adapter etc is corrupt) when it finishes flashing the ubuntu image on the 64GB emmc(blue color), but surprisingly the emmc boots ok(at least I haven't seen some issue yet). Etcher also gives me an error before it starts flashing the android image on the 16GB emmc(white color), saying diskpart in Windows 10 failed to clean it. The reason I want to reflash Android is because I ran the Odroid Updater and it found an update which I downloaded and executed,but noticed late that it was for XU3(when the board I own is an XU4). It booted ok, but it messed up the Ethernet usage. IP and MAC are set to zeroes. I've tried flashing Android through Windows 10 with Etcher and Win32DiskImager, as well as through Linux(both apps) and using a different USB adapter(the purchase was two sets of the same stuff so there was an extra USB adapter), but no dice.

PS: At the moment I'm backing up stuff from a microSD to try the flashing procedure from Odroid. Will it work, considering the above?

User avatar
odroid
Site Admin
Posts: 30028
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: emmc dosent work

Unread post by odroid » Mon Jan 14, 2019 10:02 am

@npatch,
Try other USB adapter.
viewtopic.php?f=53&t=2725

User avatar
rooted
Posts: 6437
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Contact:

Re: emmc dosent work

Unread post by rooted » Mon Jan 14, 2019 8:07 pm

That reader did not come from Hardkernel.

npatch
Posts: 10
Joined: Sat Jan 12, 2019 3:21 am
languages_spoken: english
ODROIDs: XU4
Contact:

Re: emmc dosent work

Unread post by npatch » Mon Jan 14, 2019 8:14 pm

You're right. It was Ameridroid. My bad. Someone else made the purchase.

As to the Android part though, I tried the 4.4.4 Android(v6.6) sd2emmc image on a spare SD card. The instructions say the status LED has to blink when it's done. But it never did. It straight up turned off. It works now.

User avatar
rooted
Posts: 6437
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Contact:

Re: emmc dosent work

Unread post by rooted » Mon Jan 14, 2019 10:43 pm

Glad you got it sorted

npatch
Posts: 10
Joined: Sat Jan 12, 2019 3:21 am
languages_spoken: english
ODROIDs: XU4
Contact:

Re: emmc dosent work

Unread post by npatch » Mon Jan 14, 2019 10:46 pm

Thx. My issue is towards the tutorial at this point. Has the "Once it starts blinking,it's finished" part changed? I tried this process like 4-5 times, but it never blinked. At the end I noticed the emmc worked(though it did 1-2 restarts before it booted propely...resizing partitions?!).

User avatar
rooted
Posts: 6437
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Contact:

Re: emmc dosent work

Unread post by rooted » Mon Jan 14, 2019 10:49 pm

I can't say, it's been a good while since I last used the recovery method.

npatch
Posts: 10
Joined: Sat Jan 12, 2019 3:21 am
languages_spoken: english
ODROIDs: XU4
Contact:

Re: emmc dosent work

Unread post by npatch » Mon Jan 14, 2019 10:52 pm

I wonder if @odroid can verify.

User avatar
odroid
Site Admin
Posts: 30028
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: emmc dosent work

Unread post by odroid » Tue Jan 15, 2019 9:03 am

npatch wrote:
Mon Jan 14, 2019 8:14 pm
You're right. It was Ameridroid. My bad. Someone else made the purchase.

As to the Android part though, I tried the 4.4.4 Android(v6.6) sd2emmc image on a spare SD card. The instructions say the status LED has to blink when it's done. But it never did. It straight up turned off. It works now.
I've slightly updated the step 6. Sorry for the confusion caused.

npatch
Posts: 10
Joined: Sat Jan 12, 2019 3:21 am
languages_spoken: english
ODROIDs: XU4
Contact:

Re: emmc dosent work

Unread post by npatch » Sun Feb 03, 2019 5:46 pm

No problem. Managed to fix both versions anyway(Android only through the SD workaround and Linux through the incompatible usb adapter,somehow it works :S).

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: Bing [Bot] and 0 guests