XU4 Android 14.1 - Network keeps dropping!

Moderators: mdrjr, odroid

XU4 Android 14.1 - Network keeps dropping!

Unread postby Naass » Sun Sep 09, 2018 3:58 pm

Greetings to all forumers,
I flashed the Lineage 14.1 as per Voodik instruction and followed it by the update.
Everything went right, but network connection keeps dropping.
I gave the XU4 a static address on my router and kept the setting on XU4 itself as DHCP.
The network keeps dropping. I have to disconnect the Ethernet cable and reconnect it to retrieve the connection.
I use a quality 1 meter CAT 7 Ethernet cable and the power supply is the one supplied by Hardkernel!
Anybody has a solution?
Thanks in advance.
Naass
Naass
 
Posts: 5
Joined: Sun Sep 09, 2018 3:50 pm
languages_spoken: english
ODROIDs: XU4

Re: XU4 Android 14.1 - Network keeps dropping!

Unread postby rooted » Sun Sep 09, 2018 5:03 pm

Could you show the output of dmesg after losing connection?
User avatar
rooted
 
Posts: 5474
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: XU4 Android 14.1 - Network keeps dropping!

Unread postby Naass » Sun Sep 09, 2018 10:16 pm

rooted wrote:Could you show the output of dmesg after losing connection?


Hi Rooted,
Could you please tell me how to oibtain this "dmesg" output?
Thanks
Naass
 
Posts: 5
Joined: Sun Sep 09, 2018 3:50 pm
languages_spoken: english
ODROIDs: XU4

Re: XU4 Android 14.1 - Network keeps dropping!

Unread postby mad_ady » Sun Sep 09, 2018 10:22 pm

Install a terminal emulator from the play store and type in dmesg. The last 10 lines should be enough
User avatar
mad_ady
 
Posts: 4466
Joined: Wed Jul 15, 2015 5:00 pm
Location: Bucharest, Romania
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1

Re: XU4 Android 14.1 - Network keeps dropping!

Unread postby Naass » Mon Sep 10, 2018 1:48 am

Ouf!
I hope I didn't mess it up!
Anyway, this is what I get with demsg, the last 20 lines:

[10338.596734] [c2] type=1400 audit(1536509017.769:47): avc: denied { open } for pid=7019 comm="profman" name="primary.prof" dev="mmcblk0p3" ino=375720 scontext=u:r:profman:s0 tcontext=u:object_r:user_profile_data_file:s0 tclass=file permissive=1
[10338.757437] [c3] type=1400 audit(1536509017.934:48): avc: denied { getattr } for pid=4198 comm="sAsyncHandlerTh" path="/cache/backup" dev="mmcblk0p4" ino=8195 scontext=u:r:priv_app:s0:c512,c768 tcontext=u:object_r:cache_private_backup_file:s0 tclass=dir permissive=1
[11337.665917] [c3] s5p-hdmi 14530000.hdmi: HDMI interrupt changed to internal
[11359.661079] [c4] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[11375.360892] [c1] set_aud_pll_rate[51] : aud_pll set_rate=180633600, get_rate = 180633609
[11382.690422] [c3] set_aud_pll_rate[51] : aud_pll set_rate=180633600, get_rate = 180633609
[11386.276231] [c0] set_aud_pll_rate[51] : aud_pll set_rate=180633600, get_rate = 180633609
[11389.617583] [c0] samsung-i2s 3830000.i2s: i2s_set_sysclk:504 Other DAI busy
[11393.948110] [c2] pd-g3d: Power-off latency exceeded, new value 2242084 ns
[11394.817620] [c2] set_aud_pll_rate[51] : aud_pll set_rate=180633600, get_rate = 180633609
[11409.926056] [c0] set_aud_pll_rate[51] : aud_pll set_rate=180633600, get_rate = 180633609
[11423.490389] [c3] type=1400 audit(1536510102.664:49): avc: denied { read } for pid=4199 comm="ngs.android.pop" name="build.prop" dev="mmcblk0p2" ino=463 scontext=u:r:untrusted_app:s0:c512,c768 tcontext=u:object_r:rootfs:s0 tclass=file permissive=1
[11423.511536] [c1] type=1400 audit(1536510102.664:50): avc: denied { open } for pid=4199 comm="ngs.android.pop" path="/system/build.prop" dev="mmcblk0p2" ino=463 scontext=u:r:untrusted_app:s0:c512,c768 tcontext=u:object_r:rootfs:s0 tclass=file permissive=1
[11423.536988] [c2] type=1400 audit(1536510102.664:51): avc: denied { getattr } for pid=4199 comm="ngs.android.pop" path="/system/build.prop" dev="mmcblk0p2" ino=463 scontext=u:r:untrusted_app:s0:c512,c768 tcontext=u:object_r:rootfs:s0 tclass=file permissive=1
[11426.744059] [c0] set_aud_pll_rate[51] : aud_pll set_rate=180633600, get_rate = 180633609
[11431.383967] [c0] set_aud_pll_rate[51] : aud_pll set_rate=180633600, get_rate = 180633609
[11435.807914] [c0] set_aud_pll_rate[51] : aud_pll set_rate=180633600, get_rate = 180633609
[11439.259888] [c2] binder: 3396:3471 transaction failed 29189, size 340-0
[11446.024413] [c0] set_aud_pll_rate[51] : aud_pll set_rate=180633600, get_rate = 180633609
$[x] 0

Cheers
Naass
 
Posts: 5
Joined: Sun Sep 09, 2018 3:50 pm
languages_spoken: english
ODROIDs: XU4

Re: XU4 Android 14.1 - Network keeps dropping!

Unread postby rooted » Mon Sep 10, 2018 2:04 am

You did that after the network dropped out?

Open a terminal and do this:

Code: Select all
su
echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6


I think ipv6 may be problematic for you.
User avatar
rooted
 
Posts: 5474
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: XU4 Android 14.1 - Network keeps dropping!

Unread postby Naass » Mon Sep 10, 2018 2:21 am

It returned 255
Naass
 
Posts: 5
Joined: Sun Sep 09, 2018 3:50 pm
languages_spoken: english
ODROIDs: XU4

Re: XU4 Android 14.1 - Network keeps dropping!

Unread postby mad_ady » Mon Sep 10, 2018 2:46 am

The ipv6 message usually appears after each link up event.
Doeas the problem manifest itself randomly or about every lease interval?
I'd recommend setting a static ip to bypass the dhcp server.
User avatar
mad_ady
 
Posts: 4466
Joined: Wed Jul 15, 2015 5:00 pm
Location: Bucharest, Romania
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1

Re: XU4 Android 14.1 - Network keeps dropping!

Unread postby rooted » Mon Sep 10, 2018 3:38 am

mad_ady wrote:The ipv6 message usually appears after each link up event.
Doeas the problem manifest itself randomly or about every lease interval?
I'd recommend setting a static ip to bypass the dhcp server.
ipv6 is buggy on some gateways, disabling it removes that from the equation.

I have had problems with it on my last two.
User avatar
rooted
 
Posts: 5474
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: XU4 Android 14.1 - Network keeps dropping!

Unread postby voodik » Mon Sep 10, 2018 7:11 pm

please post logcat output
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
User avatar
voodik
 
Posts: 1374
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian

Re: XU4 Android 14.1 - Network keeps dropping!

Unread postby Naass » Mon Sep 10, 2018 7:48 pm

Hi Folks,
Static IP address didn't work, with or without IP address reservation on the router.
It connects to the router, but no internet at all.
What seems to have solved the problem (fingers crossed) is turning IP6 off on the router.
Thanks to you all for your precious help.
Have a great weekend.

P. S.
To Voodik, do you still need that output?
Thanks for your great efforts.

Sent from my Active using Tapatalk
Naass
 
Posts: 5
Joined: Sun Sep 09, 2018 3:50 pm
languages_spoken: english
ODROIDs: XU4


Return to Android

Who is online

Users browsing this forum: No registered users and 0 guests