[SOLVED] Lightdm stopped working

Moderators: mdrjr, odroid

[SOLVED] Lightdm stopped working

Unread postby ARnonym123 » Mon Aug 13, 2018 8:53 am

Hello,
today I was experimenting with getting the cloudshell's lcd display to run. Whilst trying various things it seems like I somehow broke my lightdm. Upon boot, I see some flashing white lines and then just a blinking cursor. I can still Ctrl+Alt+F1/F2/... into the other consoles. I already reverted the lightdm configs under /etc/lightdm and /usr/share/lightdm to their installation state. I also reverted the /etc/X11/xorg.conf file, as I modified this in order to use the lcd. I am stuck right now. I updated all packages with
Code: Select all
apt-get update && apt-get dist-upgrade
.
Am I not seeing something? If you need additional log- or configfiles please tell me.

Additional info: I am using the system off an ssd, which is conencted through cloudshell. It worked previously with this setup. I don't know, what I messed up :(

Code: Select all
root@odroid:/root# uname -a
Linux odroid 3.10.105 #1 SMP PREEMPT Tue Mar 28 13:17:20 UTC 2017 armv7l armv7l armv7l GNU/Linux


Code: Select all
root@odroid:/root# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.5 LTS
Release:        16.04
Codename:       xenial


Code: Select all
root@odroid:/root# systemctl restart lightdm
root@odroid:/root# systemctl status lightdm
‚óŹ lightdm.service - Light Display Manager
   Loaded: loaded (/lib/systemd/system/lightdm.service; enabled; vendor preset: enabled)
   Active: inactive (dead) (Result: exit-code) since Mon 2018-08-13 01:40:03 CEST; 754ms ago
     Docs: man:lightdm(1)
  Process: 8665 ExecStart=/usr/sbin/lightdm (code=exited, status=1/FAILURE)
  Process: 8660 ExecStartPre=/bin/sh -c [ "$(basename $(cat /etc/X11/default-display-manager 2>/dev/null))" = "lightdm" ] (code=exited, status=0/SUCCESS)
 Main PID: 8665 (code=exited, status=1/FAILURE)

Aug 13 01:40:03 odroid systemd[1]: lightdm.service: Unit entered failed state.
Aug 13 01:40:03 odroid systemd[1]: lightdm.service: Failed with result 'exit-code'.
Aug 13 01:40:03 odroid systemd[1]: lightdm.service: Service hold-off time over, scheduling restart.
Aug 13 01:40:03 odroid systemd[1]: Stopped Light Display Manager.
Aug 13 01:40:03 odroid systemd[1]: lightdm.service: Start request repeated too quickly.
Aug 13 01:40:03 odroid systemd[1]: Failed to start Light Display Manager.
lines 1-14/14 (END)


Code: Select all
root@odroid:/root# lightdm --test-mode --debug
[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.18.3, UID=0 PID=8802
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-disable-log-backup.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-ubuntu-mate.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: Using Xephyr for X servers
[+0.00s] DEBUG: Registered seat module xlocal
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Registered seat module unity
[+0.01s] DEBUG: Monitoring logind for seats
[+0.01s] DEBUG: New seat added from logind: seat0
[+0.02s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.02s] DEBUG: Seat seat0: Starting
[+0.02s] DEBUG: Seat seat0: Creating greeter session
[+0.02s] DEBUG: Seat seat0: Creating display server of type x
[+0.02s] DEBUG: Using VT 7
[+0.02s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.02s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
[+0.02s] DEBUG: DisplayServer x-0: Can't launch X server Xephyr, not found in path
[+0.02s] DEBUG: DisplayServer x-0: X server stopped
[+0.02s] DEBUG: Releasing VT 7
[+0.02s] DEBUG: Seat seat0: Display server stopped
[+0.02s] DEBUG: Seat seat0: Can't create display server for greeter
[+0.02s] DEBUG: Seat seat0: Session stopped
[+0.02s] DEBUG: Seat seat0: Stopping display server, no sessions require it
[+0.02s] DEBUG: Seat seat0: Stopping
[+0.02s] DEBUG: Seat seat0: Stopped
[+0.02s] DEBUG: Failed to start seat: seat0

And with Xephyr installed(which I didn't have, before I tried to use the lcd. I installed it after lightdm threw these errors):
Code: Select all
root@odroid:/root# lightdm --test-mode --debug
[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.18.3, UID=0 PID=9324
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-disable-log-backup.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-ubuntu-mate.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: Using Xephyr for X servers
[+0.00s] DEBUG: Registered seat module xlocal
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Registered seat module unity
[+0.02s] DEBUG: Monitoring logind for seats
[+0.02s] DEBUG: New seat added from logind: seat0
[+0.02s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.02s] DEBUG: Seat seat0: Starting
[+0.02s] DEBUG: Seat seat0: Creating greeter session
[+0.02s] DEBUG: Seat seat0: Creating display server of type x
[+0.02s] DEBUG: Using VT 7
[+0.02s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.02s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
[+0.02s] DEBUG: DisplayServer x-0: Writing X server authority to /var/run/lightdm/root/:0
[+0.02s] DEBUG: DisplayServer x-0: Launching X Server
[+0.03s] DEBUG: Launching process 9330: /usr/bin/Xephyr :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.03s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
[+0.03s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.03s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.03s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.03s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+0.04s] DEBUG: User /org/freedesktop/Accounts/User64055 added
[+0.05s] DEBUG: User /org/freedesktop/Accounts/User1001 added
[+0.05s] DEBUG: Process 9330 exited with return value 1
[+0.05s] DEBUG: DisplayServer x-0: X server stopped
[+0.05s] DEBUG: Releasing VT 7
[+0.05s] DEBUG: DisplayServer x-0: Removing X server authority /var/run/lightdm/root/:0
[+0.05s] DEBUG: Seat seat0: Display server stopped
[+0.05s] DEBUG: Seat seat0: Stopping; greeter display server failed to start
[+0.05s] DEBUG: Seat seat0: Stopping
[+0.05s] DEBUG: Seat seat0: Stopping session
[+0.05s] DEBUG: Seat seat0: Session stopped
[+0.05s] DEBUG: Seat seat0: Stopped
[+0.05s] DEBUG: Required seat has stopped
[+0.05s] DEBUG: Stopping display manager
[+0.05s] DEBUG: Display manager stopped
[+0.05s] DEBUG: Stopping daemon
[+0.05s] DEBUG: Seat seat0: Stopping session
[+0.06s] DEBUG: Exiting with return value 1


Code: Select all
root@odroid:/etc/X11# cat xorg.conf
Section "Device"
        Identifier      "Mali-Fbdev"
        Driver          "armsoc"
        Option          "fbdev"         "/dev/fb0"
        Option          "Debug"         "true"
        Option          "DPMS"          "false"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "Mali-Fbdev"
        DefaultDepth    24
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Option          "BlankTime"     "0"
        Option          "StandbyTime"   "0"
        Option          "SuspendTime"   "0"
        Option          "OffTime"       "0"
EndSection

Section "DRI"
        Mode            0666
EndSection




~ARnonym123
~ARnonym123~
Odroid:Odroid XU4, CloudShell, 8 GB SD (boot), 32 GB Transcend SSD (operating system)

PC:ASRock Z68 Pro3, Intel I5-2500k, ASUS GTX 1050 Ti, Crucial MX300 525 GB SSD, 2 TB Toshiba HDD

NAS:Synology DiskStation DS414j, 4x 3 TB WD HDD
ARnonym123
 
Posts: 5
Joined: Thu Feb 23, 2017 10:24 pm
languages_spoken: German, English, (a bit of) French
ODROIDs: XU4 and Cloudshell

Re: Lightdm stopped working

Unread postby odroid » Mon Aug 13, 2018 10:59 am

Consider flashing the latest Ubuntu 18.04 / Kernel 4.14 image.
Your Kernel version is really old.

BTW, are you going to run the x11 desktop on the small 320x240 LCD?
User avatar
odroid
Site Admin
 
Posts: 28701
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Lightdm stopped working

Unread postby ARnonym123 » Mon Aug 13, 2018 5:40 pm

Thank you for your reply. I will try to flash the latest Ubuntu. Is there anything I need to pay attention to? And what configfiles can I backup and use in the newer version? I am currently running a PiHole network ad-blocker on my odroid.

Uhm. I don't think so. I tried to setup the pihole chronometer (stats and stuff) in order to work like the example cloudshell-lcd program.
~ARnonym123~
Odroid:Odroid XU4, CloudShell, 8 GB SD (boot), 32 GB Transcend SSD (operating system)

PC:ASRock Z68 Pro3, Intel I5-2500k, ASUS GTX 1050 Ti, Crucial MX300 525 GB SSD, 2 TB Toshiba HDD

NAS:Synology DiskStation DS414j, 4x 3 TB WD HDD
ARnonym123
 
Posts: 5
Joined: Thu Feb 23, 2017 10:24 pm
languages_spoken: German, English, (a bit of) French
ODROIDs: XU4 and Cloudshell

Re: Lightdm stopped working

Unread postby phaseshifter » Mon Aug 13, 2018 5:50 pm

all you need to back up is your own data all your own config files the standard files will be updated with the new image once you flash it..

also once you boot the new image let it power off to complete the expansion of the root file system partition...then re-power and start the procedure to update the new image /system..etc..etc..

also this only needs to be done on the first initial boot of the system..
after that run an update ..open a terminal..and change to super user..etc..run update..etc..
after that your good to go with it..
Last edited by phaseshifter on Mon Aug 13, 2018 6:01 pm, edited 1 time in total.
Odroids
phaseshifter
 
Posts: 2930
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: N-1..c1+ ..c-2..xu3 lite,xu4...u-3..
u-2...other odroid acc`s as well

Re: Lightdm stopped working

Unread postby phaseshifter » Mon Aug 13, 2018 5:56 pm

look around the cloudshell there is a stat`s program you could most prolly run on the screena
as it was meant for c-shell II..
.but when i find it i will post back..it could be in the wiki pages..mem failing me atm..
Last edited by phaseshifter on Mon Aug 13, 2018 6:16 pm, edited 1 time in total.
Odroids
phaseshifter
 
Posts: 2930
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: N-1..c1+ ..c-2..xu3 lite,xu4...u-3..
u-2...other odroid acc`s as well

Re: Lightdm stopped working

Unread postby ARnonym123 » Mon Aug 13, 2018 5:59 pm

So the procedure to move the operating system to the ssd will also work as before?
I really liked this performance boost through a ssd :(
~ARnonym123~
Odroid:Odroid XU4, CloudShell, 8 GB SD (boot), 32 GB Transcend SSD (operating system)

PC:ASRock Z68 Pro3, Intel I5-2500k, ASUS GTX 1050 Ti, Crucial MX300 525 GB SSD, 2 TB Toshiba HDD

NAS:Synology DiskStation DS414j, 4x 3 TB WD HDD
ARnonym123
 
Posts: 5
Joined: Thu Feb 23, 2017 10:24 pm
languages_spoken: German, English, (a bit of) French
ODROIDs: XU4 and Cloudshell

Re: Lightdm stopped working

Unread postby phaseshifter » Mon Aug 13, 2018 6:04 pm

Odroids
phaseshifter
 
Posts: 2930
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: N-1..c1+ ..c-2..xu3 lite,xu4...u-3..
u-2...other odroid acc`s as well

Re: Lightdm stopped working

Unread postby phaseshifter » Mon Aug 13, 2018 6:07 pm

you`ll have to move the opp system as you did from scratch unfortunately
you just cannot flash the image to sd/emmc and use the old root file system on ssd as files will all be different..etc..etc...

yeah ssd`s are nice.
Last edited by phaseshifter on Mon Aug 13, 2018 6:08 pm, edited 1 time in total.
Odroids
phaseshifter
 
Posts: 2930
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: N-1..c1+ ..c-2..xu3 lite,xu4...u-3..
u-2...other odroid acc`s as well

Re: Lightdm stopped working

Unread postby odroid » Mon Aug 13, 2018 6:07 pm

Refer this guide to move the rootfs to the SSD.
https://wiki.odroid.com/odroid-xu4/soft ... _partition
User avatar
odroid
Site Admin
 
Posts: 28701
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Lightdm stopped working

Unread postby ARnonym123 » Mon Aug 13, 2018 6:26 pm

phaseshifter wrote:https://forum.odroid.com/viewtopic.php?f=147&t=30469#p218632

Thanks. I will take a look into it.

phaseshifter wrote:you`ll have to move the opp system as you did from scratch unfortunately
you just cannot flash the image to sd/emmc and use the old root file system on ssd as files will all be different..etc..etc...
[..]

No, that would be kinda horrible.

odroid wrote:Refer this guide to move the rootfs to the SSD.
https://wiki.odroid.com/odroid-xu4/soft ... _partition

This looks good. I'll definitely give this a try.
~ARnonym123~
Odroid:Odroid XU4, CloudShell, 8 GB SD (boot), 32 GB Transcend SSD (operating system)

PC:ASRock Z68 Pro3, Intel I5-2500k, ASUS GTX 1050 Ti, Crucial MX300 525 GB SSD, 2 TB Toshiba HDD

NAS:Synology DiskStation DS414j, 4x 3 TB WD HDD
ARnonym123
 
Posts: 5
Joined: Thu Feb 23, 2017 10:24 pm
languages_spoken: German, English, (a bit of) French
ODROIDs: XU4 and Cloudshell

Re: Lightdm stopped working

Unread postby ARnonym123 » Mon Aug 13, 2018 10:49 pm

So far everything worked. The flashing procedure was fast and moving the operating system was much easier thanks to the new guide.
Now I'll try the LCD..

[Edit]
LCD is working quite well. Xorg is now running on the LCD.
I think this topic is solved.
~ARnonym123~
Odroid:Odroid XU4, CloudShell, 8 GB SD (boot), 32 GB Transcend SSD (operating system)

PC:ASRock Z68 Pro3, Intel I5-2500k, ASUS GTX 1050 Ti, Crucial MX300 525 GB SSD, 2 TB Toshiba HDD

NAS:Synology DiskStation DS414j, 4x 3 TB WD HDD
ARnonym123
 
Posts: 5
Joined: Thu Feb 23, 2017 10:24 pm
languages_spoken: German, English, (a bit of) French
ODROIDs: XU4 and Cloudshell


Return to Issues

Who is online

Users browsing this forum: bavader and 5 guests