Mount error

Moderators: odroid, mdrjr, wrxtasy, Raybuntu

Mount error

Unread postby JEDI JF » Thu Jul 19, 2018 6:43 am

​Hi

I just go an Odroid C2 and wanted to use LibreElec. I bought 2 kits from ameridoid with eMMC that were installed with Kodi. I booted the first unit and it worked fine. There was an update that was downloaded so I rebooted and then I got an error: Error in mount_flash: mount_common: Could not mount /dev/mmcblk0p1

I downloaded LibreELEC.USB-SD.Creator.Win32.exe and the latest image and I flashed the eMMC using the Transcend USB 3 SD card reader/writer (bought from ameridroid)​. It booted fine and then I did a reboot from the Kodi and same error: Error in mount_flash: mount_common: Could not mount /dev/mmcblk0p1

I flashed again using etcher, I tried the second power supply, second eMMC, second Odroid C2​ but I still have the same issue. I don't think both units would be defective so I must be doing something wrong. I really don't know what to do at this point.
JEDI JF
 
Posts: 5
Joined: Thu Jul 19, 2018 6:41 am
languages_spoken: english, french
ODROIDs: C2

Re: Mount error

Unread postby JEDI JF » Thu Jul 19, 2018 9:19 am

Update: I tried the exact same thing with an old 32 GB SD card I had instead of both eMMC 32 GB. I used the LibreELEC.USB-SD.Creator.Win32.exe and the latest image and I flashed the eMMC using the Transcend USB 3 SD card reader/writer. With the SD card it is working fine. I rebooted multiple times and it seems to always work.

I noticed the PCB of the eMMC I have doesn't say HardKernel. Could it be incompatible? This is what I have:
https://ameridroid.com/products/emmc-bl ... 5907492898

I have 2 of them so I don't think both could be defective but I guess both could be incompatible? I bought them from that web site, it was in the Kodi kit so I assume it should be compatible? I'll admit I am lost at this point.
JEDI JF
 
Posts: 5
Joined: Thu Jul 19, 2018 6:41 am
languages_spoken: english, french
ODROIDs: C2

Re: Mount error

Unread postby odroid » Thu Jul 19, 2018 9:34 am

It is not our official product.
Our official one must be black or orange.
https://www.hardkernel.com/main/product ... 5622510341
https://www.hardkernel.com/main/product ... 0825660587

I don't know why they are selling a slow fake eMMC instead of our genuine storage.

I've just downloaded LibreELEC-Odroid_C2.aarch64-8.2.5.img.gz image and flashed to our official eMMC with Etcher.
It worked well.
User avatar
odroid
Site Admin
 
Posts: 29088
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Mount error

Unread postby rooted » Thu Jul 19, 2018 11:21 am

odroid wrote:
I don't know why they are selling a slow fake eMMC instead of our genuine storage.

I've just downloaded LibreELEC-Odroid_C2.aarch64-8.2.5.img.gz image and flashed to our official eMMC with Etcher.
It worked well.


I would definitely tell Ameridroid to stop selling those as compatible with odroid products.
User avatar
rooted
 
Posts: 5873
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english

Re: Mount error

Unread postby Ameridroid » Thu Jul 19, 2018 11:32 am

Hello HK and Rooted,

I would be more than happy to send you some for your testing. I have done side by side comparisons across all boards and with all images. I even tried to replicate the above error, but I installed a fresh LibreELEC-Odroid_C2.aarch64-8.2.5.img and it worked and is still working without fail. I would be more than happy to replace the above eMMCs with the orange module if needed. @Jedi JF, please let me know.

SH
AD
Ameridroid
 
Posts: 164
Joined: Thu Mar 17, 2016 4:19 am
languages_spoken: english

Re: Mount error

Unread postby JEDI JF » Thu Jul 19, 2018 12:00 pm

Hi

I got your private message unfortunately I just registered to this forum so I cannot write private messages yet. I sent an e-mail before your post to 'orders@ameridroid.com' at 8:56 PM eastern time so you should be able to find it. Please let me know because private messages are not available to me yet.

Thanks
JEDI JF
 
Posts: 5
Joined: Thu Jul 19, 2018 6:41 am
languages_spoken: english, french
ODROIDs: C2

Re: Mount error

Unread postby Ameridroid » Thu Jul 19, 2018 12:05 pm

JEDI JF wrote:Hi

I got your private message unfortunately I just registered to this forum so I cannot write private messages yet. I sent an e-mail before your post to 'orders@ameridroid.com' at 8:56 PM eastern time so you should be able to find it. Please let me know because private messages are not available to me yet.

Thanks


Hello Jedi JF,

Sure thing. I will look for it now. Maybe one of the staff filed it. I will find it

Sorry for the inconvenience.

Sincerely
SH
ameriDroid
Ameridroid
 
Posts: 164
Joined: Thu Mar 17, 2016 4:19 am
languages_spoken: english

Re: Mount error

Unread postby rooted » Thu Jul 19, 2018 12:18 pm

I would have asked which LE image they used exactly but it booted once so it must be the right image.

@Ameridroid
Since you have the same eMMC, you could try to replicate the issue with the same file they used. Or at least this is what I would try.
User avatar
rooted
 
Posts: 5873
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english

Re: Mount error

Unread postby Anto2 » Sat Aug 11, 2018 2:37 am

Hello, I just received the order of Ameridroid with a module "Red box of 8 gb" and I have the same problem with the emmc module that says "JEDI JF"
I am using the same image LibreELEC-Odroid_C2.aarch64-8.2.5.img installed with Etcher
I have done a lot of tests and it continues with the same error

What is the solution? Is the emmc module not compatible?

regards
Attachments
20180807_202308_resized.jpg
20180807_202308_resized.jpg (75.09 KiB) Viewed 1248 times
Anto2
 
Posts: 6
Joined: Sat Aug 11, 2018 2:21 am
languages_spoken: spanish
ODROIDs: Odroid C2 - 8 GB emmc

Re: Mount error

Unread postby rooted » Sat Aug 11, 2018 5:55 am

There seems to be some type of compatibility issue.
User avatar
rooted
 
Posts: 5873
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english

Re: Mount error

Unread postby Anto2 » Mon Aug 13, 2018 6:32 am

Thank you,

I have written to Ameridroid asking for a solution.


regards
Anto2
 
Posts: 6
Joined: Sat Aug 11, 2018 2:21 am
languages_spoken: spanish
ODROIDs: Odroid C2 - 8 GB emmc

Re: Mount error

Unread postby JEDI JF » Wed Aug 15, 2018 12:08 am

I replaced mine with HardKernel Orange eMMC and everything works great now. I didn't find a solution with the white eMMC (which worked fine with Ubuntu and Android but not LibreELEC).
JEDI JF
 
Posts: 5
Joined: Thu Jul 19, 2018 6:41 am
languages_spoken: english, french
ODROIDs: C2

Re: Mount error

Unread postby Ameridroid » Tue Aug 21, 2018 1:13 am

There are no problems with the eMMCs. I am running the exact same setup up on mine.
If you have issues with an eMMC I recommend cleaning the eMMC using diskpart.

I have received the same error before with Etcher on the Orange eMMCs and did the above.

Due to the hit and miss with Etcher, I usually use win32 with no issues.

Thank you
AD
Ameridroid
 
Posts: 164
Joined: Thu Mar 17, 2016 4:19 am
languages_spoken: english

Re: Mount error

Unread postby Anto2 » Sun Aug 26, 2018 8:53 am

Hello,
finally after talking with Ameridroid this has been your answer:

Hello Antonio,

I am running tests now on that model and I can see it looks like this is an error when trying to expand during the first boot. The strange part is the exact same chip on the 16GB does not give this error.

Thank you for bringing this to my attention. I will go ahead and refund you for that chip. You can keep it and us it for a different OS in the meantime.

Once I have a solution I will let you know.

Sorry for the inconvenience.

Thank you
Anto2
 
Posts: 6
Joined: Sat Aug 11, 2018 2:21 am
languages_spoken: spanish
ODROIDs: Odroid C2 - 8 GB emmc

Re: Mount error

Unread postby leo5111 » Fri Sep 07, 2018 11:04 pm

so no fix ?
leo5111
 
Posts: 57
Joined: Sat Jan 14, 2017 9:50 am
languages_spoken: english

Re: Mount error

Unread postby Anto2 » Sun Sep 09, 2018 2:28 am

no, at the moment
Anto2
 
Posts: 6
Joined: Sat Aug 11, 2018 2:21 am
languages_spoken: spanish
ODROIDs: Odroid C2 - 8 GB emmc

Re: Mount error

Unread postby Ameridroid » Thu Sep 13, 2018 10:30 am

Hello All,

Here is the latest update: Our eMMCs work with all boards across all images. Even have a developer who is Sweden who compared his cluster of XU4s with our eMMCs and said he sees they are 4 seconds faster. I am not a developer so I really cannot understand how 4 seconds is a big thing, but he is using the XU4s for calculations on banking software and says that he is getting 2 BILLION calculations per day. I cannot comprehend. Anyway that lets you know they are not slow.

Regarding the C2 LibreElec image which has been the big issue. According to some people I talked with over at LibreElec think it might be a kernel / driver issue for that was compiled for the orange eMMCs. The C2 nightly build 9 works on the eMMCs with the C2. The C1 LibreElec image also works with the eMMCs. We are getting closer to solving the issue, but in the meantime if you are having issues with our eMMC and LibreElec you can send the eMMCs back to me unless you would like to install the nightly build in the meantime: LibreELEC-Odroid_C2.arm-9.0-nightly-20180911-5c961f9.img.gz

This works like a charm, though it is only a nightly build.

In the meantime, until this is all worked out, if nightly builds are not your option, then you can send back and I will replace with an orange eMMC so that you are not all held up on the forum when you could be watching movies:)

Keep you all posted.

Thank you
AD
Ameridroid
 
Posts: 164
Joined: Thu Mar 17, 2016 4:19 am
languages_spoken: english

Re: Mount error

Unread postby Anto2 » Sat Sep 15, 2018 6:42 am

Hello,

thank you very much for the explanations you are giving, it seems that it is a problem that you think is important.

I will continue listening to the news that is coming out.

I do not need tips on how to spend my time, so I'll spend it on whatever I want. ;)

regards
Anto2
 
Posts: 6
Joined: Sat Aug 11, 2018 2:21 am
languages_spoken: spanish
ODROIDs: Odroid C2 - 8 GB emmc

Re: Mount error

Unread postby Anto2 » Sat Sep 22, 2018 4:24 am

Hello,
Finally, I installed the latest available version of Libreelec
LibreELEC-Odroid_C2.arm-8.90.005.img.gz
and everything works correctly. :)

regards
Anto2
 
Posts: 6
Joined: Sat Aug 11, 2018 2:21 am
languages_spoken: spanish
ODROIDs: Odroid C2 - 8 GB emmc


Return to LibreELEC - Kodi Project for C1/C2

Who is online

Users browsing this forum: No registered users and 5 guests