LineageOS-15.1 Android TV for ODROID-XU3/XU4

nakotic
Posts: 7
Joined: Wed Nov 08, 2017 8:01 pm
languages_spoken: english, german
ODROIDs: XU4 noob with RaspPi3 experience
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by nakotic » Fri Nov 16, 2018 6:56 pm

Hey guys,
I did some investigations and realized, that BT is aktually working, but with extremely poor range. I can just connect my BT speakers, when they are like 1 cm next to the dongle (more or less NFC distance). Same with BT remotes, headphones and gamepads.
First I thought the dongle antenna is broken, but on my laptop it works flawless.
Any idea why the performance is so bad with XU4 LineageOS ATV 15.1?

gregauletta
Posts: 5
Joined: Sat Nov 17, 2018 7:36 am
languages_spoken: english
ODROIDs: c2, xu4
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by gregauletta » Sat Nov 17, 2018 7:45 am

Hey voodik thanks for all your hard work . I got this up and running today following your steps. The issue I have now is I can't login to Google play store. I successfully registered device, updated to TV version but when I put in my login credentials I get an error saying problem connecting to Google servers, try again later. I've tried both emmc and SD card and this problem persists. Anyone know how to fix?

User avatar
voodik
Posts: 1426
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by voodik » Sat Nov 17, 2018 3:51 pm

gregauletta wrote:Hey voodik thanks for all your hard work . I got this up and running today following your steps. The issue I have now is I can't login to Google play store. I successfully registered device, updated to TV version but when I put in my login credentials I get an error saying problem connecting to Google servers, try again later. I've tried both emmc and SD card and this problem persists. Anyone know how to fix?
Read first post ...
First install non ATV LineageOS-15.1 then add Google account and only after that update to ATV version.
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io

gregauletta
Posts: 5
Joined: Sat Nov 17, 2018 7:36 am
languages_spoken: english
ODROIDs: c2, xu4
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by gregauletta » Sun Nov 18, 2018 4:47 am

I did follow these instructions exactly as you laid them out. I register the device before updating to tv version. i was signed into google play and the tablet version was working. once i updated to tv version i could no longer sign in to my account. play services are installed as i can use youtube without signing in. the issue is when i enter my login credentials it says '' couldnt log in, problem contacting google servers, try again later"....
could the issue be that i checked format user data when updating to tv version? im trying to start over, but now the google commands do not return a new value. if anyone could help it would be greatly appreciated. thanks again voodik for all your efforts.

User avatar
voodik
Posts: 1426
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by voodik » Sun Nov 18, 2018 10:59 am

could the issue be that i checked format user data when updating to tv version?
yes, you need update without wipe to keep google account.
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io

gregauletta
Posts: 5
Joined: Sat Nov 17, 2018 7:36 am
languages_spoken: english
ODROIDs: c2, xu4
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by gregauletta » Tue Nov 20, 2018 1:58 am

ok thanks. i figured this is where i messed up. now my issue is that the commands used to return value needed for registration with google are not returning any new value. Also the old number i registered first still shows. now i just need to figure out how to re-register the framework id.

emperornovio
Posts: 27
Joined: Sat Jan 20, 2018 12:55 am
languages_spoken: english
ODROIDs: Odroid XU4
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by emperornovio » Thu Nov 22, 2018 7:31 pm

nakotic wrote:Hey guys,
I have the latest ATV Update running on my XU4, thanks you for that amazing effort! Nevertheless, I am struggling with my bluetooth connections. I have the following Bluetooth Dongel:
https://www.amazon.de/CSL-Bluetooth-ver ... und+64-Bit
and I enabled Bluetooth in the Odroid Settings. I cannot connect my mobile or my Bluetooth Speaker (disabled sink profile on lineageos). Any help? :)
BRs
I have the same problem too. My odroid can see other Bluetooth devices like my phone, game controller and Bluetooth headset but cannot pair or connect. I have tried both with Bluetooth sink off and on. Here's my Bluetooth dongle
https://www.amazon.com/ameriDroid-USB-B ... +Bluetooth

redbird
Posts: 61
Joined: Thu Nov 14, 2013 1:23 am
languages_spoken: english
ODROIDs: U2, C2x5, XU4Qx2
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by redbird » Fri Nov 23, 2018 11:27 am

This is an amazing build!

Me and a few others are having trouble with the volume button on the remote not working. I plugged a wired usb keyboard in as well that had volume buttons on it and it would not work either.

My remote's volume buttons worked on 14.1.

Is there anything I can do that would help debug?

p.s. I happen to be using a non-smart (no cec) samsung tv if that matters.

User avatar
voodik
Posts: 1426
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by voodik » Fri Nov 23, 2018 11:59 am

emperornovio wrote:
nakotic wrote:Hey guys,
I have the latest ATV Update running on my XU4, thanks you for that amazing effort! Nevertheless, I am struggling with my bluetooth connections. I have the following Bluetooth Dongel:
https://www.amazon.de/CSL-Bluetooth-ver ... und+64-Bit
and I enabled Bluetooth in the Odroid Settings. I cannot connect my mobile or my Bluetooth Speaker (disabled sink profile on lineageos). Any help? :)
BRs
I have the same problem too. My odroid can see other Bluetooth devices like my phone, game controller and Bluetooth headset but cannot pair or connect. I have tried both with Bluetooth sink off and on. Here's my Bluetooth dongle
https://www.amazon.com/ameriDroid-USB-B ... +Bluetooth
Can you try your dongle on other versions e.g Lineage-14.1 or non ATV 15.1 ?
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io

User avatar
voodik
Posts: 1426
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by voodik » Fri Nov 23, 2018 12:00 pm

redbird wrote:This is an amazing build!

Me and a few others are having trouble with the volume button on the remote not working. I plugged a wired usb keyboard in as well that had volume buttons on it and it would not work either.

My remote's volume buttons worked on 14.1.

Is there anything I can do that would help debug?

p.s. I happen to be using a non-smart (no cec) samsung tv if that matters.
I will check for volume issues.
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io

emperornovio
Posts: 27
Joined: Sat Jan 20, 2018 12:55 am
languages_spoken: english
ODROIDs: Odroid XU4
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by emperornovio » Sat Nov 24, 2018 7:48 pm

voodik wrote:
emperornovio wrote:
nakotic wrote:Hey guys,
I have the latest ATV Update running on my XU4, thanks you for that amazing effort! Nevertheless, I am struggling with my bluetooth connections. I have the following Bluetooth Dongel:
https://www.amazon.de/CSL-Bluetooth-ver ... und+64-Bit
and I enabled Bluetooth in the Odroid Settings. I cannot connect my mobile or my Bluetooth Speaker (disabled sink profile on lineageos). Any help? :)
BRs
I have the same problem too. My odroid can see other Bluetooth devices like my phone, game controller and Bluetooth headset but cannot pair or connect. I have tried both with Bluetooth sink off and on. Here's my Bluetooth dongle
https://www.amazon.com/ameriDroid-USB-B ... +Bluetooth
Can you try your dongle on other versions e.g Lineage-14.1 or non ATV 15.1 ?

It did not work on lineage 14.1 ATV, but I'll check 15.1 and 14.1 tablet versions. Unlike someone that posted earlier, my Bluetooth dongle doesn't work regardless of the distance

emperornovio
Posts: 27
Joined: Sat Jan 20, 2018 12:55 am
languages_spoken: english
ODROIDs: Odroid XU4
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by emperornovio » Tue Dec 04, 2018 7:01 am

Hello Voodik, how can I grant permanent root access to an app? I have to grant the apps access every time it requires it. I know that SU can grant permanent access to apps so they don't have to ask every time.

veccini
Posts: 11
Joined: Sat Oct 06, 2018 8:28 am
languages_spoken: english
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by veccini » Sun Dec 09, 2018 3:19 pm

It is a fact, the Bluetooth does not work in this version, other devices are displayed but it is not able to connect. I use the same Bluetooth usb in other versions and there it works.

misterboo
Posts: 1
Joined: Sun Feb 04, 2018 8:48 am
languages_spoken: german, english
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by misterboo » Thu Dec 13, 2018 5:36 am

i see that tvheadend is included. How do i configure it?

User avatar
voodik
Posts: 1426
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by voodik » Thu Dec 13, 2018 12:32 pm

misterboo wrote:i see that tvheadend is included. How do i configure it?
run it from terminal with root.

Code: Select all

tvheadend
then you can access to web interface

Code: Select all

http://your_ip:9981
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io

sisero
Posts: 1
Joined: Sat Dec 15, 2018 2:34 am
languages_spoken: english
ODROIDs: C2 & XU4
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by sisero » Sat Dec 15, 2018 2:40 am

Hi, I can´t get this working, I installed the operating system, and everything boots correctly, but I can´t update to TV-OS. I pressed "Get the latest version" changed the URL, pressed download. After it was finished downloading, I validated the file and pressed Extract. Nothing happens unless I double-press it, and then it just extracts for hours, without finishing. If I just press once on extract, I can press "Reboot for update", but then it doesn't update. Any ideas?

User avatar
chippey5
Posts: 22
Joined: Sat Oct 26, 2013 10:51 pm
languages_spoken: english, swedish, dutch
ODROIDs: ODROID XU4. ODROID U2
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by chippey5 » Sun Dec 23, 2018 12:16 am

sisero wrote:
Sat Dec 15, 2018 2:40 am
Hi, I can´t get this working, I installed the operating system, and everything boots correctly, but I can´t update to TV-OS. I pressed "Get the latest version" changed the URL, pressed download. After it was finished downloading, I validated the file and pressed Extract. Nothing happens unless I double-press it, and then it just extracts for hours, without finishing. If I just press once on extract, I can press "Reboot for update", but then it doesn't update. Any ideas?
Hey, maybe something is going south during the flashing segment? Try to redownload, reflash and verify the image. Then you can try to follow my instructions I posted on August 12th (page 1). I haven't actually flashed everything with the most recent version. If that doesn't work, try flashing the older version of ATV: https://oph.mdrjr.net/voodik/5422/ODROI ... update.zip and after that, update to the other two versions in chronological order.

kenmystro
Posts: 2
Joined: Sun Dec 30, 2018 4:23 am
languages_spoken: english
ODROIDs: XU-4
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by kenmystro » Sun Dec 30, 2018 7:42 am

I must be missing something as comments seem happy with the product.
After install of ATV I have youtube and google PLAY movies,tv etc and a live tv app(which might show trailers or something)
IS that it? or are there more steps? Are the only apps from google play.
I intend to use showbox, popcorn time and was hoping for something along the likes of kodi repos or something interesting,
Please, what am I missing or is that it?

peterl
Posts: 3
Joined: Thu Nov 10, 2016 1:53 am
languages_spoken: english
ODROIDs: XU4
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by peterl » Mon Dec 31, 2018 5:01 am

Issue: Installing KODI.
It all worked very well for me after I followed the instuctions carefully. I can log into google properly but I cannot seem to use PLAYSTORE. It gives me a "install pending" error when I try to install KODI . In fact I see that I cannot install any apps. When building ATV version with the upgrade, I did have Google authentication. I did go into settings and downversion playstore and also tried stopping it, clearing memory and cache, rebooting, etc. but none of that works. BTW I use a logitech wireless KB/mouse and that works fine.
Any thoughts on this; maybe there is some permission that I am missing somewhere?

peterl
Posts: 3
Joined: Thu Nov 10, 2016 1:53 am
languages_spoken: english
ODROIDs: XU4
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by peterl » Mon Dec 31, 2018 7:39 am

Update:
It turns out that I needed to stop any version upgraded going on with the OS. After I did that, I was able to DL and install KODI. I'm pleased to report that it all seems to work FANTASTIC now. Thank you Voodik and all other who have contributed to this; very cool.

User avatar
chippey5
Posts: 22
Joined: Sat Oct 26, 2013 10:51 pm
languages_spoken: english, swedish, dutch
ODROIDs: ODROID XU4. ODROID U2
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by chippey5 » Sat Jan 05, 2019 3:06 am

The only issue I'm basically having is seeking in videos/movies. I've tried VLC, MX Player and Kodi, none of them allow me to seek. Is anyone else experiencing this too? Other than that I'm in love with having ATV on my XU4 :D

Jaraf
Posts: 1
Joined: Sat Jan 12, 2019 1:51 am
languages_spoken: english spanish
ODROIDs: XU4
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by Jaraf » Sat Jan 12, 2019 2:45 am

Hello guys, i am new, i am testing this rom, thank you very much voodik for your work.

I could not make work Netflix. Some one found an apk that works?

gregauletta
Posts: 5
Joined: Sat Nov 17, 2018 7:36 am
languages_spoken: english
ODROIDs: c2, xu4
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by gregauletta » Mon Jan 14, 2019 1:48 am

hey guys, i managed to re-register my google framework ID and update to tv version. The problem i now have is that google play store will not download anything for me. apps wont update and new apps wont install. If i try to install an app from playstore it just says download pending forever. same thing happens when trying to update an app. Is there a way i could sideload? youtube works fine but i really just want sling tv app. I cant find any way to browse files as the file manager is gone after the tv update. any help is appreciated.

User avatar
rooted
Posts: 6107
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by rooted » Mon Jan 14, 2019 6:02 am

I doubt sling TV will work without widevine support. Try clearing the data to Google play.

User avatar
memeka
Posts: 4083
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by memeka » Mon Jan 14, 2019 8:09 am

Quick question, since i still use the previous version (i like the UI better than on Oreo):
is the live tv app working with DVB now? in 14.1 it only works with ATSC afaik. anyone that tested it?

Jeremycarlson
Posts: 13
Joined: Sat Nov 05, 2016 9:36 am
languages_spoken: english
ODROIDs: C2 XU4
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by Jeremycarlson » Mon Jan 14, 2019 1:05 pm

First off awesome job with 15.1 ATV. I have came into a snag trying to live tv to work with hdhomerun tuner. I can get the channels sycned and get the guide to appear once but everytime after the first guide appearance, I press the center button of the remote and live tv kicks me out to atv 15.1 homepage isntead of showing me the guide. Any suggestions it worked out fine in 14.1 ATV press center button and get guide.


Edit: I think the fact that Live tv is in Beta. That is the problem.
Last edited by Jeremycarlson on Fri Jan 18, 2019 11:28 am, edited 2 times in total.

gregauletta
Posts: 5
Joined: Sat Nov 17, 2018 7:36 am
languages_spoken: english
ODROIDs: c2, xu4
Contact:

Re: LineageOS-15.1 Android TV for ODROID-XU3/XU4

Unread post by gregauletta » Wed Jan 16, 2019 1:23 am

rooted wrote:
Mon Jan 14, 2019 6:02 am
I doubt sling TV will work without widevine support. Try clearing the data to Google play.
actually it works very well now. I just had to remove updates to google play store and clear cache. Everything is working great now. only have 2 small issues. 1- bluetooth will connect, but if it sits idle it looses connection and needs to be re-synced in bluetooth settings before it will work again. 2- Volume control is not working at all. other than that this build is great, all my apps are working very well.

Post Reply

Return to “Android”

Who is online

Users browsing this forum: No registered users and 1 guest