Little help on running kodi on ubuntu minimal

Moderators: mdrjr, odroid

Little help on running kodi on ubuntu minimal

Unread postby alpe » Fri Jul 13, 2018 12:00 pm

(Odroid C1)
I instaled Kodi but I can't get hardware acceleration to work. CPU usage is always close to 100% and video is always decoded via software.

My systemd service:
Code: Select all
[Unit]
Description=Kodi standalone
After=systemd-user-sessions.service network-online.target sound.target mysqld.service
Requires=network-online.target
Conflicts=getty@tty1.service

[Service]
User=kodi
Group=kodi
PAMName=login
TTYPath=/dev/tty1
ExecStart=/usr/bin/xinit /usr/bin/kodi-standalone -- :0 -nolisten tcp vt1
Restart=on-abort
StandardInput=tty

[Install]
WantedBy=graphical.target



I tried adding
Code: Select all
Environment="LD_LIBRARY_PATH=/usr/lib/arm-linux-gnueabihf/"
to my systemd service (viewtopic.php?t=27059#p190735) and it stopped working with this crashlog:

Code: Select all
############## Kodi CRASH LOG ###############

################ SYSTEM INFO ################
 Date: Thu Jul 12 23:42:32 -03 2018
 Kodi Options:
 Arch: armv7l
 Kernel: Linux 3.10.107-190 #1 SMP PREEMPT Mon Sep 4 20:41:37 UTC 2017
 Release: Ubuntu 18.10 (Cosmic Cuttlefish)
############## END SYSTEM INFO ##############

############### STACK TRACE #################
gdb not installed, can't get stack trace.
############# END STACK TRACE ###############

################# LOG FILE ##################

23:42:31.563 T:2917466128  NOTICE: special://profile/ is mapped to: special://masterprofile/
23:42:31.563 T:2917466128  NOTICE: -----------------------------------------------------------------------
23:42:31.563 T:2917466128  NOTICE: Starting Kodi from Debian (17.6 Debian package version: 2:17.6+dfsg1-2build1). Platform: Linux ARM (Thumb) 32-bit
23:42:31.563 T:2917466128  NOTICE: Using Release Kodi from Debian x32 build
23:42:31.563 T:2917466128  NOTICE: Kodi from Debian compiled from 2:17.6+dfsg1-2build1 by GCC 7.3.0 for Linux ARM (Thumb) 32-bit version 4.15.18 (266002)
23:42:31.564 T:2917466128  NOTICE: Running on Ubuntu Cosmic Cuttlefish (development branch) 18.10, kernel: Linux ARM 32-bit version 3.10.107-190
23:42:31.564 T:2917466128  NOTICE: FFmpeg version/source: 3.4.2-2build2
23:42:31.564 T:2917466128  NOTICE: Host CPU: ARMv7 Processor rev 1 (v7l), 4 cores available
23:42:31.564 T:2917466128  NOTICE: ARM Features: Neon disabled
23:42:31.564 T:2917466128  NOTICE: special://xbmc/ is mapped to: /usr/share/kodi
23:42:31.564 T:2917466128  NOTICE: special://xbmcbin/ is mapped to: /usr/lib/arm-linux-gnueabihf/kodi
23:42:31.564 T:2917466128  NOTICE: special://xbmcbinaddons/ is mapped to: /usr/lib/arm-linux-gnueabihf/kodi/addons
23:42:31.564 T:2917466128  NOTICE: special://masterprofile/ is mapped to: /home/kodi/.kodi/userdata
23:42:31.564 T:2917466128  NOTICE: special://envhome/ is mapped to: /home/kodi
23:42:31.564 T:2917466128  NOTICE: special://home/ is mapped to: /home/kodi/.kodi
23:42:31.564 T:2917466128  NOTICE: special://temp/ is mapped to: /home/kodi/.kodi/temp
23:42:31.564 T:2917466128  NOTICE: special://logpath/ is mapped to: /home/kodi/.kodi/temp
23:42:31.564 T:2917466128  NOTICE: The executable running is: /usr/lib/arm-linux-gnueabihf/kodi/kodi.bin
23:42:31.564 T:2917466128  NOTICE: Local hostname: odroid
23:42:31.564 T:2917466128  NOTICE: Log File is located: /home/kodi/.kodi/temp//kodi.log
23:42:31.564 T:2917466128  NOTICE: -----------------------------------------------------------------------
23:42:31.588 T:2917466128   ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files
23:42:31.626 T:2917466128  NOTICE: load settings...
23:42:31.671 T:2917466128   ERROR: PulseAudio: Failed to connect context
23:42:31.671 T:2917466128  NOTICE: PulseAudio might not be running. Context was not created.
23:42:31.695 T:2917466128  NOTICE: Found 1 Lists of Devices
23:42:31.695 T:2917466128  NOTICE: Enumerated ALSA devices:
23:42:31.695 T:2917466128  NOTICE:     Device 1
23:42:31.695 T:2917466128  NOTICE:         m_deviceName      : default
23:42:31.695 T:2917466128  NOTICE:         m_displayName     : Default (ODROID-HDMI Analog)
23:42:31.695 T:2917466128  NOTICE:         m_displayNameExtra:
23:42:31.695 T:2917466128  NOTICE:         m_deviceType      : AE_DEVTYPE_PCM
23:42:31.695 T:2917466128  NOTICE:         m_channels        : FL,FR,BL,BR,FC,LFE,SL,SR
23:42:31.695 T:2917466128  NOTICE:         m_sampleRates     : 8000,11025,16000,22050,32000,44100,48000,64000,88200,96000,176400,192000,384000
23:42:31.695 T:2917466128  NOTICE:         m_dataFormats     : AE_FMT_S24NE4,AE_FMT_S32NE,AE_FMT_S16NE,AE_FMT_S16LE
23:42:31.695 T:2917466128  NOTICE:         m_streamTypes     : No passthrough capabilities
23:42:31.704 T:2917466128  NOTICE: No settings file to load (special://xbmc/system/advancedsettings.xml)
23:42:31.704 T:2917466128  NOTICE: No settings file to load (special://masterprofile/advancedsettings.xml)
23:42:31.704 T:2917466128  NOTICE: Default Video Player: VideoPlayer
23:42:31.704 T:2917466128  NOTICE: Default Audio Player: paplayer
23:42:31.704 T:2917466128  NOTICE: Disabled debug logging due to GUI setting. Level 0.
23:42:31.704 T:2917466128  NOTICE: Log level changed to "LOG_LEVEL_NORMAL"
23:42:31.704 T:2917466128  NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
23:42:31.705 T:2917466128  NOTICE: Loaded playercorefactory configuration
23:42:31.705 T:2917466128  NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
23:42:31.705 T:2917466128  NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
23:42:31.720 T:2917466128  NOTICE: Running database version Addons27
23:42:31.781 T:2917466128  NOTICE: ADDONS: Using repository repository.xbmc.org
23:42:31.865 T:2917466128  NOTICE: Checking resolution 16
23:42:31.865 T:2917466128  NOTICE: CWinSystemX11GLESContext::CreateNewWindow
23:42:31.866 T:2917466128  NOTICE: CWinSystemX11GLESContext::GetVisual() m_pGLContext:(nil) GetVisual
23:42:31.866 T:2917466128  NOTICE: Create new CGLContextEGL at CWinSystemX11GLESContext::CreateNewWindow, m_dpy=0xb704c590
23:42:31.869 T:2917466128   ERROR: failed to initialize egl display
23:42:31.869 T:2917466128   ERROR: Failed to find matching visual


############### END LOG FILE ################

############ END Kodi CRASH LOG #############


Code: Select all
alpe@odroid:~$ find /usr -name libMali.so
/usr/lib/arm-linux-gnueabihf/libMali.so
/usr/share/mali/libs/libMali.so
alpe@odroid:~$ ls -la /usr/lib/arm-linux-gnueabihf/lib*GL*.so*
lrwxrwxrwx 1 root root     20 Jul  2 05:27 /usr/lib/arm-linux-gnueabihf/libEGL_mesa.so.0 -> libEGL_mesa.so.0.0.0
-rw-r--r-- 1 root root 142340 Jul  2 05:27 /usr/lib/arm-linux-gnueabihf/libEGL_mesa.so.0.0.0
lrwxrwxrwx 1 root root     11 Sep  6  2016 /usr/lib/arm-linux-gnueabihf/libEGL.so -> libEGL.so.1
lrwxrwxrwx 1 root root     13 Sep  6  2016 /usr/lib/arm-linux-gnueabihf/libEGL.so.1 -> libEGL.so.1.4
-rw-r--r-- 1 root root  46784 May 30 04:20 /usr/lib/arm-linux-gnueabihf/libEGL.so.1.1.0
lrwxrwxrwx 1 root root     10 Sep  6  2016 /usr/lib/arm-linux-gnueabihf/libEGL.so.1.4 -> libMali.so
lrwxrwxrwx 1 root root     22 May 30 04:20 /usr/lib/arm-linux-gnueabihf/libGLdispatch.so.0 -> libGLdispatch.so.0.0.0
-rw-r--r-- 1 root root 382524 May 30 04:20 /usr/lib/arm-linux-gnueabihf/libGLdispatch.so.0.0.0
lrwxrwxrwx 1 root root     17 Sep  6  2016 /usr/lib/arm-linux-gnueabihf/libGLESv1_CM.so -> libGLESv1_CM.so.1
lrwxrwxrwx 1 root root     19 Sep  6  2016 /usr/lib/arm-linux-gnueabihf/libGLESv1_CM.so.1 -> libGLESv1_CM.so.1.1
lrwxrwxrwx 1 root root     10 Sep  6  2016 /usr/lib/arm-linux-gnueabihf/libGLESv1_CM.so.1.1 -> libMali.so
lrwxrwxrwx 1 root root     14 Sep  6  2016 /usr/lib/arm-linux-gnueabihf/libGLESv2.so -> libGLESv2.so.2
lrwxrwxrwx 1 root root     16 Sep  6  2016 /usr/lib/arm-linux-gnueabihf/libGLESv2.so.2 -> libGLESv2.so.2.0
lrwxrwxrwx 1 root root     10 Sep  6  2016 /usr/lib/arm-linux-gnueabihf/libGLESv2.so.2.0 -> libMali.so
-rw-r--r-- 1 root root  54752 May 30 04:20 /usr/lib/arm-linux-gnueabihf/libGLESv2.so.2.1.0
lrwxrwxrwx 1 root root     14 May 30 04:20 /usr/lib/arm-linux-gnueabihf/libGL.so.1 -> libGL.so.1.7.0
-rw-r--r-- 1 root root 452072 May 30 04:20 /usr/lib/arm-linux-gnueabihf/libGL.so.1.7.0
lrwxrwxrwx 1 root root     16 Jul  2 05:27 /usr/lib/arm-linux-gnueabihf/libGLX_indirect.so.0 -> libGLX_mesa.so.0
lrwxrwxrwx 1 root root     20 Jul  2 05:27 /usr/lib/arm-linux-gnueabihf/libGLX_mesa.so.0 -> libGLX_mesa.so.0.0.0
-rw-r--r-- 1 root root 305936 Jul  2 05:27 /usr/lib/arm-linux-gnueabihf/libGLX_mesa.so.0.0.0
lrwxrwxrwx 1 root root     15 May 30 04:20 /usr/lib/arm-linux-gnueabihf/libGLX.so.0 -> libGLX.so.0.0.0
-rw-r--r-- 1 root root  42636 May 30 04:20 /usr/lib/arm-linux-gnueabihf/libGLX.so.0.0.0


Already ran:

Code: Select all
usermod -a -G audio kodi
usermod -a -G video kodi
usermod -a -G dialout kodi
usermod -a -G plugdev kodi
usermod -a -G tty kodi
chmod 666 /dev/am*
chmod 666 /sys/class/video/axis
chmod 666 /sys/class/video/screen_mode
chmod 666 /sys/class/video/disable_video
chmod 666 /sys/class/tsync/pts_pcrscr
chmod 666 /sys/class/audiodsp/digital_raw

No change.

All my installed packages:
Code: Select all
adduser/cosmic,now 3.117ubuntu1 all [installed]
adwaita-icon-theme/cosmic,now 3.28.0-1ubuntu1 all [installed,automatic]
alsa-base/xenial,cosmic,now 1.0.25+dfsg-0ubuntu5 all [installed]
alsa-tools/cosmic,now 1.1.3-1 armhf [installed]
alsa-utils/cosmic,now 1.1.3-1ubuntu2 armhf [installed]
apport/cosmic,now 2.20.10-0ubuntu5 all [installed,automatic]
apport-symptoms/xenial,cosmic,now 0.20 all [installed,automatic]
apt/cosmic,now 1.7.0~alpha2 armhf [installed]
apt-utils/cosmic,now 1.7.0~alpha2 armhf [installed,automatic]
at-spi2-core/cosmic,now 2.28.0-3 armhf [installed,automatic]
attr/cosmic,now 1:2.4.47-2build1 armhf [installed,automatic]
autoconf/cosmic,now 2.69-11 all [installed,automatic]
automake/cosmic,now 1:1.15.1-3ubuntu2 all [installed,automatic]
autopoint/cosmic,now 0.19.8.1-6build1 all [installed,automatic]
autotools-dev/cosmic,now 20180224.1 all [installed,automatic]
base-files/cosmic,now 10.1ubuntu4 armhf [installed]
base-passwd/cosmic,now 3.5.45 armhf [installed]
bash/cosmic,now 4.4.18-2ubuntu2 armhf [installed]
binutils/cosmic,now 2.30-22ubuntu1 armhf [installed]
binutils-arm-linux-gnueabihf/cosmic,now 2.30-22ubuntu1 armhf [installed,automatic]
binutils-common/cosmic,now 2.30-22ubuntu1 armhf [installed,automatic]
bootini/unknown,now 20180117-40 armhf [installed]
bsdmainutils/cosmic,now 11.1.2ubuntu2 armhf [installed,automatic]
bsdutils/cosmic,now 1:2.32-0.1ubuntu1 armhf [installed]
build-essential/cosmic,now 12.5ubuntu2 armhf [installed]
busybox-initramfs/cosmic,now 1:1.27.2-2ubuntu3 armhf [installed,automatic]
bzip2/cosmic,now 1.0.6-8.1 armhf [installed]
bzip2-doc/cosmic,now 1.0.6-8.1 all [installed,automatic]
ca-certificates/cosmic,now 20180409 all [installed,automatic]
checkinstall/cosmic,now 1.6.2-4ubuntu2 armhf [installed]
console-setup/cosmic,now 1.178ubuntu3 all [installed,automatic]
console-setup-linux/cosmic,now 1.178ubuntu3 all [installed,automatic]
coreutils/cosmic,now 8.28-1ubuntu1 armhf [installed]
cpio/cosmic,now 2.12+dfsg-6 armhf [installed,automatic]
cpp/cosmic,now 4:7.3.0-3ubuntu3 armhf [installed]
cpp-5/cosmic,now 5.5.0-12ubuntu1 armhf [installed]
cpp-7/cosmic,now 7.3.0-24ubuntu1 armhf [installed,automatic]
crda/cosmic,now 3.18-1build1 armhf [installed,automatic]
cron/cosmic,now 3.0pl1-128.1ubuntu1 armhf [installed,automatic]
curl/cosmic,now 7.60.0-2ubuntu1 armhf [installed]
dash/cosmic,now 0.5.8-2.10 armhf [installed]
dbus/cosmic,now 1.12.2-1ubuntu1 armhf [installed,automatic]
dconf-gsettings-backend/cosmic,now 0.26.0-2ubuntu3 armhf [installed,automatic]
dconf-service/cosmic,now 0.26.0-2ubuntu3 armhf [installed,automatic]
debconf/cosmic,now 1.5.66 all [installed]
debconf-i18n/cosmic,now 1.5.66 all [installed,automatic]
debhelper/now 11.2.1ubuntu2 all [installed,upgradable to: 11.3.2ubuntu1]
debianutils/cosmic,now 4.8.6 armhf [installed]
deluge-common/cosmic,now 1.3.15-2 all [installed,automatic]
deluge-console/cosmic,now 1.3.15-2 all [installed]
deluge-web/cosmic,now 1.3.15-2 all [installed]
deluged/cosmic,now 1.3.15-2 all [installed]
dh-autoreconf/cosmic,now 19 all [installed,automatic]
dh-strip-nondeterminism/cosmic,now 0.042-1 all [installed,automatic]
dialog/cosmic,now 1.3-20171209-1build1 armhf [installed,automatic]
diffutils/cosmic,now 1:3.6-1 armhf [installed]
dirmngr/cosmic,now 2.2.8-1ubuntu1 armhf [installed,automatic]
distro-info-data/cosmic,now 0.38 all [installed,automatic]
dosfstools/cosmic,now 4.1-2 armhf [installed,automatic]
dpkg/cosmic,now 1.19.0.5ubuntu3 armhf [installed]
dpkg-dev/cosmic,now 1.19.0.5ubuntu3 all [installed]
e2fslibs/cosmic,now 1.44.3-1 armhf [installed]
e2fsprogs/cosmic,now 1.44.3-1 armhf [installed]
e2fsprogs-l10n/cosmic,now 1.44.3-1 all [installed,automatic]
eject/cosmic,now 2.1.5+deb1+cvs20081104-13.2 armhf [installed,automatic]
ethtool/cosmic,now 1:4.16-1 armhf [installed]
fake-hwclock/cosmic,now 0.11 all [installed]
fbset/cosmic,now 2.1-30 armhf [installed,automatic]
fdisk/cosmic,now 2.32-0.1ubuntu1 armhf [installed,automatic]
file/cosmic,now 1:5.33-3 armhf [installed,automatic]
findutils/cosmic,now 4.6.0+git+20170828-2 armhf [installed]
fontconfig/cosmic,now 2.12.6-0ubuntu2 armhf [installed,automatic]
fontconfig-config/cosmic,now 2.12.6-0ubuntu2 all [installed,automatic]
fonts-dejavu-core/cosmic,now 2.37-1 all [installed,automatic]
fonts-freefont-ttf/cosmic,now 20120503-8 all [installed,automatic]
fonts-noto-hinted/cosmic,now 20171026-2 all [installed,automatic]
fonts-noto-mono/cosmic,now 20171026-2 all [installed,automatic]
fonts-roboto-hinted/cosmic,now 2:0~20160106-2 all [installed,automatic]
fuse/cosmic,now 2.9.7-1ubuntu1 armhf [installed,automatic]
g++/cosmic,now 4:7.3.0-3ubuntu3 armhf [installed]
g++-5/cosmic,now 5.5.0-12ubuntu1 armhf [installed]
g++-7/cosmic,now 7.3.0-24ubuntu1 armhf [installed,automatic]
gcc/cosmic,now 4:7.3.0-3ubuntu3 armhf [installed]
gcc-5/cosmic,now 5.5.0-12ubuntu1 armhf [installed]
gcc-5-base/cosmic,now 5.5.0-12ubuntu1 armhf [installed]
gcc-6-base/cosmic,now 6.4.0-18ubuntu2 armhf [installed]
gcc-7/cosmic,now 7.3.0-24ubuntu1 armhf [installed,automatic]
gcc-7-base/cosmic,now 7.3.0-24ubuntu1 armhf [installed,automatic]
gcc-8-base/cosmic,now 8.1.0-9ubuntu1 armhf [installed,automatic]
gdisk/cosmic,now 1.0.3-1build1 armhf [installed,automatic]
geoip-database/cosmic,now 20180315-1 all [installed]
gettext/cosmic,now 0.19.8.1-6build1 armhf [installed,automatic]
gettext-base/cosmic,now 0.19.8.1-6build1 armhf [installed,automatic]
gir1.2-glib-2.0/cosmic,now 1.56.1-1 armhf [installed,automatic]
gir1.2-harfbuzz-0.0/cosmic,now 1.8.2-2 armhf [installed,automatic]
git/cosmic,now 1:2.17.1-1ubuntu1 armhf [installed]
git-man/cosmic,now 1:2.17.1-1ubuntu1 all [installed,automatic]
glib-networking/cosmic,now 2.56.1-1 armhf [installed,automatic]
glib-networking-common/cosmic,now 2.56.1-1 all [installed,automatic]
glib-networking-services/cosmic,now 2.56.1-1 armhf [installed,automatic]
gnupg/cosmic,now 2.2.8-1ubuntu1 armhf [installed]
gnupg-l10n/cosmic,now 2.2.8-1ubuntu1 all [installed,automatic]
gnupg-utils/cosmic,now 2.2.8-1ubuntu1 armhf [installed,automatic]
gpg/cosmic,now 2.2.8-1ubuntu1 armhf [installed,automatic]
gpg-agent/cosmic,now 2.2.8-1ubuntu1 armhf [installed,automatic]
gpg-wks-client/cosmic,now 2.2.8-1ubuntu1 armhf [installed,automatic]
gpg-wks-server/cosmic,now 2.2.8-1ubuntu1 armhf [installed,automatic]
gpgconf/cosmic,now 2.2.8-1ubuntu1 armhf [installed,automatic]
gpgsm/cosmic,now 2.2.8-1ubuntu1 armhf [installed,automatic]
gpgv/cosmic,now 2.2.8-1ubuntu1 armhf [installed]
grep/cosmic,now 3.1-2 armhf [installed]
groff-base/cosmic,now 1.22.3-10 armhf [installed,automatic]
gsettings-desktop-schemas/cosmic,now 3.28.0-1ubuntu1 all [installed,automatic]
gtk-update-icon-cache/cosmic,now 3.22.30-2ubuntu1 armhf [installed,automatic]
guile-2.0-libs/cosmic,now 2.0.13+1-5build3 armhf [installed,auto-removable]
gzip/cosmic,now 1.6-5ubuntu1 armhf [installed]
hd-idle/now 1.05 armhf [installed,local]
hicolor-icon-theme/cosmic,now 0.17-2 all [installed,automatic]
hostname/cosmic,now 3.20 armhf [installed]
htop/cosmic,now 2.2.0-1 armhf [installed]
humanity-icon-theme/cosmic,now 0.6.15 all [installed,automatic]
ibverbs-providers/cosmic,now 19.0-1 armhf [installed,automatic]
icu-devtools/cosmic,now 60.2-6ubuntu1 armhf [installed,automatic]
ifupdown/cosmic,now 0.8.34ubuntu1 armhf [installed]
init/cosmic,now 1.51 armhf [installed]
init-system-helpers/cosmic,now 1.51 all [installed]
initramfs-tools/cosmic,now 0.130ubuntu10 all [installed,automatic]
initramfs-tools-bin/cosmic,now 0.130ubuntu10 armhf [installed,automatic]
initramfs-tools-core/cosmic,now 0.130ubuntu10 all [installed,automatic]
initscripts/xenial,now 2.88dsf-59.3ubuntu2 armhf [installed]
insserv/xenial,now 1.14.0-5ubuntu3 armhf [installed]
intltool/cosmic,now 0.51.0-5ubuntu1 all [installed]
intltool-debian/xenial,cosmic,now 0.35.0+20060710.4 all [installed,automatic]
iproute2/cosmic,now 4.15.0-2ubuntu1 armhf [installed,automatic]
iputils-ping/cosmic,now 3:20161105-1ubuntu2 armhf [installed,automatic]
isc-dhcp-client/cosmic,now 4.3.5-3ubuntu7 armhf [installed]
isc-dhcp-common/cosmic,now 4.3.5-3ubuntu7 armhf [installed,automatic]
iso-codes/cosmic,now 3.79-1 all [installed,automatic]
iw/cosmic,now 4.14-0.1 armhf [installed]
javascript-common/xenial,cosmic,now 11 all [installed,automatic]
joe/cosmic,now 4.6-1build1 armhf [installed]
kbd/cosmic,now 2.0.4-2ubuntu1 armhf [installed,automatic]
kernel-common/cosmic,now 13.018+nmu1 all [installed,automatic]
keyboard-configuration/cosmic,now 1.178ubuntu3 all [installed,automatic]
klibc-utils/cosmic,now 2.0.4-9ubuntu2 armhf [installed,automatic]
kmod/cosmic,now 25-1ubuntu1 armhf [installed,automatic]
kodi/cosmic,now 2:17.6+dfsg1-2build1 armhf [installed]
kodi-bin/cosmic,now 2:17.6+dfsg1-2build1 armhf [installed,automatic]
kodi-data/cosmic,now 2:17.6+dfsg1-2build1 all [installed,automatic]
kodi-repository-kodi/cosmic,now 2:17.6+dfsg1-2build1 all [installed,automatic]
kodi-visualization-spectrum/cosmic,now 1.1.1-1ubuntu2 armhf [installed,automatic]
krb5-locales/cosmic,now 1.16-2build1 all [installed,automatic]
language-pack-en/cosmic,now 1:18.04+20180423 all [installed,automatic]
language-pack-en-base/cosmic,now 1:18.04+20180423 all [installed]
less/cosmic,now 487-0.1build1 armhf [installed,automatic]
libaacs0/cosmic,now 0.9.0-1 armhf [installed,automatic]
libacl1/cosmic,now 2.2.52-3build1 armhf [installed]
libacl1-dev/cosmic,now 2.2.52-3build1 armhf [installed]
libapparmor1/cosmic,now 2.12-4ubuntu5 armhf [installed]
libapt-inst2.0/cosmic,now 1.7.0~alpha2 armhf [installed,automatic]
libapt-pkg5.0/cosmic,now 1.7.0~alpha2 armhf [installed]
libarchive-zip-perl/cosmic,now 1.60-1ubuntu1 all [installed,automatic]
libargon2-0/now 0~20161029-2 armhf [installed,upgradable to: 0~20171227-0.1]
libasan2/cosmic,now 5.5.0-12ubuntu1 armhf [installed]
libasan4/cosmic,now 7.3.0-24ubuntu1 armhf [installed,automatic]
libasn1-8-heimdal/cosmic,now 7.5.0+dfsg-2 armhf [installed,automatic]
libasound2/cosmic,now 1.1.6-1ubuntu1 armhf [installed,automatic]
libasound2-data/cosmic,now 1.1.6-1ubuntu1 all [installed,automatic]
libass9/cosmic,now 1:0.14.0-2 armhf [installed,automatic]
libassuan0/cosmic,now 2.5.1-2 armhf [installed,automatic]
libasyncns0/cosmic,now 0.8-6 armhf [installed,automatic]
libatasmart4/cosmic,now 0.19-5 armhf [installed,automatic]
libatk-bridge2.0-0/cosmic,now 2.26.2-1 armhf [installed,automatic]
libatk1.0-0/cosmic,now 2.28.1-1 armhf [installed,automatic]
libatk1.0-data/cosmic,now 2.28.1-1 all [installed,automatic]
libatm1/cosmic,now 1:2.5.1-2build1 armhf [installed,automatic]
libatomic1/cosmic,now 8.1.0-9ubuntu1 armhf [installed]
libatspi2.0-0/cosmic,now 2.28.0-3 armhf [installed,automatic]
libattr1/cosmic,now 1:2.4.47-2build1 armhf [installed]
libattr1-dev/cosmic,now 1:2.4.47-2build1 armhf [installed,automatic]
libaudit-common/now 1:2.8.3-1ubuntu1 all [installed,upgradable to: 1:2.8.3-1ubuntu2]
libaudit1/now 1:2.8.3-1ubuntu1 armhf [installed,upgradable to: 1:2.8.3-1ubuntu2]
libauthen-sasl-perl/xenial,cosmic,now 2.1600-1 all [installed,automatic]
libavahi-client3/cosmic,now 0.7-4ubuntu1 armhf [installed,automatic]
libavahi-common-data/cosmic,now 0.7-4ubuntu1 armhf [installed,automatic]
libavahi-common3/cosmic,now 0.7-4ubuntu1 armhf [installed,automatic]
libavcodec57/cosmic,now 7:3.4.2-2build2 armhf [installed,automatic]
libavfilter6/cosmic,now 7:3.4.2-2build2 armhf [installed,automatic]
libavformat57/cosmic,now 7:3.4.2-2build2 armhf [installed,automatic]
libavresample3/cosmic,now 7:3.4.2-2build2 armhf [installed,automatic]
libavutil55/cosmic,now 7:3.4.2-2build2 armhf [installed,automatic]
libbdplus0/cosmic,now 0.1.2-3 armhf [installed,automatic]
libbinutils/cosmic,now 2.30-22ubuntu1 armhf [installed,automatic]
libblas3/cosmic,now 3.8.0-1 armhf [installed,automatic]
libblkid1/cosmic,now 2.32-0.1ubuntu1 armhf [installed]
libblockdev-crypto2/cosmic,now 2.16-2 armhf [installed,automatic]
libblockdev-fs2/cosmic,now 2.16-2 armhf [installed,automatic]
libblockdev-loop2/cosmic,now 2.16-2 armhf [installed,automatic]
libblockdev-part-err2/cosmic,now 2.16-2 armhf [installed,automatic]
libblockdev-part2/cosmic,now 2.16-2 armhf [installed,automatic]
libblockdev-swap2/cosmic,now 2.16-2 armhf [installed,automatic]
libblockdev-utils2/cosmic,now 2.16-2 armhf [installed,automatic]
libblockdev2/cosmic,now 2.16-2 armhf [installed,automatic]
libbluetooth3/cosmic,now 5.50-0ubuntu1 armhf [installed,automatic]
libbluray2/cosmic,now 1:1.0.2-3 armhf [installed,automatic]
libboost-python1.65.1/cosmic,now 1.65.1+dfsg-0ubuntu9 armhf [installed,automatic]
libboost-system1.65.1/cosmic,now 1.65.1+dfsg-0ubuntu9 armhf [installed,automatic]
libbs2b0/xenial,cosmic,now 3.1.0+dfsg-2.2 armhf [installed,automatic]
libbsd0/cosmic,now 0.9.1-1 armhf [installed,automatic]
libbz2-1.0/cosmic,now 1.0.6-8.1 armhf [installed]
libbz2-dev/cosmic,now 1.0.6-8.1 armhf [installed]
libc-bin/cosmic,now 2.27-3ubuntu1 armhf [installed]
libc-dev-bin/cosmic,now 2.27-3ubuntu1 armhf [installed]
libc6/cosmic,now 2.27-3ubuntu1 armhf [installed]
libc6-dev/cosmic,now 2.27-3ubuntu1 armhf [installed]
libcaca0/cosmic,now 0.99.beta19-2build2~gcc5.3 armhf [installed,automatic]
libcairo-gobject2/cosmic,now 1.15.10-3 armhf [installed,automatic]
libcairo2/cosmic,now 1.15.10-3 armhf [installed,automatic]
libcap-ng0/cosmic,now 0.7.9-1 armhf [installed,automatic]
libcap2/cosmic,now 1:2.25-1.2 armhf [installed]
libcap2-bin/cosmic,now 1:2.25-1.2 armhf [installed]
libcc1-0/cosmic,now 8.1.0-9ubuntu1 armhf [installed]
libcdio18/cosmic,now 2.0.0-2 armhf [installed,automatic]
libcec4/unknown,now 4.0.2.1~xenial armhf [installed,automatic]
libcephfs2/cosmic,now 12.2.4-0ubuntu1.1build1 armhf [installed,automatic]
libchromaprint1/cosmic,now 1.4.3-2 armhf [installed,automatic]
libcilkrts5/cosmic,now 7.3.0-24ubuntu1 armhf [installed,automatic]
libcolord2/cosmic,now 1.3.3-2build1 armhf [installed,automatic]
libcom-err2/cosmic,now 1.44.3-1 armhf [installed,automatic]
libcomerr2/cosmic,now 1.44.3-1 armhf [installed]
libcroco3/cosmic,now 0.6.12-2 armhf [installed,automatic]
libcrossguid0/cosmic,now 0.0+git200150803-2ubuntu1 armhf [installed,automatic]
libcryptsetup12/now 2:2.0.2-1ubuntu2 armhf [installed,upgradable to: 2:2.0.2-1ubuntu3]
libcryptsetup4/xenial-updates,now 2:1.6.6-5ubuntu2.1 armhf [installed]
libcups2/cosmic,now 2.2.7-1ubuntu2 armhf [installed,automatic]
libcurl3-gnutls/cosmic,now 7.60.0-2ubuntu1 armhf [installed,automatic]
libcurl4/cosmic,now 7.60.0-2ubuntu1 armhf [installed,automatic]
libcurl4-openssl-dev/cosmic,now 7.60.0-2ubuntu1 armhf [installed]
libdata-dump-perl/xenial,cosmic,now 1.23-1 all [installed,automatic]
libdatrie1/cosmic,now 0.2.12-1 armhf [installed,automatic]
libdb5.3/cosmic,now 5.3.28-13.1ubuntu1 armhf [installed]
libdbus-1-3/cosmic,now 1.12.2-1ubuntu1 armhf [installed,automatic]
libdconf1/cosmic,now 0.26.0-2ubuntu3 armhf [installed,automatic]
libdebconfclient0/cosmic,now 0.213ubuntu1 armhf [installed]
libdevmapper1.02.1/cosmic,now 2:1.02.145-4.1ubuntu3 armhf [installed]
libdns-export1100/cosmic,now 1:9.11.3+dfsg-2ubuntu1 armhf [installed,automatic]
libdpkg-perl/cosmic,now 1.19.0.5ubuntu3 all [installed]
libdrm-amdgpu1/cosmic,now 2.4.92-1 armhf [installed,automatic]
libdrm-common/cosmic,now 2.4.92-1 all [installed,automatic]
libdrm-etnaviv1/cosmic,now 2.4.92-1 armhf [installed,automatic]
libdrm-freedreno1/cosmic,now 2.4.92-1 armhf [installed,automatic]
libdrm-nouveau2/cosmic,now 2.4.92-1 armhf [installed,automatic]
libdrm-radeon1/cosmic,now 2.4.92-1 armhf [installed,automatic]
libdrm2/cosmic,now 2.4.92-1 armhf [installed,automatic]
libedit2/cosmic,now 3.1-20180525-1 armhf [installed,automatic]
libegl-mesa0/cosmic,now 18.1.3-1ubuntu1 armhf [installed,automatic]
libegl1/cosmic,now 1.0.0+git20180308-3ubuntu1 armhf [installed,automatic]
libelf1/cosmic,now 0.170-0.5 armhf [installed,automatic]
libencode-locale-perl/xenial,cosmic,now 1.05-1 all [installed,automatic]
libepoxy0/cosmic,now 1.4.3-1 armhf [installed,automatic]
liberror-perl/cosmic,now 0.17026-1 all [installed,automatic]
libestr0/cosmic,now 0.1.10-2.1 armhf [installed,automatic]
libev-dev/xenial,cosmic,now 1:4.22-1 armhf [installed]
libev4/xenial,cosmic,now 1:4.22-1 armhf [installed,automatic]
libevdev2/cosmic,now 1.5.9+dfsg-2 armhf [installed,automatic]
libexpat1/cosmic,now 2.2.5-3 armhf [installed,automatic]
libexpat1-dev/cosmic,now 2.2.5-3 armhf [installed,automatic]
libext2fs2/cosmic,now 1.44.3-1 armhf [installed,automatic]
libfastjson4/cosmic,now 0.99.8-2 armhf [installed,automatic]
libfdisk1/cosmic,now 2.32-0.1ubuntu1 armhf [installed]
libffi6/cosmic,now 3.2.1-8 armhf [installed,automatic]
libfftw3-double3/cosmic,now 3.3.8-1 armhf [installed,automatic]
libfftw3-single3/cosmic,now 3.3.8-1 armhf [installed,automatic]
libfile-basedir-perl/cosmic,now 0.08-1 all [installed,automatic]
libfile-desktopentry-perl/xenial,cosmic,now 0.22-1 all [installed,automatic]
libfile-listing-perl/xenial,cosmic,now 6.04-1 all [installed,automatic]
libfile-mimeinfo-perl/cosmic,now 0.28-1 all [installed,automatic]
libfile-stripnondeterminism-perl/cosmic,now 0.042-1 all [installed,automatic]
libflac8/cosmic,now 1.3.2-3 armhf [installed,automatic]
libflite1/cosmic,now 2.1-release-2 armhf [installed,automatic]
libfluidsynth1/cosmic,now 1.1.11-1 armhf [installed,automatic]
libfont-afm-perl/cosmic,now 1.20-2 all [installed,automatic]
libfontconfig1/cosmic,now 2.12.6-0ubuntu2 armhf [installed,automatic]
libfontenc1/xenial,cosmic,now 1:1.1.3-1 armhf [installed,automatic]
libfreetype6/cosmic,now 2.8.1-2ubuntu2 armhf [installed,automatic]
libfribidi0/cosmic,now 0.19.7-2 armhf [installed,automatic]
libfuse2/cosmic,now 2.9.7-1ubuntu1 armhf [installed,automatic]
libgail-common/cosmic,now 2.24.32-2ubuntu1 armhf [installed,automatic]
libgail18/cosmic,now 2.24.32-2ubuntu1 armhf [installed,automatic]
libgbm1/cosmic,now 18.1.3-1ubuntu1 armhf [installed,automatic]
libgc1c2/cosmic,now 1:7.4.2-8ubuntu1 armhf [installed,auto-removable]
libgcc-5-dev/cosmic,now 5.5.0-12ubuntu1 armhf [installed]
libgcc-7-dev/cosmic,now 7.3.0-24ubuntu1 armhf [installed,automatic]
libgcc1/cosmic,now 1:8.1.0-9ubuntu1 armhf [installed]
libgcrypt20/now 1.8.2-2ubuntu1 armhf [installed,upgradable to: 1.8.3-1ubuntu1]
libgdbm-compat4/cosmic,now 1.14.1-6 armhf [installed,automatic]
libgdbm3/xenial,now 1.8.3-13.1 armhf [installed]
libgdbm5/cosmic,now 1.14.1-6 armhf [installed,automatic]
libgdk-pixbuf2.0-0/cosmic,now 2.36.11-2 armhf [installed,automatic]
libgdk-pixbuf2.0-bin/cosmic,now 2.36.11-2 armhf [installed,automatic]
libgdk-pixbuf2.0-common/cosmic,now 2.36.11-2 all [installed,automatic]
libgeoip1/cosmic,now 1.6.12-1 armhf [installed,automatic]
libgfortran4/cosmic,now 7.3.0-24ubuntu1 armhf [installed,automatic]
libgif7/cosmic,now 5.1.4-3 armhf [installed,automatic]
libgirepository-1.0-1/cosmic,now 1.56.1-1 armhf [installed,automatic]
libgl1/cosmic,now 1.0.0+git20180308-3ubuntu1 armhf [installed,automatic]
libgl1-mesa-dri/cosmic,now 18.1.3-1ubuntu1 armhf [installed,automatic]
libgl1-mesa-glx/cosmic,now 18.1.3-1ubuntu1 armhf [installed,automatic]
libglade2-0/xenial,cosmic,now 1:2.6.4-2 armhf [installed,automatic]
libglapi-mesa/cosmic,now 18.1.3-1ubuntu1 armhf [installed,automatic]
libgles2/cosmic,now 1.0.0+git20180308-3ubuntu1 armhf [installed,automatic]
libglib2.0-0/cosmic,now 2.56.1-2ubuntu1 armhf [installed,automatic]
libglib2.0-bin/cosmic,now 2.56.1-2ubuntu1 armhf [installed,automatic]
libglib2.0-data/cosmic,now 2.56.1-2ubuntu1 all [installed,automatic]
libglib2.0-dev/cosmic,now 2.56.1-2ubuntu1 armhf [installed,automatic]
libglib2.0-dev-bin/cosmic,now 2.56.1-2ubuntu1 armhf [installed,automatic]
libglvnd0/cosmic,now 1.0.0+git20180308-3ubuntu1 armhf [installed,automatic]
libglx-mesa0/cosmic,now 18.1.3-1ubuntu1 armhf [installed,automatic]
libglx0/cosmic,now 1.0.0+git20180308-3ubuntu1 armhf [installed,automatic]
libgme0/cosmic,now 0.6.2-1 armhf [installed,automatic]
libgmp10/cosmic,now 2:6.1.2+dfsg-3 armhf [installed]
libgnutls30/cosmic,now 3.5.18-1ubuntu1 armhf [installed,automatic]
libgomp1/cosmic,now 8.1.0-9ubuntu1 armhf [installed]
libgpg-error0/cosmic,now 1.31-1 armhf [installed]
libgpgme11/cosmic,now 1.11.1-1ubuntu1 armhf [installed,automatic]
libgpm2/cosmic,now 1.20.7-5 armhf [installed,automatic]
libgraphite2-3/cosmic,now 1.3.11-2 armhf [installed,automatic]
libgraphite2-dev/cosmic,now 1.3.11-2 armhf [installed,automatic]
libgsasl7/cosmic,now 1.8.0-8ubuntu3 armhf [installed,auto-removable]
libgsm1/cosmic,now 1.0.13-4build1 armhf [installed,automatic]
libgssapi-krb5-2/cosmic,now 1.16-2build1 armhf [installed,automatic]
libgssapi3-heimdal/cosmic,now 7.5.0+dfsg-2 armhf [installed,automatic]
libgtk-3-0/cosmic,now 3.22.30-2ubuntu1 armhf [installed,automatic]
libgtk-3-bin/cosmic,now 3.22.30-2ubuntu1 armhf [installed,automatic]
libgtk-3-common/cosmic,now 3.22.30-2ubuntu1 all [installed,automatic]
libgtk2.0-0/cosmic,now 2.24.32-2ubuntu1 armhf [installed,automatic]
libgtk2.0-bin/cosmic,now 2.24.32-2ubuntu1 armhf [installed,automatic]
libgtk2.0-common/cosmic,now 2.24.32-2ubuntu1 all [installed,automatic]
libgudev-1.0-0/cosmic,now 1:232-2 armhf [installed,automatic]
libharfbuzz-dev/cosmic,now 1.8.2-2 armhf [installed,automatic]
libharfbuzz-gobject0/cosmic,now 1.8.2-2 armhf [installed,automatic]
libharfbuzz-icu0/cosmic,now 1.8.2-2 armhf [installed,automatic]
libharfbuzz0b/cosmic,now 1.8.2-2 armhf [installed,automatic]
libhcrypto4-heimdal/cosmic,now 7.5.0+dfsg-2 armhf [installed,automatic]
libheimbase1-heimdal/cosmic,now 7.5.0+dfsg-2 armhf [installed,automatic]
libheimntlm0-heimdal/cosmic,now 7.5.0+dfsg-2 armhf [installed,automatic]
libhogweed4/cosmic,now 3.4-1 armhf [installed,automatic]
libhtml-form-perl/xenial,cosmic,now 6.03-1 all [installed,automatic]
libhtml-format-perl/cosmic,now 2.12-1 all [installed,automatic]
libhtml-parser-perl/cosmic,now 3.72-3build1 armhf [installed,automatic]
libhtml-tagset-perl/cosmic,now 3.20-3 all [installed,automatic]
libhtml-tree-perl/cosmic,now 5.07-1 all [installed,automatic]
libhttp-cookies-perl/cosmic,now 6.04-1 all [installed,automatic]
libhttp-daemon-perl/xenial,cosmic,now 6.01-1 all [installed,automatic]
libhttp-date-perl/xenial,cosmic,now 6.02-1 all [installed,automatic]
libhttp-message-perl/cosmic,now 6.18-1 all [installed,automatic]
libhttp-negotiate-perl/cosmic,now 6.01-1 all [installed,automatic]
libhx509-5-heimdal/cosmic,now 7.5.0+dfsg-2 armhf [installed,automatic]
libibverbs1/cosmic,now 19.0-1 armhf [installed,automatic]
libice6/cosmic,now 2:1.0.9-2 armhf [installed,automatic]
libicu-dev/cosmic,now 60.2-6ubuntu1 armhf [installed,automatic]
libicu-le-hb-dev/cosmic,now 1.0.3+git161113-5 armhf [installed,automatic]
libicu-le-hb0/cosmic,now 1.0.3+git161113-5 armhf [installed,automatic]
libicu60/cosmic,now 60.2-6ubuntu1 armhf [installed,automatic]
libiculx60/cosmic,now 60.2-6ubuntu1 armhf [installed,automatic]
libidn11/cosmic,now 1.33-2.1ubuntu1 armhf [installed,automatic]
libidn2-0/cosmic,now 2.0.4-1.1build2 armhf [installed,automatic]
libinput-bin/cosmic,now 1.11.1-1 armhf [installed,automatic]
libinput10/cosmic,now 1.11.1-1 armhf [installed,automatic]
libio-html-perl/xenial,cosmic,now 1.001-1 all [installed,automatic]
libio-socket-ssl-perl/cosmic,now 2.056-1 all [installed,automatic]
libip4tc0/cosmic,now 1.6.1-2ubuntu2 armhf [installed,automatic]
libipc-system-simple-perl/cosmic,now 1.25-4 all [installed,automatic]
libisc-export169/cosmic,now 1:9.11.3+dfsg-2ubuntu1 armhf [installed,automatic]
libisl15/cosmic,now 0.18-4 armhf [installed]
libisl19/cosmic,now 0.19-1 armhf [installed,automatic]
libiw30/cosmic,now 30~pre9-12ubuntu1 armhf [installed,automatic]
libjack-jackd2-0/cosmic,now 1.9.12~dfsg-2 armhf [installed,automatic]
libjansson4/cosmic,now 2.11-1 armhf [installed,automatic]
libjbig0/cosmic,now 2.1-3.1build1 armhf [installed,automatic]
libjpeg-turbo8/cosmic,now 1.5.2-0ubuntu6 armhf [installed,automatic]
libjpeg8/xenial,cosmic,now 8c-2ubuntu8 armhf [installed,automatic]
libjs-iscroll/cosmic,now 5.2.0+dfsg1-1 all [installed,automatic]
libjs-jquery/cosmic,now 3.2.1-1 all [installed,automatic]
libjson-c3/cosmic,now 0.12.1-1.3 armhf [installed,automatic]
libjson-glib-1.0-0/cosmic,now 1.4.2-4 armhf [installed,automatic]
libjson-glib-1.0-common/cosmic,now 1.4.2-4 all [installed,automatic]
libk5crypto3/cosmic,now 1.16-2build1 armhf [installed,automatic]
libkeyutils1/cosmic,now 1.5.9-9.2ubuntu3 armhf [installed,automatic]
libklibc/cosmic,now 2.0.4-9ubuntu2 armhf [installed,automatic]
libkmod2/cosmic,now 25-1ubuntu1 armhf [installed]
libkrb5-26-heimdal/cosmic,now 7.5.0+dfsg-2 armhf [installed,automatic]
libkrb5-3/cosmic,now 1.16-2build1 armhf [installed,automatic]
libkrb5support0/cosmic,now 1.16-2build1 armhf [installed,automatic]
libksba8/cosmic,now 1.3.5-2 armhf [installed,automatic]
libkyotocabinet16v5/cosmic,now 1.2.76-4.2 armhf [installed,auto-removable]
liblapack3/cosmic,now 3.8.0-1 armhf [installed,automatic]
liblcms2-2/cosmic,now 2.9-2 armhf [installed,automatic]
libldap-2.4-2/cosmic,now 2.4.46+dfsg-5ubuntu1 armhf [installed,automatic]
libldap-common/cosmic,now 2.4.46+dfsg-5ubuntu1 all [installed,automatic]
libldb1/cosmic,now 2:1.3.3-1 armhf [installed,automatic]
libllvm6.0/cosmic,now 1:6.0.1-2ubuntu1 armhf [installed,automatic]
liblocale-gettext-perl/cosmic,now 1.07-3build2 armhf [installed,automatic]
libltdl-dev/cosmic,now 2.4.6-2.1 armhf [installed,automatic]
libltdl7/cosmic,now 2.4.6-2.1 armhf [installed,automatic]
liblua5.3-0/cosmic,now 5.3.3-1 armhf [installed,automatic]
liblua5.3-dev/cosmic,now 5.3.3-1 armhf [installed]
liblwp-mediatypes-perl/xenial,cosmic,now 6.02-1 all [installed,automatic]
liblwp-protocol-https-perl/cosmic,now 6.07-2 all [installed,automatic]
liblz4-1/cosmic,now 1.8.2-1ubuntu1 armhf [installed]
liblzma5/cosmic,now 5.2.2-1.3 armhf [installed]
liblzo2-2/cosmic,now 2.10-0.1 armhf [installed,automatic]
libmad0/xenial,cosmic,now 0.15.1b-8ubuntu1 armhf [installed,automatic]
libmagic-mgc/cosmic,now 1:5.33-3 armhf [installed,automatic]
libmagic1/cosmic,now 1:5.33-3 armhf [installed,automatic]
libmailtools-perl/cosmic,now 2.18-1 all [installed,automatic]
libmailutils5/cosmic,now 1:3.4-1build1 armhf [installed,auto-removable]
libmicrohttpd12/cosmic,now 0.9.59-1 armhf [installed,automatic]
libmikmod3/cosmic,now 3.3.11.1-4 armhf [installed,automatic]
libmnl0/cosmic,now 1.0.4-2 armhf [installed,automatic]
libmodplug1/cosmic,now 1:0.8.9.0-2 armhf [installed,automatic]
libmount1/cosmic,now 2.32-0.1ubuntu1 armhf [installed]
libmp3lame0/cosmic,now 3.100-2build1 armhf [installed,automatic]
libmpc3/cosmic,now 1.1.0-1 armhf [installed]
libmpdec2/cosmic,now 2.4.2-2 armhf [installed,automatic]
libmpfr4/xenial,now 3.1.4-1 armhf [installed]
libmpfr6/cosmic,now 4.0.1-1 armhf [installed,automatic]
libmpg123-0/cosmic,now 1.25.10-2 armhf [installed,automatic]
libmtdev1/cosmic,now 1.1.5-1ubuntu3 armhf [installed,automatic]
libmysofa0/cosmic,now 0.6~dfsg0-2 armhf [installed,automatic]
libmysqlclient20/cosmic,now 5.7.22-0ubuntu18.04.1 armhf [installed,automatic]
libncurses-dev/cosmic,now 6.1+20180210-4ubuntu1 armhf [installed,automatic]
libncurses5/cosmic,now 6.1+20180210-4ubuntu1 armhf [installed]
libncurses6/cosmic,now 6.1+20180210-4ubuntu1 armhf [installed,automatic]
libncursesw5/cosmic,now 6.1+20180210-4ubuntu1 armhf [installed]
libncursesw6/cosmic,now 6.1+20180210-4ubuntu1 armhf [installed,automatic]
libnet-dbus-perl/cosmic,now 1.1.0-4build2 armhf [installed,automatic]
libnet-http-perl/cosmic,now 6.18-1 all [installed,automatic]
libnet-smtp-ssl-perl/cosmic,now 1.04-1 all [installed,automatic]
libnet-ssleay-perl/cosmic,now 1.85-1 armhf [installed,automatic]
libnettle6/cosmic,now 3.4-1 armhf [installed,automatic]
libnewt0.52/cosmic,now 0.52.20-4ubuntu2 armhf [installed,automatic]
libnfs11/cosmic,now 2.0.0-1~exp1 armhf [installed,automatic]
libnghttp2-14/cosmic,now 1.32.0-1 armhf [installed,automatic]
libnl-3-200/cosmic,now 3.2.29-0ubuntu3 armhf [installed,automatic]
libnl-genl-3-200/cosmic,now 3.2.29-0ubuntu3 armhf [installed,automatic]
libnl-route-3-200/cosmic,now 3.2.29-0ubuntu3 armhf [installed,automatic]
libnorm1/cosmic,now 1.5.7+dfsg1-1 armhf [installed,automatic]
libnotify4/cosmic,now 0.7.7-3 armhf [installed,automatic]
libnpth0/cosmic,now 1.5-4 armhf [installed,automatic]
libnspr4/cosmic,now 2:4.18-1ubuntu1 armhf [installed,automatic]
libnss-systemd/cosmic,now 237-3ubuntu10 armhf [installed,automatic]
libnss3/cosmic,now 2:3.36.1-1ubuntu1 armhf [installed,automatic]
libntfs-3g88/cosmic,now 1:2017.3.23-2 armhf [installed,automatic]
libntlm0/cosmic,now 1.4-8 armhf [installed,auto-removable]
libogg0/xenial,cosmic,now 1.3.2-1 armhf [installed,automatic]
libopenal-data/cosmic,now 1:1.18.2-3 all [installed,automatic]
libopenal1/cosmic,now 1:1.18.2-3 armhf [installed,automatic]
libopenjp2-7/cosmic,now 2.3.0-1 armhf [installed,automatic]
libopenmpt0/cosmic,now 0.3.10-1 armhf [installed,automatic]
libopts25/cosmic,now 1:5.18.12-4 armhf [installed,automatic]
libopus0/xenial,cosmic,now 1.1.2-1ubuntu1 armhf [installed,automatic]
libp11-kit0/cosmic,now 0.23.12-2 armhf [installed,automatic]
libp8-platform2/cosmic,now 2.1.0.1+dfsg1-1 armhf [installed,automatic]
libpam-modules/cosmic,now 1.1.8-3.6ubuntu2 armhf [installed]
libpam-modules-bin/cosmic,now 1.1.8-3.6ubuntu2 armhf [installed]
libpam-runtime/cosmic,now 1.1.8-3.6ubuntu2 all [installed]
libpam-systemd/cosmic,now 237-3ubuntu10 armhf [installed,automatic]
libpam0g/cosmic,now 1.1.8-3.6ubuntu2 armhf [installed]
libpango-1.0-0/cosmic,now 1.42.1-2 armhf [installed,automatic]
libpangocairo-1.0-0/cosmic,now 1.42.1-2 armhf [installed,automatic]
libpangoft2-1.0-0/cosmic,now 1.42.1-2 armhf [installed,automatic]
libparted-fs-resize0/cosmic,now 3.2-21 armhf [installed,automatic]
libparted2/cosmic,now 3.2-21 armhf [installed,automatic]
libpciaccess0/cosmic,now 0.14-1 armhf [installed,automatic]
libpcre16-3/cosmic,now 2:8.39-9 armhf [installed,automatic]
libpcre3/cosmic,now 2:8.39-9 armhf [installed]
libpcre3-dev/cosmic,now 2:8.39-9 armhf [installed]
libpcre32-3/cosmic,now 2:8.39-9 armhf [installed,automatic]
libpcrecpp0v5/cosmic,now 2:8.39-9 armhf [installed,automatic]
libpcsclite1/cosmic,now 1.8.23-3 armhf [installed,automatic]
libperl5.26/cosmic,now 5.26.2-6 armhf [installed,automatic]
libpgm-5.2-0/xenial,cosmic,now 5.2.122~dfsg-2 armhf [installed,automatic]
libpipeline1/cosmic,now 1.5.0-1 armhf [installed,automatic]
libpixman-1-0/cosmic,now 0.34.0-2 armhf [installed,automatic]
libplist3/cosmic,now 2.0.0-4 armhf [installed,automatic]
libpng16-16/cosmic,now 1.6.34-1 armhf [installed,automatic]
libpolkit-agent-1-0/cosmic,now 0.105-20 armhf [installed,automatic]
libpolkit-backend-1-0/cosmic,now 0.105-20 armhf [installed,automatic]
libpolkit-gobject-1-0/cosmic,now 0.105-20 armhf [installed,automatic]
libpopt0/cosmic,now 1.16-11 armhf [installed,automatic]
libportmidi0/cosmic,now 1:217-6 armhf [installed,automatic]
libpostproc54/cosmic,now 7:3.4.2-2build2 armhf [installed,automatic]
libprocps4/xenial-updates,xenial-security,now 2:3.3.10-4ubuntu2.4 armhf [installed]
libprocps6/now 2:3.3.12-3ubuntu2 armhf [installed,local]
libproxy1v5/cosmic,now 0.4.15-1 armhf [installed,automatic]
libpsl5/cosmic,now 0.20.2-1 armhf [installed,automatic]
libpulse0/now 1:11.1-1ubuntu8 armhf [installed,upgradable to: 1:12.0-1ubuntu1]
libpython-dev/now 2.7.15~rc1-1 armhf [installed,upgradable to: 2.7.15-3]
libpython-stdlib/now 2.7.15~rc1-1 armhf [installed,upgradable to: 2.7.15-3]
libpython2.7/cosmic,now 2.7.15-1 armhf [installed,automatic]
libpython2.7-dev/cosmic,now 2.7.15-1 armhf [installed,automatic]
libpython2.7-minimal/cosmic,now 2.7.15-1 armhf [installed,automatic]
libpython2.7-stdlib/cosmic,now 2.7.15-1 armhf [installed,automatic]
libpython3-stdlib/cosmic,now 3.6.5-3 armhf [installed,automatic]
libpython3.6-minimal/cosmic,now 3.6.6-1 armhf [installed,automatic]
libpython3.6-stdlib/cosmic,now 3.6.6-1 armhf [installed,automatic]
librados2/cosmic,now 12.2.4-0ubuntu1.1build1 armhf [installed,automatic]
libreadline-dev/cosmic,now 7.0-5 armhf [installed,automatic]
libreadline6/xenial,now 6.3-8ubuntu2 armhf [installed]
libreadline7/cosmic,now 7.0-5 armhf [installed,automatic]
librest-0.7-0/cosmic,now 0.8.0-2 armhf [installed,automatic]
libroken18-heimdal/cosmic,now 7.5.0+dfsg-2 armhf [installed,automatic]
librsvg2-2/cosmic,now 2.40.20-2 armhf [installed,automatic]
librsvg2-common/cosmic,now 2.40.20-2 armhf [installed]
librtmp1/cosmic,now 2.4+20151223.gitfa8646d.1-2 armhf [installed,automatic]
librubberband2/cosmic,now 1.8.1-7ubuntu2 armhf [installed,automatic]
libsamplerate0/cosmic,now 0.1.9-2 armhf [installed,automatic]
libsasl2-2/cosmic,now 2.1.27~101-g0780600+dfsg-3ubuntu2 armhf [installed,automatic]
libsasl2-modules/cosmic,now 2.1.27~101-g0780600+dfsg-3ubuntu2 armhf [installed,automatic]
libsasl2-modules-db/cosmic,now 2.1.27~101-g0780600+dfsg-3ubuntu2 armhf [installed,automatic]
libsdl-image1.2/cosmic,now 1.2.12-8 armhf [installed,automatic]
libsdl-mixer1.2/cosmic,now 1.2.12-14 armhf [installed,automatic]
libsdl-ttf2.0-0/cosmic,now 2.0.11-4 armhf [installed,automatic]
libsdl1.2debian/cosmic,now 1.2.15+dfsg2-1 armhf [installed,automatic]
libsdl2-2.0-0/cosmic,now 2.0.8+dfsg1-1ubuntu2 armhf [installed,automatic]
libseccomp2/cosmic,now 2.3.3-3ubuntu1 armhf [installed]
libselinux1/cosmic,now 2.8-1 armhf [installed]
libsemanage-common/cosmic,now 2.8-1build1 all [installed]
libsemanage1/cosmic,now 2.8-1build1 armhf [installed]
libsensors4/cosmic,now 1:3.4.0-4 armhf [installed,automatic]
libsepol1/cosmic,now 2.8-1 armhf [installed]
libshine3/cosmic,now 3.1.1-2 armhf [installed,automatic]
libsigsegv2/cosmic,now 2.12-2 armhf [installed,automatic]
libslang2/cosmic,now 2.3.2-1ubuntu1 armhf [installed,automatic]
libsm6/xenial,cosmic,now 2:1.2.2-1 armhf [installed,automatic]
libsmartcols1/cosmic,now 2.32-0.1ubuntu1 armhf [installed]
libsmbclient/cosmic,now 2:4.7.6+dfsg~ubuntu-0ubuntu3 armhf [installed,automatic]
libsmpeg0/cosmic,now 0.4.5+cvs20030824-7.2 armhf [installed,automatic]
libsnappy1v5/cosmic,now 1.1.7-1 armhf [installed,automatic]
libsndfile1/cosmic,now 1.0.28-4 armhf [installed,automatic]
libsndio6.1/cosmic,now 1.1.0-3 armhf [installed,automatic]
libsodium23/cosmic,now 1.0.16-2 armhf [installed,automatic]
libsoup-gnome2.4-1/cosmic,now 2.62.2-2 armhf [installed,automatic]
libsoup2.4-1/cosmic,now 2.62.2-2 armhf [installed,automatic]
libsoxr0/cosmic,now 0.1.2-3 armhf [installed,automatic]
libspeex1/cosmic,now 1.2~rc1.2-1ubuntu2 armhf [installed,automatic]
libsqlite3-0/cosmic,now 3.22.0-1 armhf [installed,automatic]
libss2/cosmic,now 1.44.3-1 armhf [installed]
libssh-gcrypt-4/cosmic,now 0.8.0~20170825.94fa1e38-1build1 armhf [installed,automatic]
libssl-dev/cosmic,now 1.1.0g-2ubuntu5 armhf [installed]
libssl-doc/cosmic,now 1.1.0g-2ubuntu5 all [installed,automatic]
libssl1.0.0/cosmic,now 1.0.2n-1ubuntu6 armhf [installed,automatic]
libssl1.1/cosmic,now 1.1.0g-2ubuntu5 armhf [installed,automatic]
libstdc++-5-dev/cosmic,now 5.5.0-12ubuntu1 armhf [installed]
libstdc++-7-dev/cosmic,now 7.3.0-24ubuntu1 armhf [installed,automatic]
libstdc++6/cosmic,now 8.1.0-9ubuntu1 armhf [installed]
libswresample2/cosmic,now 7:3.4.2-2build2 armhf [installed,automatic]
libswscale4/cosmic,now 7:3.4.2-2build2 armhf [installed,automatic]
libsystemd-dev/cosmic,now 237-3ubuntu10 armhf [installed]
libsystemd0/cosmic,now 237-3ubuntu10 armhf [installed]
libtag1v5/cosmic,now 1.11.1+dfsg.1-0.2build2 armhf [installed,automatic]
libtag1v5-vanilla/cosmic,now 1.11.1+dfsg.1-0.2build2 armhf [installed,automatic]
libtalloc2/cosmic,now 2.1.11-2ubuntu1 armhf [installed,automatic]
libtasn1-6/cosmic,now 4.13-3 armhf [installed,automatic]
libtcl8.6/cosmic,now 8.6.8+dfsg-4 armhf [installed,automatic]
libtdb1/cosmic,now 1.3.15-4 armhf [installed,automatic]
libtevent0/cosmic,now 0.9.36-2 armhf [installed,automatic]
libtext-charwidth-perl/cosmic,now 0.04-7.1 armhf [installed,automatic]
libtext-iconv-perl/cosmic,now 1.7-5build6 armhf [installed,automatic]
libtext-wrapi18n-perl/xenial,cosmic,now 0.06-7.1 all [installed,automatic]
libthai-data/cosmic,now 0.1.27-2 all [installed,automatic]
libthai0/cosmic,now 0.1.27-2 armhf [installed,automatic]
libtheora0/cosmic,now 1.1.1+dfsg.1-14 armhf [installed,automatic]
libtie-ixhash-perl/xenial,cosmic,now 1.23-2 all [installed,automatic]
libtiff5/cosmic,now 4.0.9-6 armhf [installed,automatic]
libtimedate-perl/xenial,cosmic,now 2.3000-2 all [installed,automatic]
libtinfo5/cosmic,now 6.1+20180210-4ubuntu1 armhf [installed]
libtinfo6/cosmic,now 6.1+20180210-4ubuntu1 armhf [installed,automatic]
libtinyxml2.6.2v5/cosmic,now 2.6.2-4 armhf [installed,automatic]
libtk8.6/cosmic,now 8.6.8-4 armhf [installed,automatic]
libtool/cosmic,now 2.4.6-2.1 all [installed,automatic]
libtool-bin/cosmic,now 2.4.6-2.1 armhf [installed,automatic]
libtorrent-rasterbar9/cosmic,now 1.1.5-1build2 armhf [installed]
libtry-tiny-perl/cosmic,now 0.30-1 all [installed,automatic]
libtwolame0/cosmic,now 0.3.13-4 armhf [installed,automatic]
libubsan0/cosmic,now 7.3.0-24ubuntu1 armhf [installed]
libudev1/xenial-updates,now 229-4ubuntu21.2 armhf [installed,upgradable to: 237-3ubuntu10]
libudisks2-0/cosmic,now 2.7.6-3 armhf [installed,automatic]
libunistring2/cosmic,now 0.9.9-0ubuntu1 armhf [installed,automatic]
liburi-perl/cosmic,now 1.74-1 all [installed,automatic]
libusb-0.1-4/cosmic,now 2:0.1.12-32 armhf [installed]
libusb-1.0-0/cosmic,now 2:1.0.22-2 armhf [installed,automatic]
libustr-1.0-1/cosmic,now 1.0.4-6 armhf [installed]
libutempter0/xenial,cosmic,now 1.1.6-3 armhf [installed,automatic]
libuuid1/cosmic,now 2.32-0.1ubuntu1 armhf [installed]
libva-drm2/cosmic,now 2.1.0-3 armhf [installed,automatic]
libva-x11-2/cosmic,now 2.1.0-3 armhf [installed,automatic]
libva2/cosmic,now 2.1.0-3 armhf [installed,automatic]
libvdpau1/xenial,cosmic,now 1.1.1-3ubuntu1 armhf [installed,automatic]
libvncclient1/cosmic,now 0.9.11+dfsg-1ubuntu1 armhf [installed,automatic]
libvncserver1/cosmic,now 0.9.11+dfsg-1ubuntu1 armhf [installed,automatic]
libvolume-key1/cosmic,now 0.3.10-1 armhf [installed,automatic]
libvorbis0a/cosmic,now 1.3.6-1 armhf [installed,automatic]
libvorbisenc2/cosmic,now 1.3.6-1 armhf [installed,automatic]
libvorbisfile3/cosmic,now 1.3.6-1 armhf [installed,automatic]
libvpx5/cosmic,now 1.7.0-3 armhf [installed,automatic]
libwacom-bin/cosmic,now 0.29-1 armhf [installed,automatic]
libwacom-common/cosmic,now 0.29-1 all [installed,automatic]
libwacom2/cosmic,now 0.29-1 armhf [installed,automatic]
libwavpack1/cosmic,now 5.1.0-3 armhf [installed,automatic]
libwayland-client0/cosmic,now 1.15.0-2 armhf [installed,automatic]
libwayland-cursor0/cosmic,now 1.15.0-2 armhf [installed,automatic]
libwayland-egl1/cosmic,now 1.15.0-2 armhf [installed,automatic]
libwayland-egl1-mesa/cosmic,now 18.1.3-1ubuntu1 armhf [installed,auto-removable]
libwayland-server0/cosmic,now 1.15.0-2 armhf [installed,automatic]
libwbclient0/cosmic,now 2:4.7.6+dfsg~ubuntu-0ubuntu3 armhf [installed,automatic]
libwebp6/cosmic,now 0.6.1-2 armhf [installed,automatic]
libwebpdemux2/cosmic,now 0.6.1-2 armhf [installed,automatic]
libwebpmux3/cosmic,now 0.6.1-2 armhf [installed,automatic]
libwind0-heimdal/cosmic,now 7.5.0+dfsg-2 armhf [installed,automatic]
libwrap0/cosmic,now 7.6.q-27 armhf [installed,automatic]
libwww-perl/cosmic,now 6.34-1 all [installed,automatic]
libwww-robotrules-perl/cosmic,now 6.02-1 all [installed,automatic]
libx11-6/cosmic,now 2:1.6.4-3 armhf [installed,automatic]
libx11-data/cosmic,now 2:1.6.4-3 all [installed,automatic]
libx11-protocol-perl/xenial,cosmic,now 0.56-7 all [installed,automatic]
libx11-xcb1/cosmic,now 2:1.6.4-3 armhf [installed,automatic]
libx264-152/cosmic,now 2:0.152.2854+gite9a5903-2 armhf [installed,automatic]
libx265-160/cosmic,now 2.8-4 armhf [installed,automatic]
libxau6/xenial,cosmic,now 1:1.0.8-1 armhf [installed,automatic]
libxaw7/xenial,cosmic,now 2:1.0.13-1 armhf [installed,automatic]
libxcb-dri2-0/cosmic,now 1.13-1 armhf [installed,automatic]
libxcb-dri3-0/cosmic,now 1.13-1 armhf [installed,automatic]
libxcb-glx0/cosmic,now 1.13-1 armhf [installed,automatic]
libxcb-present0/cosmic,now 1.13-1 armhf [installed,automatic]
libxcb-render0/cosmic,now 1.13-1 armhf [installed,automatic]
libxcb-shape0/cosmic,now 1.13-1 armhf [installed,automatic]
libxcb-shm0/cosmic,now 1.13-1 armhf [installed,automatic]
libxcb-sync1/cosmic,now 1.13-1 armhf [installed,automatic]
libxcb-xfixes0/cosmic,now 1.13-1 armhf [installed,automatic]
libxcb1/cosmic,now 1.13-1 armhf [installed,automatic]
libxcomposite1/cosmic,now 1:0.4.4-2 armhf [installed,automatic]
libxcursor1/cosmic,now 1:1.1.15-1 armhf [installed,automatic]
libxdamage1/cosmic,now 1:1.1.4-3 armhf [installed,automatic]
libxdmcp6/cosmic,now 1:1.1.2-3 armhf [installed,automatic]
libxext6/xenial,cosmic,now 2:1.3.3-1 armhf [installed,automatic]
libxfixes3/cosmic,now 1:5.0.3-1 armhf [installed,automatic]
libxfont2/cosmic,now 1:2.0.3-1 armhf [installed,automatic]
libxft2/cosmic,now 2.3.2-2 armhf [installed,automatic]
libxi6/cosmic,now 2:1.7.9-1 armhf [installed,automatic]
libxinerama1/xenial,cosmic,now 2:1.1.3-1 armhf [installed,automatic]
libxkbcommon0/cosmic,now 0.8.0-2 armhf [installed,automatic]
libxkbfile1/cosmic,now 1:1.0.9-2 armhf [installed,automatic]
libxml-parser-perl/cosmic,now 2.44-2build3 armhf [installed,automatic]
libxml-twig-perl/cosmic,now 1:3.50-1 all [installed,automatic]
libxml-xpathengine-perl/cosmic,now 0.14-1 all [installed,automatic]
libxml2/cosmic,now 2.9.4+dfsg1-6.1ubuntu1 armhf [installed,automatic]
libxml2-dev/cosmic,now 2.9.4+dfsg1-6.1ubuntu1 armhf [installed]
libxmu6/xenial,cosmic,now 2:1.1.2-2 armhf [installed,automatic]
libxmuu1/xenial,cosmic,now 2:1.1.2-2 armhf [installed,automatic]
libxpm4/cosmic,now 1:3.5.12-1 armhf [installed,automatic]
libxrandr2/cosmic,now 2:1.5.1-1 armhf [installed,automatic]
libxrender1/cosmic,now 1:0.9.10-1 armhf [installed,automatic]
libxshmfence1/cosmic,now 1.3-1 armhf [installed,automatic]
libxslt1.1/cosmic,now 1.1.32-2 armhf [installed,automatic]
libxss1/xenial,cosmic,now 1:1.2.2-1 armhf [installed,automatic]
libxt6/cosmic,now 1:1.1.5-1 armhf [installed,automatic]
libxtables12/cosmic,now 1.6.1-2ubuntu2 armhf [installed,automatic]
libxtst6/cosmic,now 2:1.2.3-1 armhf [installed,automatic]
libxv1/cosmic,now 2:1.0.11-1 armhf [installed,automatic]
libxvidcore4/cosmic,now 2:1.3.5-1 armhf [installed,automatic]
libxxf86dga1/xenial,cosmic,now 2:1.1.4-1 armhf [installed,automatic]
libxxf86vm1/xenial,cosmic,now 1:1.1.4-1 armhf [installed,automatic]
libyajl2/cosmic,now 2.1.0-2build1 armhf [installed,automatic]
libyaml-0-2/cosmic,now 0.2.1-1 armhf [installed,automatic]
libzip-dev/cosmic,now 1.1.2-1.1 armhf [installed]
libzip4/cosmic,now 1.1.2-1.1 armhf [installed,automatic]
libzmq5/cosmic,now 4.2.5-1 armhf [installed,automatic]
libzstd1/cosmic,now 1.3.3+dfsg-2ubuntu1 armhf [installed,automatic]
libzvbi-common/cosmic,now 0.2.35-13 all [installed,automatic]
libzvbi0/cosmic,now 0.2.35-13 armhf [installed,automatic]
lighttpd/now 1.4.49-1 armhf [installed,local]
linux-base/cosmic,now 4.5ubuntu1 all [installed,automatic]
linux-firmware/cosmic,now 1.174 all [installed,automatic]
linux-image-3.10.107-190/unknown,now 20170904 armhf [installed,automatic]
linux-image-c1/now 190-1 armhf [installed,upgradable to: 192-1]
linux-libc-dev/cosmic,now 4.15.0-23.25 armhf [installed]
linux-sound-base/xenial,cosmic,now 1.0.25+dfsg-0ubuntu5 all [installed,automatic]
locales/cosmic,now 2.27-3ubuntu1 all [installed]
login/cosmic,now 1:4.5-1ubuntu1 armhf [installed]
logrotate/cosmic,now 3.11.0-0.1ubuntu1 armhf [installed]
lsb-base/cosmic,now 9.20170808ubuntu1 all [installed]
lsb-release/cosmic,now 9.20170808ubuntu1 all [installed,automatic]
lsof/xenial,cosmic,now 4.89+dfsg-0.1 armhf [installed]
lua5.3/cosmic,now 5.3.3-1 armhf [installed]
m4/cosmic,now 1.4.18-1 armhf [installed,automatic]
mailutils-common/cosmic,now 1:3.4-1build1 all [installed,auto-removable]
make/cosmic,now 4.1-9.1ubuntu1 armhf [installed]
makedev/cosmic,now 2.3.1-93ubuntu2 all [installed]
mali-x11/unknown,now 20160906-r6p2-ceeaf8a-23 armhf [installed]
man-db/cosmic,now 2.8.3-2 armhf [installed]
mawk/cosmic,now 1.3.3-17ubuntu3 armhf [installed]
mesa-utils/cosmic,now 8.4.0-1 armhf [installed,automatic]
mesa-va-drivers/cosmic,now 18.1.3-1ubuntu1 armhf [installed,automatic]
mesa-vdpau-drivers/cosmic,now 18.1.3-1ubuntu1 armhf [installed,automatic]
mime-support/cosmic,now 3.60ubuntu1 all [installed,automatic]
monit/cosmic,now 1:5.25.2-1 armhf [installed]
mount/cosmic,now 2.32-0.1ubuntu1 armhf [installed]
multiarch-support/cosmic,now 2.27-3ubuntu1 armhf [installed]
mysql-common/cosmic,now 5.8+1.0.4 all [installed,automatic]
nano/cosmic,now 2.9.8-1 armhf [installed]
ncurses-base/cosmic,now 6.1+20180210-4ubuntu1 all [installed]
ncurses-bin/cosmic,now 6.1+20180210-4ubuntu1 armhf [installed]
ncurses-term/cosmic,now 6.1+20180210-4ubuntu1 all [installed,automatic]
netbase/cosmic,now 5.4 all [installed,automatic]
netcat-openbsd/cosmic,now 1.190-2 armhf [installed,automatic]
netplan.io/now 0.37.1 armhf [installed,upgradable to: 0.38]
networkd-dispatcher/cosmic,now 1.7-0ubuntu6 all [installed,automatic]
notification-daemon/cosmic,now 3.20.0-3 armhf [installed,automatic]
ntfs-3g/cosmic,now 1:2017.3.23-2 armhf [installed,automatic]
ntp/cosmic,now 1:4.2.8p11+dfsg-1ubuntu1 armhf [installed]
ntpstat/cosmic,now 0.0.0.1-2 armhf [installed]
openssh-client/cosmic,now 1:7.7p1-2 armhf [installed,automatic]
openssh-server/cosmic,now 1:7.7p1-2 armhf [installed,automatic]
openssh-sftp-server/cosmic,now 1:7.7p1-2 armhf [installed,automatic]
openssl/cosmic,now 1.1.0g-2ubuntu5 armhf [installed,automatic]
p7zip/cosmic,now 16.02+dfsg-6 armhf [installed,automatic]
p7zip-full/cosmic,now 16.02+dfsg-6 armhf [installed]
parted/cosmic,now 3.2-21 armhf [installed,automatic]
passwd/cosmic,now 1:4.5-1ubuntu1 armhf [installed]
patch/cosmic,now 2.7.6-2ubuntu1 armhf [installed]
perl/cosmic,now 5.26.2-6 armhf [installed]
perl-base/cosmic,now 5.26.2-6 armhf [installed]
perl-modules-5.26/cosmic,now 5.26.2-6 all [installed,automatic]
perl-openssl-defaults/cosmic,now 3build1 armhf [installed,automatic]
php/now 7.2.5-1 armhf [installed,upgradable to: 1:7.2+60ubuntu1]
pinentry-curses/cosmic,now 1.1.0-1build2 armhf [installed,automatic]
pkg-config/cosmic,now 0.29.1-0ubuntu2 armhf [installed]
po-debconf/cosmic,now 1.0.20 all [installed,automatic]
policykit-1/cosmic,now 0.105-20 armhf [installed]
procps/now 2:3.3.12-3ubuntu2 armhf [installed,upgradable to: 2:3.3.15-2ubuntu1]
psmisc/cosmic,now 23.1-1build1 armhf [installed]
publicsuffix/cosmic,now 20180523.2326-2 all [installed,automatic]
python/now 2.7.15~rc1-1 armhf [installed,upgradable to: 2.7.15-3]
python-apt/cosmic,now 1.7.0~alpha0~ubuntu3 armhf [installed,automatic]
python-apt-common/cosmic,now 1.7.0~alpha0~ubuntu3 all [installed,automatic]
python-asn1crypto/cosmic,now 0.24.0-1 all [installed,automatic]
python-attr/cosmic,now 17.4.0-2 all [installed,automatic]
python-automat/cosmic,now 0.6.0-1 all [installed,automatic]
python-cairo/cosmic,now 1.16.2-1build1 armhf [installed,automatic]
python-cffi-backend/cosmic,now 1.11.5-1build1 armhf [installed,automatic]
python-chardet/cosmic,now 3.0.4-1 all [installed]
python-click/cosmic,now 6.7-5 all [installed,automatic]
python-colorama/xenial,cosmic,now 0.3.7-1 all [installed,automatic]
python-constantly/cosmic,now 15.1.0-1 all [installed,automatic]
python-crypto/cosmic,now 2.6.1-9build1 armhf [installed,automatic]
python-cryptography/cosmic,now 2.2.2-1 armhf [installed,automatic]
python-dev/now 2.7.15~rc1-1 armhf [installed,upgradable to: 2.7.15-3]
python-dnspython/cosmic,now 1.15.0-1 all [installed,automatic]
python-enum34/cosmic,now 1.1.6-2 all [installed,automatic]
python-glade2/cosmic,now 2.24.0-5.1ubuntu2 armhf [installed]
python-gobject-2/cosmic,now 2.28.6-12ubuntu3 armhf [installed,automatic]
python-gtk2/cosmic,now 2.24.0-5.1ubuntu2 armhf [installed,automatic]
python-hyperlink/cosmic,now 17.3.1-2 all [installed,automatic]
python-idna/cosmic,now 2.6-1 all [installed,automatic]
python-incremental/cosmic,now 16.10.1-3 all [installed,automatic]
python-ipaddress/cosmic,now 1.0.17-1 all [installed,automatic]
python-ldb/cosmic,now 2:1.3.3-1 armhf [installed,automatic]
python-libtorrent/cosmic,now 1.1.5-1build2 armhf [installed]
python-mako/cosmic,now 1.0.7+ds1-1 all [installed]
python-markupsafe/cosmic,now 1.0-1build2 armhf [installed,automatic]
python-minimal/now 2.7.15~rc1-1 armhf [installed,upgradable to: 2.7.15-3]
python-notify/xenial,cosmic,now 0.1.1-4 armhf [installed]
python-numpy/cosmic,now 1:1.14.5-1ubuntu2 armhf [installed,automatic]
python-olefile/cosmic,now 0.45.1-1 all [installed,automatic]
python-openssl/cosmic,now 18.0.0-1 all [installed]
python-pam/cosmic,now 0.4.2-13.2ubuntu5 armhf [installed,automatic]
python-pil/cosmic,now 5.2.0-1 armhf [installed,automatic]
python-pkg-resources/cosmic,now 39.2.0-1 all [installed,automatic]
python-pyasn1/cosmic,now 0.4.2-3 all [installed,automatic]
python-pyasn1-modules/cosmic,now 0.2.1-0.2 all [installed,automatic]
python-pycurl/cosmic,now 7.43.0.1-0.2build1 armhf [installed,automatic]
python-pygame/cosmic,now 1.9.1release+dfsg-10build1 armhf [installed]
python-samba/cosmic,now 2:4.7.6+dfsg~ubuntu-0ubuntu3 armhf [installed,automatic]
python-serial/cosmic,now 3.4-3 all [installed,automatic]
python-service-identity/xenial,cosmic,now 16.0.0-2 all [installed,automatic]
python-setuptools/cosmic,now 39.2.0-1 all [installed]
python-six/cosmic,now 1.11.0-2 all [installed,automatic]
python-software-properties/xenial-updates,now 0.96.20.7 all [installed]
python-talloc/cosmic,now 2.1.11-2ubuntu1 armhf [installed,automatic]
python-tdb/cosmic,now 1.3.15-4 armhf [installed,automatic]
python-twisted/cosmic,now 17.9.0-2 all [installed]
python-twisted-bin/cosmic,now 17.9.0-2 armhf [installed,automatic]
python-twisted-core/cosmic,now 17.9.0-2 all [installed,automatic]
python-xdg/cosmic,now 0.25-4ubuntu1 all [installed]
python-zope.interface/cosmic,now 4.3.2-1build3 armhf [installed,automatic]
python2.7/cosmic,now 2.7.15-1 armhf [installed,automatic]
python2.7-dev/cosmic,now 2.7.15-1 armhf [installed,automatic]
python2.7-minimal/cosmic,now 2.7.15-1 armhf [installed,automatic]
python3/cosmic,now 3.6.5-3 armhf [installed,automatic]
python3-apport/cosmic,now 2.20.10-0ubuntu5 all [installed,automatic]
python3-apt/cosmic,now 1.7.0~alpha0~ubuntu3 armhf [installed,automatic]
python3-certifi/cosmic,now 2018.4.16-1 all [installed,automatic]
python3-chardet/cosmic,now 3.0.4-1 all [installed,automatic]
python3-dbus/cosmic,now 1.2.8-2build1 armhf [installed,automatic]
python3-distutils/cosmic,now 3.6.6-1 all [installed,automatic]
python3-gi/cosmic,now 3.28.2-1build1 armhf [installed,automatic]
python3-httplib2/cosmic,now 0.9.2+dfsg-1 all [installed,automatic]
python3-idna/cosmic,now 2.6-1 all [installed,automatic]
python3-lib2to3/cosmic,now 3.6.6-1 all [installed,automatic]
python3-minimal/cosmic,now 3.6.5-3 armhf [installed,automatic]
python3-pkg-resources/cosmic,now 39.2.0-1 all [installed,automatic]
python3-ply/cosmic,now 3.11-2 all [installed,automatic]
python3-problem-report/cosmic,now 2.20.10-0ubuntu5 all [installed,automatic]
python3-requests/cosmic,now 2.18.4-2 all [installed,automatic]
python3-requests-unixsocket/cosmic,now 0.1.5-3 all [installed,automatic]
python3-six/cosmic,now 1.11.0-2 all [installed,automatic]
python3-slimit/cosmic,now 0.8.1-3 all [installed,automatic]
python3-software-properties/cosmic,now 0.96.24.34 all [installed,automatic]
python3-systemd/cosmic,now 234-2build1 armhf [installed,automatic]
python3-urllib3/cosmic,now 1.22-1 all [installed,automatic]
python3-yaml/cosmic,now 3.12-1build3 armhf [installed,automatic]
python3.6/cosmic,now 3.6.6-1 armhf [installed,automatic]
python3.6-minimal/cosmic,now 3.6.6-1 armhf [installed,automatic]
readline-common/cosmic,now 7.0-5 all [installed]
resolvconf/cosmic,now 1.79ubuntu10 all [installed,automatic]
rng-tools/cosmic,now 5-0ubuntu4 armhf [installed]
rsyslog/cosmic,now 8.32.0-1ubuntu5 armhf [installed,automatic]
samba/cosmic,now 2:4.7.6+dfsg~ubuntu-0ubuntu3 armhf [installed]
samba-common/cosmic,now 2:4.7.6+dfsg~ubuntu-0ubuntu3 all [installed,automatic]
samba-common-bin/cosmic,now 2:4.7.6+dfsg~ubuntu-0ubuntu3 armhf [installed,automatic]
samba-dsdb-modules/cosmic,now 2:4.7.6+dfsg~ubuntu-0ubuntu3 armhf [installed,automatic]
samba-libs/cosmic,now 2:4.7.6+dfsg~ubuntu-0ubuntu3 armhf [installed,automatic]
samba-vfs-modules/cosmic,now 2:4.7.6+dfsg~ubuntu-0ubuntu3 armhf [installed,automatic]
sed/cosmic,now 4.5-1 armhf [installed]
sensible-utils/cosmic,now 0.0.12 all [installed]
shared-mime-info/cosmic,now 1.9-2 armhf [installed,automatic]
slimit/cosmic,now 0.8.1-3 all [installed]
smartmontools/cosmic,now 6.5+svn4324-1 armhf [installed]
sntp/now 1:4.2.8p10+dfsg-5ubuntu7 armhf [installed,upgradable to: 1:4.2.8p11+dfsg-1ubuntu1]
software-properties-common/cosmic,now 0.96.24.34 all [installed]
ssh/cosmic,now 1:7.7p1-2 all [installed]
ssh-import-id/cosmic,now 5.7-24-g4001a38e-0ubuntu1 all [installed,automatic]
ssl-cert/cosmic,now 1.0.39 all [installed,auto-removable]
sudo/cosmic,now 1.8.21p2-3ubuntu1 armhf [installed,automatic]
systemd/cosmic,now 237-3ubuntu10 armhf [installed]
systemd-sysv/cosmic,now 237-3ubuntu10 armhf [installed]
sysv-rc/xenial,now 2.88dsf-59.3ubuntu2 all [installed]
sysvinit-utils/cosmic,now 2.88dsf-59.10ubuntu1 armhf [installed]
tar/cosmic,now 1.30+dfsg-2 armhf [installed]
tcl/xenial,cosmic,now 8.6.0+9 armhf [installed,automatic]
tcl8.6/cosmic,now 8.6.8+dfsg-4 armhf [installed,automatic]
tdb-tools/cosmic,now 1.3.15-4 armhf [installed,automatic]
timgm6mb-soundfont/xenial,cosmic,now 1.3-2 all [installed,automatic]
tk/xenial,cosmic,now 8.6.0+9 armhf [installed,automatic]
tk8.6/cosmic,now 8.6.8-4 armhf [installed,automatic]
tzdata/cosmic,now 2018e-1 all [installed]
u-boot/unknown,now 20160712-e8d530f-17 armhf [installed]
u-boot-tools/now 2016.03+dfsg1-6ubuntu2 armhf [installed,upgradable to: 2018.03+dfsg1-2ubuntu1]
ubuntu-advantage-tools/cosmic,now 17 all [installed,automatic]
ubuntu-keyring/cosmic,now 2018.02.28 all [installed]
ubuntu-minimal/cosmic,now 1.421 armhf [installed]
ubuntu-mono/cosmic,now 16.10+18.04.20180421.1-0ubuntu1 all [installed,automatic]
ucf/cosmic,now 3.0038 all [installed,automatic]
udev/xenial-updates,now 229-4ubuntu21.2 armhf [installed]
udisks2/cosmic,now 2.7.6-3 armhf [installed,automatic]
unattended-upgrades/now 1.2ubuntu1 all [installed,upgradable to: 1.4ubuntu1]
unzip/cosmic,now 6.0-21ubuntu1 armhf [installed]
usbutils/cosmic,now 1:007-4build1 armhf [installed]
util-linux/cosmic,now 2.32-0.1ubuntu1 armhf [installed]
va-driver-all/cosmic,now 2.1.0-3 armhf [installed,automatic]
vdpau-driver-all/xenial,cosmic,now 1.1.1-3ubuntu1 armhf [installed,automatic]
vim-common/cosmic,now 2:8.0.1766-1ubuntu1 all [installed,automatic]
vim-tiny/cosmic,now 2:8.0.1766-1ubuntu1 armhf [installed,automatic]
wget/cosmic,now 1.19.5-1ubuntu1 armhf [installed,automatic]
whiptail/cosmic,now 0.52.20-4ubuntu2 armhf [installed,automatic]
wireless-regdb/cosmic,now 2018.05.09-0ubuntu1 all [installed,automatic]
wireless-tools/cosmic,now 30~pre9-12ubuntu1 armhf [installed]
wpasupplicant/cosmic,now 2:2.6-16ubuntu1 armhf [installed]
x11-common/cosmic,now 1:7.7+19ubuntu8 all [installed,automatic]
x11-utils/cosmic,now 7.7+4 armhf [installed,automatic]
x11-xkb-utils/cosmic,now 7.7+4 armhf [installed,automatic]
x11-xserver-utils/cosmic,now 7.7+8 armhf [installed,automatic]
x11vnc/cosmic,now 0.9.13-6 armhf [installed]
x11vnc-data/cosmic,now 0.9.13-6 all [installed,automatic]
xauth/cosmic,now 1:1.0.10-1 armhf [installed,automatic]
xbitmaps/xenial,cosmic,now 1.1.1-2 all [installed,automatic]
xdg-user-dirs/cosmic,now 0.17-1ubuntu1 armhf [installed,automatic]
xdg-utils/cosmic,now 1.1.3-1ubuntu1 all [installed]
xfonts-base/xenial,cosmic,now 1:1.0.4+nmu1 all [installed,automatic]
xfonts-encodings/xenial,cosmic,now 1:1.0.4-2 all [installed,automatic]
xfonts-utils/cosmic,now 1:7.7+6 armhf [installed,automatic]
xinit/cosmic,now 1.4.0-1ubuntu1 armhf [installed]
xkb-data/cosmic,now 2.23.1-1ubuntu1 all [installed,automatic]
xserver-common/cosmic,now 2:1.19.6-1ubuntu4 all [installed,automatic]
xserver-xorg/cosmic,now 1:7.7+19ubuntu8 armhf [installed,automatic]
xserver-xorg-core/cosmic,now 2:1.19.6-1ubuntu4 armhf [installed,automatic]
xserver-xorg-input-all/cosmic,now 1:7.7+19ubuntu8 armhf [installed,automatic]
xserver-xorg-input-libinput/cosmic,now 0.27.1-1 armhf [installed,automatic]
xserver-xorg-input-wacom/cosmic,now 1:0.36.1-0ubuntu1 armhf [installed,automatic]
xserver-xorg-legacy/cosmic,now 2:1.19.6-1ubuntu4 armhf [installed,automatic]
xserver-xorg-video-all/cosmic,now 1:7.7+19ubuntu8 armhf [installed,automatic]
xserver-xorg-video-amdgpu/cosmic,now 18.0.1-1 armhf [installed,automatic]
xserver-xorg-video-ati/cosmic,now 1:18.0.1-1 armhf [installed,automatic]
xserver-xorg-video-fbdev/cosmic,now 1:0.4.4-1build6 armhf [installed,automatic]
xserver-xorg-video-mali/unknown,now 20160712-fa6394b-5 armhf [installed]
xserver-xorg-video-nouveau/cosmic,now 1:1.0.15-2 armhf [installed,automatic]
xserver-xorg-video-radeon/cosmic,now 1:18.0.1-1 armhf [installed,automatic]
xserver-xorg-video-vesa/cosmic,now 1:2.3.4-1build3 armhf [installed,automatic]
xterm/cosmic,now 330-1ubuntu3 armhf [installed,automatic]
xxd/cosmic,now 2:8.0.1766-1ubuntu1 armhf [installed,automatic]
xz-utils/cosmic,now 5.2.2-1.3 armhf [installed]
zlib1g/cosmic,now 1:1.2.11.dfsg-0ubuntu2 armhf [installed]
zlib1g-dev/cosmic,now 1:1.2.11.dfsg-0ubuntu2 armhf [installed]
alpe
 
Posts: 28
Joined: Sat Apr 12, 2014 1:21 pm
Location: Rio de Janeiro, Brazil
languages_spoken: portuguese, english
ODROIDs: C1

Re: Little help on running kodi on ubuntu minimal

Unread postby alpe » Fri Jul 13, 2018 1:08 pm

Installed aml-libs and mali-fbdev and removed mali-x11 and now it runs with Environment="LD_LIBRARY_PATH=/usr/lib/arm-linux-gnueabihf/" set. But no acceleration.
alpe
 
Posts: 28
Joined: Sat Apr 12, 2014 1:21 pm
Location: Rio de Janeiro, Brazil
languages_spoken: portuguese, english
ODROIDs: C1

Re: Little help on running kodi on ubuntu minimal

Unread postby alpe » Fri Jul 13, 2018 1:31 pm

I'm using the devel repository and noticed that the kodi available on the C1 repository have "amlogic" in the version field.
So I pinned kodi* on apt to this repository. And reinstalled. Still no hardware acceleration. :/
alpe
 
Posts: 28
Joined: Sat Apr 12, 2014 1:21 pm
Location: Rio de Janeiro, Brazil
languages_spoken: portuguese, english
ODROIDs: C1

Re: Little help on running kodi on ubuntu minimal

Unread postby odroid » Fri Jul 13, 2018 1:58 pm

Did you install "kodi-fbdev" package?

BTW, we've been preparing Ubuntu 18.04 image for C1.
It will support Kodi 17.6 on fbdev/minimal image.
I hope the image will be available by end of July.
User avatar
odroid
Site Admin
 
Posts: 28610
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Little help on running kodi on ubuntu minimal

Unread postby alpe » Fri Jul 13, 2018 3:18 pm

Code: Select all
E: Unable to locate package kodi-fbdev


I googled and download it from http://deb.odroid.in/c1/pool/main/k/kodi-fbdev/ despite being from 2015.
Got a lot of dependencies problems and couldn't fix it with apt-get -f install.

Tomorrow I'll try again.
But I think I'll end up just waiting for this release.

Edit:
Installed from here now: http://deb.odroid.in/5422/pool/main/k/kodi-fbdev/

Code: Select all
X.Org X Server 1.19.6
Release Date: 2017-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-119-generic armv7l Ubuntu
Current Operating System: Linux odroid 3.10.107-190 #1 SMP PREEMPT Mon Sep 4 20:41:37 UTC 2017 armv7l
Kernel command line: root=UUID=e139ce78-9841-40fe-8823-96a304a09859 rootwait ro console=ttyS0,115200n8 no_console_suspend fsck.repair=yes vdaccfg=0xa000 logo=osd1,loaded,0x7900000,720p,full dmfc=3 cvbsmode=480cvbs hdmimode=720p m_bpp=32 vout=hdmi disablehpd=true monitor_onoff=false max_freq=1824
Build Date: 13 April 2018  08:09:42PM
xorg-server 2:1.19.6-1ubuntu4 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.34.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jul 13 10:56:27 2018
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
/usr/bin/kodi: 164: /usr/bin/kodi: cannot create /sys/class/graphics/fbcon/cursor_blink: Permission denied
E: [pulseaudio] shm.c: shared memfd open() failed: Function not implemented
W: [pulseaudio] core.c: Failed to allocate shared memfd memory pool. Falling back to a normal memory pool.
W: [pulseaudio] authkey.c: Failed to open cookie file '/home/kodi/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authentication key '/home/kodi/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to open cookie file '/home/kodi/.pulse-cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authentication key '/home/kodi/.pulse-cookie': No such file or directory
W: [pulseaudio] server-lookup.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.Spawn.ExecFailed: /usr/bin/dbus-launch terminated abnormally without any error message
W: [pulseaudio] main.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.Spawn.ExecFailed: /usr/bin/dbus-launch terminated abnormally without any error message
shared memfd open() failed: Function not implemented
shared memfd open() failed: Function not implemented
E: [alsa-sink-SPDIF PCM dit-hifi-0] alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write!
E: [alsa-sink-SPDIF PCM dit-hifi-0] alsa-sink.c: Most likely this is a bug in the ALSA driver '(null)'. Please report this issue to the ALSA developers.
E: [alsa-sink-SPDIF PCM dit-hifi-0] alsa-sink.c: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
libEGL warning: DRI2: failed to authenticate
ERROR: Unable to create GUI. Exiting
free(): invalid pointer
Aborted (core dumped)
Crash report available at /home/kodi/kodi_crashlog-20180713_105716.log
/usr/bin/kodi: 182: /usr/bin/kodi: cannot create /sys/class/graphics/fbcon/cursor_blink: Permission denied
/usr/bin/xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.
alpe
 
Posts: 28
Joined: Sat Apr 12, 2014 1:21 pm
Location: Rio de Janeiro, Brazil
languages_spoken: portuguese, english
ODROIDs: C1

Re: Little help on running kodi on ubuntu minimal

Unread postby alpe » Sat Jul 14, 2018 9:07 am

Any chance of Kernel 4.x being released officially to C1?
alpe
 
Posts: 28
Joined: Sat Apr 12, 2014 1:21 pm
Location: Rio de Janeiro, Brazil
languages_spoken: portuguese, english
ODROIDs: C1

Re: Little help on running kodi on ubuntu minimal

Unread postby odroid » Sat Jul 14, 2018 11:21 am

There is no S805 driver for HDMI/GPU/VPU in Kernel 4.x at this moment. There are tons of other issues too.
Refer this link to check the progress.
viewtopic.php?f=111&t=19292
User avatar
odroid
Site Admin
 
Posts: 28610
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID


Return to Ubuntu

Who is online

Users browsing this forum: No registered users and 0 guests