Odroid xu4 overheating :/ ?

Moderators: mdrjr, odroid

Odroid xu4 overheating :/ ?

Unread postby mrperfekotne » Wed Jul 11, 2018 12:25 am

I have an odroid xu4 that sits in cloudshell 2 tonight something went wrong that made it unmounted one hard drive and used 95% of system recorers - Until I discovered it and restarted it - I got throtel alert to my email - Is odroid xu4 protected from overheating? - I think it behaves strangely afterwards and does not know if it has hurt?
mrperfekotne
 
Posts: 62
Joined: Fri Nov 10, 2017 12:40 am
languages_spoken: Danish
ODROIDs: XU4

Re: Odroid xu4 overheating :/ ?

Unread postby rooted » Wed Jul 11, 2018 2:42 am

It does have thermal protection, it will shut down if it gets too hot. It throttles the CPU speed before that happens.

Did you have the CloudShell fan enabled?
User avatar
rooted
 
Posts: 5473
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: Odroid xu4 overheating :/ ?

Unread postby mrperfekotne » Wed Jul 11, 2018 3:26 am

Yes cloud shell 2 fan run constantly but have lowered the speed a bit with a resistance and switched the original fan to a noctua fan to avoid noise in the living room :) But nice to know there is safety in case of overheating :)

I have experienced that cloudshell 2 periodically gets a mount problem on one disk or another - so it unmount. - Is that something you've experienced? - Also what happened when the cpu load hit 90% it had unmount sdb disk?!
mrperfekotne
 
Posts: 62
Joined: Fri Nov 10, 2017 12:40 am
languages_spoken: Danish
ODROIDs: XU4

Re: Odroid xu4 overheating :/ ?

Unread postby rooted » Wed Jul 11, 2018 3:54 am

Are you running Open Media Vault?
User avatar
rooted
 
Posts: 5473
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: Odroid xu4 overheating :/ ?

Unread postby mrperfekotne » Wed Jul 11, 2018 4:17 am

Yes i am running openmediavault 4 :)
mrperfekotne
 
Posts: 62
Joined: Fri Nov 10, 2017 12:40 am
languages_spoken: Danish
ODROIDs: XU4

Re: Odroid xu4 overheating :/ ?

Unread postby rooted » Wed Jul 11, 2018 6:38 am

mrperfekotne wrote:Yes i am running openmediavault 4 :)
OMV 4 is broken on the XU4 (FOR ME), and you can no longer get OMV 3.

You can do similar to what I did, I installed meveric's Debian Stretch minimal and webmin to setup NFS/SMB and the disks.

viewtopic.php?p=219509

A member said he was able to install OMV on DietPI

viewtopic.php?p=225831#p225831

The kernel is broken on Armbian (on XU4), it had a bunch of stack traces on boot up causing a long (88 seconds +) pause that breaks the mounts. OMV images run on top of Armbian. I'm not sure whose fault it is, just that it's broken and you should use something that works for now.

Official Ubuntu, meveric's Debian (Jessie or Stretch)..etc.
Last edited by rooted on Wed Jul 11, 2018 10:21 pm, edited 2 times in total.
User avatar
rooted
 
Posts: 5473
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: Odroid xu4 overheating :/ ?

Unread postby joshua.yang » Wed Jul 11, 2018 6:26 pm

Well, just to ensure whether OMV 4 has more heat than OMV 3 or not, I have tested on
- HC2 with OMV 3, 4
- CloudShell2 (XU4Q) with OMV 4.

Nothing seems strange in IDLE, so I made a 100GB dummy file and transferred it via Samba and monitor them how much its CPU temperature reaches.
HC2 reaches around 75 'C, but it doesn't get throttled at least in big cores, and CS2 (XU4Q) reaches around only 55 'C due to the fan of the CS2 I think.

These results are attached. :)
Attachments
180711_xu4_omv4.1.8_samba_100g_cpu_temp_freq_load.log
(3.54 KiB) Downloaded 34 times
180711_hc2_omv4.1.8_samba_100g_cpu_temp_freq_load.log
(3.96 KiB) Downloaded 28 times
180711_hc2_omv3_samba_50g_cpu_temp_freq_load.log
(1.7 KiB) Downloaded 32 times
joshua.yang
 
Posts: 76
Joined: Fri Sep 22, 2017 5:54 pm
languages_spoken: English
ODROIDs: XU4, XU4Q + Cloudshell2

Re: Odroid xu4 overheating :/ ?

Unread postby tkaiser » Wed Jul 11, 2018 7:12 pm

rooted wrote:
mrperfekotne wrote:Yes i am running openmediavault 4 :)
OMV 4 is broken for the XU4


BS. You're just biased and fail to diagnose simple problems your installation suffers from for whatever reasons: https://forum.openmediavault.org/index. ... post178670

At least now I know where this stupid 'OMV is broken' campaign originates from...
tkaiser
 
Posts: 373
Joined: Mon Nov 09, 2015 12:30 am
languages_spoken: english
ODROIDs: C1+, C2, XU4, HC1

Re: Odroid xu4 overheating :/ ?

Unread postby tkaiser » Wed Jul 11, 2018 7:23 pm

joshua.yang wrote:These results are attached. :)


On any Armbian based image like OMV you can simply run 'sudo armbianmonitor -m' to get simple CLI monitoring. No need to script stuff yourself...
tkaiser
 
Posts: 373
Joined: Mon Nov 09, 2015 12:30 am
languages_spoken: english
ODROIDs: C1+, C2, XU4, HC1

Re: Odroid xu4 overheating :/ ?

Unread postby tkaiser » Wed Jul 11, 2018 7:31 pm

mrperfekotne wrote:I have experienced that cloudshell 2 periodically gets a mount problem on one disk or another - so it unmount


Check your cables and whether plug and receptacle fit perfectly (I doubt they do).

The XU4 (unlike HC1 and HC2) is problematic as NAS especially when combined with those Cloudshell things. It's about cable/contact issues and it's 100% useless to search for software or thermal issues unless you can ensure that there are no physical issues with the USB3 SuperSpeed connection between board and CS (which is somewhat hard to achieve given what a crappy connector USB3-A is especially with receptacles that do not fit tightly): https://forum.armbian.com/topic/3953-pr ... ment=32340
tkaiser
 
Posts: 373
Joined: Mon Nov 09, 2015 12:30 am
languages_spoken: english
ODROIDs: C1+, C2, XU4, HC1

Re: Odroid xu4 overheating :/ ?

Unread postby rooted » Wed Jul 11, 2018 9:32 pm

tkaiser wrote:
rooted wrote:
mrperfekotne wrote:Yes i am running openmediavault 4 :)
OMV 4 is broken for the XU4


BS. You're just biased and fail to diagnose simple problems your installation suffers from for whatever reasons: https://forum.openmediavault.org/index. ... post178670

At least now I know where this stupid 'OMV is broken' campaign originates from...
Do you have a CloudShell 2 running OMV 4?

It's not BS Thomas, it's not a simple problem. Every boot would have a kernel stack trace, causing my drives to be UNMOUNTABLE....

Standard installation with nothing enabled but NFS.

It's the kernel, and are you a kernel developer Thomas? You want to tell me what changes Armbian has done?

Why don't you get a CloudShell 2 and try it yourself!

OMV 4 is broken on the CloudShell 2 FOR ME

You are the one who is biased, you are part of Armbian so nothing could possibly be wrong with Armbian.

*edit*
I changed one thing, I added "FOR ME"

I believe it has something to do with the firmware revision of the CloudShell 2, I'm running the original firmware. So if you want to diagnose the problem go ahead.

No USB accessories attached, just UART

1.) Flash original JMicron firmware to CloudShell 2 board.

2.) Flash latest OMV 4 image. (2018-06-03)

3.) Setup one 3.5" (mechanical) Drive, I have 2

4.) Enable NFS

5.) Reboot

6.) Boot takes excessive amount of time, when up and running you will see a UAS related stack trace(s) and your drives won't be mountable.

This is directly related to something Armbian has done, some tweak that doesn't work with the original JMicron firmware.

On the standard kernel from Hardkernel Git and Debian Stretch I have no such issue.

I don't have time to diagnose the problem as my wife and kids use this particular server all the time. I need it to work.
User avatar
rooted
 
Posts: 5473
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: Odroid xu4 overheating :/ ?

Unread postby ryecoaaron » Thu Jul 12, 2018 6:39 am

I replied to your post on the OMV forum but you blame OMV a bit too quickly. OMV has nothing to do with support for USB devices. I wish I was home to figure out what problem you are having but from your last post, it seems it is simply a module that is not enabled in the armbian kernel. The reason the OMV 3.x xu4 image was deleted was because we had no reports of problems. I guess most xu4 users are not using the cloudshell.
ryecoaaron
 
Posts: 98
Joined: Tue Dec 23, 2014 6:02 am
Location: Wisconsin
languages_spoken: english
ODROIDs: odroid-c1 x2, odroid-c2 x1, odroid-xu4 x3, cloudshell xu4

Re: Odroid xu4 overheating :/ ?

Unread postby rooted » Thu Jul 12, 2018 7:52 am

I don't have a problem with OMV, it's the Armbian kernel or a tweak. In actuality I think OMV is the bees knees.

I said it on your forum and I will say it here, I like OMV.

I have had bad luck with OMV/Armbian on the XU4 and Thomas is so brash I can't post on your forum with any amount of composure. I tried to install OMV on Stretch following your instructions but as you may know it fails.

So if I can't install it myself, I can't use OMV/Armbian I did the only other option. I went with straight Stretch.
User avatar
rooted
 
Posts: 5473
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)


Return to Hardware and peripherals

Who is online

Users browsing this forum: rrobinet and 1 guest