gles2 on ubuntu 18.04 does not work

Moderators: mdrjr, odroid

gles2 on ubuntu 18.04 does not work

Unread postby meister ivar » Sun Jul 08, 2018 7:36 pm

Hello all,

yesterday i flashed my c2 with new ubuntu 18 image and updated to kernel 3.16.57-24.

For me it seems the opengl-es issue workaround discribed in hk-blog is still not ready?

es2gears:
Code: Select all
EGL_VERSION = 1.4 Linux-r6p1-01rel0
EGLUT: failed to create context


es2gears_x11:
Code: Select all
EGL_VERSION = 1.4 Linux-r6p1-01rel0
EGLUT: failed to create context


es2info:
Code: Select all
ERROR: eglCreateContext failed


glmark2-es2:
Code: Select all
Error: eglCreateContext() failed with error: 0x3005
Error: CanvasGeneric: Invalid EGL state
Error: main: Could not initialize canvas


How to solve this?
Thanks in advance,
Ivar
meister ivar
 
Posts: 4
Joined: Fri Jan 05, 2018 7:27 pm
languages_spoken: english german
ODROIDs: xu4q c2

Re: gles2 on ubuntu 18.04 does not work

Unread postby odroid » Sun Jul 08, 2018 8:19 pm

When I tested, es2gears and glmark2-es2 worked well.
Try sudo apt-get download mali-x11 and sudo dpkg -i mali-x11*.deb.
Anyway, I will check this issue tomorrow carefully.
User avatar
odroid
Site Admin
 
Posts: 28849
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: gles2 on ubuntu 18.04 does not work

Unread postby meister ivar » Sun Jul 08, 2018 8:26 pm

thank you very much, that solved the problem.
meister ivar
 
Posts: 4
Joined: Fri Jan 05, 2018 7:27 pm
languages_spoken: english german
ODROIDs: xu4q c2

Re: gles2 on ubuntu 18.04 does not work

Unread postby odroid » Mon Jul 09, 2018 11:33 am

I freshly flashed the latest 18.04 image ubuntu-18.04-3.16-mate-odroid-c2-20180620.img.xz and es2gears and glmark2-es2 had worked well
After full system updating with sudo apt update && sudo apt dist-upgrade && reboot, those gles2 software still worked well too.
I think you might break the files or symlinks for Mali/EGL libraries accidentally.

Anyway, good to hear reinstalling the Mali package solved your issue.
User avatar
odroid
Site Admin
 
Posts: 28849
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: gles2 on ubuntu 18.04 does not work

Unread postby meister ivar » Mon Oct 01, 2018 1:42 am

Hi all,
just to close this case, here an update:

The problem discribed above comes after upgrading libgles*
Mali seems to lose the link (or something similar).

So after upgrading gles-stuff you should run sudo apt-get install --reinstall mali-x11 and all goes the right way ;-)

Thank you,
Ivar
meister ivar
 
Posts: 4
Joined: Fri Jan 05, 2018 7:27 pm
languages_spoken: english german
ODROIDs: xu4q c2

Re: gles2 on ubuntu 18.04 does not work

Unread postby odroid » Mon Oct 01, 2018 1:34 pm

Ahh... some updated mesa package seemed to break the Mali GPU driver links.
I had to run sudo apt install --reinstall mali-x11 too fix the problem.
User avatar
odroid
Site Admin
 
Posts: 28849
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: gles2 on ubuntu 18.04 does not work

Unread postby butmonkeh » Fri Oct 05, 2018 6:57 am

This also prevented Kodi from starting for me. The kodi crashlogs hinted at a gles2 problem, but I had no clue what had changed. I was about ->||<- close to wiping and reinstalling, when I saw this post. Thank you! :)
butmonkeh
 
Posts: 7
Joined: Sun Oct 01, 2017 8:13 pm
languages_spoken: english

Re: gles2 on ubuntu 18.04 does not work

Unread postby martouf » Tue Oct 16, 2018 10:38 pm

Hooray! It's fixed!

I'd been doing normal updates to the Ubuntu install and suddenly Kodi quit working a few weeks ago.

Error messages when starting Kodi from shell:
Code: Select all
MESA-LOADER: failed to retrieve device information
libEGL warning: DRI2: failed to open exynos (search paths {elided})

then a CPU would spin at 100% until i hit CTRL-C

reinstalled mali-x11 and all is great again .. thanks!
martouf
 
Posts: 3
Joined: Mon Jul 16, 2018 12:13 am
languages_spoken: English
ODROIDs: XU4 + acc.


Return to Issues

Who is online

Users browsing this forum: No registered users and 3 guests