Module 5 Realtek rtl8812au monitor mode

Moderators: mdrjr, odroid

Module 5 Realtek rtl8812au monitor mode

Unread postby muddy » Wed Jun 27, 2018 4:21 am

Has anyone found a way to make the Module 5 WiFi adapter go into monitor mode? And are you able to do packet injection with it? I know Hardkernel doesn't support Kali Linux, but I know many of you have dabbled with the Kali C2 distro.

iw phy0 info
reports that monitor mode IS supported... I just can't get it into it even with the specific rtl8812au package pushed out by offensive security. Had someone there help me with a rebuild to correct for cross linking - still no go.
I do see something interesting - "iw dev wlan0 interface add mon0 type monitor" executes without complaint, and airmon-ng shows it there as an unknown device with ??????.
Further, airodump-ng displays a screen - unfortunately it doesn't see traffic. Tried this with NetworkManager stopped, and started. Ran the Check Kill etc.
Also tried ifconfig down, iwconfig wlan0 mode monitor - it complained....and stopped.

I note that no matter what I do (edit the NetworkManager.conf etc.) iwconfig reports it as "Managed"

Anybody have any success and/or suggestions?
Thanks.
muddy
 
Posts: 19
Joined: Thu Sep 07, 2017 12:12 am
languages_spoken: english
ODROIDs: C0, C2

Re: Module 5 Realtek rtl8812au monitor mode

Unread postby moon.linux » Tue Jul 10, 2018 1:56 pm

If followed instruction to enable monitor mode.

Code: Select all
root@odroid:~# lsusb -t
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 2: Dev 3, If 0, Class=Vendor Specific Class, Driver=rtl8812au, 480M
root@odroid:~#
root@odroid:~#
root@odroid:~#
root@odroid:~# sudo ifconfig wlan0 down
root@odroid:~# iw dev wlan0 interface add mon0 type monitor
root@odroid:~# iwconfig
lo        no wireless extensions.

wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated
          Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/100  Signal level=0 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

mon0      IEEE 802.11abgn  Mode:Monitor  Tx-Power=12 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

eth0      no wireless extensions.
moon.linux
 
Posts: 1109
Joined: Thu Oct 02, 2014 11:42 pm
languages_spoken: english


Return to General Chat

Who is online

Users browsing this forum: No registered users and 5 guests