Please help! Blue LED not flashing or glowing

Moderators: odroid, mdrjr

Please help! Blue LED not flashing or glowing

Unread postby Loth » Mon Jun 11, 2018 11:07 pm

Hello Friends, good day!
I am experiencing problems with my C2 unity.
It was functioning normally, with LibreELEC as a HTPC connected to my receiver.
It happens that during one beautiful day, I noticed that it was only with the red led active, and when I went to check it was not working.

The blue led does not light, does not blink, does absolutely nothing.
I checked here in the forum possible reports of similar situations and checked that the blue led is related to the operating system.

I did some tests and reinstalled the system, tried to change the system (libreelec, ubuntu), tried to change the microSD and nothing worked.
Both microSDs are working normally on my Raspberry Pi 2. Unfortunately the Pi 2 does not work with high definition digital audio formats (dtsx, atmos, etc).

According to the manual:

LED status
The ODROID-C2 includes several LED lights that indicate the
status of the device:
The red LED
• Is on when power to the device is available
The blue LED
• Is on (solid light) when the bootloader is running
The blue LED
• Blinks slowly when the kernel is running, like a heartbeat
The blue LED
• Blinks quickly when the kernel is in panic mode
Red LED not glowing
If the red LED is not glowing, power is not being supplied to the
board. Check the connections, and verify that the plug is inserted
properly. Also, make sure that a 5V/2A power supply is being used,
and that it is plugged in.
Blue LED not flashing or glowing
If the blue LED is not flashing or glowing at all, something went
wrong with the image writing or the card is not correctly inserted. Try
to download, extract and write the image again. If that doesn’t solve
the issue, try downloading and flashing a different image.

Help me Odroid community, you are my only hope.
Posts: 1
Joined: Mon Jun 11, 2018 10:46 pm
languages_spoken: english/pt-br
ODROIDs: C2 Odroid

Re: Please help! Blue LED not flashing or glowing

Unread postby rooted » Tue Jun 12, 2018 3:47 am

Try a different power supply.
User avatar
Posts: 4897
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
HiFi Shield 2
Smart Power (original)

Return to Issues

Who is online

Users browsing this forum: Google [Bot] and 1 guest