HC1 ethernet sometimes missing after warm boot

Test and fix the Kernel 4.14 features

Moderators: odroid, mdrjr

HC1 ethernet sometimes missing after warm boot

Unread postby qoli » Mon Jun 04, 2018 9:58 am

I have an HC1 device, running NixOS using the upstream 4.16.13 kernel.

Every time I boot this device from cold (i.e. by physically disconnecting and reconnecting the power), everything works perfectly. However, sometimes, when I perform a soft-reboot, the device still boots, but is missing its ethernet device. It has not been renamed, either - the device is missing.

I've searched around and found various mentions of this type of problem on the XU4, but no clear answer. Some patches appear to exist (to things like the power management IC driver) in various GitHub repos; I've tried some of these without success.

Is this problem known/expected, using an upstream kernel? Are there patches? Let me know what info would be useful to help debug.

Thanks!
qoli
 
Posts: 3
Joined: Mon Jun 04, 2018 9:42 am
languages_spoken: english
ODROIDs: HC1

Re: HC1 ethernet sometimes missing after warm boot

Unread postby odroid » Mon Jun 04, 2018 10:54 am

We had a couple of patches to avoid the USB host detection issue in Kernel 4.14 LTS.
I don't think upstream kernel has the fix.
User avatar
odroid
Site Admin
 
Posts: 27934
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: HC1 ethernet sometimes missing after warm boot

Unread postby qoli » Mon Jun 04, 2018 11:41 am

Oooh, exciting. Can you give me a link to these patches? Or should I really just use the the Odroid 4.14 kernel fork instead of upstream?
qoli
 
Posts: 3
Joined: Mon Jun 04, 2018 9:42 am
languages_spoken: english
ODROIDs: HC1

Re: HC1 ethernet sometimes missing after warm boot

Unread postby odroid » Mon Jun 04, 2018 12:11 pm

Because of 30~40 important commits in our kernel github, consider using our maintained 4.14 Kernel if you have no specific reason.
We can't support upstream kernel intensively due to extremely limited resources.
We will develop another LTS kernel (5.x?) in early next year probably.

BTW, try to apply three commits to fix your issue.
drivers/regulator/s2mps11.c s2mps11.c
commit e85ba4b9e6208f266b13df745bc5d3efd4d560f1
commit 8c8fbcf0f87ed7d427e8dcd9823731bd7b47d4be
commit 4c80de8b32d20bfa326201516543f11d72af39ce
User avatar
odroid
Site Admin
 
Posts: 27934
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: HC1 ethernet sometimes missing after warm boot

Unread postby qoli » Mon Jun 04, 2018 12:48 pm

Oh wow, thanks! I'll give both options a try. Thanks a lot.
qoli
 
Posts: 3
Joined: Mon Jun 04, 2018 9:42 am
languages_spoken: english
ODROIDs: HC1


Return to Linux Kernel 4.14 Debugging Party

Who is online

Users browsing this forum: No registered users and 0 guests