New XU4, intermittent network?

Post Reply
bug2k18
Posts: 4
Joined: Sun May 13, 2018 2:58 am
languages_spoken: english
ODROIDs: XU4
Contact:

New XU4, intermittent network?

Unread post by bug2k18 » Sun May 13, 2018 3:13 am

Hi, I've just purchased my first XU4, actually this is my first sbc that isn't a Raspberry Pi. I've used Linux as my main OS for nearly 10 years and have maybe 10 or so Pis on various duties.

Having tried 3 or 4 images (on sdcard), a couple of different Ubuntu versions, Armbian and Arch. They all boot up fine and obtain an ip via dhcp. If I ping the router I get maybe 90+% dropped, sometimes a minute or more before a reply gets picked up. This is using a cable. I have 4 other devices on this switch working fine, swapped cables etc. it's definately an issue with the XU4. I managed to ssh in once but the connection hung immediately causing it to eventually timeout.

The XU4 seems fine from a directly connected keyboard with no errors showing in the logs. I did think it was running a bit warm considering it had just booted to a minimal install with the cpu reading 55degC doing nothing other than just logging in as root on a clean install. This is the version with active cooling fan. It's being powered with the supplied 4A supply.

I'm possibly missing something obvious, any help on what could be wrong would be appreciated.

Thanks.

User avatar
mad_ady
Posts: 5107
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1
Location: Bucharest, Romania
Contact:

Re: New XU4, intermittent network?

Unread post by mad_ady » Sun May 13, 2018 12:20 pm

The temperature is normal. Regarding networking - does dmesg show link up/down events?

bug2k18
Posts: 4
Joined: Sun May 13, 2018 2:58 am
languages_spoken: english
ODROIDs: XU4
Contact:

Re: New XU4, intermittent network?

Unread post by bug2k18 » Sun May 13, 2018 2:04 pm

Shows the link is up and is not dropping. I have tried manually dropping the connection and then bringing it back up with the same result.

User avatar
mad_ady
Posts: 5107
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1
Location: Bucharest, Romania
Contact:

Re: New XU4, intermittent network?

Unread post by mad_ady » Sun May 13, 2018 6:23 pm

I suspect you might have a duplicate address in your network. Check the IP you get for your odroid, turn it off, ping that ip and see if anything responds or replies to arp.

bug2k18
Posts: 4
Joined: Sun May 13, 2018 2:58 am
languages_spoken: english
ODROIDs: XU4
Contact:

Re: New XU4, intermittent network?

Unread post by bug2k18 » Sun May 13, 2018 8:24 pm

There's no other device using this ip, arp -a shows just the one entry for this ip with the mac address of the xu4. I've tried swapping the patch cable and plugging directly into the router with no change.

bug2k18
Posts: 4
Joined: Sun May 13, 2018 2:58 am
languages_spoken: english
ODROIDs: XU4
Contact:

Re: New XU4, intermittent network?

Unread post by bug2k18 » Sun May 13, 2018 10:14 pm

Ok, found the issue. Turns out it was an old xbox that was connected to the network, it was switched off and hadn't been used for a year or more, it didn't show in the lease list on the dhcp server and didn't respond to pings when the xu4 was switched off, didn't show in any of my machines arp tables. Anyway, unplugged it and all is good.

Thanks mad_ady for the tip, something I should have checked before posting.

User avatar
mad_ady
Posts: 5107
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1
Location: Bucharest, Romania
Contact:

Re: New XU4, intermittent network?

Unread post by mad_ady » Mon May 14, 2018 2:09 am

Finding duplicate ips is always a painful process. It's important to know the symptoms - sporadic outages without link loss, good transfer when pinging the gateway continuously.

Post Reply

Return to “General Chat”

Who is online

Users browsing this forum: No registered users and 0 guests