cloudshell2 drive powers on and then off before OS boots

Moderators: mdrjr, odroid

cloudshell2 drive powers on and then off before OS boots

Unread postby neilmacneil » Tue May 01, 2018 1:47 am

Hello,

I've had my cloudshell2 for about a year now. I'm not sure what has happened from there until here but I can't get any drives connected to the raid assembly to work (or stay powered on). I've never used "RAID" with this before, I Just had a single drive in it. For whatever reason, when I power it on now I can see the red LEDs flash and the drives power on (i've tried a couple) but then they power themselves off and the OS starts to boot. I've tried fumbling with the dip switches but they are both in the "down" or PM position. Seems like I might have done system that I can't remember in the Uboot settings tinkering one night, i'm not sure. Can anyway comment?

Thanks!

-Neil
neilmacneil
 
Posts: 6
Joined: Thu Oct 12, 2017 3:51 am
languages_spoken: english
ODROIDs: xu4

Re: cloudshell2 drive powers on and then off before OS boots

Unread postby neilmacneil » Tue May 01, 2018 1:49 am

oh, an i've been power cycling the thing while holding the little switch below the LCD.
neilmacneil
 
Posts: 6
Joined: Thu Oct 12, 2017 3:51 am
languages_spoken: english
ODROIDs: xu4

Re: cloudshell2 drive powers on and then off before OS boots

Unread postby rooted » Tue May 01, 2018 8:40 am

Since you can't remember what you did it will be hard to diagnose.
User avatar
rooted
 
Posts: 5583
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: cloudshell2 drive powers on and then off before OS boots

Unread postby neilmacneil » Tue May 01, 2018 9:54 am

lol, I 100% agree. I'm going to console in now and see what I did. I have 0 experience with uboot beyond breaking it (possibly), any ideas what it might be? I'll figure it out
neilmacneil
 
Posts: 6
Joined: Thu Oct 12, 2017 3:51 am
languages_spoken: english
ODROIDs: xu4

Re: cloudshell2 drive powers on and then off before OS boots

Unread postby neilmacneil » Sun May 06, 2018 3:42 pm

I haven't found anything yet.. I just suggested that I might have done tweaked something on UBOOT but I'm honestly not sure that I would have changed anything on there. The drives spin up and then spin down once the OS starts so I'm kind of clueless now as to the issue.

0Neil
neilmacneil
 
Posts: 6
Joined: Thu Oct 12, 2017 3:51 am
languages_spoken: english
ODROIDs: xu4

Re: cloudshell2 drive powers on and then off before OS boots

Unread postby rooted » Sun May 06, 2018 11:55 pm

Do the drives not work? Power management should spin the drives down but not soon as you boot.

How are you accessing the drives? SMB, NFS?

What OS are you running?

What does this show?

Code: Select all
cat /etc/fstab
User avatar
rooted
 
Posts: 5583
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: cloudshell2 drive powers on and then off before OS boots

Unread postby neilmacneil » Thu May 10, 2018 2:30 am

The drives work, when I access the serial management/console I don't see anything strange. I just notice that I can hear them spin up and then the raid leds flashs a pattern and then once it start to run ubuntu (latest 18 image (patched) they spin down (like the sound when you pull the power. There is nothing in dmesg suggesting it detected any new drives and fdisk -l is not showing them :/
/etc/fstab is just stock with root and swap mounts on sd card.
neilmacneil
 
Posts: 6
Joined: Thu Oct 12, 2017 3:51 am
languages_spoken: english
ODROIDs: xu4

Re: cloudshell2 drive powers on and then off before OS boots

Unread postby neilmacneil » Thu May 10, 2018 2:33 am

i've ran dietpi, arch and ubuntu with the same results. I would suspect the drives to stay alive when the OS is booting so this is why I'm thinking maybe my Uboot is messed up. I'm definitely not an expert with uboot. Is there something I could do to reset to defaults in the uboot menu/prompt?
neilmacneil
 
Posts: 6
Joined: Thu Oct 12, 2017 3:51 am
languages_spoken: english
ODROIDs: xu4


Return to CloudShell

Who is online

Users browsing this forum: No registered users and 0 guests