[SOLVED!] No sound HDMI (passthrough or software)

Moderators: mdrjr, odroid, Raybuntu, wrxtasy

[SOLVED!] No sound HDMI (passthrough or software)

Unread postby earithramir » Sun Apr 22, 2018 5:11 am

Hi,

I can not seem to get any audio from the odroid c2.
Neither passthrough or software encoded.
if i view /sys/class/amhdmitx/amhdmitx0/aud_cap then the result is empty.
it can not be hardware related, the receiver and cable are in pristine condition and functioning on my Raspberry Pi 2b. This box is ment to be to be a replacement for the Pi.
The same settings are functioning fine on Pi.
Im running LibreELEC-Odroid_C2.aarch64-8.2.5

Is there something i need to configure / install ?
Tried messing around with the passthrough settings and also tried without passthrough but no sound comes from the device. I've selected the HDMI as ouput device.

Thanks in advance!

Hardware:
device: Odroid C2
SD: SANDISK 64GB EXTREME PRO UHS II (not new but using this until my nand arrives)
receiver: Yamaha RX-V383
cable: Hama HDMI 1.4 goldplated
TV: LG 55 inch plasma (1080p)
Adapter: A-grade 2500mah 5volt DC jack

I thought the solution was CoreElec with the disable UHS switch in boot.ini. but this only worked once and only for a night the next day i had a black screen and needed to reboot and the GUI never came back :(


LibereElec: HDMI image good quality but no sound (passthrough or software) (uhs swtich doesnt seem to have any effect)
CoreElec: No GUI in fullscreen (only a mouse cursor), in windowed screen i have a GUI without text, with the UHS switch
Android: Unstable both 5.1.1 and 6.0.1, even without playstore its unstable.

Tried multiple SD cards: 8gb class 8, 16gb class 10, 32gb uhs1 and 64gb uhs 2, but a little performance they make no difference (mostly noticeable in CoreElec or LibreElec)

=== PROBLEM and SOLUTION ===
Code: Select all
The problem was an incompatible HDMI cable. replaced it with another one (which i thought had the same specs) same length and everything works like a charm.
Attachments
WhatsApp Image 2018-04-21 at 10.32.00 PM(1).jpeg
Audio settings page - Kodi [2/2]
WhatsApp Image 2018-04-21 at 10.32.00 PM(1).jpeg (157.59 KiB) Viewed 1286 times
WhatsApp Image 2018-04-21 at 10.32.00 PM.jpeg
Audio settings page - Kodi [1/2]
WhatsApp Image 2018-04-21 at 10.32.00 PM.jpeg (157.59 KiB) Viewed 1286 times
Last edited by earithramir on Sat Apr 28, 2018 2:23 am, edited 4 times in total.
earithramir
 
Posts: 13
Joined: Thu Apr 19, 2018 2:08 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: No sound HDMI (passthrough or software)

Unread postby rooted » Sun Apr 22, 2018 9:48 am

Try CoreELEC and see if it's the same

https://github.com/CoreELEC/CoreELEC/re ... tag/8.90.0
User avatar
rooted
 
Posts: 5579
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: No sound HDMI (passthrough or software)

Unread postby earithramir » Mon Apr 23, 2018 12:57 am

Hi,

unfortunately CoreElec doesn't run.
It installs fine then displays the CoreElec logo briefly and stalls on a black screen.
The machine seems to be running as i am able to ssh into it but the GUI doesn't pop up.
The process is running , even tried restarting the process with systemctl but the result is the same.

What am i doing wrong, or could my oDroid be defective ?
The speed of the SD card (measured with a USB2 cardreader) is about 50/46 MB/sec.
That should be sufficient, right?
earithramir
 
Posts: 13
Joined: Thu Apr 19, 2018 2:08 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: No sound HDMI (passthrough or software)

Unread postby rooted » Mon Apr 23, 2018 1:52 am

I think you may be running into an incompatibility with SD cards, try disabling UHS in the boot.ini
User avatar
rooted
 
Posts: 5579
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: No sound HDMI (passthrough or software)

Unread postby earithramir » Mon Apr 23, 2018 1:59 am

Hmmz i've tried two card both with the same result. i'll try that settings, thanks again!
I've ordered a EMMC at odroid store, but i'll have to wait for them to delivery it, that could take some time as i live the EU and they are located in Asia.
Is there a QVL (quality vendor list) which lists tested cards?

I've added to the configuration file /flash/boot.ini
setenv disableuhs "disableuhs"
But that did not change anything, on libreelec still no sound.. i could also test on coreelec but i do not think this can be the issue as im trying two (different) SD cards.
earithramir
 
Posts: 13
Joined: Thu Apr 19, 2018 2:08 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: No sound HDMI (passthrough or software)

Unread postby rooted » Mon Apr 23, 2018 2:22 am

I was referring to the CoreELEC issue, it's using more Amlogic specific patches and seemed to be showing an incompatibility with your SD card.

Have you tried enabling pass through?

*edit*
I see you have tried pass through.
User avatar
rooted
 
Posts: 5579
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: No sound HDMI (passthrough or software)

Unread postby earithramir » Mon Apr 23, 2018 2:26 am

Oh CoreElec, i'll try that later this night.. And come back with the results.
earithramir
 
Posts: 13
Joined: Thu Apr 19, 2018 2:08 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: No sound HDMI (passthrough or software)

Unread postby earithramir » Mon Apr 23, 2018 5:53 am

@rooted Thank you!! i've added disable UHS to the boot.ini of CoreElec image before the first run and now it started in a couple of seconds.
There even was sound !
Thanks again!!
earithramir
 
Posts: 13
Joined: Thu Apr 19, 2018 2:08 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: [SOLVED!] No sound HDMI (passthrough or software)

Unread postby rooted » Mon Apr 23, 2018 6:43 am

You're welcome, glad it is working.
User avatar
rooted
 
Posts: 5579
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: No sound HDMI (passthrough or software)

Unread postby earithramir » Wed Apr 25, 2018 2:13 am

I was cheering too fast..
The next day it didnt boot anymore.
Even tried the same installation procedure again and everytime the same result:
A kodi that doesnt have a GUI. i only see a mouse cursor and if i press \ a GUI without text (really small) im not able to force it to full screen. That is in coreElec.
On LibreElec i only have image and no sound.

So its either image without sound or sound without image, haha.
Already tried 3 SD cards, is this a hardware issue?
earithramir
 
Posts: 13
Joined: Thu Apr 19, 2018 2:08 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: No sound HDMI (passthrough or software)

Unread postby rooted » Wed Apr 25, 2018 6:03 am

What power supply are you using?
User avatar
rooted
 
Posts: 5579
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: No sound HDMI (passthrough or software)

Unread postby earithramir » Wed Apr 25, 2018 11:45 pm

Tried using the adapter that came with it a 5v 2a (dc jack) with the jumper removed.
And my supply i use for the raspberry pi a a grade 5v 3a micro usb.
Both with the same result
earithramir
 
Posts: 13
Joined: Thu Apr 19, 2018 2:08 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: No sound HDMI (passthrough or software)

Unread postby earithramir » Thu Apr 26, 2018 5:40 am

Could this be my (cheap) usb-3 sd card reader (which is connected through a type-c -> usb3 adapter on my macbook)? I thought if it verifies i should be good, right?
Any other tips/hints ?
earithramir
 
Posts: 13
Joined: Thu Apr 19, 2018 2:08 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: No sound HDMI (passthrough or software)

Unread postby rooted » Thu Apr 26, 2018 6:34 am

earithramir wrote:Could this be my (cheap) usb-3 sd card reader (which is connected through a type-c -> usb3 adapter on my macbook)? I thought if it verifies i should be good, right?
Any other tips/hints ?
It could be but I'm like you, if it verifies it should be correct AFAIK.
User avatar
rooted
 
Posts: 5579
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: No sound HDMI (passthrough or software)

Unread postby earithramir » Thu Apr 26, 2018 7:01 am

Yeah, that's what you'd think.
I'll try to test some other variables later this week. Else i'll wait for my EMMC to arrive on the first of next month. That will rule out bad memory cards/reader as it is preinstalled.
Thanks for helping me out so far.. keep ya posted!
earithramir
 
Posts: 13
Joined: Thu Apr 19, 2018 2:08 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: No sound HDMI (passthrough or software)

Unread postby rooted » Thu Apr 26, 2018 7:12 am

Do you have sound if directly connected to the TV?
User avatar
rooted
 
Posts: 5579
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: No sound HDMI (passthrough or software)

Unread postby earithramir » Thu Apr 26, 2018 2:35 pm

Didnt try... ill check in a couple of hours
earithramir
 
Posts: 13
Joined: Thu Apr 19, 2018 2:08 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: No sound HDMI (passthrough or software)

Unread postby earithramir » Sat Apr 28, 2018 2:21 am

Hi,

I managed to get everything working, although its not using the suggested CoreElec.
The problem was an incompatible HDMI cable, luckily i had one spare.
I don't know why but a HDMI cable that was working properly on my Raspberry Pi 2b did not function properly on the oDroid.
all my cables are as short as possible and i try not to have data and power mixed.
I now have a gold plated HDMI 1.4 cable about 20cm in length (same as previous) and everything works for LibreElec.
earithramir
 
Posts: 13
Joined: Thu Apr 19, 2018 2:08 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: [SOLVED!] No sound HDMI (passthrough or software)

Unread postby rooted » Sat Apr 28, 2018 2:27 am

That would have eventually been a suggestion, but since it did work once I was going a different direction.

Anyway glad it's resolved.
User avatar
rooted
 
Posts: 5579
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)


Return to LibreELEC - Kodi Project for C1/C2

Who is online

Users browsing this forum: No registered users and 1 guest