LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

User avatar
mad_ady
Posts: 5089
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1
Location: Bucharest, Romania
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by mad_ady » Sat Oct 27, 2018 8:58 pm

This is why we test these things when the wife is not around! :)

veccini
Posts: 11
Joined: Sat Oct 06, 2018 8:28 am
languages_spoken: english
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by veccini » Sun Oct 28, 2018 2:16 am

Hi voodik, I've tried the aptx codec, and now I can connect my KZ headphones with the aptx function, and it works fine. I have also connected other standard bluetooth headphones and there of course the SBC codec is activated, all right in the bluetooth section.

I have seen some conflict when scrolling when selecting options in a menu with horizontal lines, so that it is not marked or can not be selected, for example, when trying to freeze or delete applications with Titanium Backup .

Something last for now, I have seen that the Android 4.4.4 version automatically hide the navigation bar and the status bar when entering a game, and as I use keyboard and mouse, there is no problem if I move the pointer to the side top or bottom of the screen, but both in the Android versions 7.1.2 and 8.1.0 that you have so brilliantly ported, if I do that movement, both bars appear: navigation and status, which makes it impossible to handle the game for a few seconds until disappear; so I ask, is there no way with some plane application to deactivate both bars so they do not interfere with the game or the application?

Sorry for the english, google translate on

Thank's a lot !!!

The_Ponderer
Posts: 40
Joined: Fri Aug 08, 2014 3:12 pm
languages_spoken: english
ODROIDs: odroid-u3
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by The_Ponderer » Sun Oct 28, 2018 2:17 pm

So I proceeded with the update you provided. I seem to be stuck in a boot loop for some reason.

Would anyone happen to know why this has happened?

Did nothing out of the ordinary, just used the odroid updated provided and the loop started.

mfny
Posts: 2
Joined: Fri Nov 02, 2018 1:08 am
languages_spoken: english
ODROIDs: XU4
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by mfny » Sat Nov 03, 2018 10:15 am

Hi,

Does this release support the use of GPIO and such ?

joy
Posts: 610
Joined: Fri Oct 02, 2015 1:44 pm
languages_spoken: english
ODROIDs: ODROID-C1+, XU4, X
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by joy » Mon Nov 05, 2018 5:30 pm

Hi voodik, :)

Could you refer to this thread and add a new resolution 1200x1920p60hz for the next release of LineageOS version?
viewtopic.php?f=97&t=32519&p=237346#p237346
Relative kernel commit has been merged on Hardkernel github.

And 800x480p60hz timing is also changed and here is the commit.
https://github.com/hardkernel/linux/com ... 7373b8d4db
viewtopic.php?f=98&t=32173
https://github.com/hardkernel/linux/pull/363

If you need more information, please let me know.

User avatar
voodik
Posts: 1426
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by voodik » Mon Nov 05, 2018 11:37 pm

joy wrote:Hi voodik, :)

Could you refer to this thread and add a new resolution 1200x1920p60hz for the next release of LineageOS version?
viewtopic.php?f=97&t=32519&p=237346#p237346
Relative kernel commit has been merged on Hardkernel github.

And 800x480p60hz timing is also changed and here is the commit.
https://github.com/hardkernel/linux/com ... 7373b8d4db
viewtopic.php?f=98&t=32173
https://github.com/hardkernel/linux/pull/363

If you need more information, please let me know.
Hi, thanks for your hard work, i will merge all comits and release update soon.
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io

User avatar
voodik
Posts: 1426
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by voodik » Tue Nov 06, 2018 6:17 pm

Update :!:
20181106 Alpha-v0.6
  • Merge BSP changes
    *Supported 1200x1920p60hz resolustion.
    *Adjusted hdmi timing for 800x480p60hz to support Vu5A
    *Added test_mt_v[p]id boot arg(Hexadecimal string) to test USB Multitouch device without Kernel building.
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io

GGGxxx
Posts: 14
Joined: Sat Sep 29, 2018 3:28 am
languages_spoken: english
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by GGGxxx » Wed Nov 07, 2018 4:04 am

Hi all!
Thank you voodik for fast update!

But i can't confirm that it's worked.
I installed "android-lineage-15.1-alpha-0.3-sd2emmc_installer-odroidxu4-2018-07-18.img.zip" and run odroid updater app which install Alpha-0.6_06.11.18. Is it correct way to update?

When i tried to check which resolution set via adb i got next respond

Code: Select all

C:\adb>adb shell wm size
Physical size: 1200x31336
I think that 31336 is little more than needs to be here

in boot.ini i see next arguments

Code: Select all

setenv fb_x_res "1200"
setenv fb_y_res "1920"
setenv hdmi_phy_res "1200x1920p60hz"
And here is dmesg output

Code: Select all

[ 1594.694162] [c0] s5p-hdmi 14530000.hdmi: unplugged
[ 1594.952576] [c0] s5p-hdmi 14530000.hdmi: HDMI interrupt changed to external
[ 1596.454537] [c0] ###########################################
[ 1596.458887] [c0] # HDMI HPD state 1 #
[ 1596.462380] [c0] ###########################################
[ 1596.624690] [c0] Reserved SVD code 0
[ 1596.626810] [c0] Reserved SVD code 0
[ 1596.630439] [c0] Reserved SVD code 0
[ 1596.633972] [c0] Reserved SVD code 0
[ 1596.637484] [c0] Reserved SVD code 0
[ 1596.641088] [c0] Reserved SVD code 0
[ 1596.644655] [c0] Reserved SVD code 0
[ 1596.648163] [c0] EDID: misc flags 00000004
[ 1596.652107] EDID: Audio channels 2
[ 1596.655661] [c0] ###########################################
[ 1596.661364] [c0] # HDMI PHY Resolution 1200x1920p60hz #
[ 1596.666512] [c0] ###########################################
[ 1596.672157] [c0] ###########################################
[ 1596.677816] [c0] # HDMI EDID mode 0 #
[ 1596.681720] [c0] ###########################################
[ 1596.687089] [c0] ###########################################
[ 1596.692724] [c0] # hdev->dvi_mode false #
[ 1596.696706] [c0] ###########################################
[ 1596.703456] [c0] s5p-hdmi 14530000.hdmi: plugged
[ 1597.288474] [c2] s5p-hdmi 14530000.hdmi: state restore latency exceeded, new value 27858584 ns
[ 1597.295822] [c2] s5p-hdmi 14530000.hdmi: HDMI interrupt changed to internal

GGGxxx
Posts: 14
Joined: Sat Sep 29, 2018 3:28 am
languages_spoken: english
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by GGGxxx » Wed Nov 07, 2018 4:28 am

little upd:
after adb shell wm size 1200x1920 i get image on screen.

Code: Select all

C:\adb>adb shell wm size 1200x1920

C:\adb>adb shell wm size
Physical size: 1200x31336
Override size: 1200x1920

User avatar
voodik
Posts: 1426
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by voodik » Wed Nov 07, 2018 12:28 pm

Can you post output of

Code: Select all

dumpsys SurfaceFlinger
before and after

Code: Select all

wm size 1200x1920
command.

P.S.
direct upload output

Code: Select all

dumpsys SurfaceFlinger | curl -F 'f:1=<-' ix.io
also please post all logs before wm command

Code: Select all

(dmesg; logcat -d) | curl -F 'f:1=<-' ix.io
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io

GGGxxx
Posts: 14
Joined: Sat Sep 29, 2018 3:28 am
languages_spoken: english
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by GGGxxx » Wed Nov 07, 2018 10:35 pm

Here is ouput of dumpsys SurfaceFlinger
surface_1200x31336.txt
surface_1200x1920.txt

And dmesg and logcat -d output after wm size reset and rebot
dm.txt
logcat.txt

User avatar
voodik
Posts: 1426
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by voodik » Thu Nov 08, 2018 3:09 pm

GGGxxx wrote:Here is ouput of dumpsys SurfaceFlinger
surface_1200x31336.txt
surface_1200x1920.txt

And dmesg and logcat -d output after wm size reset and rebot
dm.txt
logcat.txt
Fixed, re-download and update.
gcc 4.9 issue, switched back kernel build with gcc 4.8.
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io

GGGxxx
Posts: 14
Joined: Sat Sep 29, 2018 3:28 am
languages_spoken: english
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by GGGxxx » Thu Nov 08, 2018 9:19 pm

It's working.
On start i get next pop-up message:
Android System
A vendor image mismatch has been detected. Typically this means your vendor image is out of date. Please ensure your vendor image matches OPM7.181005.003

NJdsal
Posts: 1
Joined: Thu Nov 08, 2018 9:54 pm
languages_spoken: english
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by NJdsal » Thu Nov 08, 2018 9:59 pm

Hello,

I previously had LineageOS 15.1 working OK on my XU4. I was able to register the device with Google so that the Google Play Store worked.

I just formatted my SDCard and reinstaled LineageOS 15.1

I tried to register the device again but it doesn't work.

The ID that I got is listed here as registered, but I still get warning that the device is not certified and I can't login to google play.
https://www.google.com/android/uncertified/

What am I missing?






I also tried downloading the Device+ID.apk file, but of course the default file manager can't or won't open the file.

EDIT: Moving the .apk to a root folder allows the .apk to be installed.




OK, figured it out.

First, you download Device+ID.apk and move it to a root folder.
Second you install it and find your google services ID.
Third you register your XU4
Fourth you log into Gmail through the General Google App.
Fifth, open the play store and you're good to go.

Sailor
Posts: 2
Joined: Wed Nov 14, 2018 4:09 am
languages_spoken: english
ODROIDs: C2, XU4
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by Sailor » Wed Nov 14, 2018 6:32 pm

Good morning,

Please can someone assist?
I am running the LineageOS-15.1 Android 8.1 (Brilliant! Thanks) but I am having difficulty with some settings.
In the Odroid Utility on the C2 there are settings to assign actions to Function Keys F7, F8, F9, and F10. I can't find these on the XU4 Odroid Utility.

Am I looking in the right place? Or are these stored elswhere?

Thanks and kind regards

Mark B.

User avatar
voodik
Posts: 1426
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by voodik » Thu Nov 15, 2018 3:36 pm

Sailor wrote:Good morning,

Please can someone assist?
I am running the LineageOS-15.1 Android 8.1 (Brilliant! Thanks) but I am having difficulty with some settings.
In the Odroid Utility on the C2 there are settings to assign actions to Function Keys F7, F8, F9, and F10. I can't find these on the XU4 Odroid Utility.

Am I looking in the right place? Or are these stored elswhere?

Thanks and kind regards

Mark B.
This setting isn't available in my builds.
BTW
i started new Odroid Utility development and this feature also will be ported.
ETA 1-2 weeks.
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io

Sailor
Posts: 2
Joined: Wed Nov 14, 2018 4:09 am
languages_spoken: english
ODROIDs: C2, XU4
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by Sailor » Thu Nov 15, 2018 8:54 pm

Many thanks Voodik,

Appreciate your efforts. Will you announce here or in another, different, thread?

Thanks again, and kind regards

Mark B.

licux
Posts: 1
Joined: Wed Nov 21, 2018 10:29 am
languages_spoken: english
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by licux » Wed Nov 21, 2018 10:37 am

Hi, I want to know the source code is available.
If it is available, I want to get it.

gekoch
Posts: 48
Joined: Fri Jun 30, 2017 3:32 pm
languages_spoken: english
ODROIDs: xu4
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by gekoch » Tue Dec 04, 2018 12:27 am

Hy

I have a 10.1inch HDMI LCD (B) (with case) and somehow it does not work with Android 8.1
Its a capacitive touch screen. The screen itself works great but the touch functionality does
not work
Does someone have similar problems?

Andy

User avatar
odroid
Site Admin
Posts: 29322
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by odroid » Tue Dec 04, 2018 9:59 am

gekoch wrote:Hy

I have a 10.1inch HDMI LCD (B) (with case) and somehow it does not work with Android 8.1
Its a capacitive touch screen. The screen itself works great but the touch functionality does
not work
Does someone have similar problems?

Andy
Try to change "disable_vu7" option in your boot.ini file.
https://github.com/mdrjr/5422_bootini/b ... #L134-L135

gekoch
Posts: 48
Joined: Fri Jun 30, 2017 3:32 pm
languages_spoken: english
ODROIDs: xu4
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by gekoch » Tue Dec 04, 2018 2:48 pm

great thx! Changing the settings and set it to "true" did the trick.

Thx a lot!
Andy

bart47
Posts: 1
Joined: Fri Dec 07, 2018 6:53 am
languages_spoken: english/french
ODROIDs: UX4
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by bart47 » Fri Dec 07, 2018 7:01 am

Hello, I just tried your lineage OS on my UX4, Everything is very smooth... But i 've got a little problem:

I can't mount my NAS Folder as internal storage (as a sMB or a CIFS or NFS folder) I tried to add mount script on bbot butI'm clearly not enough gifted for that..... and i have to reinstall everything. could you tell me a how to do that or add an option in the odroid utility for that, that would be great.

For sharing that path there is four parameter

Network adress

login

Password

Mounting internal folder

dack
Posts: 8
Joined: Fri Feb 06, 2015 11:16 am
languages_spoken: english
ODROIDs: XU3-Lite
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by dack » Tue Dec 25, 2018 12:39 am

I'm having some issues... When I go to the Play Store and click "Sign In" it does nothing. I also tried going into settings and setting up a Google account and it makes an animation like it's opening a transparent window and the login dialog never shows (just the settings screen but not clickable because of the transparent window over top). It also keeps giving me the "not certified" warning even though I registered over 12 hours ago.

Here's what I did:
- flashed the image from https://oph.mdrjr.net/voodik/5422/ODROI ... _18.07.18/
- started up the device and waited a very long time before I got the Lineage page with "next >" button
- went to odroid updater and updated to the latest which is Alpha 0.6
- I used adb to fetch the android id to "register" it and I inputted just the number after "android_id|"

I read through the thread and one person talked about installing mindthegapps through the odroid updater, but the format of the zip is completely different than the update.zip files and I really doubt it'd work. I've also cleared the data on Google Play, Google Play Services, and Google multiple times.

I'm also constantly getting " ... is not responding" error prompts and just keep hitting "wait" for all of them. Not sure if that's related, but it's really annoying.

My end goal is to install Android TV, but the instructions were to get Play working first, so here I am.

EDIT: just recently I occasionally get a full-sized blue screen with a circle saying it's "checking" but then after several minutes it just disappears and says nothing. I'm not sure if it's triggered by clicking "sign in" on the Play Store or hitting OK on the page warning about not being certified as it seems to happen quite a bit after I do either.

kenmystro
Posts: 2
Joined: Sun Dec 30, 2018 4:23 am
languages_spoken: english
ODROIDs: XU-4
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by kenmystro » Sun Dec 30, 2018 7:43 am

hi,
Today I finally got android installed on the emmc. Yet more layers of problems arise. THis device id chat, wtf DO I need to worry about this if no plans to use google play?
additionally, i can get the android id, when I input into device reg page, the reply is not a "16 digit hex or 19 digit string" when it is a hex code 16 digit that i input. Further research leads me to believe their is an android id and a google services id - or is this the wrong path?

I have terminal in android and connect .\adb shell through powershell (using root)
Got the same device id using both methods but cannot find a google id

a.artemev
Posts: 3
Joined: Wed Jun 20, 2018 5:03 pm
languages_spoken: english
ODROIDs: C2
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by a.artemev » Mon Dec 31, 2018 4:44 pm

Hey guys,

I have a problem with screen mirroring. I'm trying to use `scrcpy` to mirror the screen to my computer to remotely control the device. It worked well with LineageOS-14.1 Android 7.1.1 Nougat, but stopped working with the 8 one :(

To reproduce, you need to connect your device with adb, then just run

Code: Select all

adb shell screenrecord /sdcard/file.mp4
You will see

Code: Select all

ERROR: unable to create encoder input surface (err=-1010)
WARNING: failed at 1920x1080, retrying at 1280x720
ERROR: unable to create encoder input surface (err=-1010)
The output of adb logcut

Code: Select all

12-31 12:35:43.713  3311  4517 I WifiService: getWifiApEnabledState uid=10080
12-31 12:35:45.215  3152  3581 I OMXMaster: makeComponentInstance(OMX.Exynos.AVC.Encoder) in android.hardwar process
12-31 12:35:45.220  3152  3581 D libexynosv4l2: try node: /dev/video6
12-31 12:35:45.221  3152  3581 D libexynosv4l2: try node: /dev/video7
12-31 12:35:45.221  3152  3581 I libexynosv4l2: node found for device s5p-mfc-enc: /dev/video7
12-31 12:35:45.236  3152  3581 I libexynosv4l2: open video device /dev/video7
12-31 12:35:45.239  3152  3581 I ExynosVideoEncoder: MFC_Exynos_Video_GetInstInfo_Encoder: MFC HwVersion=0x80
12-31 12:35:45.261  3152  4123 W OMXNodeInstance: [0xaa187060:Exynos.AVC.Encoder] component does not support metadata mode; using fallback
12-31 12:35:45.263 29488 29497 W OMXUtils: do not know color format 0x7f000011 = 2130706449
12-31 12:35:45.265 29488 29497 W OMXUtils: do not know color format 0x10 = 16
12-31 12:35:45.266 29488 29497 W OMXUtils: do not know color format 0x7f000013 = 2130706451
12-31 12:35:45.266 29488 29497 W OMXUtils: do not know color format 0x7f000789 = 2130708361
12-31 12:35:45.267 29488 29497 I ACodec  : setupAVCEncoderParameters with [profile: Baseline] [level: Level31]
12-31 12:35:45.268 29488 29497 I ACodec  : [OMX.Exynos.AVC.Encoder] cannot encode color aspects. Ignoring.
12-31 12:35:45.268 29488 29497 I ACodec  : [OMX.Exynos.AVC.Encoder] cannot encode HDR static metadata. Ignoring.
12-31 12:35:45.268 29488 29497 I ACodec  : setupVideoEncoder succeeded
12-31 12:35:45.269 29488 29497 W OMXUtils: do not know color format 0x7f000789 = 2130708361
12-31 12:35:45.269  3152  4123 E OMXNodeInstance: getConfig(0xaa187060:Exynos.AVC.Encoder, ConfigLatency(0x6f800005)) ERROR: UnsupportedIndex(0x8000101a)
12-31 12:35:45.269  3152  4123 E OMXNodeInstance: getConfig(0xaa187060:Exynos.AVC.Encoder, ConfigAndroidIntraRefresh(0x6f60000a)) ERROR: UnsupportedIndex(0x8000101a)
12-31 12:35:45.272  3152  4123 E OMXNodeInstance: getExtensionIndex(0xaa187060:Exynos.AVC.Encoder, OMX.google.android.index.storeMetaDataInBuffers) ERROR: BadParameter(0x80001005)
12-31 12:35:45.272  3152  4123 E BWGraphicBufferSource: Unable to set input surface: -1010
12-31 12:35:45.272 29488 29497 E ACodec  : [OMX.Exynos.AVC.Encoder] Unable to configure for node (err -1010)
12-31 12:35:45.272 29488 29497 E ACodec  : [OMX.Exynos.AVC.Encoder] onCreateInputSurface returning error -1010
12-31 12:35:45.272 29488 29488 W MediaCodec: createInputSurface failed, err=-1010
12-31 12:35:45.278  3152  3227 I OMXMaster: makeComponentInstance(OMX.Exynos.AVC.Encoder) in android.hardwar process
12-31 12:35:45.280  3152  3227 D libexynosv4l2: try node: /dev/video6
12-31 12:35:45.281  3152  3227 D libexynosv4l2: try node: /dev/video7
12-31 12:35:45.281  3152  3227 I libexynosv4l2: node found for device s5p-mfc-enc: /dev/video7
12-31 12:35:45.296  3152  3227 I libexynosv4l2: open video device /dev/video7
12-31 12:35:45.296  3152  3227 I ExynosVideoEncoder: MFC_Exynos_Video_GetInstInfo_Encoder: MFC HwVersion=0x80
12-31 12:35:45.316  3152  3227 W OMXNodeInstance: [0xaa5a28a0:Exynos.AVC.Encoder] component does not support metadata mode; using fallback
12-31 12:35:45.319 29488 29501 W OMXUtils: do not know color format 0x7f000011 = 2130706449
12-31 12:35:45.320 29488 29501 W OMXUtils: do not know color format 0x10 = 16
12-31 12:35:45.320 29488 29501 W OMXUtils: do not know color format 0x7f000013 = 2130706451
12-31 12:35:45.321 29488 29501 W OMXUtils: do not know color format 0x7f000789 = 2130708361
12-31 12:35:45.324 29488 29501 I ACodec  : setupAVCEncoderParameters with [profile: Baseline] [level: Level31]
12-31 12:35:45.325 29488 29501 I ACodec  : [OMX.Exynos.AVC.Encoder] cannot encode color aspects. Ignoring.
12-31 12:35:45.326 29488 29501 I ACodec  : [OMX.Exynos.AVC.Encoder] cannot encode HDR static metadata. Ignoring.
12-31 12:35:45.326 29488 29501 I ACodec  : setupVideoEncoder succeeded
12-31 12:35:45.327 29488 29501 W OMXUtils: do not know color format 0x7f000789 = 2130708361
12-31 12:35:45.327  3152  3227 E OMXNodeInstance: getConfig(0xaa5a28a0:Exynos.AVC.Encoder, ConfigLatency(0x6f800005)) ERROR: UnsupportedIndex(0x8000101a)
12-31 12:35:45.328  3152  3227 E OMXNodeInstance: getConfig(0xaa5a28a0:Exynos.AVC.Encoder, ConfigAndroidIntraRefresh(0x6f60000a)) ERROR: UnsupportedIndex(0x8000101a)
12-31 12:35:45.332  3152  3227 E OMXNodeInstance: getExtensionIndex(0xaa5a28a0:Exynos.AVC.Encoder, OMX.google.android.index.storeMetaDataInBuffers) ERROR: BadParameter(0x80001005)
12-31 12:35:45.332  3152  3227 E BWGraphicBufferSource: Unable to set input surface: -1010
12-31 12:35:45.332 29488 29501 E ACodec  : [OMX.Exynos.AVC.Encoder] Unable to configure for node (err -1010)
12-31 12:35:45.332 29488 29501 E ACodec  : [OMX.Exynos.AVC.Encoder] onCreateInputSurface returning error -1010
12-31 12:35:45.332 29488 29488 W MediaCodec: createInputSurface failed, err=-1010
12-31 12:35:45.336 29488 29488 D ScreenRecord: failed
12-31 12:35:46.718  3311  4517 I WifiService: getWifiApEnabledState uid=10080
Am i doing something wrong?
Thank you!

User avatar
chippey5
Posts: 22
Joined: Sat Oct 26, 2013 10:51 pm
languages_spoken: english, swedish, dutch
ODROIDs: ODROID XU4. ODROID U2
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by chippey5 » Sat Jan 05, 2019 6:03 am

kenmystro wrote:
Sun Dec 30, 2018 7:43 am
hi,
Today I finally got android installed on the emmc. Yet more layers of problems arise. THis device id chat, wtf DO I need to worry about this if no plans to use google play?
additionally, i can get the android id, when I input into device reg page, the reply is not a "16 digit hex or 19 digit string" when it is a hex code 16 digit that i input. Further research leads me to believe their is an android id and a google services id - or is this the wrong path?

I have terminal in android and connect .\adb shell through powershell (using root)
Got the same device id using both methods but cannot find a google id
Go the the LineageOS 15 ATV forum (viewtopic.php?f=94&t=31569), check my post and try the 4th part of the instruction. Check if that gets your Google services up and running. Good luck

iceamaura
Posts: 4
Joined: Sun Jan 06, 2019 12:45 pm
languages_spoken: english
ODROIDs: ODROID XU4
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by iceamaura » Wed Jan 09, 2019 1:44 am

When I try to get the device ID over ADB, I get a code back that google doesn't accept due to not being the correct length. The console is also really garbled with wrong characters everywhere in the ADB console after connecting. Is there any way to fix this? Also, does performance get better once you do activate google play? Device is nearly unusable when unactivated. Maybe a Google Play-less image would be good?

User avatar
rooted
Posts: 6060
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by rooted » Wed Jan 09, 2019 6:35 am

iceamaura wrote:When I try to get the device ID over ADB, I get a code back that google doesn't accept due to not being the correct length. The console is also really garbled with wrong characters everywhere in the ADB console after connecting. Is there any way to fix this? Also, does performance get better once you do activate google play? Device is nearly unusable when unactivated. Maybe a Google Play-less image would be good?
It's not Google Play, it's that your SD card random IOPS is too slow for Android.

You need to have an A1 compatible micro SD card or eMMC to run it with any amount of speed.

hetii
Posts: 7
Joined: Tue Aug 25, 2015 7:34 pm
languages_spoken: english
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by hetii » Wed Jan 09, 2019 2:07 pm

For those who need netflix on xu4, the way to install it via play store is not possible.
Even downloading latest netflix apk from apkmirror, after running it it, raise that is not compatible with xu4.

Step by step I install each version from apkmirror and discover that latest working version is 4.16.3 build 15172.
I wonder what they change from version 5.x.x that is not compatible anymore, but It seams that 4.16.3 works fine so far.

iceamaura
Posts: 4
Joined: Sun Jan 06, 2019 12:45 pm
languages_spoken: english
ODROIDs: ODROID XU4
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by iceamaura » Thu Jan 10, 2019 4:01 am

rooted wrote:
Wed Jan 09, 2019 6:35 am
iceamaura wrote:When I try to get the device ID over ADB, I get a code back that google doesn't accept due to not being the correct length. The console is also really garbled with wrong characters everywhere in the ADB console after connecting. Is there any way to fix this? Also, does performance get better once you do activate google play? Device is nearly unusable when unactivated. Maybe a Google Play-less image would be good?
It's not Google Play, it's that your SD card random IOPS is too slow for Android.

You need to have an A1 compatible micro SD card or eMMC to run it with any amount of speed.
I don't need excessive r/w access, I'm only using this as a thin client for a remote machine. Maybe I'll decrease swappiness or turn it off altogether once I get it working. However I'm still having issues with garbage text being sent over ADB, preventing me from activating the device at all.

User avatar
rooted
Posts: 6060
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by rooted » Thu Jan 10, 2019 4:36 am

It's not about excessive R/W, the way Android works it needs high IOPS or applications force close or fail to respond.

I'm not sure why you're getting garbage over ADB but if I had to guess it's client side.

User avatar
voodik
Posts: 1426
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by voodik » Thu Jan 10, 2019 10:46 pm

iceamaura wrote:
Thu Jan 10, 2019 4:01 am
rooted wrote:
Wed Jan 09, 2019 6:35 am
iceamaura wrote:When I try to get the device ID over ADB, I get a code back that google doesn't accept due to not being the correct length. The console is also really garbled with wrong characters everywhere in the ADB console after connecting. Is there any way to fix this? Also, does performance get better once you do activate google play? Device is nearly unusable when unactivated. Maybe a Google Play-less image would be good?
It's not Google Play, it's that your SD card random IOPS is too slow for Android.

You need to have an A1 compatible micro SD card or eMMC to run it with any amount of speed.
I don't need excessive r/w access, I'm only using this as a thin client for a remote machine. Maybe I'll decrease swappiness or turn it off altogether once I get it working. However I'm still having issues with garbage text being sent over ADB, preventing me from activating the device at all.
Search in google "putty adb" try to setup adb access with putty.
Buy me a beer Here ;)
BTC: 3Lx83Vh9HL7UbsD9oDBcMR9pQMRSPEfRmg
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io

hogin
Posts: 2
Joined: Sun Sep 07, 2014 9:49 pm
languages_spoken: english
ODROIDs: X2
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by hogin » Sat Jan 12, 2019 7:00 pm

Hello,

I have LineageOS-15.1 Android 8.1 Oreo for ODROID-XU4 commissioned with an customized kernel.

SELinux blocks the binary file:

dmesg output

Code: Select all

[   19.577820] [c7] init: service eGTouchD does not have a SELinux domain defined
[   19.584672] [c7] init: starting service 'eGTouchD'...
[   20.020379] [c4] init: Service 'eGTouchD' (pid 3163) killed by signal 1
How and where can I create the rule * .te file?

Is this set in the kernel file system or do you need the android resources, which are not available at the moment?


I have made the following entry in the init.odroidxu3.rc.

Code: Select all

service eGTouchD /system/bin/sh /system/bin/eGTouchD
    class main
    user root
    group shell
    oneshot
Can someone help me there, please? I know the SELinux synonymous not so good and switch off is not an option.

User avatar
darkmen
Posts: 40
Joined: Mon Jan 25, 2016 12:06 am
languages_spoken: english, ukrainian
ODROIDs: XU4
Contact:

Re: LineageOS-15.1 Android 8.1 Oreo for ODROID-XU3/XU4

Unread post by darkmen » Tue Jan 15, 2019 11:50 pm

Hi
Installation steps go smooth. Great job. TY
Many small lags. One big: kodi runs with no sound.

Post Reply

Return to “Android”

Who is online

Users browsing this forum: No registered users and 0 guests