Could not initalize OpenGL. Error running OpenGL application

Moderators: mdrjr, odroid

Could not initalize OpenGL. Error running OpenGL application

Unread postby pavanshetty » Fri May 19, 2017 5:29 pm

Hello, I installed apm planner on ubuntu mate 16.04 on my Odroid XU4, but when I try running it, the start up screen appears for 2 seconds and closes, When I run it from the terminal I get an error FATAL: Could not initalize OpenGL. This happened with other applications as well. Any suggestions? Thanks
Code: Select all
odroid@odroid:~/Desktop/apm_planner$ ./release/apmplanner2
[20170511 11:26:18.727 INFO ] - QGCCore::initialize()
[20170511 11:26:18.727 INFO ] - Current Build Info
[20170511 11:26:18.727 INFO ] - Git Hash: 38b21e1f0c4e9f4203f5a273aab4a57d1d3294ba
[20170511 11:26:18.728 INFO ] - Git Commit: 2.0.25-rc1-16-g38b21e1-DEV
[20170511 11:26:18.728 INFO ] - APPLICATION_NAME: "APM Planner"
[20170511 11:26:18.728 INFO ] - APPLICATION_VERSION: "v2.0.25-rc1"
[20170511 11:26:18.728 INFO ] - APP_PLATFORM: ubuntu32
[20170511 11:26:18.729 INFO ] - APP_TYPE: stable
[20170511 11:26:18.748 WARN ] - Unable to find an X11 visual which matches EGL config 9
[20170511 11:26:18.748 WARN ] - Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
[20170511 11:26:18.842 INFO ] - Start Link Manager
[20170511 11:26:18.843 DEBUG] - Create MAVLinkDecoder:  MAVLinkDecoder(0xaa657008)
[20170511 11:26:18.845 INFO ] - Start UAS Manager
[20170511 11:26:18.935 DEBUG] - Creating MainWindow
[20170511 11:26:19.208 INFO ] - Creating SubMainWindow:  SubMainWindow(0xe0bc38)
[20170511 11:26:19.208 INFO ] - setting objectName:  "VIEW_MISSION"
[20170511 11:26:19.362 INFO ] - Creating SubMainWindow:  SubMainWindow(0xe63f70)
[20170511 11:26:19.362 INFO ] - setting objectName:  "VIEW_FLIGHT"
[20170511 11:26:19.494 INFO ] - Creating SubMainWindow:  SubMainWindow(0xf2fde8)
[20170511 11:26:19.494 INFO ] - setting objectName:  "VIEW_HARDWARE_CONFIG"
[20170511 11:26:19.866 DEBUG] - fillPortsInfo
[20170511 11:26:20.436 INFO ] - Inserting  "ttySAC0"
[20170511 11:26:20.437 INFO ] - Inserting  "ttySAC1"
[20170511 11:26:20.437 INFO ] - Inserting  "ttySAC2"
[20170511 11:26:20.437 INFO ] - Inserting  "ttySAC3"
[20170511 11:26:20.437 INFO ] - Changed Link to: "ttySAC0"
[20170511 11:26:21.631 INFO ] - Creating SubMainWindow:  SubMainWindow(0x1336798)
[20170511 11:26:21.632 INFO ] - setting objectName:  "VIEW_SOFTWARE_CONFIG"
[20170511 11:26:21.678 DEBUG] - Disable Controls
[20170511 11:26:22.118 INFO ] - Creating SubMainWindow:  SubMainWindow(0x185d6b0)
[20170511 11:26:22.119 INFO ] - setting objectName:  "VIEW_ENGINEER"
[20170511 11:26:22.145 INFO ] - Creating SubMainWindow:  SubMainWindow(0x19f0c20)
[20170511 11:26:22.145 INFO ] - setting objectName:  "VIEW_SIMULATOR"
[20170511 11:26:22.338 DEBUG] - MODE: 0
[20170511 11:26:22.354 DEBUG] - "D|PREFLIGHT"
[20170511 11:26:22.355 DEBUG] - MODE: 80
[20170511 11:26:22.356 DEBUG] - "D|STABILIZED"
[20170511 11:26:22.356 DEBUG] - MODE: 64
[20170511 11:26:22.357 DEBUG] - "D|MANUAL"
[20170511 11:26:22.358 DEBUG] - MODE: 88
[20170511 11:26:22.359 DEBUG] - "D|VECTOR|STABILIZED"
[20170511 11:26:22.359 DEBUG] - MODE: 92
[20170511 11:26:22.360 DEBUG] - "D|AUTO|STABILIZED"
[20170511 11:26:22.360 DEBUG] - MODE: 66
[20170511 11:26:22.361 DEBUG] - "D|TEST"
[20170511 11:26:22.542 DEBUG] - QUrl("file:///home/odroid/Desktop/apm_planner/qml/PrimaryFlightDisplayQML.qml")
[20170511 11:26:22.756 DEBUG] - QML Status: 1
[20170511 11:26:22.761 DEBUG] - QUrl("file:///home/odroid/Desktop/apm_planner/qml/PrimaryFlightDisplayQML.qml")
[20170511 11:26:22.880 DEBUG] - QML Status: 1
[20170511 11:26:22.895 INFO ] - UASActionsWidget creating  UASActionsWidget(0x1d68d10)
[20170511 11:26:22.902 DEBUG] - QuickView: load settings
[20170511 11:26:22.903 DEBUG] - QuickView: loading key:  "GCS GPS.GPS Fix ()"  type: "text"
[20170511 11:26:22.981 DEBUG] - QuickView: loading key:  "GCS GPS.GPS HDOP ()"  type: "text"
[20170511 11:26:22.985 DEBUG] - QuickView: loading key:  "GCS GPS.GPS Sats (n)"  type: "text"
[20170511 11:26:22.990 DEBUG] - QuickView: loading key:  "GCS Metric.Alt MSL (m)"  type: "text"
[20170511 11:26:22.995 DEBUG] - QuickView: loading key:  "GCS Metric.Alt REL (m)"  type: "text"
[20170511 11:26:23.001 DEBUG] - QuickView: loading key:  "GCS Status.Battery (%)"  type: "text"
[20170511 11:26:23.008 DEBUG] - QuickView: loading key:  "GCS Status.Climb (m/s)"  type: "text"
[20170511 11:26:23.015 DEBUG] - QuickView: loading key:  "GCS Status.Current (A)"  type: "text"
[20170511 11:26:23.023 DEBUG] - QuickView: loading key:  "GCS Status.Pitch (deg)"  type: "text"
[20170511 11:26:23.031 DEBUG] - QuickView: loading key:  "GCS Status.Roll (deg)"  type: "text"
[20170511 11:26:23.040 DEBUG] - QuickView: loading key:  "GCS Status.Voltage (V)"  type: "text"
[20170511 11:26:23.049 DEBUG] - QuickView: loading key:  "GCS Status.Yaw (deg)"  type: "text"
[20170511 11:26:23.068 DEBUG] - QuickView: load settings END
[20170511 11:26:23.249 INFO ] - Using Alsa Audio driver
[20170511 11:26:23.251 WARN ] - Dir directory tmp_audio exists
[20170511 11:26:23.288 DEBUG] - qmlBaseDir "/home/odroid/Desktop/apm_planner"
[20170511 11:26:23.289 DEBUG] - QUrl("file:///home/odroid/Desktop/apm_planner/qml/ApmToolBar.qml")
[20170511 11:26:23.338 DEBUG] - APMToolBar: button label SELECTED
[20170511 11:26:23.392 DEBUG] - QML Status: 1
[20170511 11:26:23.396 INFO ] - NETWORK_PROXY: Disabling System Network Proxies
[20170511 11:26:23.409 INFO ] - Screen Size is  QRect(0,0 1920x1080)
[20170511 11:26:23.411 WARN ] - Unable to find an X11 visual which matches EGL config 9
[20170511 11:26:23.412 WARN ] - Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
[20170511 11:26:23.699 WARN ] - Unable to find an X11 visual which matches EGL config 19
[20170511 11:26:23.700 FATAL] - Could not initialize OpenGL
Aborted
pavanshetty
 
Posts: 6
Joined: Sat May 06, 2017 12:19 am
languages_spoken: english
ODROIDs: XU4

Re: Could not initalize OpenGL. Error running OpenGL applica

Unread postby meveric » Fri May 19, 2017 5:40 pm

Can you try the same on this image: viewtopic.php?f=98&t=7322

If I see this right your application uses Qt5 and there is a bug in Qt5 that requires a fix to run certain application. That fix does not exists on Ubuntu image provided by HardKernel.

You probably have to follow these steps:
viewtopic.php?p=190559#p190559

Since there's an issue with the repository that needs to be fixed manually at the moment.
User avatar
meveric
 
Posts: 7959
Joined: Mon Feb 25, 2013 2:41 pm
languages_spoken: german, english
ODROIDs: X2, U2, U3, XU-Lite, XU3, XU3-Lite, C1, XU4, C2, C1+, XU4Q, HC1

Re: Could not initalize OpenGL. Error running OpenGL applica

Unread postby pavanshetty » Fri May 19, 2017 6:17 pm

Hi meveric,
Thank you for the reply, I followed the below steps but unfortunately I get the same error again.
Code: Select all
cd /etc/apt/sources.list.d/
sed -i "s/^deb/#deb/" *.list
apt-get update
apt-get install apt-transport-https ca-certificates
sed -i "s/#deb/deb/" *.list
apt-get update
pavanshetty
 
Posts: 6
Joined: Sat May 06, 2017 12:19 am
languages_spoken: english
ODROIDs: XU4

Re: Could not initalize OpenGL. Error running OpenGL applica

Unread postby meveric » Fri May 19, 2017 9:03 pm

The steps above are ONLY for the image I mentioned, they do absolutely NOTHING on the Ubuntu image and won't help you with your issue.
Did you install the image I mentioned above?
User avatar
meveric
 
Posts: 7959
Joined: Mon Feb 25, 2013 2:41 pm
languages_spoken: german, english
ODROIDs: X2, U2, U3, XU-Lite, XU3, XU3-Lite, C1, XU4, C2, C1+, XU4Q, HC1


Return to Ubuntu

Who is online

Users browsing this forum: No registered users and 4 guests