Odroid XU4 "read back data is different from original data."

Post Reply
TinyAppleTree
Posts: 5
Joined: Sun Feb 19, 2017 11:43 am
languages_spoken: English, Korean
ODROIDs: Odroid XU4
Has thanked: 0
Been thanked: 0
Contact:

Odroid XU4 "read back data is different from original data."

Unread post by TinyAppleTree » Sun Feb 19, 2017 11:58 am

Hello.

first of all I'm korean so I can't speak english that well. I hope you understand.

I bought Odroid XU4 and Micro SD card 16GB from HardKernel.

before buying Micro SD card I tried with my own card, it return read back data error.

then I bought installed one, and it worked.

but i have to reset OS, so I format it with SDFormatter and write "ubuntu-16.04-mate-odroid-xu3-20161011".

again, it said "read back data is different from original data.".

I thought it must be the problem of micro SD card reader, buy new one.

sadly it's not working either.

all two of them wrong or am I doing something wrong?

please answer it. thanks.

User avatar
odroid
Site Admin
Posts: 30266
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 3 times
Been thanked: 24 times
Contact:

Re: Odroid XU4 "read back data is different from original da

Unread post by odroid » Sun Feb 19, 2017 12:51 pm

Did you run the win32diskimager as administrator?
http://odroid.com/dokuwiki/doku.php?id= ... diskimager

Image

TinyAppleTree
Posts: 5
Joined: Sun Feb 19, 2017 11:43 am
languages_spoken: English, Korean
ODROIDs: Odroid XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: Odroid XU4 "read back data is different from original da

Unread post by TinyAppleTree » Mon Feb 20, 2017 8:23 am

yes, and I also checked run as administrator.
캡처.PNG
(24.26 KiB) Downloaded 413 times

User avatar
odroid
Site Admin
Posts: 30266
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 3 times
Been thanked: 24 times
Contact:

Re: Odroid XU4 "read back data is different from original da

Unread post by odroid » Mon Feb 20, 2017 10:30 am

We couldn't reproduce the issue on our Windows 10 and 8.1 PCs.
But some other users reported it worked with only Windows 7.
Do you have any other PC which runs Windows 7?

TinyAppleTree
Posts: 5
Joined: Sun Feb 19, 2017 11:43 am
languages_spoken: English, Korean
ODROIDs: Odroid XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: Odroid XU4 "read back data is different from original da

Unread post by TinyAppleTree » Tue Feb 21, 2017 12:12 pm

No, but I got VirtualBox Windows 7. I'll try with this one.

TinyAppleTree
Posts: 5
Joined: Sun Feb 19, 2017 11:43 am
languages_spoken: English, Korean
ODROIDs: Odroid XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: Odroid XU4 "read back data is different from original da

Unread post by TinyAppleTree » Wed Feb 22, 2017 11:06 am

finally, it worked.

Thank you for your help.

User avatar
odroid
Site Admin
Posts: 30266
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 3 times
Been thanked: 24 times
Contact:

Re: Odroid XU4 "read back data is different from original da

Unread post by odroid » Wed Feb 22, 2017 11:43 am

Good to hear you solved the issue.
Did you solve the issue on Win7 in a virtual machine?

TinyAppleTree
Posts: 5
Joined: Sun Feb 19, 2017 11:43 am
languages_spoken: English, Korean
ODROIDs: Odroid XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: Odroid XU4 "read back data is different from original da

Unread post by TinyAppleTree » Wed Feb 22, 2017 6:47 pm

yes I use VirtualBox Windows 7 64 bit.

thanks again.

hellonearthis
Posts: 10
Joined: Fri Jan 09, 2015 7:18 pm
languages_spoken: english
ODROIDs: oDroid-C1
Has thanked: 0
Been thanked: 0
Contact:

Re: Odroid XU4 "read back data is different from original da

Unread post by hellonearthis » Mon Mar 06, 2017 4:12 am

I am constantly getting this under win10 pro

I don't have win7 as I upgraded to win10
oOdroid.png
(29.76 KiB) Downloaded 332 times
Tried running as Admin, no difference.

User avatar
odroid
Site Admin
Posts: 30266
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 3 times
Been thanked: 24 times
Contact:

Re: Odroid XU4 "read back data is different from original da

Unread post by odroid » Tue Mar 07, 2017 10:07 am

Your card reader might not be compatible.
http://forum.odroid.com/viewtopic.php?f=53&t=2725

Or try other flashing utility.
I saw a new flashing tool introduction in our forum. But I can't recall where it was.

hellonearthis
Posts: 10
Joined: Fri Jan 09, 2015 7:18 pm
languages_spoken: english
ODROIDs: oDroid-C1
Has thanked: 0
Been thanked: 0
Contact:

Re: Odroid XU4 "read back data is different from original da

Unread post by hellonearthis » Tue Mar 07, 2017 1:16 pm

I managed to write to the eMMC module (a red one) using windows XP

User avatar
odroid
Site Admin
Posts: 30266
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 3 times
Been thanked: 24 times
Contact:

Re: Odroid XU4 "read back data is different from original da

Unread post by odroid » Tue Mar 07, 2017 4:27 pm

Ah.. I can recall it now.
https://etcher.io/

Russ^
Posts: 20
Joined: Sat Mar 04, 2017 1:49 am
languages_spoken: english
ODROIDs: ODROID XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: Odroid XU4 "read back data is different from original da

Unread post by Russ^ » Wed Mar 15, 2017 5:22 am

Not sure if its relevant, but I got that read back data error as well when writing the 4.9 test kernel image. But I just ignored it and put it in the xu4 and it was fine.

phaseshifter
Posts: 3242
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: U-2,U3+,,XU-3,,XU3-LITE,,XU-4
C1+,,C-2,,,
N-1,,N-2 @15 V D.C ,,...other odroid acc`s as well
Has thanked: 10 times
Been thanked: 20 times
Contact:

Re: Odroid XU4 "read back data is different from original da

Unread post by phaseshifter » Wed Mar 15, 2017 7:03 am

it is a flashing issue often even if it fails it often can be used ...however there still may be errors on/in the image..
you can simply reflash it again..if the problem persists after re-flashing several times then your media is faulty.
.i have what i believe to be my first 16Gb emmc card and it has slowly died even after recovered it many times..using the recovery methods as per wiki ..
.but now i cannot read/write to it at all..the emmc i got in approx AUG 2014..and it has done a lot of work...
Build It And They Will Come...Be Bold And Mighty Forces Will Come To Your Aid..!!!

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 3 guests