Odroid C1+ show a few unwanted dirty pixels

Post Reply
hsu95066
Posts: 51
Joined: Wed Aug 10, 2016 5:01 pm
languages_spoken: Chinese, English
ODROIDs: C1, C1+, C2, XU4
Has thanked: 3 times
Been thanked: 6 times
Contact:

Odroid C1+ show a few unwanted dirty pixels

Post by hsu95066 »

I am a newer about Linux ARM. I have developed an application on Odroid C1+ for displaying image from camera. Application displayed image by rendering texture of OpenGL ES 2.0. Recently, I found that the bottom area of image often show a few unwanted dirty pixels when camera captured moving images.


At the first time, I think my coding my be something’s wrong. But I found that the rotozoom and shadow_map of Mali SDK samples and glmark2-es2 have the same problems.


Then, I tested different Ubuntu OS version for one C1 board and two C1+ boards.
(1) Ubuntu 14.04.02 LTS
(2) Ubuntu 14.04.04 LTS
(3) Upgrade Ubuntu 14.04.05 LTS
(4) Ubuntu 16.04 LTS

There are the same results.

Finally, I test a XU4 board with Ubuntu 14.04.04 LTS and a C2 board with Ubuntu 16.04 LTS (64 bit), and they all show correctly.

So, how can I do for this problem?
Attachments
glmark2-es2
glmark2-es2
shadow_map
shadow_map
rotozoom
rotozoom
My application
My application

mdrjr
Site Admin
Posts: 11764
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 29 times
Contact:

Re: Odroid C1+ show a few unwanted dirty pixels

Post by mdrjr »

I'll try to replicate your issue.. give me a couple days :)

hsu95066
Posts: 51
Joined: Wed Aug 10, 2016 5:01 pm
languages_spoken: Chinese, English
ODROIDs: C1, C1+, C2, XU4
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: Odroid C1+ show a few unwanted dirty pixels

Post by hsu95066 »

Thank you!
This problem has been bothered me for several days.

mdrjr
Site Admin
Posts: 11764
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 29 times
Contact:

Re: Odroid C1+ show a few unwanted dirty pixels

Post by mdrjr »

Hello,

I can confirm this issue!
We'll try to fix it here.

mdrjr
Site Admin
Posts: 11764
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 29 times
Contact:

Re: Odroid C1+ show a few unwanted dirty pixels

Post by mdrjr »

I'm testing new Mali drivers for C1 and the issue still there.. however it appears to only happen on X11 and when its windowed. fullscreen applications doesn't show it.

Can you confirm on your application?

hsu95066
Posts: 51
Joined: Wed Aug 10, 2016 5:01 pm
languages_spoken: Chinese, English
ODROIDs: C1, C1+, C2, XU4
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: Odroid C1+ show a few unwanted dirty pixels

Post by hsu95066 »

Hi,

I tested glmark2-es2 --fullscreen, the issue rarely occured. I just saw one time for ten tests.
I found that the the issue concerned with the frame rate and window size.
It also seldom occured with glmark2-es2 --size 1900x1000, but it often occured with glmark2-es2 --size 400x300.
The FPS of [ideas] decreased from 104 to 43 when glmark2-es2 executed default to full screen.

The rotozoom and shadow_map of Mali SDK samples also have the same result.
When the window size enlarged by mouse, the FPS decreased and the issue rarely occured.

I have tested the C1+ board with
(1) Ubuntu 14.04.04 LTS - 1.4 linux-r5p0-01rel0
(2) Ubuntu 16.04 LTS - 1.4 linux-r5p0-01rel0

I will test the C2 board with Ubuntu 16.04 LTS (64 bit) later, the mali version is 1.4 linux-r6p1-01rel0.

hsu95066
Posts: 51
Joined: Wed Aug 10, 2016 5:01 pm
languages_spoken: Chinese, English
ODROIDs: C1, C1+, C2, XU4
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: Odroid C1+ show a few unwanted dirty pixels

Post by hsu95066 »

Hi,

I have tested the C2 board with Ubuntu 16.04 LTS (64 bit).
The issue never occurred even though the glmark2-es2 downsize to 200x150 and frame rate is higher than 400 fps.

I don't know the issue is concerned with GPU hardware or software driver.
So, Is it possible to correct the problem for C1 when the Mali driver upgrade to r6p1?

mdrjr
Site Admin
Posts: 11764
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 29 times
Contact:

Re: Odroid C1+ show a few unwanted dirty pixels

Post by mdrjr »

At this time the issue isn't the Mali binaries.

I have the same issue with r6p2 too :(

User avatar
rooted
Posts: 7974
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 724 times
Been thanked: 243 times
Contact:

Re: Odroid C1+ show a few unwanted dirty pixels

Post by rooted »

What if you change the display resolution?

hsu95066
Posts: 51
Joined: Wed Aug 10, 2016 5:01 pm
languages_spoken: Chinese, English
ODROIDs: C1, C1+, C2, XU4
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: Odroid C1+ show a few unwanted dirty pixels

Post by hsu95066 »

Hi,

I was very surprised that you got the same issue with r6p2 for C1.
I thought that C1 with r6p1 may be no problem because C2 with r6p1 hasn't the issue,and they have the same GPU type - Mali 450.
If the issue isn't the Mali driver, is it possibility of GPU hardware?
May I have the opportunity to get r6p2 for C1 testing?

I may have to give up using C1 board if it still have the issue.

mdrjr
Site Admin
Posts: 11764
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 29 times
Contact:

Re: Odroid C1+ show a few unwanted dirty pixels

Post by mdrjr »

I should release r6p2 soon....

hsu95066
Posts: 51
Joined: Wed Aug 10, 2016 5:01 pm
languages_spoken: Chinese, English
ODROIDs: C1, C1+, C2, XU4
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: Odroid C1+ show a few unwanted dirty pixels

Post by hsu95066 »

Hi mdrjr,

Thanks! Looking forward to your release.

hsu95066
Posts: 51
Joined: Wed Aug 10, 2016 5:01 pm
languages_spoken: Chinese, English
ODROIDs: C1, C1+, C2, XU4
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: Odroid C1+ show a few unwanted dirty pixels

Post by hsu95066 »

Hi mdrjr,

Is the below link r6p2 release for C1?

http://deb.odroid.in/c1/pool/main/m/mali-x11/
mali-x11_20160906-r6p2-ceeaf8a-23_armhf.deb 06-Sep-2016 09:22 464278

mdrjr
Site Admin
Posts: 11764
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 29 times
Contact:

Re: Odroid C1+ show a few unwanted dirty pixels

Post by mdrjr »

Correct.

hsu95066
Posts: 51
Joined: Wed Aug 10, 2016 5:01 pm
languages_spoken: Chinese, English
ODROIDs: C1, C1+, C2, XU4
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: Odroid C1+ show a few unwanted dirty pixels

Post by hsu95066 »

Hi mdrjr,

I have downloaded the mali-x11_20160906-r6p2-ceeaf8a-23_armhf.deb and installed it on Ubuntu 14.04.05 LTS for C1+.
dpkg -i mali-x11_20160906-r6p2-ceeaf8a-23_armhf.deb
then apt-get update, upgrade and dist-upgrade.

It show some errors when I typed glmark2-es2 in terminal
ERROR in Mali driver:
* Device driver API mismatch
* Device driver API version: 600
* User space API version: 900
Error: eglInitialize() failed with error: 12291
Error: Error: Could not get a valid XVisualInfo!
Error: Error: Couldn't create X Window!
Error: main: Could not initialize canvas

There are no problems for Ubuntu 16.04 LTS for the same update procedures.
But the issue is still there as you previously mentioned, even though mali driver has been updated to r6p2.

It seems not only Mali driver but also the X11 driver are responsible for updating the content .
So, it is impossible to correct the issue for C1 when X11 is used.
Last edited by hsu95066 on Fri Sep 16, 2016 1:16 am, edited 1 time in total.

mdrjr
Site Admin
Posts: 11764
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 29 times
Contact:

Re: Odroid C1+ show a few unwanted dirty pixels

Post by mdrjr »

Hi hsu,

I'm aware of the issue.. I'm trying to understand it ;(
It seems to be kernel related at this time.

As for your Ubuntu 14.04, two things we stopped updates for it.
You also need to update the kernel to have the new kernel drivers.

hsu95066
Posts: 51
Joined: Wed Aug 10, 2016 5:01 pm
languages_spoken: Chinese, English
ODROIDs: C1, C1+, C2, XU4
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: Odroid C1+ show a few unwanted dirty pixels

Post by hsu95066 »

Hi,

I returned back to use C1 board because the C2 board had some issues on Ubuntu 16.04 x64.
I downloaded ODROBIAN-Jessie-2.0-mate-S805.img and installed it on C1 board.
After update and upgrade, there are still the same issue on the bottom side of window.

I just do not understand why the issue occured on C1 board but not on XU4 board with Ubuntu 14.04 32 bit.

hsu95066
Posts: 51
Joined: Wed Aug 10, 2016 5:01 pm
languages_spoken: Chinese, English
ODROIDs: C1, C1+, C2, XU4
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: Odroid C1+ show a few unwanted dirty pixels

Post by hsu95066 »

I found that the unwanted dirty pixels only occured on the bottom side of window.
My current workaround is to add dummy height of display window, for example 100 pixels height,
and call glViewport(0, 100, width, height) to update image above the dummy area.
There are no the issue either windowed or full screen.
Attachments
001.jpg
Default backgroud color.
(106.74 KiB) Downloaded 402 times
002.jpg
Set the black background color
(109.55 KiB) Downloaded 402 times

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 3 guests