Activating Autologin

Post Reply
odroidinator
Posts: 1
Joined: Thu Mar 31, 2016 8:23 pm
languages_spoken: english
ODROIDs: XU4
Contact:

Activating Autologin

Unread post by odroidinator » Thu Mar 31, 2016 8:27 pm

Hi,
I'm running the standard 15.10 Ubuntu Mate for my Odroid xu4
I resized my partitions and updated and upgraded evrything.

Now iwant the standard user odroid to autologin.

I tried a lot "autologin-user=odroid" insertions into conf files. But none worked out.

Did anyone solved this yet?

Thanks in advance
odroidinator

User avatar
odroid
Site Admin
Posts: 30050
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: Activating Autologin

Unread post by odroid » Fri Apr 01, 2016 11:39 am

Edit /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf

Just paste this line at the end of the file.

Code: Select all

autologin-user=odroid

richard-g8jvm
Posts: 356
Joined: Sun Jan 18, 2015 1:27 am
languages_spoken: english
ODROIDs: C1+ C2, XU4
Location: Telford UK
Contact:

Re: Activating Autologin

Unread post by richard-g8jvm » Sat Apr 02, 2016 10:33 pm

Hi
I have a similar problem with Mate DM
I have autologin set to on, but it doesn't
In fact if I set the greeter to login "odroid" no password is required , but clicking on login , attempts to do something, but reverts
back to the greeter .
If I change the user to the other account, it asks for the password then logs in without a hitch.
I've looked in syslog and dmesg, cant see anything.
All I've found in /var/log/lightdm/lightdm.log is this

Code: Select all

[+2.53s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
[+3.64s] DEBUG: Got signal 10 from process 1132
[+3.64s] DEBUG: DisplayServer x-0: Got signal from X server :0
[+3.64s] DEBUG: DisplayServer x-0: Connecting to XServer :0
[+3.65s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+3.65s] DEBUG: Session pid=1143: Started with service 'lightdm-greeter', username 'lightdm'
[+3.69s] DEBUG: Session pid=1143: Authentication complete with return value 0: Success
[+3.69s] DEBUG: Seat seat0: Session authenticated, running command
[+3.69s] DEBUG: Session pid=1143: Running command /usr/lib/lightdm/lightdm-greeter-session /usr/sbin/lightdm-gtk-greeter
[+3.69s] DEBUG: Creating shared data directory /var/lib/lightdm-data/lightdm
[+3.69s] DEBUG: Session pid=1143: Logging to /var/log/lightdm/x-0-greeter.log
[+4.18s] DEBUG: Activating VT 7
[+4.18s] WARNING: Error using VT_ACTIVATE 7 on /dev/console: Inappropriate ioctl for device
[+4.18s] WARNING: Error using VT_WAITACTIVE 7 on /dev/console: Inappropriate ioctl for device
[+4.18s] DEBUG: Activating login1 session c2
[+4.18s] DEBUG: Seat seat0 changes active session to c2
[+4.18s] DEBUG: Session c2 is already active
[+5.00s] DEBUG: Session pid=1143: Greeter connected version=1.16.7 resettable=false
[+6.47s] DEBUG: Session pid=1143: Greeter start authentication for odroid
[+6.48s] DEBUG: Session pid=1261: Started with service 'lightdm', username 'odroid'
[+6.55s] DEBUG: Session pid=1261: Authentication complete with return value 0: Success
[+6.55s] DEBUG: Session pid=1143: Authenticate result for user odroid: Success
[+6.55s] DEBUG: Session pid=1143: User odroid authorized
That if I understand right, it says the login was successful, so any idea why its bouncing back to the greeter if the user odroid is used ????

SSH login with odroid as user is fine.

Thanks
BR
Richard G8JVM

User avatar
odroid
Site Admin
Posts: 30050
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: Activating Autologin

Unread post by odroid » Sun Apr 03, 2016 1:52 pm

I've tested my instruction on XU4 Ubuntu 15.10 image and it worked for me.

I hope other people can find a clue in your lightdm.log file.

richard-g8jvm
Posts: 356
Joined: Sun Jan 18, 2015 1:27 am
languages_spoken: english
ODROIDs: C1+ C2, XU4
Location: Telford UK
Contact:

Re: Activating Autologin

Unread post by richard-g8jvm » Sun Apr 03, 2016 5:33 pm

Thanks Odroid
Looks like something has got corrupted.
I'll take the easy way out and autologin the other user.




Added later in the day

only problem is it does exactly the same

Code: Select all

[Seat:*]
greeter-session=lightdm-gtk-greeter
autologin-user=richard
BR
Richard G8JVM

User avatar
odroid
Site Admin
Posts: 30050
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: Activating Autologin

Unread post by odroid » Mon Apr 04, 2016 8:55 am

I think adding a new user account caused the problem.
Some x11 or lightdm file might not be updated the permission/owner for the new user. :(
It seems to be a bug in Ubuntu 15.10.

User avatar
robroy
Posts: 3401
Joined: Mon Feb 25, 2013 2:29 am
languages_spoken: English
ODROIDs: Q2, X, X2, U2, U3, XU-E, XU3, XU4, C1, C1+, C2
Location: San Francisco, California
Contact:

Re: Activating Autologin

Unread post by robroy » Mon Apr 04, 2016 11:59 am

Delete the file /home/odroid/.Xauthority.
Rob Roy, Editor-in-Chief of ODROID Magazine (submit an article | make a donation)

richard-g8jvm
Posts: 356
Joined: Sun Jan 18, 2015 1:27 am
languages_spoken: english
ODROIDs: C1+ C2, XU4
Location: Telford UK
Contact:

Re: Activating Autologin

Unread post by richard-g8jvm » Mon Apr 04, 2016 5:39 pm

Thanks Robroy

That fixed it, and for the first time I'm seeing the normal Mate desktop and at the correct resolution :)
I even tried removing the second user directory and turning encryption off in case the second user home had been encrypted as that apparently stops autologin.
But it wasn't, I did back it up before deleting , so nothing lost
BR
Richard G8JVM

Ameridroid
Posts: 172
Joined: Thu Mar 17, 2016 4:19 am
languages_spoken: english
Contact:

Re: Activating Autologin

Unread post by Ameridroid » Fri Apr 29, 2016 11:48 pm

We've also seen some cases where there is no 60-*.conf file. In one case, it was 50-unity-greeter.conf that we added the autologin command to in order for it to work.

Longrunner262
Posts: 2
Joined: Tue Oct 30, 2018 10:51 pm
languages_spoken: english
ODROIDs: 4
Contact:

Re: Activating Autologin

Unread post by Longrunner262 » Sun Nov 11, 2018 5:39 am

For what it's worth, on the XU4 with Ubuntu 18.04 Mate, the file is:
/usr/share/lightdm/lightdm.conf.d/50-ubuntu-mate.conf

As above, just add one line to the bottom of the file:
autologin-user=odroid

I use this in conjunction with a headless setup so I needed the XU4 to always boot and be ready for remote login after a cold start. Thanks to those above for the original posts, it helped me get where I wanted to be.

firxworx
Posts: 7
Joined: Fri Jan 11, 2019 1:27 am
languages_spoken: english
ODROIDs: XU4
Contact:

Re: Activating Autologin

Unread post by firxworx » Sat Jan 12, 2019 1:42 pm

Taking it a step further, there is no correct file, only a correct path to put your conf file...

In Debian/Ubuntu, confs in .d folders will get looped through and included as if they were part of a megalithic conf. This enables apt scripts (and your own scripts) to drop files in this folder where they won't be at risk of overwriting or deleting other settings (e.g. if you were awk/sed/etc'ing a conf or ini file it'd be risky) and someone updating or deleting a package won't risk clobbering your custom setting. The number in front helps set a priority, as files are processed in order. Many daemons use the most recent setting when faced with a dupe.

For example, you can make your own 50-.. or 51-.. or any number really prefixed file with a .conf extension and put it in the /usr/share/lightdm/lightdm.conf.d folder with the contents:

Code: Select all

[Seat:*]
autologin-user=username
And it will work, and your custom setting will be safer from getting clobbered by accident :)

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: MastaG and 3 guests